[jitsi-users] Jitsi meet: Video and audio not working


#1

Hi everybody!

I am having troubles in the installation of Jitsi meet on Ubuntu 16.04.
I ran the quick install [0], set up the cert and so on. No other changes have been made, except editing /etc/prosody/conf.d/meet.fabrisg.eu.cfg.lua in order to not allow anonymous connection - changed authentication in VirtualHost to "internal_plain".

What is working: authentication, chat between users

What is not working: audio/video communication. Users' see their video, but not others' - they just see the default placeholder (that colored face) instead of others streams.

The instance runs behind a NAT, but the problem remains even for two devices attached to the same network.

I think I set up iptables correctly: http(s) + UDP ports (200000 - 203000). I edited the default port range under /etc/jitsi/videobridge/sip-communicator.properties. Anyway, no luck even with the default range (10000-20000).

I also installed Oracle's JRE (version 8), no luck.

Here's probably the only useful information I found on logs: /var/log/jitsi/jicofo.log

Jicofo 2017-02-04 21:00:40.458 INFO: [75] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().415 Focus request for room: preciseworkersgathersadly@conference.meet.fabrisg.eu
Jicofo 2017-02-04 21:00:40.460 INFO: [75] org.jitsi.jicofo.FocusManager.log() Created new focus for preciseworkersgathersadly@conference.meet.fabrisg.eu@meet.fabrisg.eu conferences count: 1 options:
    channelLastN: -1
    enableLipSync: true
    adaptiveLastN: false
    openSctp: true
    simulcastMode: rewriting
    disableRtx: true
Jicofo 2017-02-04 21:00:40.460 INFO: [75] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Lip-sync enabled in preciseworkersgathersadly@conference.meet.fabrisg.eu
Jicofo 2017-02-04 21:00:43.200 SEVERE: [102] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: SASL authentication DIGEST-MD5 failed: not-authorized
SASL authentication DIGEST-MD5 failed: not-authorized:
  at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
  at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
  at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
  at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
  at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
  at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
  at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
  at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
  at java.util.concurrent.FutureTask.run(FutureTask.java:266)
  at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
  at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
  at java.lang.Thread.run(Thread.java:745)

I have no clue how to fix this, nor I know whether this sasl authentication problem actually causes the malfunction.

Thanks to anyone could give some hints.

Cheers,
Giacomo

[0] https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md


#2

You have to add your local ip and your public ip in que sipcommunicator file in /etc/jitsi/videobridge as is referenced here

https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md

Cheers.

···

El 4 de febrero de 2017 4:25:08 p. m. GMT-05:00, Giacomo Fabris <mail@fabrisg.eu> escribió:

Hi everybody!

I am having troubles in the installation of Jitsi meet on Ubuntu 16.04.
I ran the quick install [0], set up the cert and so on. No other
changes have been made, except editing
/etc/prosody/conf.d/meet.fabrisg.eu.cfg.lua in order to not allow
anonymous connection - changed authentication in VirtualHost to
"internal_plain".

What is working: authentication, chat between users

What is not working: audio/video communication. Users' see their video,

but not others' - they just see the default placeholder (that colored
face) instead of others streams.

The instance runs behind a NAT, but the problem remains even for two
devices attached to the same network.

I think I set up iptables correctly: http(s) + UDP ports (200000 -
203000). I edited the default port range under
/etc/jitsi/videobridge/sip-communicator.properties. Anyway, no luck
even with the default range (10000-20000).

I also installed Oracle's JRE (version 8), no luck.

Here's probably the only useful information I found on logs:
/var/log/jitsi/jicofo.log

Jicofo 2017-02-04 21:00:40.458 INFO: [75]
org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().415 Focus
request for room: preciseworkersgathersadly@conference.meet.fabrisg.eu
Jicofo 2017-02-04 21:00:40.460 INFO: [75]
org.jitsi.jicofo.FocusManager.log() Created new focus for
preciseworkersgathersadly@conference.meet.fabrisg.eu@meet.fabrisg.eu
conferences count: 1 options:
   channelLastN: -1
   enableLipSync: true
   adaptiveLastN: false
   openSctp: true
   simulcastMode: rewriting
   disableRtx: true
Jicofo 2017-02-04 21:00:40.460 INFO: [75]
org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Lip-sync enabled in
preciseworkersgathersadly@conference.meet.fabrisg.eu
Jicofo 2017-02-04 21:00:43.200 SEVERE: [102]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to
connect/login: SASL authentication DIGEST-MD5 failed: not-authorized
SASL authentication DIGEST-MD5 failed: not-authorized:
at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

I have no clue how to fix this, nor I know whether this sasl
authentication problem actually causes the malfunction.

Thanks to anyone could give some hints.

Cheers,
Giacomo

[0]
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi brevedad.