[jitsi-users] JItsi-meet room name


#1

Hello,

We have some user demand on special character use for room names in our JItsi-meet platform.
Looking at default Nginx configuration we can find a rewrite rules that redirect room url to index.html :

location ~ ^/([a-zA-Z0-9=\?]+)$ {
rewrite ^/(.*)$ / break;
}

location / {
ssi on;
}

With this standard Nginx configuration all url not matching this regexp and not matching with other configured location is redirected to a 404 error page.

I made some test on meet.jit.si and it accept special character in URL like : https://meet.jit.si/good-----day
So I think your Nginx configuration is different, isn't it ?

I try to modify configuration in my server and it seems to work with regexp location remove and try_files usage.
location / {
ssi on;
try_files $uri /index.html;
}

Do you think it is safe to allow special character in room names ?

Regards,
Damien.


#2

Hi,

So the problem is that you may hit some not allowed chars for room
names inside prosody.
So currently meet is using: ^/([^/?&:]+)$ using those I think it's
safe, we need to push those to the default config.

Regards
damencho

···

On Fri, Jun 30, 2017 at 10:36 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Hello,

We have some user demand on special character use for room names in our
JItsi-meet platform.
Looking at default Nginx configuration we can find a rewrite rules that
redirect room url to index.html :

location ~ ^/([a-zA-Z0-9=\?]+)$ {
    rewrite ^/(.*)$ / break;
}

location / {
    ssi on;
}

With this standard Nginx configuration all url not matching this regexp and
not matching with other configured location is redirected to a 404 error
page.

I made some test on meet.jit.si and it accept special character in URL like
: https://meet.jit.si/good-----day
So I think your Nginx configuration is different, isn't it ?

I try to modify configuration in my server and it seems to work with regexp
location remove and try_files usage.
location / {
   ssi on;
   try_files $uri /index.html;
}

Do you think it is safe to allow special character in room names ?

Regards,
Damien.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi Damian,

thanks for sharing your regexp.

I try to use it on Nginx configuration :

location ~ ^/([^/?&:]+)$ {
        rewrite ^/(.*)$ / break;
}

But Nginx was unable to serve jitsi-meet page and fail with error : rewrite or internal redirection cycle.

Could-you share your full Nginx configuration file ?
Or maybe you serve page directly from videobridge ?

I also notice a strange behavior with quick-installation process.
For an fresh install on Ubuntu-14 Nginx is installed but doing the same process on Ubuntu 16 Nginx isn't installed and jitsi-meet are served by videobridge's jetty server.

Regards,
Damien

----- Mail original -----

···

De: "Damian Minkov" <damencho@jitsi.org>
À: "Jitsi Users" <users@jitsi.org>
Envoyé: Vendredi 30 Juin 2017 18:05:16
Objet: Re: [jitsi-users] JItsi-meet room name

Hi,

So the problem is that you may hit some not allowed chars for room
names inside prosody.
So currently meet is using: ^/([^/?&:]+)$ using those I think it's
safe, we need to push those to the default config.

Regards
damencho

On Fri, Jun 30, 2017 at 10:36 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Hello,

We have some user demand on special character use for room names in our
JItsi-meet platform.
Looking at default Nginx configuration we can find a rewrite rules that
redirect room url to index.html :

location ~ ^/([a-zA-Z0-9=\?]+)$ {
    rewrite ^/(.*)$ / break;
}

location / {
    ssi on;
}

With this standard Nginx configuration all url not matching this regexp and
not matching with other configured location is redirected to a 404 error
page.

I made some test on meet.jit.si and it accept special character in URL like
: https://meet.jit.si/good-----day
So I think your Nginx configuration is different, isn't it ?

I try to modify configuration in my server and it seems to work with regexp
location remove and try_files usage.
location / {
   ssi on;
   try_files $uri /index.html;
}

Do you think it is safe to allow special character in room names ?

Regards,
Damien.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

Hi Damian,

thanks for sharing your regexp.

I try to use it on Nginx configuration :

location ~ ^/([^/?&:]+)$ {
        rewrite ^/(.*)$ / break;
}

But Nginx was unable to serve jitsi-meet page and fail with error : rewrite or internal redirection cycle.

Ok, I will test it tomorrow and will share my findings.

Could-you share your full Nginx configuration file ?
Or maybe you serve page directly from videobridge ?

I also notice a strange behavior with quick-installation process.
For an fresh install on Ubuntu-14 Nginx is installed but doing the same process on Ubuntu 16 Nginx isn't installed and jitsi-meet are served by videobridge's jetty server.

Yep this is normal. In ubuntu 14, java8 is missing, while in ubuntu 16
it is the default. Java8 is a requirement for serving meet through jvb
and this is the default behavior is possible.

Regards
damencho

···

On Mon, Jul 3, 2017 at 10:50 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Regards,
Damien

----- Mail original -----
De: "Damian Minkov" <damencho@jitsi.org>
À: "Jitsi Users" <users@jitsi.org>
Envoyé: Vendredi 30 Juin 2017 18:05:16
Objet: Re: [jitsi-users] JItsi-meet room name

Hi,

So the problem is that you may hit some not allowed chars for room
names inside prosody.
So currently meet is using: ^/([^/?&:]+)$ using those I think it's
safe, we need to push those to the default config.

Regards
damencho

On Fri, Jun 30, 2017 at 10:36 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Hello,

We have some user demand on special character use for room names in our
JItsi-meet platform.
Looking at default Nginx configuration we can find a rewrite rules that
redirect room url to index.html :

location ~ ^/([a-zA-Z0-9=\?]+)$ {
    rewrite ^/(.*)$ / break;
}

location / {
    ssi on;
}

With this standard Nginx configuration all url not matching this regexp and
not matching with other configured location is redirected to a 404 error
page.

I made some test on meet.jit.si and it accept special character in URL like
: https://meet.jit.si/good-----day
So I think your Nginx configuration is different, isn't it ?

I try to modify configuration in my server and it seems to work with regexp
location remove and try_files usage.
location / {
   ssi on;
   try_files $uri /index.html;
}

Do you think it is safe to allow special character in room names ?

Regards,
Damien.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Damian,

Do you have any update on RegExp for Nginx configuration ?

My last test with your new regexp failed on redirection cycle until I change it to ^/([^/?&:.]+)$,
but then I had to change http-bind location line to : location = /http-bind

I'm actually testing a version with redirection to 404 for unwanted characters and try_file that seems to work.

location ~ ^/(.*[:'&]+.*)$ {
        return 404 ;
}

location / {
       ssi on;
       try_files $uri /index.html;
}

Best regards,
Damien Fetis

----- Mail original -----

···

De: "Damian Minkov" <damencho@jitsi.org>
À: "Jitsi Users" <users@jitsi.org>
Envoyé: Mardi 4 Juillet 2017 20:55:08
Objet: Re: [jitsi-users] JItsi-meet room name

Hi,

On Mon, Jul 3, 2017 at 10:50 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Hi Damian,

thanks for sharing your regexp.

I try to use it on Nginx configuration :

location ~ ^/([^/?&:]+)$ {
        rewrite ^/(.*)$ / break;
}

But Nginx was unable to serve jitsi-meet page and fail with error : rewrite or internal redirection cycle.

Ok, I will test it tomorrow and will share my findings.

Could-you share your full Nginx configuration file ?
Or maybe you serve page directly from videobridge ?

I also notice a strange behavior with quick-installation process.
For an fresh install on Ubuntu-14 Nginx is installed but doing the same process on Ubuntu 16 Nginx isn't installed and jitsi-meet are served by videobridge's jetty server.

Yep this is normal. In ubuntu 14, java8 is missing, while in ubuntu 16
it is the default. Java8 is a requirement for serving meet through jvb
and this is the default behavior is possible.

Regards
damencho

Regards,
Damien

----- Mail original -----
De: "Damian Minkov" <damencho@jitsi.org>
À: "Jitsi Users" <users@jitsi.org>
Envoyé: Vendredi 30 Juin 2017 18:05:16
Objet: Re: [jitsi-users] JItsi-meet room name

Hi,

So the problem is that you may hit some not allowed chars for room
names inside prosody.
So currently meet is using: ^/([^/?&:]+)$ using those I think it's
safe, we need to push those to the default config.

Regards
damencho

On Fri, Jun 30, 2017 at 10:36 AM, Damien FETIS <damien.fetis@renater.fr> wrote:

Hello,

We have some user demand on special character use for room names in our
JItsi-meet platform.
Looking at default Nginx configuration we can find a rewrite rules that
redirect room url to index.html :

location ~ ^/([a-zA-Z0-9=\?]+)$ {
    rewrite ^/(.*)$ / break;
}

location / {
    ssi on;
}

With this standard Nginx configuration all url not matching this regexp and
not matching with other configured location is redirected to a 404 error
page.

I made some test on meet.jit.si and it accept special character in URL like
: https://meet.jit.si/good-----day
So I think your Nginx configuration is different, isn't it ?

I try to modify configuration in my server and it seems to work with regexp
location remove and try_files usage.
location / {
   ssi on;
   try_files $uri /index.html;
}

Do you think it is safe to allow special character in room names ?

Regards,
Damien.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users