[jitsi-users] Jitsi Meet recording help


#1

I have a working Jitsi Meet (yay!) on a small droplet at Digital Ocean, but
I can't seem to get recording to work.

When I click the REC button, I get the message, "The live streaming service
is currently unavailable. Please try again later."

Your instructions say:

To enable it, add the following properties to sip-communicator.properties:

org.jitsi.videobridge.ENABLE_MEDIA_RECORDING=true
org.jitsi.videobridge.MEDIA_RECORDING_PATH=/path/to/recordings/dir
org.jitsi.videobridge.MEDIA_RECORDING_TOKEN=secret

But there are two files called sip-communicator.properties:

root@ubuntu-512mb-nyc3-01:/# locate sip-communicator
/etc/jitsi/jicofo/sip-communicator.properties
/etc/jitsi/videobridge/sip-communicator.properties

I have this in the file under /videobridge. Should it be under /jicofo?

Also, speaking of live streaming, I just used the YouTube live stream on
meet.jit.si, which was awesome ... is this feature currently available on
the self-hosted Jitsi Meet?


#2

These instructions are for recording on the bridge. It appears that your config.js is set to try and use jibri[0], so you will need to set that up.

Regards,
Boris

[0] https://github.com/jitsi/jibri

···

On 21/04/16 20:47, David Dumonde wrote:

I have a working Jitsi Meet (yay!) on a small droplet at Digital Ocean,
but I can't seem to get recording to work.

When I click the REC button, I get the message, "The live streaming
service is currently unavailable. Please try again later."

Your instructions say:

    To enable it, add the following properties to
    sip-communicator.properties:

    org.jitsi.videobridge.ENABLE_MEDIA_RECORDING=true
    org.jitsi.videobridge.MEDIA_RECORDING_PATH=/path/to/recordings/dir
    org.jitsi.videobridge.MEDIA_RECORDING_TOKEN=secret