[jitsi-users] jitsi-meet has stopped working after upgrade


#1

Hello,

I've upgraded jitsi-meet to new version "1.0.683-1" and now
videobridge seems not working anymore, I can't see or hear
participants.
I see this exception in my log

2015-08-30 16:52:34.782 SEVERE: [96]
util.UtilActivator.uncaughtException().108 An uncaught exception
occurred in thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main]
and message was: Could not initialize class org.jitsi.sctp4j.Sctp
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.sctp4j.Sctp
at org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

full log can be found here http://pastebin.com/kicrh0My

Strange thing, "sip-communicator.properties" file was missing after
upgrade, I've created a new one with same settings as before and it
was working for really short time (1-2 min.), now it's broken again.

My system:

Debian Wheezy
ii jitsi-meet 1.0.683-1
ii jitsi-meet-prosody 1.0.683-1
ii jitsi-videobridge 521-1
Java 8

Best,
Stan


#2

Hello,

I think the configuration file was moved into /etc/jitsi/videobridge/

About the NoClassDefFoundError, are you running the latest version of jitsi-videobridge? We had a faulty binary release about a week ago.

Best,
George

···

On Sep 30, 2015, at 10:21 AM, Stanislav Kopp <staskopp@gmail.com> wrote:

Hello,

I've upgraded jitsi-meet to new version "1.0.683-1" and now
videobridge seems not working anymore, I can't see or hear
participants.
I see this exception in my log

2015-08-30 16:52:34.782 SEVERE: [96]
util.UtilActivator.uncaughtException().108 An uncaught exception
occurred in thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main]
and message was: Could not initialize class org.jitsi.sctp4j.Sctp
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.sctp4j.Sctp
at org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

full log can be found here http://pastebin.com/kicrh0My

Strange thing, "sip-communicator.properties" file was missing after
upgrade, I've created a new one with same settings as before and it
was working for really short time (1-2 min.), now it's broken again.

My system:

Debian Wheezy
ii jitsi-meet 1.0.683-1
ii jitsi-meet-prosody 1.0.683-1
ii jitsi-videobridge 521-1
Java 8

Best,
Stan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I’m sorry, I didn’t see that you shared the versions in your first message. You seem to be running latest of everything. Hmm this is weird..

···

On Sep 30, 2015, at 10:41 AM, George Politis <gp@jitsi.org> wrote:

Hello,

I think the configuration file was moved into /etc/jitsi/videobridge/

About the NoClassDefFoundError, are you running the latest version of jitsi-videobridge? We had a faulty binary release about a week ago.

Best,
George

On Sep 30, 2015, at 10:21 AM, Stanislav Kopp <staskopp@gmail.com> wrote:

Hello,

I've upgraded jitsi-meet to new version "1.0.683-1" and now
videobridge seems not working anymore, I can't see or hear
participants.
I see this exception in my log

2015-08-30 16:52:34.782 SEVERE: [96]
util.UtilActivator.uncaughtException().108 An uncaught exception
occurred in thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main]
and message was: Could not initialize class org.jitsi.sctp4j.Sctp
java.lang.NoClassDefFoundError: Could not initialize class org.jitsi.sctp4j.Sctp
at org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

full log can be found here http://pastebin.com/kicrh0My

Strange thing, "sip-communicator.properties" file was missing after
upgrade, I've created a new one with same settings as before and it
was working for really short time (1-2 min.), now it's broken again.

My system:

Debian Wheezy
ii jitsi-meet 1.0.683-1
ii jitsi-meet-prosody 1.0.683-1
ii jitsi-videobridge 521-1
Java 8

Best,
Stan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

That looks almost identical to the problem I had after installing Jitsi Meet
onto a Debian Wheezy machine about 2 weeks ago.

The solution was to upgrade libc6 from the Jessie repository. Nothing else
seems affected, and Jitsi's working fine.

http://lists.jitsi.org/pipermail/users/2015-September/010063.html

Regards,

Antony.

···

On Wednesday 30 September 2015 at 17:21:56, Stanislav Kopp wrote:

Hello,

I've upgraded jitsi-meet to new version "1.0.683-1" and now
videobridge seems not working anymore, I can't see or hear
participants.
I see this exception in my log

2015-08-30 16:52:34.782 SEVERE: [96]
util.UtilActivator.uncaughtException().108 An uncaught exception
occurred in
thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main]
and message was: Could not initialize class org.jitsi.sctp4j.Sctp
java.lang.NoClassDefFoundError: Could not initialize class
org.jitsi.sctp4j.Sctp at
org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454) at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:
1142) at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java
:617) at java.lang.Thread.run(Thread.java:745)

--
If you were ploughing a field, which would you rather use - two strong oxen or
1024 chickens?

- Seymour Cray, pioneer of supercomputing

                                                   Please reply to the list;
                                                         please *don't* CC me.


#5

>
> 2015-08-30 16:52:34.782 SEVERE: [96]
> util.UtilActivator.uncaughtException().108 An uncaught exception
> occurred in
> thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main
> ] and message was: Could not initialize class org.jitsi.sctp4j.Sctp
> java.lang.NoClassDefFoundError: Could not initialize class
> org.jitsi.sctp4j.Sctp at
> org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454) at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java
> : 1142) at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java
> :617) at java.lang.Thread.run(Thread.java:745)

That looks almost identical to the problem I had after installing Jitsi
Meet onto a Debian Wheezy machine about 2 weeks ago.

The solution was to upgrade libc6 from the Jessie repository. Nothing else
seems affected, and Jitsi's working fine.

http://lists.jitsi.org/pipermail/users/2015-September/010063.html

Oh, and http://lists.jitsi.org/pipermail/users/2015-September/010064.html for
more details of *exactly* what I did, if needed :slight_smile:

···

On Wednesday 30 September 2015 at 17:48:36, Antony Stone wrote:

On Wednesday 30 September 2015 at 17:21:56, Stanislav Kopp wrote:

Regards,

Antony.

--
This sentence contains exactly threee erors.

                                                   Please reply to the list;
                                                         please *don't* CC me.


#6

HI,

I've downgraded jitsi-videobridge package to version "449-1" and it's
working again, seems like bug to me.
@Antony what version of jitsi-videobridge do you use?

Best,
Stan

···

2015-09-30 17:56 GMT+02:00 Antony Stone <Antony.Stone@jitsi.open.source.it>:

On Wednesday 30 September 2015 at 17:48:36, Antony Stone wrote:

On Wednesday 30 September 2015 at 17:21:56, Stanislav Kopp wrote:
>
> 2015-08-30 16:52:34.782 SEVERE: [96]
> util.UtilActivator.uncaughtException().108 An uncaught exception
> occurred in
> thread=Thread[org.jitsi.videobridge.SctpConnection-pool-5-thread-2,5,main
> ] and message was: Could not initialize class org.jitsi.sctp4j.Sctp
> java.lang.NoClassDefFoundError: Could not initialize class
> org.jitsi.sctp4j.Sctp at
> org.jitsi.videobridge.SctpConnection$1.run(SctpConnection.java:454) at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java
> : 1142) at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java
> :617) at java.lang.Thread.run(Thread.java:745)

That looks almost identical to the problem I had after installing Jitsi
Meet onto a Debian Wheezy machine about 2 weeks ago.

The solution was to upgrade libc6 from the Jessie repository. Nothing else
seems affected, and Jitsi's working fine.

http://lists.jitsi.org/pipermail/users/2015-September/010063.html

Oh, and http://lists.jitsi.org/pipermail/users/2015-September/010064.html for
more details of *exactly* what I did, if needed :slight_smile:

Regards,

Antony.

--
This sentence contains exactly threee erors.

                                                   Please reply to the list;
                                                         please *don't* CC me.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

HI,

I've downgraded jitsi-videobridge package to version "449-1" and it's
working again, seems like bug to me.
@Antony what version of jitsi-videobridge do you use?

Please follow the thread I posted links to - the original message (plus
others) show what I installed (which was the latest at the time).

>> http://lists.jitsi.org/pipermail/users/2015-September/010063.html

Antony.

···

On Wednesday 30 September 2015 at 18:04:57, Stanislav Kopp wrote:

--
"It is easy to be blinded to the essential uselessness of them by the sense of
achievement you get from getting them to work at all. In other words - and
this is the rock solid principle on which the whole of the Corporation's
Galaxy-wide success is founded - their fundamental design flaws are completely
hidden by their superficial design flaws."

- Douglas Noel Adams

                                                   Please reply to the list;
                                                         please *don't* CC me.