[jitsi-users] Jitsi-meet-electron does not run properly


#1

Hi,

I have cloned and installed jitsi-meet-electron from
https://github.com/jitsi/jitsi-meet-electron, but when I use 'npm start',
it only shows a blank white window. The terminal does not show any error
message as well. I am using on Ubuntu 16.04. Any suggestion?

Cheers,
Han


#2

You can open the developer tools from the View menu (IIRC) and check if there are any console errors. Do you see any errors there?

Cheers,

···

On Mar 22, 2017, at 06:12, Han Gyeol Oh <leook0209@gmail.com> wrote:

Hi,

I have cloned and installed jitsi-meet-electron from https://github.com/jitsi/jitsi-meet-electron, but when I use 'npm start', it only shows a blank white window. The terminal does not show any error message as well. I am using on Ubuntu 16.04. Any suggestion?

--
Saúl


#3

Hi Saúl,

Yes, I see this message on the Console.

Uncaught Error: Module version mismatch. Expected 50, got 51.

Any advice?

Cheers,
Han

···

On 22 March 2017 at 13:12, Han Gyeol Oh <leook0209@gmail.com> wrote:

Hi,

I have cloned and installed jitsi-meet-electron from
https://github.com/jitsi/jitsi-meet-electron, but when I use 'npm start',
it only shows a blank white window. The terminal does not show any error
message as well. I am using on Ubuntu 16.04. Any suggestion?

Cheers,
Han


#4

Have you executed "npm install" ?

That should have installed all dependencies and rebuilt all electron packages with the right ABI version.

Give that a try and run "npm start" again.

Cheers,

···

On Mar 22, 2017, at 12:35, Han Gyeol Oh <leook0209@gmail.com> wrote:

Hi Saúl,

Yes, I see this message on the Console.

Uncaught Error: Module version mismatch. Expected 50, got 51.

Any advice?

--
Saúl


#5

When I used 'sudo npm install', I got this warning message

npm WARN lifecycle jitsi-meet-electron@0.0.0~postinstall: cannot run in wd
%s %s (wd=%s) jitsi-meet-electron@0.0.0 electron-rebuild
/home/han/git/jitsi-meet-electron

Maybe because I used sudo command? But if I dont use sudo, I get a
permission denied error instead.

Error: EACCES: permission denied, mkdir
'/home/han/git/jitsi-meet-electron/node_modules/.staging'

Han

···

On 23 March 2017 at 02:05, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

> On Mar 22, 2017, at 12:35, Han Gyeol Oh <leook0209@gmail.com> wrote:
>
>
> Hi Saúl,
>
> Yes, I see this message on the Console.
>
> Uncaught Error: Module version mismatch. Expected 50, got 51.
>
> Any advice?
>

Have you executed "npm install" ?

That should have installed all dependencies and rebuilt all electron
packages with the right ABI version.

Give that a try and run "npm start" again.

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

You do not need sudo, but if you tried it once, it may create some
files and later without sudo you will be unable to edit them.
So using sudo delete node_modules folder and then without sudo try
doing npm install.

···

On Wed, Mar 22, 2017 at 10:14 PM, Han Gyeol Oh <leook0209@gmail.com> wrote:

When I used 'sudo npm install', I got this warning message

npm WARN lifecycle jitsi-meet-electron@0.0.0~postinstall: cannot run in wd
%s %s (wd=%s) jitsi-meet-electron@0.0.0 electron-rebuild
/home/han/git/jitsi-meet-electron

Maybe because I used sudo command? But if I dont use sudo, I get a
permission denied error instead.

Error: EACCES: permission denied, mkdir
'/home/han/git/jitsi-meet-electron/node_modules/.staging'

Han

On 23 March 2017 at 02:05, Saúl Ibarra Corretgé <scorretge@atlassian.com> > wrote:

> On Mar 22, 2017, at 12:35, Han Gyeol Oh <leook0209@gmail.com> wrote:
>
>
> Hi Saúl,
>
> Yes, I see this message on the Console.
>
> Uncaught Error: Module version mismatch. Expected 50, got 51.
>
> Any advice?
>

Have you executed "npm install" ?

That should have installed all dependencies and rebuilt all electron
packages with the right ABI version.

Give that a try and run "npm start" again.

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi Damian,

Thanks, it solved the problem.

Cheers,
Han

···

On 23 March 2017 at 11:36, Damian Minkov <damencho@jitsi.org> wrote:

You do not need sudo, but if you tried it once, it may create some
files and later without sudo you will be unable to edit them.
So using sudo delete node_modules folder and then without sudo try
doing npm install.

On Wed, Mar 22, 2017 at 10:14 PM, Han Gyeol Oh <leook0209@gmail.com> > wrote:
> When I used 'sudo npm install', I got this warning message
>
> npm WARN lifecycle jitsi-meet-electron@0.0.0~postinstall: cannot run in
wd
> %s %s (wd=%s) jitsi-meet-electron@0.0.0 electron-rebuild
> /home/han/git/jitsi-meet-electron
>
>
> Maybe because I used sudo command? But if I dont use sudo, I get a
> permission denied error instead.
>
> Error: EACCES: permission denied, mkdir
> '/home/han/git/jitsi-meet-electron/node_modules/.staging'
>
>
> Han
>
>
> On 23 March 2017 at 02:05, Saúl Ibarra Corretgé <scorretge@atlassian.com > > > > wrote:
>>
>>
>> > On Mar 22, 2017, at 12:35, Han Gyeol Oh <leook0209@gmail.com> wrote:
>> >
>> >
>> > Hi Saúl,
>> >
>> > Yes, I see this message on the Console.
>> >
>> > Uncaught Error: Module version mismatch. Expected 50, got 51.
>> >
>> > Any advice?
>> >
>>
>> Have you executed "npm install" ?
>>
>> That should have installed all dependencies and rebuilt all electron
>> packages with the right ABI version.
>>
>> Give that a try and run "npm start" again.
>>
>>
>> Cheers,
>>
>> --
>> Saúl
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Have you installed all the dependencies with npm i ? I just tested
it on Fedora 28 and it continues to run with no problems.