[jitsi-users] Jitsi-Meet-Electron Configuration (remote control, screen sharing, frame resize)


#1

Hello,

I'm trying out Jitsi-meet-electron on a self-hosted instance of Jitsi-meet.
The main feature that got my attention was the remote control but I don't
seem to be able to get it to work (along with screen sharing).

What I have done so far is change the url in config.js to point to my jitsi
instance, run npm install and after that npm start.

Also, another minor question. When the application starts, the frame that
serves the page takes up only a portion of the window, is there a way to
have it take up the whole window (and if possible resize along with the
window).

Sorry if I'm missing something obvious (I'm relatively new to Jitsi).

Greetings,

Kolokotronis Panagiotis


#2

Hello,

I'm trying out Jitsi-meet-electron on a self-hosted instance of Jitsi-meet.
The main feature that got my attention was the remote control but I don't seem to be able to get it to work (along with screen sharing).

What I have done so far is change the url in config.js to point to my jitsi instance, run npm install and after that npm start.

The remote control option should be in the thumbnail menu, represented by the 3 vertical dots.

Also, another minor question. When the application starts, the frame that serves the page takes up only a portion of the window, is there a way to have it take up the whole window (and if possible resize along with the window).

Hum, this looks like a bug. Are you running the latest version of everything? Is it working fine with meet.jit.si ?

Cheers,

···

On Aug 7, 2017, at 04:08, Panagiotis Kolokotronis <panos122008@gmail.com> wrote:

--
Saúl


#3

* On Aug 7, 2017, at 04:08, Panagiotis Kolokotronis <panos122008 at gmail.com <http://lists.jitsi.org/mailman/listinfo/users>> wrote:

*>> >>* Hello,
*>> >>* I'm trying out Jitsi-meet-electron on a self-hosted instance
of Jitsi-meet.
*>>* The main feature that got my attention was the remote control but
I don't seem to be able to get it to work (along with screen sharing).
*>> >>* What I have done so far is change the url in config.js to
point to my jitsi instance, run npm install and after that npm start.
*>> >

The remote control option should be in the thumbnail menu, represented by the 3 vertical dots.

I can't seem to be able to find the thumbnail menu (in either the
meet.jit.si or my deployment). Screenshot of jitsi-electron-meet
pointing to meet.jit.si[1].

* Also, another minor question. When the application starts, the frame that serves the page takes up only a portion of the window, is there a way to have it take up the whole window (and if possible resize along with the window).

*>> >

Hum, this looks like a bug. Are you running the latest version of everything? Is it working fine with meet.jit.si ?

This happens in the latest version cloned from
jitsi/jitsi-meet-electron on both meet.jit.si and my own deployment.

On han-gyeol/jitsi-meet-electron on the other hand the page is
displayed correctly, takes up all the window and resizes with it (no
remote control there either).

OS tested on Ubuntu 16.04 & Debian 8.

···

--------------------------------------------------------------------------------------------------------------

[1]: http://imgur.com/a/rwTJw

2017-08-07 12:08 GMT+03:00 Panagiotis Kolokotronis <panos122008@gmail.com>:

Hello,

I'm trying out Jitsi-meet-electron on a self-hosted instance of
Jitsi-meet.
The main feature that got my attention was the remote control but I don't
seem to be able to get it to work (along with screen sharing).

What I have done so far is change the url in config.js to point to my
jitsi instance, run npm install and after that npm start.

Also, another minor question. When the application starts, the frame that
serves the page takes up only a portion of the window, is there a way to
have it take up the whole window (and if possible resize along with the
window).

Sorry if I'm missing something obvious (I'm relatively new to Jitsi).

Greetings,

Kolokotronis Panagiotis


#4

You seem to have the filmstrip hidden. Click the small arrow at the bottom right. If there is only one participant you may need to click on your own thumbnail in order for the remote thumbnail to show up.

There you will see the 3 dots.

Cheers,

···

On Aug 10, 2017, at 15:21, Panagiotis Kolokotronis <panos122008@gmail.com> wrote:

>> On Aug 7, 2017, at 04:08, Panagiotis Kolokotronis <panos122008 at gmail.com > > wrote:

>>

>>
Hello,

>>

>>
I'm trying out Jitsi-meet-electron on a self-hosted instance of Jitsi-meet.

>>
The main feature that got my attention was the remote control but I don't seem to be able to get it to work (along with screen sharing).

>>

>>
What I have done so far is change the url in config.js to point to my jitsi instance, run npm install and after that npm start.

>>

>
>The remote control option should be in the thumbnail menu, represented by the 3 vertical dots.

I can't seem to be able to find the thumbnail menu (in either the meet.jit.si or my deployment). Screenshot of jitsi-electron-meet pointing to meet.jit.si[1].

>>
Also, another minor question. When the application starts, the frame that serves the page takes up only a portion of the window, is there a way to have it take up the whole window (and if possible resize along with the window).

>>

>
>Hum, this looks like a bug. Are you running the latest version of everything? Is it working fine with
meet.jit.si ?

This happens in the latest version cloned from jitsi/jitsi-meet-electron on both meet.jit.si and my own deployment.

On han-gyeol/jitsi-meet-electron on the other hand the page is displayed correctly, takes up all the window and resizes with it (no remote control there either).

OS tested on Ubuntu 16.04 & Debian 8.

--------------------------------------------------------------------------------------------------------------

[1]: http://imgur.com/a/rwTJw

2017-08-07 12:08 GMT+03:00 Panagiotis Kolokotronis <panos122008@gmail.com>:
Hello,

I'm trying out Jitsi-meet-electron on a self-hosted instance of Jitsi-meet.
The main feature that got my attention was the remote control but I don't seem to be able to get it to work (along with screen sharing).

What I have done so far is change the url in config.js to point to my jitsi instance, run npm install and after that npm start.

Also, another minor question. When the application starts, the frame that serves the page takes up only a portion of the window, is there a way to have it take up the whole window (and if possible resize along with the window).

Sorry if I'm missing something obvious (I'm relatively new to Jitsi).

Greetings,

Kolokotronis Panagiotis

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Saúl


#5

Hi,
Ok I found the dots. Remote control works fine on meet.jit.si but on my
installation the following happens:

* Moderator requests remote control (click on the dots then select remote
control)
* Client with electron app accepts remote control
* Client's screen appears on moderator's jitsi
* Any action moderator takes (i.e. move/click mouse or press buttons) does
not affect the client
* There is no error on either side's console (or network calls that failed)

Is there any configuration server-side that has to be done to allow remote
control ?

The visual difference between meet.jit.si and my own deployment prompted me
to also try deploying nightly. When using nightly, the option to remote
control a Client that's using the electron app does not appear when
clicking on the dots, again with no errors on either side's console.

Thanks for bearing with me this far and sorry it took me 3 mails to find
the dots :s

···

2017-08-10 16:21 GMT+03:00 Panagiotis Kolokotronis <panos122008@gmail.com>:

>>* On Aug 7, 2017, at 04:08, Panagiotis Kolokotronis <panos122008 at gmail.com <http://lists.jitsi.org/mailman/listinfo/users>> wrote:
*>> >>* Hello,
*>> >>* I'm trying out Jitsi-meet-electron on a self-hosted instance of Jitsi-meet.
*>>* The main feature that got my attention was the remote control but I don't seem to be able to get it to work (along with screen sharing).
*>> >>* What I have done so far is change the url in config.js to point to my jitsi instance, run npm install and after that npm start.
*>> >
>The remote control option should be in the thumbnail menu, represented by the 3 vertical dots.

I can't seem to be able to find the thumbnail menu (in either the meet.jit.si or my deployment). Screenshot of jitsi-electron-meet pointing to meet.jit.si[1].

>>* Also, another minor question. When the application starts, the frame that serves the page takes up only a portion of the window, is there a way to have it take up the whole window (and if possible resize along with the window).
*>> >
>Hum, this looks like a bug. Are you running the latest version of everything? Is it working fine with meet.jit.si ?

This happens in the latest version cloned from jitsi/jitsi-meet-electron on both meet.jit.si and my own deployment.

On han-gyeol/jitsi-meet-electron on the other hand the page is displayed correctly, takes up all the window and resizes with it (no remote control there either).

OS tested on Ubuntu 16.04 & Debian 8.

--------------------------------------------------------------------------------------------------------------

[1]: http://imgur.com/a/rwTJw

2017-08-07 12:08 GMT+03:00 Panagiotis Kolokotronis <panos122008@gmail.com>
:

Hello,

I'm trying out Jitsi-meet-electron on a self-hosted instance of
Jitsi-meet.
The main feature that got my attention was the remote control but I don't
seem to be able to get it to work (along with screen sharing).

What I have done so far is change the url in config.js to point to my
jitsi instance, run npm install and after that npm start.

Also, another minor question. When the application starts, the frame that
serves the page takes up only a portion of the window, is there a way to
have it take up the whole window (and if possible resize along with the
window).

Sorry if I'm missing something obvious (I'm relatively new to Jitsi).

Greetings,

Kolokotronis Panagiotis