[jitsi-users] jitsi meet does not show remote users video input/audio input


#1

hello,

i just wanted to give jitsi meet a try -out of the box- but the remote
video-/audio does not show up. keyboard chat is ok.
we feel, it does not make a difference if jvb is running or not.

maybe it's important to mention, that all of our machines are placed
behind a firewall and do not have direct (no natting) internet accesss -
all internet access is done via an authenticating proxy (squid-3.5.7).

what could i do to make jits meet work?

thanks in advance, gustav

server:
Debian GNU/Linux 8
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-1~deb8u1)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

ii jicofo 1.0-143-1
amd64 JItsi Meet COnference FOcus
ii jitsi-meet 1.0.683-1
all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.683-1
all Prosody configuration for Jitsi Meet
ii jitsi-videobridge 521-1
amd64 WebRTC compatible Selective Forwarding Unit (SFU)

client1: windows/firefox-41.0

client2: Debian GNU/Linux 8/Chromium-45.0.2454.85


#2

Does meet.jit.si work for you?

If your clients have UDP filtered you will need to setup videobridge to work with TCP (and if they can't access ports other than 443, that's what the bridge will have to use).

https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md

Boris

···

On 30/09/15 09:42, Gustav Spellauge wrote:

hello,

i just wanted to give jitsi meet a try -out of the box- but the remote
video-/audio does not show up. keyboard chat is ok.
we feel, it does not make a difference if jvb is running or not.

maybe it's important to mention, that all of our machines are placed
behind a firewall and do not have direct (no natting) internet accesss -
all internet access is done via an authenticating proxy (squid-3.5.7).


#3

hello,

i just wanted to give jitsi meet a try -out of the box- but the remote
video-/audio does not show up. keyboard chat is ok.
we feel, it does not make a difference if jvb is running or not.

maybe it's important to mention, that all of our machines are placed
behind a firewall and do not have direct (no natting) internet accesss -
all internet access is done via an authenticating proxy (squid-3.5.7).

Does meet.jit.si work for you?

no, same effect - i thought that this might be due to the fact that our
clients cannot access external resources dirctly.

If your clients have UDP filtered you will need to setup videobridge
to work with TCP (and if they can't access ports other than 443,
that's what the bridge will have to use).

i'm not aware of any client side filters.

···

Am 30.09.2015 um 17:08 schrieb Boris Grozev:

On 30/09/15 09:42, Gustav Spellauge wrote:
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md


#4

from /var/log/jitsi/jvb.log on the server:

2015-08-30 15:15:22.455 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
java.specification.version=1.7
2015-08-30 15:15:22.456 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=videobridge
2015-08-30 15:15:22.458 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.460 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-defaults.properties with class loader, will continue without it.
2015-08-30 15:15:22.462 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.463 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-default-overrides.properties with class loader, will continue
without it.

···

*
*might my problem be related not found jitsi-defaults.properties and
jitsi-default-overrides.properties ? where shuld these files be located?
what should be it's contents?

Am 30.09.2015 um 17:08 schrieb Boris Grozev:

On 30/09/15 09:42, Gustav Spellauge wrote:

hello,

i just wanted to give jitsi meet a try -out of the box- but the remote
video-/audio does not show up. keyboard chat is ok.
we feel, it does not make a difference if jvb is running or not.

maybe it's important to mention, that all of our machines are placed
behind a firewall and do not have direct (no natting) internet accesss -
all internet access is done via an authenticating proxy (squid-3.5.7).

Does meet.jit.si work for you?

If your clients have UDP filtered you will need to setup videobridge
to work with TCP (and if they can't access ports other than 443,
that's what the bridge will have to use).

https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

No, these are harmless.

Regards,
Boris

···

On 30/09/15 10:42, Gustav Spellauge wrote:

from /var/log/jitsi/jvb.log on the server:

2015-08-30 15:15:22.455 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
java.specification.version=1.7
2015-08-30 15:15:22.456 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=videobridge
2015-08-30 15:15:22.458 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.460 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-defaults.properties with class loader, will continue without it.
2015-08-30 15:15:22.462 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.463 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-default-overrides.properties with class loader, will continue
without it.
*
*might my problem be related not found jitsi-defaults.properties and
jitsi-default-overrides.properties ? where shuld these files be located?
what should be it's contents?


#6

thanks for your answer

meeting is still not working. i guess, it might be a configuration problem.

during install, i changed jitsi.example.com to meeting.mydomain.com.
this resulted to

server_name meeting.mydomain.com in
/etc/nginx/sites-enabled/meeting.mydomain.com which seems to be correct
to me.

but in /etc/jitsi/meet/meeting.mydomain.com-config.js referenced by

    location /config.js {
        alias /etc/jitsi/meet/meeting.mydomain.com-config.js;
    }

i find the lines
       muc: 'conference.meeting.mydomain.com', // FIXME: use XEP-0030
       bridge: 'jitsi-videobridge.meeting.mydomain.com', // FIXME: use
XEP-0030

and i'm wondering, what these liens mean - are
conference.meeting.mydomain.com and
jitsi-videobridge.meeting.mydomain.com hostnames. if so, these hostnames
do not exist in my environment.

morover there is the line
   clientNode: 'http://jitsi.org/jitsimeet', // The name of client node
advertised in XEP-0115 'c' stanza
in /etc/jitsi/meet/meeting.mydomain.com-config.js and i wonder if this
correct.

maybe i did something wron during the installation.

still trying without any success, gustav

···

Am 30.09.2015 um 21:56 schrieb Boris Grozev:

On 30/09/15 10:42, Gustav Spellauge wrote:

from /var/log/jitsi/jvb.log on the server:

2015-08-30 15:15:22.455 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
java.specification.version=1.7
2015-08-30 15:15:22.456 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=videobridge
2015-08-30 15:15:22.458 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.460 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-defaults.properties with class loader, will continue
without it.
2015-08-30 15:15:22.462 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal
classloader
2015-08-30 15:15:22.463 INFO: [9]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to
find jitsi-default-overrides.properties with class loader, will continue
without it.
*
*might my problem be related not found jitsi-defaults.properties and
jitsi-default-overrides.properties ? where shuld these files be located?
what should be it's contents?

No, these are harmless.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi Gustav,

thanks for your answer

meeting is still not working. i guess, it might be a configuration problem.

during install, i changed jitsi.example.com to meeting.mydomain.com.
this resulted to

server_name meeting.mydomain.com in
/etc/nginx/sites-enabled/meeting.mydomain.com which seems to be correct
to me.

but in /etc/jitsi/meet/meeting.mydomain.com-config.js referenced by

     location /config.js {
         alias /etc/jitsi/meet/meeting.mydomain.com-config.js;
     }

i find the lines
        muc: 'conference.meeting.mydomain.com', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meeting.mydomain.com', // FIXME: use
XEP-0030

and i'm wondering, what these liens mean - are
conference.meeting.mydomain.com and
jitsi-videobridge.meeting.mydomain.com hostnames. if so, these hostnames
do not exist in my environment.

That's OK. These are used as identifiers in XMPP and prosody will recognize them.

morover there is the line
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node
advertised in XEP-0115 'c' stanza
in /etc/jitsi/meet/meeting.mydomain.com-config.js and i wonder if this
correct.

That's also OK -- it is an identifier of the XMPP client software (i.e. jitsi-meet).

You should next look at the logs from jicofo (or send them here).

Regards,
Boris

···

On 01/10/15 05:01, Gustav Spellauge wrote:


#8

hello boris,

here is my jicofo.log.

many thanks for your assistance, gustav

jicofo.log (17.6 KB)

···

Am 01.10.2015 um 17:18 schrieb Boris Grozev:

Hi Gustav,

On 01/10/15 05:01, Gustav Spellauge wrote:

thanks for your answer

meeting is still not working. i guess, it might be a configuration
problem.

during install, i changed jitsi.example.com to meeting.mydomain.com.
this resulted to

server_name meeting.mydomain.com in
/etc/nginx/sites-enabled/meeting.mydomain.com which seems to be correct
to me.

but in /etc/jitsi/meet/meeting.mydomain.com-config.js referenced by

     location /config.js {
         alias /etc/jitsi/meet/meeting.mydomain.com-config.js;
     }

i find the lines
        muc: 'conference.meeting.mydomain.com', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meeting.mydomain.com', // FIXME: use
XEP-0030

and i'm wondering, what these liens mean - are
conference.meeting.mydomain.com and
jitsi-videobridge.meeting.mydomain.com hostnames. if so, these hostnames
do not exist in my environment.

That's OK. These are used as identifiers in XMPP and prosody will
recognize them.

morover there is the line
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node
advertised in XEP-0115 'c' stanza
in /etc/jitsi/meet/meeting.mydomain.com-config.js and i wonder if this
correct.

That's also OK -- it is an identifier of the XMPP client software
(i.e. jitsi-meet).

You should next look at the logs from jicofo (or send them here).

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

hello,

- removed the ssl config from
"/etc/prosody/conf.d/meeting.softing.com.cfg.lua" -> no more
errors/stacktraces in /var/log/jitsi/jicofo.log

- installed firefox 41.0 on the linux machine - Debian GNU/Linux
8/Chromium-45.0.2454.85 seems to be unsuitable

problem solved - remote video/audio streams are working now.

thanks for the hints, gustav

ps.: this was step one - in step 2 i would like to replace prosody by
our existing ejabberd server. are there any howtos for this

···

Am 01.10.2015 um 19:08 schrieb Gustav Spellauge:

hello boris,

here is my jicofo.log.

many thanks for your assistance, gustav

Am 01.10.2015 um 17:18 schrieb Boris Grozev:

Hi Gustav,

On 01/10/15 05:01, Gustav Spellauge wrote:

thanks for your answer

meeting is still not working. i guess, it might be a configuration
problem.

during install, i changed jitsi.example.com to meeting.mydomain.com.
this resulted to

server_name meeting.mydomain.com in
/etc/nginx/sites-enabled/meeting.mydomain.com which seems to be correct
to me.

but in /etc/jitsi/meet/meeting.mydomain.com-config.js referenced by

     location /config.js {
         alias /etc/jitsi/meet/meeting.mydomain.com-config.js;
     }

i find the lines
        muc: 'conference.meeting.mydomain.com', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.meeting.mydomain.com', // FIXME: use
XEP-0030

and i'm wondering, what these liens mean - are
conference.meeting.mydomain.com and
jitsi-videobridge.meeting.mydomain.com hostnames. if so, these hostnames
do not exist in my environment.

That's OK. These are used as identifiers in XMPP and prosody will
recognize them.

morover there is the line
    clientNode: 'http://jitsi.org/jitsimeet', // The name of client node
advertised in XEP-0115 'c' stanza
in /etc/jitsi/meet/meeting.mydomain.com-config.js and i wonder if this
correct.

That's also OK -- it is an identifier of the XMPP client software
(i.e. jitsi-meet).

You should next look at the logs from jicofo (or send them here).


#10

hello,

- removed the ssl config from
"/etc/prosody/conf.d/meeting.softing.com.cfg.lua" -> no more
errors/stacktraces in /var/log/jitsi/jicofo.log

- installed firefox 41.0 on the linux machine - Debian GNU/Linux
8/Chromium-45.0.2454.85 seems to be unsuitable

problem solved - remote video/audio streams are working now.

Glad to hear you solved this. Just to clarify: this does *not* leave any signalling traffic leaving your server unencrypted (just between jicofo and prosody). Outside clients connect through HTTPS.

thanks for the hints, gustav

ps.: this was step one - in step 2 i would like to replace prosody by
our existing ejabberd server. are there any howtos for this

You can start here, but have in mind that this is for videobridge only:
https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

You will need to do the same thing for the jicofo component, find out how to enable anonymous logins, BOSH, and a MUC service.

Regards,
Boris

···

On 02/10/15 05:13, Gustav Spellauge wrote: