[jitsi-users] Jitsi-meet behind proxy


#1

Hi, I've been trying to set up a jitsi instnce, I want it to run on a
virtual machine without public a ip address. I followed this guide
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md ,
except it is a centos machine. I would like all traffic to go through a
machine with a public ip and an apache instance running.

I set up proxy there, the web loads correctly, but I get no video/audio
from others. I also noticed the following message:
"Pair failed: [vm's internal ip]:10000/udp/host -> [my laptop's internal
ip, a different network]/udp/host"

I set up myself a testing environment where the vm had a public ip, but web
traffic was still forwarded via apache on another machine. That worked
pretty well, video went directly to my laptop.

So my problem is probably video not getting through the machine running
apache, has anyone done this? Are there specific ports I need to open, any
changes I need to make to the config file?

Thanks

···

--
J.Tlustý


#2

You need to forward ports 10000-20000 udp besides 443 TCP. If you run the
web server a non standard port probably you have to make other adjustments
elsewhere too.

You have to explicitly specify

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=$localip
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=$realip

in

/etc/jitsi/videobridge/sip-communicator.properties

where $localip = your LAN address and $realip = your real address.

This works for me on a debian jessie VM with the default nginx setup.

···

On Mon, Dec 14, 2015 at 11:55 AM, Jan Tlusty <j.tlusty@gmail.com> wrote:

Hi, I've been trying to set up a jitsi instnce, I want it to run on a
virtual machine without public a ip address. I followed this guide
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md ,
except it is a centos machine. I would like all traffic to go through a
machine with a public ip and an apache instance running.

I set up proxy there, the web loads correctly, but I get no video/audio
from others. I also noticed the following message:
"Pair failed: [vm's internal ip]:10000/udp/host -> [my laptop's internal
ip, a different network]/udp/host"

I set up myself a testing environment where the vm had a public ip, but
web traffic was still forwarded via apache on another machine. That worked
pretty well, video went directly to my laptop.

So my problem is probably video not getting through the machine running
apache, has anyone done this? Are there specific ports I need to open, any
changes I need to make to the config file?

Thanks
--
J.Tlustý

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users