[jitsi-users] jitsi java webstart and duplicate GUI elements


#1

Hi,

When I launch Jitsi with Java Web Start I sometimes get strange Jitsi behavior. This usually happens when I compile a new Jitsi version and replace my web server's jws directory deploying the jnlp.

I tried cleaning the Java cache, made sure the Jitsi application did not appear in Contro Panel/Java, cleared the browser's cache.
I also tried to delete %APPDATA%\jitsi-jws (Windows 7 32 bits). It successfully deleted everything except for contactlist.xml and GNUZRTP4J.zid.

I then relaunched Jitsi via Java webstart and I started seeing these messages:

Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/22/2ec7cf96-17b5882f (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: jmork:1.0.5.SNAPSHOT)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/16/26ee2bd0-7eda56fa (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: com.ircclouds.irc.api:1.0.0.0015-SNAPSHOT)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/15/59c1b8cf-5fa0cb5a (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: log4j:1.2.17)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/44/304fa62c-3c26258a (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: commons-logging:1.1.2)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/24/55efd58-370b476b (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.apache.felix.bundlerepository:1.6.4)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/5/20c4a205-6d1ff234 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: bcprov:1.51.0)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/56/93d15b8-3b51fd82 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.jitsi.bccontrib:1.0.0.SNAPSHOT)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/58/128f823a-27281580 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.apache.commons.lang3:3.1.0)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/22/622d4816-333aaf5a (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: com.google.guava:15.0.0)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/20/a199714-618cb352 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: slf4j.api:1.7.5)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/63/3820823f-68bbacd5 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.apache.commons.codec:1.4.0)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/19/20687e93-55a9c5f6 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.apache.httpcomponents.httpcore:4.2.3)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/50/7ba2df32-4b7be7bb (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.apache.httpcomponents.httpclient:4.2.3)
Auto-properties install: reference:file:/C:/Users/vdipaola/AppData/LocalLow/Sun/Java/Deployment/cache/6.0/11/1aa4e7cb-2efe15c2 (org.osgi.framework.BundleException: Bundle symbolic name and version are not unique: org.hsqldb.hsqldb:2.3.1)

The application appears to launch fine but many GUI elements are duplicated. For instance, if I go to Options, I can see a lot of duplicated tabs. Please take a look at the attached screenshot.

Only rebooting the PC fixes the issue.

Any ideas?

Thanks,

Vieri