[jitsi-users] Jitsi is using huge memory usage under Win7 64bit


#1

Hi, just checked:
Win7 64 bits here.Commit: 134 MB, Private: 123 MB.

Currently using only 1 XMPP account. (I currently don’t use webcam or microphone or anything like that though. So, a pretty modest usage pattern.) It has been running at least overnight.

Danny

···

----- Original Message -----

From: calibu taranjik [mailto:kalibu@yandex.ru]

To: users@jitsi.org

Sent: Thu, 23 Jan 2014 05:06:58 +0400

Subject: [jitsi-users] Jitsi is using huge memory usage under Win7 64bit

Hi

Jitsi64 bit is using at least 1gb on my win64 system regardless off any talk, chat. It starts using around 1 gb even right after I start it. However whenn I force to use the 32bit version of jitsi it is around couple hundred at most.

thanks


users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#2

I've also noticed an important value of memory used by Jitsi nightly
x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
less (~500MB), but, IMHO, always too much.

Is there a way to reduce the amount of RAM used? Can it depend from
total RAM quantity installed?
At the moment I'm using it with only one SIP account configured.

Thanks,
Andrea

···

2014/1/23 Danny van Heumen <danny@dannyvanheumen.nl>:

Hi, just checked:
Win7 64 bits here.Commit: 134 MB, Private: 123 MB.

Currently using only 1 XMPP account. (I currently don't use webcam or
microphone or anything like that though. So, a pretty modest usage pattern.)
It has been running at least overnight.


#3

It looks like KDE does not remember to start Jitsi after restart, which is strange as it's a solid app which does not run on java command line...

figoli


#4

We are developing apps with JavaFX and noticed that a simplest demo uses up to
1.7 GB in 64 bit and mere 400 MB in 32 bit, so I'd rather let the dev team drop
64 bit support, especially that Jitsi does not need anywhere close to the memory
area where 64 bit would be justified. 64 bit is best left to database servers.

My 2c

Andrea Libralato <andrea.libralato@gmail.com> wrote :

···

I've also noticed an important value of memory used by Jitsi nightly
x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
less (~500MB), but, IMHO, always too much.

___________________________________
NOCC, http://nocc.sourceforge.net


#5

Java always is greedy, which means that if you have much RAM -
especially available RAM, it will consume much of it. It doesn't mean it
is a problem though. All OSes and computers since a few years back were
shipped as 64bit. No need to avoid supporting it. Users with older
systems would choose the 32bit version anyway, no?

I guess it would be possible to change memory usage with some
restrictive vmoptions. I don't know how that applies to Jitsi, since it
is a precompiled binary.

~A

···

On 2014-01-23 13:03, Andrea Libralato wrote:

2014/1/23 Danny van Heumen <danny@dannyvanheumen.nl>:

Hi, just checked:
Win7 64 bits here.Commit: 134 MB, Private: 123 MB.

Currently using only 1 XMPP account. (I currently don't use webcam or
microphone or anything like that though. So, a pretty modest usage pattern.)
It has been running at least overnight.

I've also noticed an important value of memory used by Jitsi nightly
x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
less (~500MB), but, IMHO, always too much.

Is there a way to reduce the amount of RAM used? Can it depend from
total RAM quantity installed?
At the moment I'm using it with only one SIP account configured.

Thanks,
Andrea

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Go to "startup applications" and add *jitsi* (without asterisk) as a
command to be executed upon system start.

I am not using KDE but you should be able to locate "startup
applications" setting somewhere in general system settings.

k.

···

On 01/23/2014 10:26 PM, info wrote:

It looks like KDE does not remember to start Jitsi after restart,
which is strange as it's a solid app which does not run on java
command line...

figoli

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

+ dev

Hey guys,

I did some tests today with compressed references ([1] [2]) to see if they
can help with the memory issues. The basic idea is that if you're using
less than 4 GB of heap space, you don't really need 64 bit pointers (i.e.
references) and you can keep them to 32 bits instead. Similarly, some VMs
support 35 or 36 bit references for 32/64 GB of heap space respectively.

I haven't tested extensively, but I do see some consistent improvements. I
added -Xcompressedrefs to the command line arguments. Here are the type of
results I'm seeing (one GMail account only, OS X 10.9):

Start Jitsi, don't do anything:
~280 MB with compressed references
~330 MB with normal references

Start Jitsi, hover over about 15 account to load additional info (avatars,
etc.):
~340 MB with compressed refs
~500 MB with normal references

Also, if we can figure out some upper bound on the size of the working set,
we can obviously use -XmxWhatever to limit the heap usage. As far as I
understand, if this limit is less than 4 GB, this option automatically
enables compressed references as well.

It would be great if someone can confirm (or refute) these numbers on other
OSes.

Cheers,
Ivan

1.
http://publib.boulder.ibm.com/infocenter/javasdk/v6r0/index.jsp?topic=%2Fcom.ibm.java.doc.diagnostics.60%2Fdiag%2Funderstanding%2Fmm_compressed_references.html
2. https://blogs.oracle.com/jrockit/entry/understanding_compressed_refer

···

On Thu, Jan 23, 2014 at 6:59 PM, A L <mail@lechevalier.se> wrote:

Java always is greedy, which means that if you have much RAM -
especially available RAM, it will consume much of it. It doesn't mean it
is a problem though. All OSes and computers since a few years back were
shipped as 64bit. No need to avoid supporting it. Users with older
systems would choose the 32bit version anyway, no?

I guess it would be possible to change memory usage with some
restrictive vmoptions. I don't know how that applies to Jitsi, since it
is a precompiled binary.

~A

On 2014-01-23 13:03, Andrea Libralato wrote:
> 2014/1/23 Danny van Heumen <danny@dannyvanheumen.nl>:
>> Hi, just checked:
>> Win7 64 bits here.Commit: 134 MB, Private: 123 MB.
>>
>> Currently using only 1 XMPP account. (I currently don't use webcam or
>> microphone or anything like that though. So, a pretty modest usage
pattern.)
>> It has been running at least overnight.
> I've also noticed an important value of memory used by Jitsi nightly
> x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
> several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
> less (~500MB), but, IMHO, always too much.
>
> Is there a way to reduce the amount of RAM used? Can it depend from
> total RAM quantity installed?
> At the moment I'm using it with only one SIP account configured.
>
> Thanks,
> Andrea
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

On Linux 64 bit (Debian) with 8 GB RAM it uses ~500MB, but if i edit the launcher and force the "-client -Xmx256m" option (which is used on 32 bit only for now), it will use ~200MB. I had no problems using this option so far.
I have 1 yahoo, 1 Google Talk, 1 SIP and 1 Facebook accounts in it.

BTW What happens if the 64 bit version is terminated? We will have to install 32 bit java too?

A L wrote:

···

Java always is greedy, which means that if you have much RAM -
especially available RAM, it will consume much of it. It doesn't mean it
is a problem though. All OSes and computers since a few years back were
shipped as 64bit. No need to avoid supporting it. Users with older
systems would choose the 32bit version anyway, no?

I guess it would be possible to change memory usage with some
restrictive vmoptions. I don't know how that applies to Jitsi, since it
is a precompiled binary.

~A

On 2014-01-23 13:03, Andrea Libralato wrote:

2014/1/23 Danny van Heumen <danny@dannyvanheumen.nl>:

Hi, just checked:
Win7 64 bits here.Commit: 134 MB, Private: 123 MB.

Currently using only 1 XMPP account. (I currently don't use webcam or
microphone or anything like that though. So, a pretty modest usage pattern.)
It has been running at least overnight.

I've also noticed an important value of memory used by Jitsi nightly
x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
less (~500MB), but, IMHO, always too much.

Is there a way to reduce the amount of RAM used? Can it depend from
total RAM quantity installed?
At the moment I'm using it with only one SIP account configured.

Thanks,
Andrea

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

On Linux 64 bit (Debian) with 8 GB RAM it uses ~500MB, but if i edit the
launcher and force the "-client -Xmx256m" option (which is used on 32 bit
only for now), it will use ~200MB. I had no problems using this option so
far.
I have 1 yahoo, 1 Google Talk, 1 SIP and 1 Facebook accounts in it.

BTW What happens if the 64 bit version is terminated? We will have to
install 32 bit java too?

If we do ditch it, then yes. Obviously we have other options before we
get there, so we'll think about those first.

Emil

···

On Tue, Feb 4, 2014 at 10:35 AM, Kertesz Laszlo <laszlo.kertesz@gmail.com> wrote:

A L wrote:

Java always is greedy, which means that if you have much RAM -
especially available RAM, it will consume much of it. It doesn't mean it
is a problem though. All OSes and computers since a few years back were
shipped as 64bit. No need to avoid supporting it. Users with older
systems would choose the 32bit version anyway, no?

I guess it would be possible to change memory usage with some
restrictive vmoptions. I don't know how that applies to Jitsi, since it
is a precompiled binary.

~A

On 2014-01-23 13:03, Andrea Libralato wrote:

2014/1/23 Danny van Heumen <danny@dannyvanheumen.nl>:

Hi, just checked:
Win7 64 bits here.Commit: 134 MB, Private: 123 MB.

Currently using only 1 XMPP account. (I currently don't use webcam or
microphone or anything like that though. So, a pretty modest usage
pattern.)
It has been running at least overnight.

I've also noticed an important value of memory used by Jitsi nightly
x64 2.3.x, about 800MB on a Win7 x64 with 8GB RAM and I've checked on
several other PC Win7 x86/x64 with 4GB RAM that the value is a bit
less (~500MB), but, IMHO, always too much.

Is there a way to reduce the amount of RAM used? Can it depend from
total RAM quantity installed?
At the moment I'm using it with only one SIP account configured.

Thanks,
Andrea

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#10

Hi all,

Apologies beforehand if it is a stupid question, but....

I've tried to add a conference room by going to File->Add chatroom. I've
written a desired name of the chatroom in the "Chat Room" box and
clicked on "Join". A chatroom window opened and all seems ok, but none
of the invitations I sent to my contacts have been received by them.

I assume I have to actually pick from a already existing list of
available chatrooms, instead of writing a name of a new one, right? If
so, where can I create a new one?

And also.... is there a privacy setting that would allow the new
chatroom to not be publicised and openly accessible to non-invitees?

thanks

karel


#11

Forgot to add that we are using xmpp jit.si network

···

---------------------------------------------

Hi all,

Apologies beforehand if it is a stupid question, but....

I've tried to add a conference room by going to File->Add chatroom. I've
written a desired name of the chatroom in the "Chat Room" box and
clicked on "Join". A chatroom window opened and all seems ok, but none
of the invitations I sent to my contacts have been received by them.

I assume I have to actually pick from a already existing list of
available chatrooms, instead of writing a name of a new one, right? If
so, where can I create a new one?

And also.... is there a privacy setting that would allow the new
chatroom to not be publicised and openly accessible to non-invitees?

thanks

karel


#12

Hey Karel,

Figuring this out would require looking through the XMPP packets that
get sent through your server.

Can you do this?

Emil

···

On Tue, Feb 4, 2014 at 5:53 PM, Karel Novotny <novotny.karel@gmail.com> wrote:

Hi all,

Apologies beforehand if it is a stupid question, but....

I've tried to add a conference room by going to File->Add chatroom. I've
written a desired name of the chatroom in the "Chat Room" box and
clicked on "Join". A chatroom window opened and all seems ok, but none
of the invitations I sent to my contacts have been received by them.

I assume I have to actually pick from a already existing list of
available chatrooms, instead of writing a name of a new one, right? If
so, where can I create a new one?

And also.... is there a privacy setting that would allow the new
chatroom to not be publicised and openly accessible to non-invitees?

thanks

karel

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#13

I see. Could you please open a ticket for this? Not sure when we will
be able to look into it though.

Emil

···

On Tue, Feb 4, 2014 at 5:57 PM, Karel Novotny <novotny.karel@gmail.com> wrote:

Forgot to add that we are using xmpp jit.si network


#14

Forgot to add that we are using xmpp jit.si network

I see. Could you please open a ticket for this? Not sure when we will
be able to look into it though.

Thanks Emil. I tried again and the room was successfully set-up. The
invitations didn't work though (none was received by any of the invitees).

karel

···

On 02/06/2014 04:40 AM, Emil Ivov wrote:

On Tue, Feb 4, 2014 at 5:57 PM, Karel Novotny <novotny.karel@gmail.com> wrote:

Emil

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#15

Something else on this:

I was able to create the chatroom, but

- No invitations received by invitees (I've already reported that)
- Although I clearly marked the chatroom/conference requiring password
to join, people who were given conference's address could join w/o any
password prompt. Issue in Jitsi or jit.si?

thanks for looking into this

karel

···

On 02/06/2014 04:40 AM, Emil Ivov wrote:

On Tue, Feb 4, 2014 at 5:57 PM, Karel Novotny <novotny.karel@gmail.com> wrote:

Forgot to add that we are using xmpp jit.si network

I see. Could you please open a ticket for this? Not sure when we will
be able to look into it though.

Emil

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users