[jitsi-users] Jitsi-Hammer installation on Ubuntu 16.04


#1

Hi
after cloning the repo, installed java:
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

installed maven:
Apache Maven 3.3.9

I've got the following error running:
./jitsi-hammer.sh -BOSHuri https://www.exmple.com/http-bind/ -users 10

tee: /home/andrea/git/jitsi-hammer/.jitsi-hammer/log/output.log: No such
file or directory
[INFO] Scanning for projects...
Downloading:
https://repo.maven.apache.org/maven2/org/codehaus/mojo/exec-maven-plugin/1.4.0/exec-maven-plugin-1.4.0.pom
[WARNING] Failed to retrieve plugin descriptor for
org.codehaus.mojo:exec-maven-plugin:1.4.0: Plugin
org.codehaus.mojo:exec-maven-plugin:1.4.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for
org.codehaus.mojo:exec-maven-plugin:jar:1.4.0
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-jar-plugin/2.4/maven-jar-plugin-2.4.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-jar-plugin:2.4: Plugin
org.apache.maven.plugins:maven-jar-plugin:2.4 or one of its dependencies
could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-jar-plugin:jar:2.4
Downloading:
https://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-surefire-plugin/2.18.1/maven-surefire-plugin-2.18.1.pom
[WARNING] Failed to retrieve plugin descriptor for
org.apache.maven.plugins:maven-surefire-plugin:2.18.1: Plugin
org.apache.maven.plugins:maven-surefire-plugin:2.18.1 or one of its
dependencies could not be resolved: Failed to read artifact descriptor for
org.apache.maven.plugins:maven-surefire-plugin:jar:2.18.1

resulting in:

[INFO]

···

------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 0.867 s
[INFO] Finished at: 2016-08-18T13:39:07+00:00
[INFO] Final Memory: 11M/171M
[INFO]
------------------------------------------------------------------------
[ERROR] No plugin found for prefix 'exec' in the current project and in the
plugin groups [org.apache.maven.plugins, org.codehaus.mojo] available from
the repositories [local (/root/.m2/repository), central (
https://repo.maven.apache.org/maven2)] -> [Help 1]

Any suggestion?

thanks

--

[image: Andrea Magatti on about.me]

Andrea Magatti
about.me/amagatti
  <http://about.me/amagatti>