[jitsi-users] Jitsi fails to start on Windows 7


#1

Hi,

I installed the latest Jitsi Client on Windows 7 and configured it.
Now 2 days later, it refuses to start. Using debug mode shows the attached errors.

I tried reinstalling it, uninstalled the 32-bit version, installed the 64-bit Version, no change.
I managed to get it working by deleting the Jitsi folder in local AppData (%User%/AppData/Local/Jitsi).

I'm just writing you to let you know. Hopefully this was a one-time error, but if this is recurring we will need a solution.

Kind regards,

Peter

jitsierror.txt (162 KB)


#2

Hi Peter,

Did you install as an upgrade, or was this the first time you installed
Jitsi?

What I'm seeing in the log is that all the libraries are missing which
implement the various aspects of Jitsi. An overly large part (maybe even
all of them) are not able to be loaded. I'm not sure how this has
happened. This should not be an issue.

One thing I can imagine, is that (part of) the Jitsi user directory
(%user%/AppData/Local/Jitsi) did not have write permissions for the
current user. Might you have started Jitsi for the first time using an
administrator account? I'm not sure about this, but it seems reasonable.

Indeed, deleting this directory lets Jitsi recreate it (as the current
user) so that fixes it. If others are reading this. It should be
sufficient to delete "%user%/AppData/Local/Jitsi/sip-communicator.bin"
directory. This would leave your personal settings in tact.

Kind regards,
Danny

···

On 08-05-15 15:05, Peter Schmidt wrote:

Hi,

I installed the latest Jitsi Client on Windows 7 and configured it.
Now 2 days later, it refuses to start. Using debug mode shows the
attached errors.

I tried reinstalling it, uninstalled the 32-bit version, installed the
64-bit Version, no change.
I managed to get it working by deleting the Jitsi folder in local
AppData (%User%/AppData/Local/Jitsi).

I'm just writing you to let you know. Hopefully this was a one-time
error, but if this is recurring we will need a solution.

Kind regards,

Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi Danny,

my original intention was showing the error to the devs and to document the workaround/solution for others.

It was the first installation of Jitsi (32-bit). After the error occurred I repaired the installation, re-installed it, uninstalled it and installed 64 bit Version.

Now that you mention it:
The user has local administrator rights on the machine (this is a windows domain network). I installed Jitsi and (possibly) it got launched right from the installer. I guess that this way Jitsi had administrative rights when it was run the first time (and created the plugins data in local AppData with administrative rights).

After a reboot, Jitsi started again and had no administrative rights (it was not started with "run as administrator").
Maybe that caused the problems.
If that was the reason, someone should fix the installers option for running Jitsi right from the installer.
Maybe someone with a virtual machine and windows 7 could test this?

Kind regards,

Peter

···

On 2015-05-09 19:54, Danny van Heumen wrote:

Hi Peter,

Did you install as an upgrade, or was this the first time you installed
Jitsi?

What I'm seeing in the log is that all the libraries are missing which
implement the various aspects of Jitsi. An overly large part (maybe even
all of them) are not able to be loaded. I'm not sure how this has
happened. This should not be an issue.

One thing I can imagine, is that (part of) the Jitsi user directory
(%user%/AppData/Local/Jitsi) did not have write permissions for the
current user. Might you have started Jitsi for the first time using an
administrator account? I'm not sure about this, but it seems reasonable.

Indeed, deleting this directory lets Jitsi recreate it (as the current
user) so that fixes it. If others are reading this. It should be
sufficient to delete "%user%/AppData/Local/Jitsi/sip-communicator.bin"
directory. This would leave your personal settings in tact.

Kind regards,
Danny

On 08-05-15 15:05, Peter Schmidt wrote:

Hi,

I installed the latest Jitsi Client on Windows 7 and configured it.
Now 2 days later, it refuses to start. Using debug mode shows the
attached errors.

I tried reinstalling it, uninstalled the 32-bit version, installed the
64-bit Version, no change.
I managed to get it working by deleting the Jitsi folder in local
AppData (%User%/AppData/Local/Jitsi).

I'm just writing you to let you know. Hopefully this was a one-time
error, but if this is recurring we will need a solution.

Kind regards,

Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users