[jitsi-users] Jitsi Disconnects on Secure Chat Begin (OTR)


#1

Hello,

I'm running:

Debian Wheezy (stable)
AMD64
jabber.org account
Jitsi 2.5.5065-1 amd64
java: oracle-j2re1.7 1.7.0+update51

[1] When i want to initiate Secure Chat with another friend with Jitsi
(same version, he is on jit.si xmpp server, and openjdk-7 java version
"1.7.0_51" 7u51-2.4.4-0ubuntu0.13.04.2) connection with xmpp server
closes and re-open

Sometimes when securechat is stablished and validated, when click to
Terminate conversation, connection to xmpp server closes and re-open.

My friend's connection to xmpp server is always up.

We test this case over internet, and in the same wireless lan.

[2] Another case is contacting over internet with jitsi + otr with java
version "1.7.0_21" from openjdk-7 7u21-2.3.9-5 in this case, when
established OTR communication, i receive friends message without
encryption (jitsi advertise me about this)

[1] 23:21:59.232 Grave: [58]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectionClosedOnError().2117
connectionClosedOnError stream:error (invalid-xml)

java.lang.IllegalArgumentException: No enum constant
org.jivesoftware.smack.packet.XMPPError.Type.501
  at java.lang.Enum.valueOf(Unknown Source)
  at org.jivesoftware.smack.packet.XMPPError$Type.valueOf(XMPPError.java:303)
  at
org.jivesoftware.smack.util.PacketParserUtils.parseError(PacketParserUtils.java:742)
  at
org.jivesoftware.smack.util.PacketParserUtils.parseIQ(PacketParserUtils.java:285)
  at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:229)
  at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:43)
  at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:70)

[2] Same log as above

Thanks


#2

[1] 23:21:59.232 Grave: [58]
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectionClosedOn
Erro r().2117 connectionClosedOnError stream:error (invalid-xml)

java.lang.IllegalArgumentException: No enum constant
org.jivesoftware.smack.packet.XMPPError.Type.501 at
java.lang.Enum.valueOf(Unknown Source) at
org.jivesoftware.smack.packet.XMPPError$Type.valueOf(XMPPError.java:303)
  at
org.jivesoftware.smack.util.PacketParserUtils.parseError(PacketParserUtil
s.ja va:742) at
org.jivesoftware.smack.util.PacketParserUtils.parseIQ(PacketParserUtils.j
ava: 285) at
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:229)
  at

org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:43)

  at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:70)

I cannot reproduce this. Can you please send us your entire logs
(https://jitsi.org/logs, especially include the .pcaps) when this happens?
If you don't want it publicly on the list, you can send them to me
privately.

Thanks

Ingo