[jitsi-users] Jitsi connection problems in win7


#1

Hello,

this morning a problem sometime some colleagues of mine already had and that was
never solved happened again: their Jitsi client suddenly can not connect to our pbx
(sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java installation is ok, local
machine firewall is off and they can ping pbx and ejabberd2. Jitsi on that machine
worked perfectly till yesterday. On Linux Debian I never had such kind of problems on
the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name: /xxx@pbx/[1],
Server name: pbx. Please check your settings or contact your network administrator
for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No address found for
ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,
  Matteo

···

--------
[1] mailto:xxx@pbx


#2

Have you tried looking at an ethereal trace? Do you see any packets going to your server? Also, is "pbx" really the name you used? If so, does that resolve in your local DNS?

Emil

···

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had and
that was never solved happened again: their Jitsi client suddenly can
not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java
installation is ok, local machine firewall is off and they can ping pbx
and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On
Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:
xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your settings
or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No
address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#3

No, but on server I can't see authentication attempts from that client even
if I can ping server from client. Yes, pbx resolves correctly and it worked till
yesterday. On another machine with the same problem I changed sip client
and it worked, some times ago.

Matteo

···

-----------------------------------------------------------------------------
From: Emil Ivov <emcho@jitsi.org>
Sent: mercoledì 2 aprile 2014
To: Jitsi Users <users@jitsi.org>
Cc:
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets
going to your server? Also, is "pbx" really the name you used? If so,
does that resolve in your local DNS?

Emil

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had

and

that was never solved happened again: their Jitsi client suddenly can
not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java
installation is ok, local machine firewall is off and they can ping pbx
and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On
Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:
xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your

settings

or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error

message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]
impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No
address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Matteo Calorio
Linux & OpenSource systems
O.R.S. s.r.l.
V. Morando 1-3
12060 Roddi (CN) - Italy
Tel. +39 173 620 211 (int.245)


#4

Are these laptops?

Aaron

···

From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Matteo Calorio
Sent: Wednesday, April 2, 2014 5:38 PM
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi connection problems in win7

No, but on server I can't see authentication attempts from that client even if I can ping server from client. Yes, pbx resolves correctly and it worked till yesterday. On another machine with the same problem I changed sip client and it worked, some times ago.

Matteo

-----------------------------------------------------------------------------

From: Emil Ivov <emcho@jitsi.org<mailto:emcho@jitsi.org>>

Sent: mercoledì 2 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets

going to your server? Also, is "pbx" really the name you used? If so,

does that resolve in your local DNS?

Emil

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had and

that was never solved happened again: their Jitsi client suddenly can

not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java

installation is ok, local machine firewall is off and they can ping pbx

and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On

Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:

xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your settings

or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]

impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No

address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________

users mailing list

users@jitsi.org<mailto:users@jitsi.org>

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Matteo Calorio

Linux & OpenSource systems

O.R.S. s.r.l.

V. Morando 1-3

12060 Roddi (CN) - Italy

Tel. +39 173 620 211 (int.245)


#5

Some are laptops, some are desktops.

Matteo

···

-----------------------------------------------------------------------------
From: Aaron Dixon <Aaron.Dixon@ssdcservices.com>
Sent: domenica 13 aprile 2014
To: Jitsi Users <users@jitsi.org>
Cc:
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Are these laptops?

Aaron

From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Matteo
Calorio
Sent: Wednesday, April 2, 2014 5:38 PM
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi connection problems in win7

No, but on server I can't see authentication attempts from that client even if I can ping
server from client. Yes, pbx resolves correctly and it worked till yesterday. On another
machine with the same problem I changed sip client and it worked, some times ago.

Matteo

-----------------------------------------------------------------------------

From: Emil Ivov <emcho@jitsi.org<mailto:emcho@jitsi.org>>

Sent: mercoledì 2 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets

going to your server? Also, is "pbx" really the name you used? If so,

does that resolve in your local DNS?

Emil

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had and

that was never solved happened again: their Jitsi client suddenly can

not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java

installation is ok, local machine firewall is off and they can ping pbx

and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On

Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:

xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your settings

or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]

impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No

address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________

users mailing list

users@jitsi.org<mailto:users@jitsi.org>

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users


#6

OK. I was thinking your issue might be similar to the issue I experienced with laptops that roamed other networks (such as their home network).

Ingo pointed out that there is a bug in java that makes Jitsi sometimes use the DNS server of a disabled (non-active) network interface in Windows.

But if this is happening on desktops then this is not the case (unless your users carry their desktops home with them lol)

Aaron Dixon | IT Specialist | SSDC Services

···

Office: 248-277-9304 | Cell: 248-935-7353 | aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Sent: Monday, April 14, 2014 3:41 AM
To: users@jitsi.org
Cc: Aaron Dixon
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Some are laptops, some are desktops.

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon <Aaron.Dixon@ssdcservices.com>

Sent: domenica 13 aprile 2014

To: Jitsi Users <users@jitsi.org>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Are these laptops?

Aaron

From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Matteo Calorio

Sent: Wednesday, April 2, 2014 5:38 PM

To: Jitsi Users

Subject: Re: [jitsi-users] Jitsi connection problems in win7

No, but on server I can't see authentication attempts from that client even if I can ping server from client. Yes, pbx resolves correctly and it worked till yesterday. On another machine with the same problem I changed sip client and it worked, some times ago.

Matteo

-----------------------------------------------------------------------------

From: Emil Ivov <emcho@jitsi.org<mailto:emcho@jitsi.org>>

Sent: mercoledì 2 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets

going to your server? Also, is "pbx" really the name you used? If so,

does that resolve in your local DNS?

Emil

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had and

that was never solved happened again: their Jitsi client suddenly can

not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java

installation is ok, local machine firewall is off and they can ping pbx

and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On

Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:

xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your settings

or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]

impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No

address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________

users mailing list

users@jitsi.org<mailto:users@jitsi.org>

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Matteo Calorio

Linux & OpenSource systems

O.R.S. s.r.l.

V. Morando 1-3

12060 Roddi (CN) - Italy

Tel. +39 173 620 211 (int.245)


#7

Very interesting! Are there any solutions or workarounds to that bug? Or is there a
place where is possible to change Java DNS configuration?

Matteo

···

-----------------------------------------------------------------------------
From: Aaron Dixon <Aaron.Dixon@ssdcservices.com>
Sent: mercoledì 16 aprile 2014
To: users@jitsi.org <users@jitsi.org>
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subject: RE: [jitsi-users] Jitsi connection problems in win7

OK. I was thinking your issue might be similar to the issue I experienced with laptops
that roamed other networks (such as their home network).

Ingo pointed out that there is a bug in java that makes Jitsi sometimes use the DNS
server of a disabled (non-active) network interface in Windows.

But if this is happening on desktops then this is not the case (unless your users carry
their desktops home with them lol)

Aaron Dixon | IT Specialist | SSDC Services
Office: 248-277-9304 | Cell: 248-935-7353 |
aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Sent: Monday, April 14, 2014 3:41 AM
To: users@jitsi.org
Cc: Aaron Dixon
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Some are laptops, some are desktops.

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon <Aaron.Dixon@ssdcservices.com>

Sent: domenica 13 aprile 2014

To: Jitsi Users <users@jitsi.org>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Are these laptops?

Aaron

From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Matteo
Calorio

Sent: Wednesday, April 2, 2014 5:38 PM

To: Jitsi Users

Subject: Re: [jitsi-users] Jitsi connection problems in win7

No, but on server I can't see authentication attempts from that client even if I can ping
server from client. Yes, pbx resolves correctly and it worked till yesterday. On another
machine with the same problem I changed sip client and it worked, some times ago.

Matteo

-----------------------------------------------------------------------------

From: Emil Ivov <emcho@jitsi.org<mailto:emcho@jitsi.org>>

Sent: mercoledì 2 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets

going to your server? Also, is "pbx" really the name you used? If so,

does that resolve in your local DNS?

Emil


#8

There is no official workaround.

My workaround was to add my DNS records to our public DNS (GoDaddy).

Because the DNS on the disabled adapter may have been pointed toward a public DNS server which will then be able to resolve your server.

Alternatively, you can use IP Addresses when setting up Jitsi instead of a hostname that must be resolved.

Aaron Dixon | IT Specialist | SSDC Services

···

Office: 248-277-9304 | Cell: 248-935-7353 | aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Sent: Wednesday, April 16, 2014 3:07 AM
To: Aaron Dixon
Cc: users@jitsi.org
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Very interesting! Are there any solutions or workarounds to that bug? Or is there a place where is possible to change Java DNS configuration?

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon <Aaron.Dixon@ssdcservices.com<mailto:Aaron.Dixon@ssdcservices.com>>

Sent: mercoledì 16 aprile 2014

To: users@jitsi.org<mailto:users@jitsi.org> <users@jitsi.org<mailto:users@jitsi.org>>

Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it<mailto:matteo.calorio@linux.ors-tech.it>>

Subject: RE: [jitsi-users] Jitsi connection problems in win7

OK. I was thinking your issue might be similar to the issue I experienced with laptops that roamed other networks (such as their home network).

Ingo pointed out that there is a bug in java that makes Jitsi sometimes use the DNS server of a disabled (non-active) network interface in Windows.

But if this is happening on desktops then this is not the case (unless your users carry their desktops home with them lol)

Aaron Dixon | IT Specialist | SSDC Services

Office: 248-277-9304 | Cell: 248-935-7353 | aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com%3cmailto:aaron.dixon@ssdcservices.com>>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]

Sent: Monday, April 14, 2014 3:41 AM

To: users@jitsi.org<mailto:users@jitsi.org>

Cc: Aaron Dixon

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Some are laptops, some are desktops.

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon <Aaron.Dixon@ssdcservices.com<mailto:Aaron.Dixon@ssdcservices.com>>

Sent: domenica 13 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Are these laptops?

Aaron

From: users-bounces@jitsi.org<mailto:users-bounces@jitsi.org> [mailto:users-bounces@jitsi.org] On Behalf Of Matteo Calorio

Sent: Wednesday, April 2, 2014 5:38 PM

To: Jitsi Users

Subject: Re: [jitsi-users] Jitsi connection problems in win7

No, but on server I can't see authentication attempts from that client even if I can ping server from client. Yes, pbx resolves correctly and it worked till yesterday. On another machine with the same problem I changed sip client and it worked, some times ago.

Matteo

-----------------------------------------------------------------------------

From: Emil Ivov <emcho@jitsi.org<mailto:emcho@jitsi.org<mailto:emcho@jitsi.org%3cmailto:emcho@jitsi.org>>>

Sent: mercoledì 2 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org<mailto:users@jitsi.org%3cmailto:users@jitsi.org>>>

Cc:

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Have you tried looking at an ethereal trace? Do you see any packets

going to your server? Also, is "pbx" really the name you used? If so,

does that resolve in your local DNS?

Emil

On 02.04.14, 12:36, Matteo Calorio wrote:

Hello,

this morning a problem sometime some colleagues of mine already had and

that was never solved happened again: their Jitsi client suddenly can

not connect to our pbx (sip) nor to our ejabberd2 server (xmpp).

Updating to last Jitsi version doesn't solve the problem, Java

installation is ok, local machine firewall is off and they can ping pbx

and ejabberd2. Jitsi on that machine worked perfectly till yesterday. On

Linux Debian I never had such kind of problems on the same network.

The error they get is:

"Jitsi: Error - Connection failed for the following account: User name:

xxx@pbx <mailto:xxx@pbx>, Server name: pbx. Please check your settings

or contact your network administrator for more informations."

Launching Jitsi from command line in debug mode gives this error message:

C:\Users\xxx>"C:\Program Files\Jitsi\Jitsi.exe" -d

11:11:49.838 SEVERE: [60]

impl.protocol.sip.ProtocolProviderServiceSipImpl.register().310 No

address found for ProtocolProviderServiceSipImpl(XXX (SIP))

Any Idea?

Bye,

Matteo

_______________________________________________

users mailing list

users@jitsi.org<mailto:users@jitsi.org<mailto:users@jitsi.org%3cmailto:users@jitsi.org>>

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Matteo Calorio

Linux & OpenSource systems

O.R.S. s.r.l.

V. Morando 1-3

12060 Roddi (CN) - Italy

Tel. +39 173 620 211 (int.245)


#9

Hello, I found this, but I don't know how to use it nor if it works or not...

/http://stackoverflow.com/questions/1256556/any-way-to-make-java-honor-the-dns-caching-timeout-ttl/[1]

Bye,
  Matteo

···

-----------------------------------------------------------------------------
From: Aaron Dixon <Aaron.Dixon@ssdcservices.com>
Sent: mercoledì 16 aprile 2014
To: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Cc: users@jitsi.org <users@jitsi.org>
Subject: RE: [jitsi-users] Jitsi connection problems in win7

There is no official workaround.

My workaround was to add my DNS records to our public DNS (GoDaddy).

Because the DNS on the disabled adapter may have been pointed toward a public
DNS server which will then be able to resolve your server.

Alternatively, you can use IP Addresses when setting up Jitsi instead of a hostname
that must be resolved.

Aaron Dixon | IT Specialist | SSDC Services
Office: 248-277-9304 | Cell: 248-935-7353 |
aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]
Sent: Wednesday, April 16, 2014 3:07 AM
To: Aaron Dixon
Cc: users@jitsi.org
Subject: Re: [jitsi-users] Jitsi connection problems in win7

Very interesting! Are there any solutions or workarounds to that bug? Or is there a
place where is possible to change Java DNS configuration?

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon
<Aaron.Dixon@ssdcservices.com<mailto:Aaron.Dixon@ssdcservices.com>>

Sent: mercoledì 16 aprile 2014

To: users@jitsi.org<mailto:users@jitsi.org>
<users@jitsi.org<mailto:users@jitsi.org>>

Cc: Matteo Calorio <matteo.calorio@linux.ors-
tech.it<mailto:matteo.calorio@linux.ors-tech.it>>

Subject: RE: [jitsi-users] Jitsi connection problems in win7

OK. I was thinking your issue might be similar to the issue I experienced with laptops
that roamed other networks (such as their home network).

Ingo pointed out that there is a bug in java that makes Jitsi sometimes use the DNS
server of a disabled (non-active) network interface in Windows.

But if this is happening on desktops then this is not the case (unless your users carry
their desktops home with them lol)

Aaron Dixon | IT Specialist | SSDC Services

Office: 248-277-9304 | Cell: 248-935-7353 |
aaron.dixon@ssdcservices.com<mailto:aaron.dixon@ssdcservices.com<mailto:aaron
.dixon@ssdcservices.com%3cmailto:aaron.dixon@ssdcservices.com>>

From: Matteo Calorio [mailto:matteo.calorio@linux.ors-tech.it]

Sent: Monday, April 14, 2014 3:41 AM

To: users@jitsi.org<mailto:users@jitsi.org>

Cc: Aaron Dixon

Subject: Re: [jitsi-users] Jitsi connection problems in win7

Some are laptops, some are desktops.

Matteo

-----------------------------------------------------------------------------

From: Aaron Dixon
<Aaron.Dixon@ssdcservices.com<mailto:Aaron.Dixon@ssdcservices.com>>

Sent: domenica 13 aprile 2014

To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>

Cc: