[jitsi-users] Jitsi client ignores server set SIP contact expiry


#1

I'm using Jitsi for Windows 2.10.5550. The client requests a contact
expiry of 600 seconds (in the SIP Contact header). The Registrar returns an
expiry of 90 seconds (in the SIP Contact header).
Jitsi appears to ignore this value and just re-registers as if the contact
expiry was as originally requested (i.e. after every 540 seconds).
This causes the client to become un-registered for long periods of time and
so does not receive calls.
I've seen this issue on a number of different Windows installs.
It was mentioned on this list back in 2015 (
http://lists.jitsi.org/pipermail/users/2015-November/010509.html) but I've
seen no further mention of the problem.


#2

I'm using Jitsi for Windows 2.10.5550. The client requests a contact expiry
of 600 seconds (in the SIP Contact header). The Registrar returns an expiry
of 90 seconds (in the SIP Contact header).
Jitsi appears to ignore this value and just re-registers as if the contact
expiry was as originally requested (i.e. after every 540 seconds).
This causes the client to become un-registered for long periods of time and
so does not receive calls.
I've seen this issue on a number of different Windows installs.
It was mentioned on this list back in 2015
(http://lists.jitsi.org/pipermail/users/2015-November/010509.html) but I've
seen no further mention of the problem.

Could you please create an issue on Github and link to the mailing list thread mentioned above? In the meantime, please configure the SIP account as described in the same thread.

Ingo