[jitsi-users] Jitsi client and Jitsi VideoBRIDGE + ejabberd


#1

I have a question after seeing a mailing list, I have a ejabberd
server (14.07) on a server and have another server Jitsi VideoBRIDGE ,
I can make video call between buddy, the strange thing is seeing a
mailing list, to make a VideoBRIDGE with client Jitsi the option is
grey and inactive.

I pass them a configuration code in ejabberd and Jitsi with debian:

ejabberd.yml

···

-
    port: 5347
    module: ejabberd_service
    hosts:
       "jitsi-videobridge.domain.com":
         password: "XXXXX1"

jitsi videobridge

JVB_HOSTNAME=jitsi-videobridge.domain.com
JVB_PORT=5347
JVB_SECRET=XXXXX1
JVB_OPTS=""

I can see that Jitsi VideoBRIDGE port is listening on both servers!
netstat -an | grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN

### ejabberd server### :
netstat -an | grep 5347
tcp 0 0 0.0.0.0:5347 0.0.0.0:*
     LISTEN

any idea?

--
rickygm

http://gnuforever.homelinux.com


#2

Hi,

you can change the following option in jvb config to specify the host
where ejabberd is listening and where jvb will connect:
JVB_OPTS="--host=ip-address-ejabberd"
By default jvb connects to localhost. I think this will work.

Regards
damencho

···

On Tue, Dec 2, 2014 at 5:41 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

I have a question after seeing a mailing list, I have a ejabberd
server (14.07) on a server and have another server Jitsi VideoBRIDGE ,
I can make video call between buddy, the strange thing is seeing a
mailing list, to make a VideoBRIDGE with client Jitsi the option is
grey and inactive.

I pass them a configuration code in ejabberd and Jitsi with debian:

ejabberd.yml

-
    port: 5347
    module: ejabberd_service
    hosts:
       "jitsi-videobridge.domain.com":
         password: "XXXXX1"

jitsi videobridge

JVB_HOSTNAME=jitsi-videobridge.domain.com
JVB_PORT=5347
JVB_SECRET=XXXXX1
JVB_OPTS=""

I can see that Jitsi VideoBRIDGE port is listening on both servers!
netstat -an | grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN

### ejabberd server### :
netstat -an | grep 5347
tcp 0 0 0.0.0.0:5347 0.0.0.0:*
     LISTEN

any idea?

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi damian, I made the changes but the option is still grayed.

my config videobridge
JVB_OPTS="--host=172.16.8.59"

···

2014-12-02 9:55 GMT-06:00 Damian Minkov <damencho@jitsi.org>:

Hi,

you can change the following option in jvb config to specify the host
where ejabberd is listening and where jvb will connect:
JVB_OPTS="--host=ip-address-ejabberd"
By default jvb connects to localhost. I think this will work.

Regards
damencho

On Tue, Dec 2, 2014 at 5:41 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

I have a question after seeing a mailing list, I have a ejabberd
server (14.07) on a server and have another server Jitsi VideoBRIDGE ,
I can make video call between buddy, the strange thing is seeing a
mailing list, to make a VideoBRIDGE with client Jitsi the option is
grey and inactive.

I pass them a configuration code in ejabberd and Jitsi with debian:

ejabberd.yml

-
    port: 5347
    module: ejabberd_service
    hosts:
       "jitsi-videobridge.domain.com":
         password: "XXXXX1"

jitsi videobridge

JVB_HOSTNAME=jitsi-videobridge.domain.com
JVB_PORT=5347
JVB_SECRET=XXXXX1
JVB_OPTS=""

I can see that Jitsi VideoBRIDGE port is listening on both servers!
netstat -an | grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN

### ejabberd server### :
netstat -an | grep 5347
tcp 0 0 0.0.0.0:5347 0.0.0.0:*
     LISTEN

any idea?

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com


#4

Check the jitsi-videobridge logs for error when connecting, it can be
firewall or something.

···

On Tue, Dec 2, 2014 at 6:34 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

Hi damian, I made the changes but the option is still grayed.


#5

Hi,

       the only thing I see in log jvb, is this:

14:27:58.761 INFO: [10]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_NAME=.sip-communicator
14:27:58.761 INFO: [10]
org.jitsi.videobridge.osgi.OSGiBundleActivator.info()
net.java.sip.communicator.SC_HOME_DIR_LOCATION=/usr/share/jitsi-v
ideobridge
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for
further details.
14:27:58.818 SEVERE: [11] util.UtilActivator.uncaughtException().108
An uncaught exception occurred in thread=Thread[main,5,main] and
message w
as: java.net.NoRouteToHostException: No route to host
org.xmpp.component.ComponentException:
java.net.NoRouteToHostException: No route to host
        at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
        at org.jitsi.videobridge.Main.main(Main.java:273)
Caused by: java.net.NoRouteToHostException: No route to host
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:327)
        at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:193)
        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:180)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:385)
        at java.net.Socket.connect(Socket.java:546)
        at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)
        ... 3 more

in this server my firewall is disabled , on ejabberd the port is open
with iptables "5347".

···

2014-12-02 14:04 GMT-06:00 Damian Minkov <damencho@jitsi.org>:

On Tue, Dec 2, 2014 at 6:34 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

Hi damian, I made the changes but the option is still grayed.

Check the jitsi-videobridge logs for error when connecting, it can be
firewall or something.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com


#6

NoRouteToHostException. Seems cannot connect to that address, strange.