[jitsi-users] Jitsi can't take incoming sip calls anymore


#1

Hi folks,

since a few days, i have problems with incoming sip calls.

I can call out, but the jingle of an incoming call can't be played.
I have no problems taking Jabber calls.

I can see this, when i start jitsi in a bash shell :

ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_dmix.c:968:(snd_pcm_dmix_open) The dmix plugin supports
only playback stream
ALSA lib pcm_dmix.c:1029:(snd_pcm_dmix_open) unable to open slave

For every line of this SIP INVITE :

12:57:03.759178 IP 217.10.79.9.sip > 192.168.0.34.sip: SIP
12:57:03.929772 IP 217.10.79.9.sip > 192.168.0.34.sip: SIP: INVITE
sip:XXXXXXXXX@192.168.0.34:5060;transport=udp;registering_acc=sipgate_de
SIP/2.0

i get a corresponding error message from jitsi in the console :

2017-07-29 12:31:23.602 SCHWERWIEGEND: [165]
impl.protocol.sip.SipStackSharing.findTargetFor().922 no listeners
2017-07-29 12:31:23.602 SCHWERWIEGEND: [165]
impl.protocol.sip.SipStackSharing.processRequest().709 couldn't find a
ProtocolProviderServiceSipImpl to dispatch to

(YES, the dates are from two different debug sessions , forget about them )

I found a years old ML entry about the exact same problem, but there was
never a solution.

My MOBILE Phone with Jitsi can take the incoming call, so it's not a
DSL Router problem.
Jitsi had not have updates in month now => not the cause
I upgraded to 2.11 nightly => no change

Can my config be damaged ? Maybe .. any ideas ?

I get a error message for each incoming SIP INVITE => not a firewall issue

What else could it be ???

best regards,
Marius


#2

Small update:

Two days ago was a Java Update :

/var/log/dnf.rpm.log:Jul 27 10:02:04 INFO Upgraded:
java-1.8.0-openjdk-headless-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:04 INFO Upgraded:
java-1.8.0-openjdk-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:09 INFO Upgraded:
java-1.8.0-openjdk-devel-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:43 INFO Upgraded:
java-1.8.0-openjdk-javadoc-1:1.8.0.141-1.b16.fc25.noarch
/var/log/dnf.rpm.log:Jul 27 10:03:25 INFO Cleanup:
java-1.8.0-openjdk-devel-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:30 INFO Cleanup:
java-1.8.0-openjdk-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:30 INFO Cleanup:
java-1.8.0-openjdk-headless-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:32 INFO Cleanup:
java-1.8.0-openjdk-javadoc-1:1.8.0.131-1.b12.fc25.noarch

Could that be causing the problem?

Marius


#3

since a few days, i have problems with incoming sip calls.

I can call out, but the jingle of an incoming call can't be played.
I have no problems taking Jabber calls.

I can see this, when i start jitsi in a bash shell :

ALSA ...
[...]

These come from Alsa directly and are irrelevant.

For every line of this SIP INVITE :

12:57:03.759178 IP 217.10.79.9.sip > 192.168.0.34.sip: SIP
12:57:03.929772 IP 217.10.79.9.sip > 192.168.0.34.sip: SIP: INVITE
sip:XXXXXXXXX@192.168.0.34:5060;transport=udp;registering_acc=sipgate_de
SIP/2.0

i get a corresponding error message from jitsi in the console :

2017-07-29 12:31:23.602 SCHWERWIEGEND: [165]
impl.protocol.sip.SipStackSharing.findTargetFor().922 no listeners
2017-07-29 12:31:23.602 SCHWERWIEGEND: [165]
impl.protocol.sip.SipStackSharing.processRequest().709 couldn't find a
ProtocolProviderServiceSipImpl to dispatch to

(YES, the dates are from two different debug sessions , forget about them )

I found a years old ML entry about the exact same problem, but there was
never a solution.

My MOBILE Phone with Jitsi can take the incoming call, so it's not a
DSL Router problem.

Huh? What are you using there? Jitsi Android?

Jitsi had not have updates in month now => not the cause
I upgraded to 2.11 nightly => no change

Can my config be damaged ? Maybe .. any ideas ?

I get a error message for each incoming SIP INVITE => not a firewall issue

What else could it be ???

I would assume that your SIP provider changed something and the INVITEs are missing a part that would let Jitsi associate the incoming package to one of the configured SIP accounts. Hard to tell without the complete logs.

Since you were also mentioning an OpenJDK update, I went through the changelog and applied patches but couldn't find anything interesting. I also tried calls with two SIP accounts (Asterisk (TLS) and something unknown (UDP)), both were working as expected (Windows, JDK 1.8.0_144).

You can try enabling the option "Bypass proxy security check for HA scenarios (use only if needed)", but please be aware that this is very dangerous (i.e. can incur costs) if someone can reach Jitsi's SIP listing port (usually 5060). If it works with this setting, it's your SIP provider's fault by sending the INVITEs from an IP different to where you REGISTERed.

I can't create a Sipgate account to test, they required me to enter a postal address in Germany to verify the account.

best regards,
Marius

Ingo


#4
···

Hey,

  First thing I notice in Oracle's release notes is "**        Disable

SHA-1 TLS Server Certificates"** . I haven’t found OpenJDK
release notes yet, but if they mirror this change, then your
secure connection might fail to establish due to your server using
“old” types of certificates.

  Danny

  On 07/29/2017 01:12 PM, Cyborg wrote:

Small update:
Two days ago was a Java Update :
/var/log/dnf.rpm.log:Jul 27 10:02:04 INFO Upgraded:
java-1.8.0-openjdk-headless-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:04 INFO Upgraded:
java-1.8.0-openjdk-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:09 INFO Upgraded:
java-1.8.0-openjdk-devel-1:1.8.0.141-1.b16.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:02:43 INFO Upgraded:
java-1.8.0-openjdk-javadoc-1:1.8.0.141-1.b16.fc25.noarch
/var/log/dnf.rpm.log:Jul 27 10:03:25 INFO Cleanup:
java-1.8.0-openjdk-devel-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:30 INFO Cleanup:
java-1.8.0-openjdk-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:30 INFO Cleanup:
java-1.8.0-openjdk-headless-1:1.8.0.131-1.b12.fc25.x86_64
/var/log/dnf.rpm.log:Jul 27 10:03:32 INFO Cleanup:
java-1.8.0-openjdk-javadoc-1:1.8.0.131-1.b12.fc25.noarch
Could that be causing the problem?
Marius
_______________________________________________
users mailing list
Unsubscribe instructions and other list options:

users@jitsi.orghttp://lists.jitsi.org/mailman/listinfo/users


#5

If that would be the case, jitsi would not be able to connect to the
server at all, but it can.

Sooner or later, we will find out what's going on.

Marius

···

Am 03.08.2017 um 22:31 schrieb Danny van Heumen:

Hey,

First thing I notice in Oracle's release notes is "*Disable SHA-1 TLS
Server Certificates"*. I haven't found OpenJDK release notes yet, but
if they mirror this change, then your secure connection might fail to
establish due to your server using "old" types of certificates.

Danny