[jitsi-users] jitsi authentication with sipxecs


#1

I should include that I can get jitsi to authenticate using xmpp however, the account is always Offline.


#2

Hey Mike,

I haven't personally used XMPP through sipxecs but we do use a lot of
openfire and haven't had any such issues. One possible reason is the
non-support of secure authentication by the server ... although in this
case you should get a visual warning.

In case the warning is broken, could you please try after checking the
"allow non-secure connections" checkbox in the configuration?

Emil

···

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using xmpp however, the account is always Offline.

Can't seem to authenticate onto openfire server on sipxecs.
Have tried using the user id and password, alias and password, various other combinations.

All of them lead to 'Authentication failed for user@mydomain.com (Jabber). The password you entered is not valid.

Anyone have jitsi working with sipx?

Mike


#3

Emil & Mike,

sipXecs has openFire integrated.

I can confirm that Jitsi will properly authenticate against sipXecs for
both SIP and XMPP accounts.

The only problem I see with XMPP is that if a user is part of multiple
openFire groups the user will only appear in one of the groups. This works
properly under Spark however, so it must be something with Jitsi.

Mike, I'd suggest inspecting your DNS records or firewall settings. Once I
accept the cert warning (if you have an unsigned cert) all is fine.

Thanks,
    Mike

Michael Picher
Director of Technical Services
eZuce, Incorporated.

···

On Tue, May 29, 2012 at 11:14 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Mike,

I haven't personally used XMPP through sipxecs but we do use a lot of
openfire and haven't had any such issues. One possible reason is the
non-support of secure authentication by the server ... although in this
case you should get a visual warning.

In case the warning is broken, could you please try after checking the
"allow non-secure connections" checkbox in the configuration?

Emil

On 29.05.12 17:07, mike@grounded.net wrote:
> I should include that I can get jitsi to authenticate using xmpp
however, the account is always Offline.
>
>> Can't seem to authenticate onto openfire server on sipxecs.
>> Have tried using the user id and password, alias and password, various
other combinations.
>>
>> All of them lead to 'Authentication failed for user@mydomain.com(Jabber). The password you entered is not valid.
>>
>> Anyone have jitsi working with sipx?
>>
>> Mike

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info


#4

In case the warning is broken, could you please try after checking the
"allow non-secure connections" checkbox in the configuration?

Same thing. I do authenticate now but as I mentioned, I see that the xmpp account is always Offline

···

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using xmpp however,
the account is always Offline.

Can't seem to authenticate onto openfire server on sipxecs.
Have tried using the user id and password, alias and password, various
other combinations.

All of them lead to 'Authentication failed for user@mydomain.com
(Jabber). The password you entered is not valid.

Anyone have jitsi working with sipx?

Mike


#5

Hey Michael,

···

On 29.05.12 17:23, Michael Picher wrote:

Emil & Mike,

sipXecs has openFire integrated.

I can confirm that Jitsi will properly authenticate against sipXecs for
both SIP and XMPP accounts.

The only problem I see with XMPP is that if a user is part of multiple
openFire groups the user will only appear in one of the groups. This
works properly under Spark however, so it must be something with Jitsi.

Yes, this one is. We don't currently handle multi-parenting for roster
entries. We'd like to support this one day but the refactoring effort is
quite substantial and there are sexier things to do until we get there
... such as finalizing our video conferencing, our android port and many
others. So this one is on stand by currently.

Emil


#6

sexier for programmers, yes...

...for users :frowning:

thanks, and fyi, I think somebody is working on provisioning for Jitsi from
within sipXecs GUI. Will be nice when this is completed.

Mike

···

On Tue, May 29, 2012 at 11:54 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Michael,

On 29.05.12 17:23, Michael Picher wrote:
> Emil & Mike,
>
> sipXecs has openFire integrated.
>
> I can confirm that Jitsi will properly authenticate against sipXecs for
> both SIP and XMPP accounts.
>
> The only problem I see with XMPP is that if a user is part of multiple
> openFire groups the user will only appear in one of the groups. This
> works properly under Spark however, so it must be something with
Jitsi. Yes, this one is. We don't currently handle multi-parenting for
roster
entries. We'd like to support this one day but the refactoring effort is
quite substantial and there are sexier things to do until we get there
... such as finalizing our video conferencing, our android port and many
others. So this one is on stand by currently.

Emil

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info


#7

The only problem I see with XMPP is that if a user is part of multiple
openFire groups the user will only appear in one of the groups. This works
properly under Spark however, so it must be something with Jitsi.

BTW, yes, SIP is not a problem, been using jitsi for a while with sipx now.
I enabled the openfire console and see that the user in question is not in any group, 'none'.

Mike


#8

sexier for programmers, yes...

...for users :frowning:

Well, while I certainly don't think multi parenting would matter more
to the average user than multi-party video conferencing, let's just
agree that it's a matter of personal preference. So in that regard, we
(BlueJimp) have made our own choices. In the mean time, if anyone else
would like to work on multi-parenting before we get to it, well, we
would be more than happy to take their patches!

thanks, and fyi, I think somebody is working on provisioning for Jitsi from
within sipXecs GUI. Will be nice when this is completed.

It would indeed. Please feel free to drop us a note here, when it happens!

Cheers,
Emil

···

On Tue, May 29, 2012 at 6:30 PM, Michael Picher <mpicher@gmail.com> wrote:

Mike

On Tue, May 29, 2012 at 11:54 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Michael,

On 29.05.12 17:23, Michael Picher wrote:
> Emil & Mike,
>
> sipXecs has openFire integrated.
>
> I can confirm that Jitsi will properly authenticate against sipXecs for
> both SIP and XMPP accounts.
>
> The only problem I see with XMPP is that if a user is part of multiple
> openFire groups the user will only appear in one of the groups. This
> works properly under Spark however, so it must be something with
> Jitsi. Yes, this one is. We don't currently handle multi-parenting for
> roster
entries. We'd like to support this one day but the refactoring effort is
quite substantial and there are sexier things to do until we get there
... such as finalizing our video conferencing, our android port and many
others. So this one is on stand by currently.

Emil

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#9

Is this working with other XMPP clients?

Emil

···

On 29.05.12 22:55, mike@grounded.net wrote:

In case the warning is broken, could you please try after checking the
"allow non-secure connections" checkbox in the configuration?

Same thing. I do authenticate now but as I mentioned, I see that the xmpp account is always Offline

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using xmpp however,
the account is always Offline.

Can't seem to authenticate onto openfire server on sipxecs.
Have tried using the user id and password, alias and password, various
other combinations.

All of them lead to 'Authentication failed for user@mydomain.com
(Jabber). The password you entered is not valid.

Anyone have jitsi working with sipx?

Mike


#10

I'm not sure, I'll have to re-install spark and test unless someone else has. I believe MPicher just mentioned in this thread that spark did work.

However, my problem isn't actually with authentication at this point. It is that even after authenticating, it is always in 'Offline' mode and I am trying to figure out why.

···

On Tue, 29 May 2012 22:56:29 +0200, Emil Ivov wrote:

Is this working with other XMPP clients?

Emil

On 29.05.12 22:55, mike@grounded.net wrote:

In case the warning is broken, could you please try after checking the
"allow non-secure connections" checkbox in the configuration?

Same thing. I do authenticate now but as I mentioned, I see that the xmpp
account is always Offline

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using xmpp
however,
the account is always Offline.

Can't seem to authenticate onto openfire server on sipxecs.
Have tried using the user id and password, alias and password,
various
other combinations.

All of them lead to 'Authentication failed for user@mydomain.com
(Jabber). The password you entered is not valid.

Anyone have jitsi working with sipx?

Mike


#11

I'm not sure, I'll have to re-install spark and test unless someone
else has. I believe MPicher just mentioned in this thread that spark
did work.

I was wondering if it (or another XMPP client) worked in that particular
setup. Just trying to confirm that this is indeed a Jitsi problem and
not something on the server side.

Emil

···

On 29.05.12 23:00, mike@grounded.net wrote:

However, my problem isn't actually with authentication at this point.
It is that even after authenticating, it is always in 'Offline' mode
and I am trying to figure out why.

On Tue, 29 May 2012 22:56:29 +0200, Emil Ivov wrote:

Is this working with other XMPP clients?

Emil

On 29.05.12 22:55, mike@grounded.net wrote:

In case the warning is broken, could you please try after
checking the "allow non-secure connections" checkbox in the
configuration?

Same thing. I do authenticate now but as I mentioned, I see that
the xmpp account is always Offline

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using
xmpp however, the account is always Offline.

Can't seem to authenticate onto openfire server on
sipxecs. Have tried using the user id and password, alias
and password, various other combinations.

All of them lead to 'Authentication failed for
user@mydomain.com (Jabber). The password you entered is not
valid.

Anyone have jitsi working with sipx?

Mike

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#12

I installed an older version of spark and it came right up without any issues.

···

On Tue, 29 May 2012 23:07:54 +0200, Emil Ivov wrote:

On 29.05.12 23:00, mike@grounded.net wrote:

I'm not sure, I'll have to re-install spark and test unless someone
else has. I believe MPicher just mentioned in this thread that spark
did work.

I was wondering if it (or another XMPP client) worked in that particular
setup. Just trying to confirm that this is indeed a Jitsi problem and
not something on the server side.

Emil

However, my problem isn't actually with authentication at this point.
It is that even after authenticating, it is always in 'Offline' mode
and I am trying to figure out why.

On Tue, 29 May 2012 22:56:29 +0200, Emil Ivov wrote:

Is this working with other XMPP clients?

Emil

On 29.05.12 22:55, mike@grounded.net wrote:

In case the warning is broken, could you please try after
checking the "allow non-secure connections" checkbox in the
configuration?

Same thing. I do authenticate now but as I mentioned, I see that
the xmpp account is always Offline

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using
xmpp however, the account is always Offline.

Can't seem to authenticate onto openfire server on
sipxecs. Have tried using the user id and password, alias
and password, various other combinations.

All of them lead to 'Authentication failed for
user@mydomain.com (Jabber). The password you entered is not
valid.

Anyone have jitsi working with sipx?

Mike


#13

Could we see your logs[0] please?

[0] https://jitsi.org/faq/logs

Emil

···

On Wed, May 30, 2012 at 4:41 AM, mike@grounded.net <mike@grounded.net> wrote:

I installed an older version of spark and it came right up without any issues.

On Tue, 29 May 2012 23:07:54 +0200, Emil Ivov wrote:

On 29.05.12 23:00, mike@grounded.net wrote:

I'm not sure, I'll have to re-install spark and test unless someone
else has. I believe MPicher just mentioned in this thread that spark
did work.

I was wondering if it (or another XMPP client) worked in that particular
setup. Just trying to confirm that this is indeed a Jitsi problem and
not something on the server side.

Emil

However, my problem isn't actually with authentication at this point.
It is that even after authenticating, it is always in 'Offline' mode
and I am trying to figure out why.

On Tue, 29 May 2012 22:56:29 +0200, Emil Ivov wrote:

Is this working with other XMPP clients?

Emil

On 29.05.12 22:55, mike@grounded.net wrote:

In case the warning is broken, could you please try after
checking the "allow non-secure connections" checkbox in the
configuration?

Same thing. I do authenticate now but as I mentioned, I see that
the xmpp account is always Offline

Emil

On 29.05.12 17:07, mike@grounded.net wrote:

I should include that I can get jitsi to authenticate using
xmpp however, the account is always Offline.

Can't seem to authenticate onto openfire server on
sipxecs. Have tried using the user id and password, alias
and password, various other combinations.

All of them lead to 'Authentication failed for
user@mydomain.com (Jabber). The password you entered is not
valid.

Anyone have jitsi working with sipx?

Mike

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#14

Hello Emil , Dmitry

I have exact same problem.
Jitsi (xmpp ) -> SipXecs(4.4 )
(Windows 7 ,Java 6u35 , Java7u7)

Any update on this ?

Thanks,
Konstantin

P.S. Only work for me with
Pidgin (xmpp)-> SipXecs(4.4 )


#15

Please publish your EXTERNAL and your INTERNAL dns records. Including the
host record.

You can make up ip's if you'd like (i.e., 1.1.1.1, but if the numbers are
the same, use the same made up #).

Thanks,
  Mike

···

On Mon, Sep 3, 2012 at 8:49 PM, <5836000@gmail.com> wrote:

Hello Emil , Dmitry

I have exact same problem.
Jitsi (xmpp ) -> SipXecs(4.4 )
(Windows 7 ,Java 6u35 , Java7u7)

Any update on this ?

Thanks,
Konstantin

P.S. Only work for me with
Pidgin (xmpp)-> SipXecs(4.4 )

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info


#16

Hello Mike

Both client and server are INTERNAL .
They talking with their correct internal IPs.
All records looks ok.
Client SRV query ok.
Self signed sertificate , ( Yes , I was prompted to accept it by Jitsi during firt time login)
Wireshark nothing , but authentication failed .

Backup DNS resolver in Jisti advanced tab are disabled .

So internal server,client,dns.

You can find query results below :

(domain changed to generic yyy.com )

##INTERNAL
# dig SRV _xmpp-client._tcp.yyy.com

; <<>> DiG n/a <<>> SRV _xmpp-client._tcp.yyy.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63892
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;_xmpp-client._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-client._tcp.yyy.com. 604800 IN SRV 1 0 5222 sip.yyy.com.

;; AUTHORITY SECTION:
yyy.com. 604800 IN NS ns.yyy.com.

;; ADDITIONAL SECTION:
sip.yyy.com. 604800 IN A 192.168.11.2
ns.yyy.com. 604800 IN A 192.168.6.23

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 4 05:44:02 2012
;; MSG SIZE rcvd: 148

###EXTERNAL
dig @8.8.8.8 SRV _xmpp-client._tcp.yyy.com

; <<>> DiG n/a <<>> @8.8.8.8 SRV _xmpp-client._tcp.yyy.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9281
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;_xmpp-client._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-client._tcp.yyy.com. 43200 IN SRV 1 0 5222 sip.yyy.com.

;; Query time: 208 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Sep 4 05:44:40 2012
;; MSG SIZE rcvd: 95

Let me know if You need more info.

Thanks,
Konstantin.

···

----- Original Message -----

From: "Michael Picher" <mpicher@gmail.com>

To: users@jitsi.java.net
Sent: Tuesday, September 4, 2012 5:04:41 AM
Subject: [jitsi-users] Re: jitsi authentication with sipxecs

Please publish your EXTERNAL and your INTERNAL dns records. Including the host record.

You can make up ip's if you'd like (i.e., 1.1.1.1, but if the numbers are the same, use the same made up #).

Thanks,
Mike

On Mon, Sep 3, 2012 at 8:49 PM, < 5836000@gmail.com > wrote:

Hello Emil , Dmitry

I have exact same problem.
Jitsi (xmpp ) -> SipXecs(4.4 )
(Windows 7 ,Java 6u35 , Java7u7)

Any update on this ?

Thanks,
Konstantin

P.S. Only work for me with
Pidgin (xmpp)-> SipXecs(4.4 )

--
There are 10 kinds of people in this world, those who understand binary and those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info


#17

DNS looks OK, Do you also have _xmpp-server records also?

I assume (always a mistake) that you have 'yum updated' this server to most
current. (reboot machine after). ISO almost never contains current code
as it is only built when there are changes that effect installation.

I also assume, you know that IM ID != SIP UserID and that IM Password !=
PIN != SIP Password

fyi, this has changed a bit in 4.6.

Mike

···

On Tue, Sep 4, 2012 at 6:07 AM, Konstantin Pobudzey <5836000@gmail.com>wrote:

Hello Mike

Both client and server are INTERNAL .
They talking with their correct internal IPs.
All records looks ok.
Client SRV query ok.
Self signed sertificate , ( Yes , I was prompted to accept it by Jitsi
during firt time login)
Wireshark nothing , but authentication failed .

Backup DNS resolver in Jisti advanced tab are disabled .

So internal server,client,dns.

You can find query results below :

(domain changed to generic yyy.com )

##INTERNAL
# dig SRV _xmpp-client._tcp.yyy.com

; <<>> DiG n/a <<>> SRV _xmpp-client._tcp.yyy.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63892
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;_xmpp-client._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-client._tcp.yyy.com. 604800 IN SRV 1 0 5222 sip.yyy.com.

;; AUTHORITY SECTION:
yyy.com. 604800 IN NS ns.yyy.com.

;; ADDITIONAL SECTION:
sip.yyy.com. 604800 IN A 192.168.11.2
ns.yyy.com. 604800 IN A 192.168.6.23

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 4 05:44:02 2012
;; MSG SIZE rcvd: 148

###EXTERNAL
dig @8.8.8.8 SRV _xmpp-client._tcp.yyy.com

; <<>> DiG n/a <<>> @8.8.8.8 SRV _xmpp-client._tcp.yyy.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9281
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;_xmpp-client._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-client._tcp.yyy.com. 43200 IN SRV 1 0 5222 sip.yyy.com.

;; Query time: 208 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Sep 4 05:44:40 2012
;; MSG SIZE rcvd: 95

Let me know if You need more info.

Thanks,
Konstantin.

----- Original Message -----
From: "Michael Picher" <mpicher@gmail.com>
To: users@jitsi.java.net
Sent: Tuesday, September 4, 2012 5:04:41 AM
Subject: [jitsi-users] Re: jitsi authentication with sipxecs

Please publish your EXTERNAL and your INTERNAL dns records. Including the
host record.

You can make up ip's if you'd like (i.e., 1.1.1.1, but if the numbers are
the same, use the same made up #).

Thanks,
Mike

On Mon, Sep 3, 2012 at 8:49 PM, < 5836000@gmail.com > wrote:

Hello Emil , Dmitry

I have exact same problem.
Jitsi (xmpp ) -> SipXecs(4.4 )
(Windows 7 ,Java 6u35 , Java7u7)

Any update on this ?

Thanks,
Konstantin

P.S. Only work for me with
Pidgin (xmpp)-> SipXecs(4.4 )

--
There are 10 kinds of people in this world, those who understand binary
and those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info


#18

Hello Mike

DNS looks OK, Do you also have _xmpp-server records also?

···

#################
Sure. See below. ( But client do not need it, if I'm not mistaken )
##################
dig SRV _xmpp-server._tcp.yyy.com

; <<>> DiG na <<>> SRV _xmpp-server._tcp.yyy.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52629
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;_xmpp-server._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-server._tcp.yyy.com. 604800 IN SRV 1 0 5269 sip.yyy.com.

;; AUTHORITY SECTION:
yyy.com. 604800 IN NS ns.yyy.com.

;; ADDITIONAL SECTION:
sip.yyy.com. 604800 IN A 192.168.11.2
ns.yyy.com. 604800 IN A 192.168.6.23

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 4 06:54:09 2012
;; MSG SIZE rcvd: 148

##################################

I assume (always a mistake) that you have 'yum updated' this server to most current. (reboot machine after). ISO almost never contains current code as it is only built when there are changes that effect installation.

##############
Yes. Yum update and reboot.
################

I also assume, you know that IM ID != SIP UserID and that IM Password != PIN != SIP Password
##########
This is correct. SIP Account working from Jitsi. IM working from Pidgin , But not from Jitsi.
( This pattern same for all = or != IM ID ,SIP ID, IM Password ,SIP Password )
##########

fyi, this has changed a bit in 4.6.

######
I'm about to move to 4.6 . It will help me ?
Since it this point I'm only suggesting Java different version on Windows7 and SipXecs

### I have another xmpp , build in Zimbra, working with Jisti just fine, but not SipXecs one.

############### Working Jitsi with Zimbra #####333

[root@mail ~]# yum list \*java-1\* | grep open
java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2 updates
java-1.6.0-openjdk-demo.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2 updates
java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2 updates
java-1.6.0-openjdk-javadoc.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2 updates
java-1.6.0-openjdk-src.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2 updates
java-1.7.0-openjdk.x86_64 1:1.7.0.5-2.2.1.el6_3 updates
java-1.7.0-openjdk-demo.x86_64 1:1.7.0.5-2.2.1.el6_3 updates
java-1.7.0-openjdk-devel.x86_64 1:1.7.0.5-2.2.1.el6_3 updates
java-1.7.0-openjdk-javadoc.noarch 1:1.7.0.5-2.2.1.el6_3 updates
java-1.7.0-openjdk-src.x86_64 1:1.7.0.5-2.2.1.el6_3 updates

######## not working Jitsi with SipXecs ##################################

[root@sip ~]# yum list \*java-1\* | grep open
java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8 installed
java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8 installed
java-1.6.0-openjdk-demo.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8 updates
java-1.6.0-openjdk-javadoc.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8 updates
java-1.6.0-openjdk-src.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8 updates

###################################################################################

Thanks for your quick answer,
Konstantin.


#19

i don't know about the java stuff...

this stuff just works out of the box. we're talking standard openfire here.

i'd suggest maybe wiping your jitsi settings and any cached info (key) and
trying again. not sure what else to tell you.

4.6 is still a bit of WIP. it is ok for testing and not prod. it's
getting closer, we're using it in prod in house for dog-fooding.

mike

···

On Tue, Sep 4, 2012 at 7:13 AM, Konstantin Pobudzey <5836000@gmail.com>wrote:

Hello Mike

DNS looks OK, Do you also have _xmpp-server records also?

#################
Sure. See below. ( But client do not need it, if I'm not mistaken )
##################
dig SRV _xmpp-server._tcp.yyy.com

; <<>> DiG na <<>> SRV _xmpp-server._tcp.yyy.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52629
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 3

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;_xmpp-server._tcp.yyy.com. IN SRV

;; ANSWER SECTION:
_xmpp-server._tcp.yyy.com. 604800 IN SRV 1 0 5269 sip.yyy.com.

;; AUTHORITY SECTION:
yyy.com. 604800 IN NS ns.yyy.com.

;; ADDITIONAL SECTION:
sip.yyy.com. 604800 IN A 192.168.11.2
ns.yyy.com. 604800 IN A 192.168.6.23

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 4 06:54:09 2012
;; MSG SIZE rcvd: 148

##################################

I assume (always a mistake) that you have 'yum updated' this server to
most current. (reboot machine after). ISO almost never contains current
code as it is only built when there are changes that effect installation.

##############
Yes. Yum update and reboot.
################

I also assume, you know that IM ID != SIP UserID and that IM Password !=
PIN != SIP Password
##########
This is correct. SIP Account working from Jitsi. IM working from
Pidgin , But not from Jitsi.
( This pattern same for all = or != IM ID ,SIP ID, IM Password ,SIP
Password )
##########

fyi, this has changed a bit in 4.6.

######
I'm about to move to 4.6 . It will help me ?
Since it this point I'm only suggesting Java different version on Windows7
and SipXecs

### I have another xmpp , build in Zimbra, working with Jisti just fine,
but not SipXecs one.

############### Working Jitsi with Zimbra #####333

[root@mail ~]# yum list \*java-1\* | grep open
java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2
updates
java-1.6.0-openjdk-demo.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2
updates
java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2
updates
java-1.6.0-openjdk-javadoc.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2
updates
java-1.6.0-openjdk-src.x86_64 1:1.6.0.0-1.48.1.11.3.el6_2
updates
java-1.7.0-openjdk.x86_64 1:1.7.0.5-2.2.1.el6_3
updates
java-1.7.0-openjdk-demo.x86_64 1:1.7.0.5-2.2.1.el6_3
updates
java-1.7.0-openjdk-devel.x86_64 1:1.7.0.5-2.2.1.el6_3
updates
java-1.7.0-openjdk-javadoc.noarch 1:1.7.0.5-2.2.1.el6_3
updates
java-1.7.0-openjdk-src.x86_64 1:1.7.0.5-2.2.1.el6_3
updates

######## not working Jitsi with SipXecs ##################################

[root@sip ~]# yum list \*java-1\* | grep open
java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8
installed
java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8
installed
java-1.6.0-openjdk-demo.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8
updates
java-1.6.0-openjdk-javadoc.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8
updates
java-1.6.0-openjdk-src.x86_64 1:1.6.0.0-1.27.1.10.8.el5_8
updates

###################################################################################

Thanks for your quick answer,
Konstantin.

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info