[jitsi-users] Jitsi Audio Codec choices.


#1

When running Jitsi clients through Asterisk Now, Jitsi always seems to be pick PCMS-8000 as the audio codec, which is OK but I think it could sound a whole lot better.
In the client there seems to be a long list of audio codecs. How do I entice Jitsi into using one higher up the list with a better sample rate? Is this decided by Asterisk?

[cid:image005.png@01D1A55F.23B51080]

Stephen Moll
Senior Systems Engineer
Defence Information, Training & Services

Please consider the environment before printing this email

BAE Systems Integrated System Technologies Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hampshire, GU14 6YU, UK
Registered in England & Wales No: 3456325

···

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************


#2

Hi Stephen,

Thank you but i had this screen onlyn when :

And when i write https://instants.live it's OK. Have you got a solution
? What files configuration i must change ?

···

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :

When running Jitsi clients through Asterisk Now, Jitsi always seems to
be pick PCMS-8000 as the audio codec, which is OK but I think it could
sound a whole lot better.

In the client there seems to be a long list of audio codecs. How do I
entice Jitsi into using one higher up the list with a better sample
rate? Is this decided by Asterisk?


#3

Hi Stephen,

Thank you but i had this screen only when i write
https://www.instants.live :

And when i write https://instants.live it's OK. Have you got a solution
? What files configuration i must change ?

···

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :

When running Jitsi clients through Asterisk Now, Jitsi always seems to
be pick PCMS-8000 as the audio codec, which is OK but I think it could
sound a whole lot better.

In the client there seems to be a long list of audio codecs. How do I
entice Jitsi into using one higher up the list with a better sample
rate? Is this decided by Asterisk?


#4

Hi Stephen,

Thank you but i had this screen only when i write
https://www.instants.live :

And when i write https://instants.live it's OK. Have you got a solution
? What files configuration i must change ?

···

Le 31/10/2016 à 10:15, Patrice Remeur a écrit :

Hi Stephen,

Thank you but i had this screen onlyn when :

And when i write https://instants.live it's OK. Have you got a
solution ? What files configuration i must change ?

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :

When running Jitsi clients through Asterisk Now, Jitsi always seems
to be pick PCMS-8000 as the audio codec, which is OK but I think it
could sound a whole lot better.

In the client there seems to be a long list of audio codecs. How do I
entice Jitsi into using one higher up the list with a better sample
rate? Is this decided by Asterisk?

--


#5

How do I get Jitsi to use the Speex codec?

As far as I can tell Speex has been allowed by Asterisk, but if I turn all codec choices off except for Speex, calls fail to connect, and only start working again when PCMS-8000 (uLaw) is enabled.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Patrice Remeur
Sent: 31 October 2016 09:31
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi Audio Codec choices.

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Dealing%20With%20Suspicious%20Emails.pdf>.

Hi Stephen,

Thank you but i had this screen only when i write https://www.instants.live :
And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 10:15, Patrice Remeur a écrit :

Hi Stephen,

Thank you but i had this screen onlyn when :

And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :
When running Jitsi clients through Asterisk Now, Jitsi always seems to be pick PCMS-8000 as the audio codec, which is OK but I think it could sound a whole lot better.
In the client there seems to be a long list of audio codecs. How do I entice Jitsi into using one higher up the list with a better sample rate? Is this decided by Asterisk?

--
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************


#6

How do I get Jitsi to use the Speex codec?

As far as I can tell Speex has been allowed by Asterisk, but if I turn all codec choices off except for Speex, calls fail to connect, and only start working again when PCMS-8000 (uLaw) is enabled.

If Speex is the only enabled codec in Jitsi and the call fails, it is most likely disabled in Asterisk. There is afaik more than one setting in Asterisk to allow/deny codecs.

If you look at the .pcap logfiles from Jitsi, you see the offered and agreed upon codecs (or send me the logs and I'll have a look).

Ingo

···

On 10 Nov 2016, at 14:36, Moll, Stephen (UK) <stephen.moll@baesystems.com> wrote:

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Patrice Remeur
Sent: 31 October 2016 09:31
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi Audio Codec choices.

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here.
If you feel the email is suspicious, please follow this process.

Hi Stephen,

Thank you but i had this screen only when i write https://www.instants.live :

And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 10:15, Patrice Remeur a écrit :
Hi Stephen,

Thank you but i had this screen onlyn when :

And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :
When running Jitsi clients through Asterisk Now, Jitsi always seems to be pick PCMS-8000 as the audio codec, which is OK but I think it could sound a whole lot better.
In the client there seems to be a long list of audio codecs. How do I entice Jitsi into using one higher up the list with a better sample rate? Is this decided by Asterisk?

--
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Getting the logs will be difficult as they are on a completely isolated system.

I had a look at some PCAP files from one of the clients, and couldn’t see anything useful in there relating to codecs.

I found a set of files named “jitsi0.log.n” with n being 0, 1 or 2. These look more promising, and appeared to show some sort of codec negotiation.

Looking in Asterisk I found a list of “Allowed” audio codecs. Speex16 was there but way down the list. I moved it to the front of the list, and I am now seeing Speex16 being selected. So I’ll let the users play with it like that for a while and see how they are fairing in a few days.

Thanks for the pointers.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: 10 November 2016 14:34
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi Audio Codec choices.

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Dealing%20With%20Suspicious%20Emails.pdf>.

On 10 Nov 2016, at 14:36, Moll, Stephen (UK) <stephen.moll@baesystems.com<mailto:stephen.moll@baesystems.com>> wrote:
How do I get Jitsi to use the Speex codec?

As far as I can tell Speex has been allowed by Asterisk, but if I turn all codec choices off except for Speex, calls fail to connect, and only start working again when PCMS-8000 (uLaw) is enabled.

If Speex is the only enabled codec in Jitsi and the call fails, it is most likely disabled in Asterisk. There is afaik more than one setting in Asterisk to allow/deny codecs.

If you look at the .pcap logfiles from Jitsi, you see the offered and agreed upon codecs (or send me the logs and I'll have a look).

Ingo

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Patrice Remeur
Sent: 31 October 2016 09:31
To: Jitsi Users
Subject: Re: [jitsi-users] Jitsi Audio Codec choices.

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://ws-sites.ent.baesystems.com/sites/HOSECStdsLibrary/StandardsLibrary/Everyone/Dealing%20With%20Suspicious%20Emails.pdf>.

Hi Stephen,

Thank you but i had this screen only when i write https://www.instants.live :
And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 10:15, Patrice Remeur a écrit :

Hi Stephen,

Thank you but i had this screen onlyn when :

And when i write https://instants.live it's OK. Have you got a solution ? What files configuration i must change ?

Le 31/10/2016 à 09:53, Moll, Stephen (UK) a écrit :
When running Jitsi clients through Asterisk Now, Jitsi always seems to be pick PCMS-8000 as the audio codec, which is OK but I think it could sound a whole lot better.
In the client there seems to be a long list of audio codecs. How do I entice Jitsi into using one higher up the list with a better sample rate? Is this decided by Asterisk?

--

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users