[jitsi-users] Jitsi as a SIP softphone


#1

I've been using Jitsi as my XMPP client for a year or so, and am very
happy with it, but recently I've tried using it as a softphone for my
SIP account (on anveo.com), and been disappointed. Voice quality is
consistently poor (broken up, noisy), while when I use Zoiper (from
zoiper.com) as my softphone for the same SIP account, on the same
Internet connection, call quality is consistently good.

I am wondering whether there is anything I can do to improve SIP
performance with Jitsi, because I'd much rather have a single client for
all my messaging needs.

The only audio codecs that anveo.com supports are GSM and u-law.

Thank you.


#2

Hi David,

in the advanced settings in your SIP account the "Enable support to encrypt
calls" is active?

from what I see there are no special settings to change
let me know,
thanks in advance

···

On Thursday, January 10, 2013 01:43:08 PM David Burleigh wrote:

I've been using Jitsi as my XMPP client for a year or so, and am very
happy with it, but recently I've tried using it as a softphone for my
SIP account (on anveo.com), and been disappointed. Voice quality is
consistently poor (broken up, noisy), while when I use Zoiper (from
zoiper.com) as my softphone for the same SIP account, on the same
Internet connection, call quality is consistently good.

I am wondering whether there is anything I can do to improve SIP
performance with Jitsi, because I'd much rather have a single client for
all my messaging needs.

The only audio codecs that anveo.com supports are GSM and u-law.

Thank you.


#3

No, I did not enable support to encrypt calls.

···

On 01/11/2013 05:58 AM, Paolo De Michele wrote:

On Thursday, January 10, 2013 01:43:08 PM David Burleigh wrote:

I've been using Jitsi as my XMPP client for a year or so, and am very
happy with it, but recently I've tried using it as a softphone for my
SIP account (on anveo.com), and been disappointed. Voice quality is
consistently poor (broken up, noisy), while when I use Zoiper (from
zoiper.com) as my softphone for the same SIP account, on the same
Internet connection, call quality is consistently good.

I am wondering whether there is anything I can do to improve SIP
performance with Jitsi, because I'd much rather have a single client for
all my messaging needs.

The only audio codecs that anveo.com supports are GSM and u-law.

Thank you.

Hi David,

in the advanced settings in your SIP account the "Enable support to encrypt
calls" is active?

from what I see there are no special settings to change
let me know,
thanks in advance


#4

Hey David,

You can try switching between PCMU and GSM and see if the quality changes.

We've also fixed a number of audio rendering issues in the latest
nightlies so, if you are currently using the stable build, it is
definitely worth trying those as well.

Hope this helps,
Emil

···

On 11.01.13, 12:17, David Burleigh wrote:

On 01/11/2013 05:58 AM, Paolo De Michele wrote:

On Thursday, January 10, 2013 01:43:08 PM David Burleigh wrote:

I've been using Jitsi as my XMPP client for a year or so, and am very
happy with it, but recently I've tried using it as a softphone for my
SIP account (on anveo.com), and been disappointed. Voice quality is
consistently poor (broken up, noisy), while when I use Zoiper (from
zoiper.com) as my softphone for the same SIP account, on the same
Internet connection, call quality is consistently good.

I am wondering whether there is anything I can do to improve SIP
performance with Jitsi, because I'd much rather have a single client for
all my messaging needs.

The only audio codecs that anveo.com supports are GSM and u-law.

Thank you.

Hi David,

in the advanced settings in your SIP account the "Enable support to encrypt
calls" is active?

from what I see there are no special settings to change
let me know,
thanks in advance

No, I did not enable support to encrypt calls.

--
https://jitsi.org


#5

Ok, I'll keep trying occasionally. I am always using the latest nightly
of Jitsi.

···

On 01/11/2013 07:29 AM, Emil Ivov wrote:

Hey David,

You can try switching between PCMU and GSM and see if the quality changes.

We've also fixed a number of audio rendering issues in the latest
nightlies so, if you are currently using the stable build, it is
definitely worth trying those as well.

Hope this helps,
Emil

On 11.01.13, 12:17, David Burleigh wrote:

On 01/11/2013 05:58 AM, Paolo De Michele wrote:

On Thursday, January 10, 2013 01:43:08 PM David Burleigh wrote:

I've been using Jitsi as my XMPP client for a year or so, and am very
happy with it, but recently I've tried using it as a softphone for my
SIP account (on anveo.com), and been disappointed. Voice quality is
consistently poor (broken up, noisy), while when I use Zoiper (from
zoiper.com) as my softphone for the same SIP account, on the same
Internet connection, call quality is consistently good.

I am wondering whether there is anything I can do to improve SIP
performance with Jitsi, because I'd much rather have a single client for
all my messaging needs.

The only audio codecs that anveo.com supports are GSM and u-law.

Thank you.

Hi David,

in the advanced settings in your SIP account the "Enable support to encrypt
calls" is active?

from what I see there are no special settings to change
let me know,
thanks in advance

No, I did not enable support to encrypt calls.