[jitsi-users] jitsi 2.0 with plain alsa audio system


#1

on debian linux, portaudio has never worked well for me whereas plain
alsa works fine. jitsi 2.0 on my host does not allow me to choose alsa
sound system, but only portaudio. as result, audio quality is really
bad.

does jitsi 2.0 support plain alsa or is alsa support just missing in the
debian package that i downloaded from jitsi site?

-- juha
.


#2

Hey Juha,

On linux Jitsi supports portaudio and pulseaudio. Both of those then use
alsa.

Portaudio does indeed tend to provide poorer results, so you might want to
give a shot to pulseaudio. (Of course you'd need to install it first)

Cheers,
Emil

--sent from my mobile

···

On Mar 23, 2013 12:29 PM, "Juha Heinanen" <jh@tutpro.com> wrote:

on debian linux, portaudio has never worked well for me whereas plain
alsa works fine. jitsi 2.0 on my host does not allow me to choose alsa
sound system, but only portaudio. as result, audio quality is really
bad.

does jitsi 2.0 support plain alsa or is alsa support just missing in the
debian package that i downloaded from jitsi site?

-- juha


#3

Hi Emil,

I already asked this, on my system, with jitsi 2.0
and pulseaudio, each time a connection is established,
all the volume control are set to the max.
This means the master volume and the mic volume,
including mic boost.
Net result is that, on my side, I get defeaned and
on the other side there is only loud noise.

If I open the alsa mixer (or equivalent) and correct the
volumes, then things improve to the expected quality.

I was wondering if there is a way to force some defaults
different from "everything to max".

Is there this possibility? How?
The settings menu does not allow to control this, I guess,
unless I'm missing something.

Thanks,

bye,

pg

···

On Sat, Mar 23, 2013 at 12:35:21PM +0100, Emil Ivov wrote:

Hey Juha,

On linux Jitsi supports portaudio and pulseaudio. Both of those then use
alsa.

Portaudio does indeed tend to provide poorer results, so you might want to
give a shot to pulseaudio. (Of course you'd need to install it first)

Cheers,
Emil

--sent from my mobile
On Mar 23, 2013 12:29 PM, "Juha Heinanen" <jh@tutpro.com> wrote:

> on debian linux, portaudio has never worked well for me whereas plain
> alsa works fine. jitsi 2.0 on my host does not allow me to choose alsa
> sound system, but only portaudio. as result, audio quality is really
> bad.
>
> does jitsi 2.0 support plain alsa or is alsa support just missing in the
> debian package that i downloaded from jitsi site?
>
> -- juha
>

--

piergiorgio


#4

Hey PG,

Are you using pulseaudio? I think we've seen this problem with it. No
workaround tho, so if that's what u r using, could you please open an issue?

Thanks,
Emil

--sent from my mobile

···

On Mar 23, 2013 12:55 PM, "Piergiorgio Sartor" <piergiorgio.sartor@nexgo.de> wrote:

Hi Emil,

I already asked this, on my system, with jitsi 2.0
and pulseaudio, each time a connection is established,
all the volume control are set to the max.
This means the master volume and the mic volume,
including mic boost.
Net result is that, on my side, I get defeaned and
on the other side there is only loud noise.

If I open the alsa mixer (or equivalent) and correct the
volumes, then things improve to the expected quality.

I was wondering if there is a way to force some defaults
different from "everything to max".

Is there this possibility? How?
The settings menu does not allow to control this, I guess,
unless I'm missing something.

Thanks,

bye,

pg

On Sat, Mar 23, 2013 at 12:35:21PM +0100, Emil Ivov wrote:
> Hey Juha,
>
> On linux Jitsi supports portaudio and pulseaudio. Both of those then use
> alsa.
>
> Portaudio does indeed tend to provide poorer results, so you might want
to
> give a shot to pulseaudio. (Of course you'd need to install it first)
>
> Cheers,
> Emil
>
> --sent from my mobile
> On Mar 23, 2013 12:29 PM, "Juha Heinanen" <jh@tutpro.com> wrote:
>
> > on debian linux, portaudio has never worked well for me whereas plain
> > alsa works fine. jitsi 2.0 on my host does not allow me to choose alsa
> > sound system, but only portaudio. as result, audio quality is really
> > bad.
> >
> > does jitsi 2.0 support plain alsa or is alsa support just missing in
the
> > debian package that i downloaded from jitsi site?
> >
> > -- juha
> >

--

piergiorgio


#5

Hi Emil,

yes, it is pulseaudio, I tried with different
devices (default or stereo) to no avail.

I tried portaudio too.
What I experienced here is that the output
volume is not changed, so it is correct, but
it seems the mic does not work.
This is interesting one. On my side, I can
see the mic level going up and down, but the
other side does seem to get only silence.
This seems (I've a lot of "seem") independent
from the device selection.

One question: is it possible to test this within
a single PC? The output volume it is clearly
audible by the ring call, but the mic?

About opening an issue, how does this work?
You mean a bug tracker at jitsi.org?

Thanks,

bye,

pg

···

On Sat, Mar 23, 2013 at 01:08:41PM +0100, Emil Ivov wrote:

Hey PG,

Are you using pulseaudio? I think we've seen this problem with it. No
workaround tho, so if that's what u r using, could you please open an issue?

Thanks,
Emil

--sent from my mobile
On Mar 23, 2013 12:55 PM, "Piergiorgio Sartor" <piergiorgio.sartor@nexgo.de> > wrote:

> Hi Emil,
>
> I already asked this, on my system, with jitsi 2.0
> and pulseaudio, each time a connection is established,
> all the volume control are set to the max.
> This means the master volume and the mic volume,
> including mic boost.
> Net result is that, on my side, I get defeaned and
> on the other side there is only loud noise.
>
> If I open the alsa mixer (or equivalent) and correct the
> volumes, then things improve to the expected quality.
>
> I was wondering if there is a way to force some defaults
> different from "everything to max".
>
> Is there this possibility? How?
> The settings menu does not allow to control this, I guess,
> unless I'm missing something.
>
> Thanks,
>
> bye,
>
> pg
>
> On Sat, Mar 23, 2013 at 12:35:21PM +0100, Emil Ivov wrote:
> > Hey Juha,
> >
> > On linux Jitsi supports portaudio and pulseaudio. Both of those then use
> > alsa.
> >
> > Portaudio does indeed tend to provide poorer results, so you might want
> to
> > give a shot to pulseaudio. (Of course you'd need to install it first)
> >
> > Cheers,
> > Emil
> >
> > --sent from my mobile
> > On Mar 23, 2013 12:29 PM, "Juha Heinanen" <jh@tutpro.com> wrote:
> >
> > > on debian linux, portaudio has never worked well for me whereas plain
> > > alsa works fine. jitsi 2.0 on my host does not allow me to choose alsa
> > > sound system, but only portaudio. as result, audio quality is really
> > > bad.
> > >
> > > does jitsi 2.0 support plain alsa or is alsa support just missing in
> the
> > > debian package that i downloaded from jitsi site?
> > >
> > > -- juha
> > >
>
> --
>
> piergiorgio
>

--

piergiorgio


#6

i installed pulseaudio and sound quality of jitsi didn't improve.

at the same time, paplay and parecord commands work fine and produce
high quality audio.

-- juha
.


#7

Did you switch to pusleaudio in Jitsi?

Emil

···

On Sat, Mar 23, 2013 at 2:55 PM, Juha Heinanen <jh@tutpro.com> wrote:

i installed pulseaudio and sound quality of jitsi didn't improve.

at the same time, paplay and parecord commands work fine and produce
high quality audio.

-- juha

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#8

Emil Ivov writes:

Did you switch to pusleaudio in Jitsi?

it switched automatically.

now the good news. when i changed audio device from Default to Build-in
Audio Analog Device, output sound quality became good. still working in
input quality.

-- juha
.


#9

Juha Heinanen writes:

now the good news. when i changed audio device from Default to Build-in
Audio Analog Device, output sound quality became good. still working in
input quality.

regarding input, it turned out that input quality was bad, because
capture mixer volume was as high as it can be. when i changed it
manually to lower level using alsamixer during the call, input quality
became good.

now the bad news. i had alsamixer still on when i placed a new call.
when call started, i saw capture mixer volume to go back up high
automatically, i.e., somehow jitsi managed to pump up calture volume and
as result input quality became bad again.

i vaguely remember someone reporting this kind of issue earlier. skype
used to have an option to turn off automatic level adjustment. perhaps
jitsi would need something similar.

-- juha
.


#10

Glad to know we are making progress.

The problem you expereince with levels (that indeed someone else also
reported today) is not something that Jitsi does. It's just that Pulseaudio
seems to be resetting volumes every time we open it. In other words, it's
not something that we can just disable.

Chenzo, I know you also had this issue. Did you find a decent workaround?

Cheers,
Emil

···

On Sat, Mar 23, 2013 at 4:16 PM, Juha Heinanen <jh@tutpro.com> wrote:

Juha Heinanen writes:

> now the good news. when i changed audio device from Default to Build-in
> Audio Analog Device, output sound quality became good. still working in
> input quality.

regarding input, it turned out that input quality was bad, because
capture mixer volume was as high as it can be. when i changed it
manually to lower level using alsamixer during the call, input quality
became good.

now the bad news. i had alsamixer still on when i placed a new call.
when call started, i saw capture mixer volume to go back up high
automatically, i.e., somehow jitsi managed to pump up calture volume and
as result input quality became bad again.

i vaguely remember someone reporting this kind of issue earlier. skype
used to have an option to turn off automatic level adjustment. perhaps
jitsi would need something similar.

-- juha

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#11

Hi Emil,

pulseaudio should be able to remember the
settings per application.
It actually does so, I can see it with
other software.

So, I guess, you're doing something not as
expected and, maybe, pulseaudio does not
understand properly.

Note that this was working with jitsi 1.0,
even if I upgraded jitsi and Fedore same time,
so I do not know if they changed something.

I can try jitsi 1.0, maybe.

bye,

pg

···

On Sat, Mar 23, 2013 at 04:29:26PM +0100, Emil Ivov wrote:

Glad to know we are making progress.

The problem you expereince with levels (that indeed someone else also
reported today) is not something that Jitsi does. It's just that Pulseaudio
seems to be resetting volumes every time we open it. In other words, it's
not something that we can just disable.

Chenzo, I know you also had this issue. Did you find a decent workaround?

Cheers,
Emil

On Sat, Mar 23, 2013 at 4:16 PM, Juha Heinanen <jh@tutpro.com> wrote:

> Juha Heinanen writes:
>
> > now the good news. when i changed audio device from Default to Build-in
> > Audio Analog Device, output sound quality became good. still working in
> > input quality.
>
> regarding input, it turned out that input quality was bad, because
> capture mixer volume was as high as it can be. when i changed it
> manually to lower level using alsamixer during the call, input quality
> became good.
>
> now the bad news. i had alsamixer still on when i placed a new call.
> when call started, i saw capture mixer volume to go back up high
> automatically, i.e., somehow jitsi managed to pump up calture volume and
> as result input quality became bad again.
>
> i vaguely remember someone reporting this kind of issue earlier. skype
> used to have an option to turn off automatic level adjustment. perhaps
> jitsi would need something similar.
>
> -- juha
>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

--

piergiorgio


#12

volumes seem to stay unchanged after i set in /etc/pulse/daemon.conf

flat-volumes = no

-- juha


#13

Hi Juha,

good information.

Actually, I still think there is something fishy
with jitsi.

In fact, the file ~/pulse/volume-restore.table
contains the volume settings for all the applications
I started in the past, but jitsi is not there, it seems.

bye,

pg

···

On Sat, Mar 23, 2013 at 06:23:53PM +0200, Juha Heinanen wrote:

volumes seem to stay unchanged after i set in /etc/pulse/daemon.conf

flat-volumes = no

-- juha

--

piergiorgio


#14

Hi Juha,

good information.

Actually, I still think there is something fishy
with jitsi.

In fact, the file ~/pulse/volume-restore.table
contains the volume settings for all the applications
I started in the past, but jitsi is not there, it seems.

Oh that's interesting. I am wondering how an application gets there. Is
it supposed to be automatic? If not then maybe we just need to do the
right call. Chenzo, I believe you last looked at this. Think you could
have a look again next week?

Emil

···

On 23.03.13, 17:38, Piergiorgio Sartor wrote:

bye,

pg

On Sat, Mar 23, 2013 at 06:23:53PM +0200, Juha Heinanen wrote:

volumes seem to stay unchanged after i set in /etc/pulse/daemon.conf

flat-volumes = no

-- juha

--
https://jitsi.org


#15

Hi Emil,

I checked again, the file ~/.pulse/volume-restore.table
is quite old, there is a new *.tdb file containing the
application settings.

This one, has an entry for "[java]", which might be for
jitsi, since it has source and sink.

I cannot say if it is correct or not.

bye,

pg

···

On Sat, Mar 23, 2013 at 07:05:33PM +0100, Emil Ivov wrote:

On 23.03.13, 17:38, Piergiorgio Sartor wrote:
> Hi Juha,
>
> good information.
>
> Actually, I still think there is something fishy
> with jitsi.
>
> In fact, the file ~/pulse/volume-restore.table
> contains the volume settings for all the applications
> I started in the past, but jitsi is not there, it seems.

Oh that's interesting. I am wondering how an application gets there. Is
it supposed to be automatic? If not then maybe we just need to do the
right call. Chenzo, I believe you last looked at this. Think you could
have a look again next week?

Emil
>
> bye,
>
> pg
>
> On Sat, Mar 23, 2013 at 06:23:53PM +0200, Juha Heinanen wrote:
>> volumes seem to stay unchanged after i set in /etc/pulse/daemon.conf
>>
>> flat-volumes = no
>>
>> -- juha
>

--
https://jitsi.org

--

piergiorgio