[jitsi-users] jitmeet + ejabberd ?


#1

Heya !

I have a ejabberd server (debian wheezy version), with jitsivideobridge. Everything's is working so far with jitsi client.
Now I would like to use jitmeet (with auth in the first place).

Here is my nginx conf:

···

######
server {
     listen 80;
     server_name xmpp.fibercryst.com;
     location / {
         root /home/fiberxmpp/jitmeet;
     }

     location ~ ^/([a-zA-Z0-9]+)$ {
         rewrite ^/(.*)$ / break;
     }

     location /http-bind {
         proxy_pass http://localhost:5280/http-bind;
         proxy_set_header X-Forwarded-For $remote_addr;
         proxy_set_header Host $http_host;
     }

     error_log /var/log/nginx/xmpp.error.log;
     access_log /var/log/nginx/xmpp.access.log;
}
######

I have edited config.js of jitmeet:
######
var config = {
     hosts: {
         domain: 'xmpp.fibercryst.com',
         muc: 'conference.xmpp.fibercryst.com', // FIXME: use XEP-0030
         bridge: 'jitsi-videobridge.xmpp.fibercryst.com' // FIXME: use XEP-0030
     },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath'; },
// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
// useIPv6: true, // ipv6 support. use at your own risk
     useNicks: true,
     bosh: '//xmpp.fibercryst.com/http-bind' // FIXME: use xep-0156 for that
};
######

And I added the mod_http_bind in ejabberd.cfg:
######
...
   {mod_time, []},
   {mod_vcard, []},
   {mod_http_bind, []},
   {mod_version, []}
  ]}.
...
######

When I load "xmpp.fibercryst.com" in Chromium, I have a "status 2" in console (CONNFAIL from Strophe, I guess). And nothing happens.
I have no error reported by ejabberd... I can't see what's wrong here.

What did I miss ? Maybe jitmeet is not ready for ejabberd yet ?

Thanks a lot !

Cordially,
Adrien


#2

Ok, I've just seen that the logs from ejabberd and from chromium console
are exactly the same, weither videobridge is started or not.

By the way, Videobridge works well, as I can use it with Jitsi client. In
addition, I see the following in ejabberd log:
Route registered for service "jitsi-videobridge.xmpp.fibercryst.com"

So the problem may lie between jitmeet and ejabberd, when Strophe tries to
connect. Here is the ejabberd log when jitmeet is accessed via chromium:

···

####
=INFO REPORT==== 2014-02-11 22:07:42 ===
I(<0.370.0>:ejabberd_listener:281) : (#Port<0.1914>) Accepted connection
{{127,0,0,1},49741} -> {{127,0,0,1},5280}

=INFO REPORT==== 2014-02-11 22:07:42 ===
I(<0.416.0>:ejabberd_http:143) : started: {gen_tcp,#Port<0.1914>}

=INFO REPORT==== 2014-02-11 22:07:42 ===
I(<0.370.0>:ejabberd_listener:281) : (#Port<0.1916>) Accepted connection
{{127,0,0,1},49742} -> {{127,0,0,1},5280}

=INFO REPORT==== 2014-02-11 22:07:42 ===
I(<0.419.0>:ejabberd_http:143) : started: {gen_tcp,#Port<0.1916>}
####

As I said, it's the same if videobridge isn't launched.
ejabberd in debug mode doesn't provide much more information.

Maybe I can activate Strophe logs ? So I can see why it can't connect.

Thanks again,
Adrien

2014-02-11 18:39 GMT+01:00 Adrien Aubourg <adrien.aubourg@gmail.com>:

Heya !

I have a ejabberd server (debian wheezy version), with jitsivideobridge.
Everything's is working so far with jitsi client.
Now I would like to use jitmeet (with auth in the first place).

Here is my nginx conf:
######
server {
    listen 80;
    server_name xmpp.fibercryst.com;
    location / {
        root /home/fiberxmpp/jitmeet;
    }

    location ~ ^/([a-zA-Z0-9]+)$ {
        rewrite ^/(.*)$ / break;
    }

    location /http-bind {
        proxy_pass http://localhost:5280/http-bind;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }

    error_log /var/log/nginx/xmpp.error.log;
    access_log /var/log/nginx/xmpp.access.log;
}
######

I have edited config.js of jitmeet:
######
var config = {
    hosts: {
        domain: 'xmpp.fibercryst.com',
        muc: 'conference.xmpp.fibercryst.com', // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.xmpp.fibercryst.com' // FIXME: use
XEP-0030
    },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath';
},
// useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
// useIPv6: true, // ipv6 support. use at your own risk
    useNicks: true,
    bosh: '//xmpp.fibercryst.com/http-bind' // FIXME: use xep-0156 for
that
};
######

And I added the mod_http_bind in ejabberd.cfg:
######
...
  {mod_time, []},
  {mod_vcard, []},
  {mod_http_bind, []},
  {mod_version, []}
]}.
...
######

When I load "xmpp.fibercryst.com" in Chromium, I have a "status 2" in
console (CONNFAIL from Strophe, I guess). And nothing happens.
I have no error reported by ejabberd... I can't see what's wrong here.

What did I miss ? Maybe jitmeet is not ready for ejabberd yet ?

Thanks a lot !

Cordially,
Adrien


#3

I think that at this point you need to use anonymous logins on the XMPP
server for the jitmeet clients.

Regards,
Boris

···

On 11/02/14 18:39, Adrien Aubourg wrote:

Heya !

I have a ejabberd server (debian wheezy version), with jitsivideobridge.
Everything's is working so far with jitsi client.
Now I would like to use jitmeet (with auth in the first place).


#4

So the config "useNicks: true" is not yet relevant ? Only anonymous is
possible for now ?

Maybe the initial config.js should tell the user.

I'll try today with anonymous login :slight_smile:

Thanks !

···

2014-02-12 9:55 GMT+01:00 Boris Grozev <boris@jitsi.org>:

On 11/02/14 18:39, Adrien Aubourg wrote:
> Heya !
>
> I have a ejabberd server (debian wheezy version), with jitsivideobridge.
> Everything's is working so far with jitsi client.
> Now I would like to use jitmeet (with auth in the first place).

I think that at this point you need to use anonymous logins on the XMPP
server for the jitmeet clients.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users