[jitsi-users] Jitmeet doesn't seem to work


#1

Hi,

I followed each step and installed any software you suggest in the instructions file on jitmeet section but it doesn't seem to work. There's a reference to smack2 , smack3 modules maybe now included just in a single module : module_smacks.lua

I installed all required softwares in the same machine and portforward 80, 3478 and 5222 ports, that's actually just a test for a personal use , not working even on lan.

The website gui is loaded but shows only a gray avatar , top banner and nothing else , it's not asked to access my webcam and microphone.

Leaving untouched the config.js shipped from jitmeet git makes all works but this way means using jitsi site not my own .

I attach the configurations and logs of my installation. (jitmeet+jitsiVideoBridge+nginx+prosody)

Any suggestion is welcome and very appreciated,
Thanks.
Mark ( mrK )

jitM_logs.txt (12.7 KB)

jitM_confs.txt (5.68 KB)


#2

Hello,

Sorry for the late reply. I don't have an answer either, just some
suggestions.

Hi,

I followed each step and installed any software you suggest in the
instructions file on jitmeet section but it doesn't seem to work.
There's a reference to smack2 , smack3 modules maybe now included just
in a single module : module_smacks.lua

Yeah, that seems a recent change in otalk-server.

I noticed you left out the "offline" module in your config. I'm just
hunting for differences, I have no idea if it is required.

I installed all required softwares in the same machine and portforward
80, 3478 and 5222 ports, that's actually just a test for a personal use
, not working even on lan.

The website gui is loaded but shows only a gray avatar , top banner and
nothing else , it's not asked to access my webcam and microphone.

That sounds weird. Maybe the javascript console log could shed some light.

From the other thread:

Hope this time message will be displayed correctly.

It was, thanks. I am replying to the original thread to keep the
description and logs together.

Regards,
Boris

···

On 13/03/14 13:10, mrk wrote:


#3

Hi,

The website gui is loaded but shows only a gray avatar , top banner and
nothing else , it's not asked to access my webcam and microphone.

That sounds weird. Maybe the javascript console log could shed some light.

Yes, please use CTRL+SHIFT+J to open the console and tell us if there
are any errors printed in the red. Probably Chrome does not allow to
access the mic. You can try to reset permissions by clicking on green
padlock on the left of "https://" and there you will be able to switch
on/off multimedia permissions.

Hope this helps !
Pawel

···

On Wed, Mar 19, 2014 at 9:38 PM, Boris Grozev <boris@jitsi.org> wrote:


#4

Hi, thanks both for your reply.

About Boris suggestion: yes i enabled also offline module on my last tests but same .

About Pawel suggestion: i have no enabled ssl module and certificate for my nginx server , it wasn't listed on the requirements, and no icon is displayed to allow use of my mic and cam when i use my test domain , only top banner with logo of jitsi and estos are displayed, no other icons.

It works fine , again, when i replace the config.js file on root server folder of jitmeet.

Here what i can read from javascript console :

init app.js?v=23:940
This appears to be Chrome strophe.jingle.adapter.js?v=1:472
status 1

In the network section of javascript console , i notice there's a pending for a long time request (around 60seconds) then it change status in 200 OK and then it makes another one :

http-bind strophe.jingle.bundles.js:3

There are some missing components in nginx installation ? restund is required even on lan use ?

Thanks,
Mark (mrK)

···

On 20/03/2014 09:01, Pawe? Domas wrote:

Hi,

On Wed, Mar 19, 2014 at 9:38 PM, Boris Grozev <boris@jitsi.org> wrote:

The website gui is loaded but shows only a gray avatar , top banner and
nothing else , it's not asked to access my webcam and microphone.

That sounds weird. Maybe the javascript console log could shed some light.

Yes, please use CTRL+SHIFT+J to open the console and tell us if there
are any errors printed in the red. Probably Chrome does not allow to
access the mic. You can try to reset permissions by clicking on green
padlock on the left of "https://" and there you will be able to switch
on/off multimedia permissions.

Hope this helps !
Pawel

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

Hi, thanks both for your reply.

About Boris suggestion: yes i enabled also offline module on my last tests
but same .

About Pawel suggestion: i have no enabled ssl module and certificate for my
nginx server , it wasn't listed on the requirements, and no icon is
displayed to allow use of my mic and cam when i use my test domain , only
top banner with logo of jitsi and estos are displayed, no other icons.

It works fine , again, when i replace the config.js file on root server
folder of jitmeet.

Here what i can read from javascript console :

init app.js?v=23:940
This appears to be Chrome strophe.jingle.adapter.js?v=1:472
status 1

In the network section of javascript console , i notice there's a pending
for a long time request (around 60seconds) then it change status in 200 OK
and then it makes another one :

http-bind strophe.jingle.bundles.js:3

There are some missing components in nginx installation ? restund is
required even on lan use ?

This request must be related to BOSH. Are you sure that it's section
configured fine in nginx and in config.js ?

You will get more details if you edit script strophe.jingle.bundles.js
so that logging part will look like below:

/**
* Strophe logger implementation. Logs from level WARN and above.
*/
Strophe.log = function (level, msg) {
    switch(level) {
        case Strophe.LogLevel.WARN:
            console.warn("Strophe: "+msg);
            break;
        case Strophe.LogLevel.ERROR:
        case Strophe.LogLevel.FATAL:
            console.error("Strophe: "+msg);
            break;
        default:
            console.log("Strophe: "+msg);
            break;
    }
};

I've added default section at the bottom which makes strophe logging
more verbose.

Regards,
Pawel

···

On Thu, Mar 20, 2014 at 10:34 AM, mrk <marcorossi2k@gmail.com> wrote:


#6

Hi ,
I modified that file as you said here the log :

init app.js:940 <http://jitmeet.example.com/app.js?v=23>
This appears to be Chrome strophe.jingle.adapter.js:472 <http://jitmeet.example.com/libs/strophe/strophe.jingle.adapter.js?v=1>
status 1 app.js:57 <http://jitmeet.example.com/app.js?v=23>
Strophe: _throttledRequestHandler called with 1 requests strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1.0 posting strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1.0 state changed to 1 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Failed to load resource http://www.google-analytics.com/analytics.js
Strophe: request id 1.1 state changed to 2 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1.1 state changed to 3 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1.1 state changed to 4 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: removing request strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: _throttledRequestHandler called with 0 requests strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1 should now be removed strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 1.1 got 200 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: _connect_cb was called strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: _throttledRequestHandler called with 1 requests strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 2.0 posting strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>
Strophe: request id 2.0 state changed to 1 strophe.jingle.bundle.js:18 <http://jitmeet.example.com/libs/strophe/strophe.jingle.bundle.js?v=8>

>Are you sure that it's section configured fine in nginx and in config.js ?

Nope I'm not sure for that I asked help :slight_smile: I checked the proxy urls provided by bosh and xmpp in a browser and they look working fine .

I post again both the ngix config and site enabled, and config.js.
Thanks, Mark (mrK)

···

----------------------------------------

+---------------------------------+

/ jitmeet config.js |

/+---------------------------------+

var config = {
     hosts: {
         domain: 'jitmeet.example.com',
         muc: 'conference.jitmeet.example.com', // FIXME: use XEP-0030
         bridge: 'jitsi-videobridge.jitmeet.example.com' // FIXME: use XEP-0030
     },
     useNicks: false,
     bosh: '//jitmeet.example.com/http-bind' // FIXME: use xep-0156 for that
};

+---------------------------------+

/ NGINX jitmeet.example.com CONF |

/+---------------------------------+

server {

         listen 80;

         server_name jitmeet.example.com;

         # set the root

         root /var/www/jitmeet.example.com;

         index index.html;

         location ~ ^/([a-zA-Z0-9]+)$ {

             rewrite ^/(.*)$ / break;

         }

     # BOSH

     location /http-bind {

         proxy_passhttp://localhost:5280/http-bind;

         proxy_set_header X-Forwarded-For $remote_addr;

         proxy_set_header Host $http_host;

     }

     # xmpp websockets

     location /xmpp-websocket {

         proxy_passhttp://localhost:5280;

         proxy_http_version 1.1;

         proxy_set_header Upgrade $http_upgrade;

         proxy_set_header Connection "upgrade";

         proxy_set_header Host $host;

         tcp_nodelay on;

     }

}

+---------------------------------+

/ NGINX CONF |

/+---------------------------------+
user www-data;
worker_processes 4;
pid /run/nginx.pid;

events {
  worker_connections 768;
  # multi_accept on;
}

http {

  sendfile on;
  tcp_nopush on;
  tcp_nodelay on;
  keepalive_timeout 65;
  types_hash_max_size 2048;

  server_names_hash_bucket_size 64;

  include /etc/nginx/mime.types;
  default_type application/octet-stream;

  access_log /var/log/nginx/access.log;
  error_log /var/log/nginx/error.log;

  gzip on;
  gzip_disable "msie6";

  include /etc/nginx/conf.d/*.conf;
  include /etc/nginx/sites-enabled/*;
}

+---------------------------------+

/ HOSTS FILE - SERVER SIDE |

/+---------------------------------+

127.0.0.1 jitmeet.example.com
127.0.0.1 conference.jitmeet.example.com
127.0.0.1 jitsi-videobridge.jitmeet.example.com

+---------------------------------+

/ HOSTS FILE - CLIENT SIDE |

/+---------------------------------+
192.168.0.211 jitmeet.example.com
192.168.0.211 conference.jitmeet.example.com
192.168.0.211 jitsi-videobridge.jitmeet.example.com