[jitsi-users] Jisi doesnt recognise srv record?


#1

Hey Folks,

I have set up openfire setver internally ip is 192.168.1.5 with domain
test.com. then set up dns on 1.6 with SRV record for eim.test.com likw below

_xmpp-client._tcp.test.com 0 0 5222 eim.test.con and ofcourse I have A
record added fir eim.test.com.

Now when i try to connect to opefore through jitsi with the users created
on openfire server, it doesnt get log in and if I add with IP address un
advanced tab it just goes in. Even i tried loggin in spark and it just logs
in bur not sure why jitsi is not able to detect srv record?

And other thing when two users logged in using ip address again only one
user is able share his drsktop if i try to share a desktop from other pc i
get below error.

Call ended by remote side. Reason: incompatible-parameters. Errorrl null

Any clue why?


#2

I have set up openfire setver internally ip is 192.168.1.5 with domain
test.com. then set up dns on 1.6 with SRV record for eim.test.com likw

below

_xmpp-client._tcp.test.com 0 0 5222 eim.test.con and ofcourse I have A
record added fir eim.test.com.

If you query for this SRV record from your OS (e.g. with dig or nslookup),
do you get the expected results?

Now when i try to connect to opefore through jitsi with the users created

on

openfire server, it doesnt get log in and if I add with IP address un
advanced tab it just goes in. Even i tried loggin in spark and it just

logs

in bur not sure why jitsi is not able to detect srv record?

And other thing when two users logged in using ip address again only one

user

is able share his drsktop if i try to share a desktop from other pc i get
below error.

Call ended by remote side. Reason: incompatible-parameters. Errorrl null

Any clue why?

Did you change anything in the codecs? If not please send us your logs
(https://jitsi.org/logs).

Ingo


#3

Yes I do get desired results when I query using nslookup.

Where canI find logs?

···

On 16 Jul 2013 11:35, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> I have set up openfire setver internally ip is 192.168.1.5 with domain
> test.com. then set up dns on 1.6 with SRV record for eim.test.com likw
below
>
> _xmpp-client._tcp.test.com 0 0 5222 eim.test.con and ofcourse I have A
> record added fir eim.test.com.

If you query for this SRV record from your OS (e.g. with dig or nslookup),
do you get the expected results?

> Now when i try to connect to opefore through jitsi with the users created
on
> openfire server, it doesnt get log in and if I add with IP address un
> advanced tab it just goes in. Even i tried loggin in spark and it just
logs
> in bur not sure why jitsi is not able to detect srv record?
>
> And other thing when two users logged in using ip address again only one
user
> is able share his drsktop if i try to share a desktop from other pc i get
> below error.
>
> Call ended by remote side. Reason: incompatible-parameters. Errorrl null
>
> Any clue why?

Did you change anything in the codecs? If not please send us your logs
(https://jitsi.org/logs).

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

My bad..havent looked at the url. Will just send you logs

···

On 16 Jul 2013 11:38, "Blason rock" <blason16@gmail.com> wrote:

Yes I do get desired results when I query using nslookup.

Where canI find logs?
On 16 Jul 2013 11:35, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> I have set up openfire setver internally ip is 192.168.1.5 with domain
> test.com. then set up dns on 1.6 with SRV record for eim.test.com likw
below
>
> _xmpp-client._tcp.test.com 0 0 5222 eim.test.con and ofcourse I have A
> record added fir eim.test.com.

If you query for this SRV record from your OS (e.g. with dig or nslookup),
do you get the expected results?

> Now when i try to connect to opefore through jitsi with the users
created
on
> openfire server, it doesnt get log in and if I add with IP address un
> advanced tab it just goes in. Even i tried loggin in spark and it just
logs
> in bur not sure why jitsi is not able to detect srv record?
>
> And other thing when two users logged in using ip address again only one
user
> is able share his drsktop if i try to share a desktop from other pc i
get
> below error.
>
> Call ended by remote side. Reason: incompatible-parameters. Errorrl null
>
> Any clue why?

Did you change anything in the codecs? If not please send us your logs
(https://jitsi.org/logs).

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Here are the log files.

log.zip (67 KB)

···

On Tue, Jul 16, 2013 at 12:35 PM, Blason rock <blason16@gmail.com> wrote:

My bad..havent looked at the url. Will just send you logs
On 16 Jul 2013 11:38, "Blason rock" <blason16@gmail.com> wrote:

Yes I do get desired results when I query using nslookup.

Where canI find logs?
On 16 Jul 2013 11:35, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> I have set up openfire setver internally ip is 192.168.1.5 with domain
> test.com. then set up dns on 1.6 with SRV record for eim.test.com likw
below
>
> _xmpp-client._tcp.test.com 0 0 5222 eim.test.con and ofcourse I have
A
> record added fir eim.test.com.

If you query for this SRV record from your OS (e.g. with dig or
nslookup),
do you get the expected results?

> Now when i try to connect to opefore through jitsi with the users
created
on
> openfire server, it doesnt get log in and if I add with IP address un
> advanced tab it just goes in. Even i tried loggin in spark and it just
logs
> in bur not sure why jitsi is not able to detect srv record?
>
> And other thing when two users logged in using ip address again only
one
user
> is able share his drsktop if i try to share a desktop from other pc i
get
> below error.
>
> Call ended by remote side. Reason: incompatible-parameters. Errorrl
null
>
> Any clue why?

Did you change anything in the codecs? If not please send us your logs
(https://jitsi.org/logs).

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Here are the log files.

First of all, running Jitsi (or any multimedia application) on Windows
Server 2008 will give you a limited experience at best, as the Windows
server editions don't come with all the necessary subsystems (even with the
desktop pack installed).

In the logs I only saw that your primary DNS doesn't answer to a query. But
I also have to say that our DNS logging in 2.2 is very basic. You might want
to try with the latest nightly (that has some more detailed logs) and send
us the logs again.

You could also try running Wireshark where the DNS queries are sent to and
what the response is (if there is any at all).

Ingo


#7

Ok - thanks for your assistance I resolved the issue. I should have entered
DNS hostname instead of IP Address and I was entering ip. Now I am able to
login with SRV record.

The other thing I observed is both my clients are windows 7, srerver
oprnfire 3.8.1, have loaded libjitsi plugin. From my one desktop I sm able
to take remote console while from other it shows below warning and call
ends. "Call ended by remote side: incompatible parameters, Error: null"

Any clue what could be the issue?

···

On 17 Jul 2013 21:02, "Ingo Bauersachs" <ingo@jitsi.org> wrote:

> Here are the log files.

First of all, running Jitsi (or any multimedia application) on Windows
Server 2008 will give you a limited experience at best, as the Windows
server editions don't come with all the necessary subsystems (even with the
desktop pack installed).

In the logs I only saw that your primary DNS doesn't answer to a query. But
I also have to say that our DNS logging in 2.2 is very basic. You might
want
to try with the latest nightly (that has some more detailed logs) and send
us the logs again.

You could also try running Wireshark where the DNS queries are sent to and
what the response is (if there is any at all).

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users