[jitsi-users] Jigasi quick install instructions incomplete?


#1

Hi,

I'm trying to install Jitsi and Jigasi using the quick install instructions. The telephone icon is not showing up after installing Jigasi and I don't know if the problem is with the gateway or the installation. In the Jitsi config file there is a line

// call_control: 'callcontrol.localhost',

Should I uncomment it? If I do, I am able to open the dialogue for calling a phone number, but when I press call I get a lot of errors. In what format should the phone number be added (country code prefix)?

So my question are

1. is there any additional configuration needed to install Jigasi than what is written in the quick install instructions

2. in what format does country code prefix need to be written when calling

3. are there any public SIP gateways that can be used for testing Jigasi? Sip2sip.info is not working because of some certificate problem

Best regards,
Markus Kullberg


#2

Hi,

Have you checked jigasi logs? You do not need to uncomment anything in
the config, it is auto-discovered.
By default what you enter is what is sent to the server. There is also
an option to supply default/supported prefixes you can check how it
looks on meet.jit.si, then it sends the prefix with the concatenated
number.

Regards
damencho

···

On Wed, Dec 20, 2017 at 1:00 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

I’m trying to install Jitsi and Jigasi using the quick install instructions.
The telephone icon is not showing up after installing Jigasi and I don’t
know if the problem is with the gateway or the installation. In the Jitsi
config file there is a line

// call_control: ‘callcontrol.localhost’,

Should I uncomment it? If I do, I am able to open the dialogue for calling a
phone number, but when I press call I get a lot of errors. In what format
should the phone number be added (country code prefix)?

So my question are

1. is there any additional configuration needed to install Jigasi than
what is written in the quick install instructions

2. in what format does country code prefix need to be written when
calling

3. are there any public SIP gateways that can be used for testing
Jigasi? Sip2sip.info is not working because of some certificate problem

Best regards,

Markus Kullberg

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

No errors in jigasi logs after the info message that says newState=RegistrationState=Registered. Still no telephone icon showing up. I saw in the JS console the following output:

[modules/xmpp/moderator.js] <i.parseConfigOptions>: Sip gateway enabled: false

So even though Jigasi successfully registers, the telephone icon does not show up. Any ideas? I'm running Jitsi on Ubuntu 16.04.

-Markus

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 20. joulukuuta 2017 17:32
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jigasi quick install instructions incomplete?

Hi,

Have you checked jigasi logs? You do not need to uncomment anything in the config, it is auto-discovered.
By default what you enter is what is sent to the server. There is also an option to supply default/supported prefixes you can check how it looks on meet.jit.si, then it sends the prefix with the concatenated number.

Regards
damencho

On Wed, Dec 20, 2017 at 1:00 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

I’m trying to install Jitsi and Jigasi using the quick install instructions.
The telephone icon is not showing up after installing Jigasi and I
don’t know if the problem is with the gateway or the installation. In
the Jitsi config file there is a line

// call_control: ‘callcontrol.localhost’,

Should I uncomment it? If I do, I am able to open the dialogue for
calling a phone number, but when I press call I get a lot of errors.
In what format should the phone number be added (country code prefix)?

So my question are

1. is there any additional configuration needed to install Jigasi than
what is written in the quick install instructions

2. in what format does country code prefix need to be written when
calling

3. are there any public SIP gateways that can be used for testing
Jigasi? Sip2sip.info is not working because of some certificate
problem

Best regards,

Markus Kullberg

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

No errors in jigasi logs after the info message that says newState=RegistrationState=Registered. Still no telephone icon showing up. I saw in the JS console the following output:

[modules/xmpp/moderator.js] <i.parseConfigOptions>: Sip gateway enabled: false

This means that jicofo is not seeing the jigasi instance and is
advertising to the client that sip gw is not enabled. Have you
modified the default configurations of any of the components prosody,
jicofo, jigasi?

···

On Thu, Dec 21, 2017 at 3:33 AM, <markus.kullberg@teliacompany.com> wrote:

So even though Jigasi successfully registers, the telephone icon does not show up. Any ideas? I'm running Jitsi on Ubuntu 16.04.

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 20. joulukuuta 2017 17:32
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jigasi quick install instructions incomplete?

Hi,

Have you checked jigasi logs? You do not need to uncomment anything in the config, it is auto-discovered.
By default what you enter is what is sent to the server. There is also an option to supply default/supported prefixes you can check how it looks on meet.jit.si, then it sends the prefix with the concatenated number.

Regards
damencho

On Wed, Dec 20, 2017 at 1:00 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

I’m trying to install Jitsi and Jigasi using the quick install instructions.
The telephone icon is not showing up after installing Jigasi and I
don’t know if the problem is with the gateway or the installation. In
the Jitsi config file there is a line

// call_control: ‘callcontrol.localhost’,

Should I uncomment it? If I do, I am able to open the dialogue for
calling a phone number, but when I press call I get a lot of errors.
In what format should the phone number be added (country code prefix)?

So my question are

1. is there any additional configuration needed to install Jigasi than
what is written in the quick install instructions

2. in what format does country code prefix need to be written when
calling

3. are there any public SIP gateways that can be used for testing
Jigasi? Sip2sip.info is not working because of some certificate
problem

Best regards,

Markus Kullberg

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users