[jitsi-users] jigasi on debian 7


#1

Hi list , I trty to install jigasi with debian 7 but fails because
need the version 2.7 of libc6

apt-get -y install jigasi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jigasi : Depends: libc6-i386 (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

someone has solved with wheezy?

regardss

···

--
rickygm

http://gnuforever.homelinux.com


#2

Any help list..

···

On Thursday, November 27, 2014, ricky gutierrez <xserverlinux@gmail.com> wrote:

Hi list , I trty to install jigasi with debian 7 but fails because
need the version 2.7 of libc6

apt-get -y install jigasi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jigasi : Depends: libc6-i386 (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

someone has solved with wheezy?

regardss

--
rickygm

http://gnuforever.homelinux.com

--
rickygm

http://gnuforever.homelinux.com


#3

Hey Ricky,

I know Yasen was looking at this yesterday. Not sure if he fixed it already
but he would do so early next week if not.

--sent from my mobile

···

On 29 Nov 2014 6:24 AM, "ricky gutierrez" <xserverlinux@gmail.com> wrote:

Any help list..

On Thursday, November 27, 2014, ricky gutierrez <xserverlinux@gmail.com> > wrote:

Hi list , I trty to install jigasi with debian 7 but fails because
need the version 2.7 of libc6

apt-get -y install jigasi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jigasi : Depends: libc6-i386 (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

someone has solved with wheezy?

regardss

--
rickygm

http://gnuforever.homelinux.com

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hey,
It was fixed in the sources. But there is no build yet, as there are some
problems with accessing the download location. Once it is resolved I will
inform you so you can test.

Regarda
damencho

···

On Nov 29, 2014 7:47 AM, "Emil Ivov" <emcho@jitsi.org> wrote:

Hey Ricky,

I know Yasen was looking at this yesterday. Not sure if he fixed it
already but he would do so early next week if not.

--sent from my mobile
On 29 Nov 2014 6:24 AM, "ricky gutierrez" <xserverlinux@gmail.com> wrote:

Any help list..

On Thursday, November 27, 2014, ricky gutierrez <xserverlinux@gmail.com> >> wrote:

Hi list , I trty to install jigasi with debian 7 but fails because
need the version 2.7 of libc6

apt-get -y install jigasi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jigasi : Depends: libc6-i386 (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

someone has solved with wheezy?

regardss

--
rickygm

http://gnuforever.homelinux.com

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Ricky,

In the meantime before the release is available for download you can fix
this manually if you want. It is a matter of editing the control file in
the debian package and removing the -i386 from the libc6 dependency. It
should become Depends: libc6 (>= 2.7)... instead of Depends: libc6-i386 (>=
2.7)...

Changing this is done by (change jigasi-xxx.deb with the exact filename of
your package; if you don't see it it should still be in
/var/cache/apt/archives/):

ar x jigasi-xxx.deb
tar -xzf control.tar.gz
sed -i "s/libc6-i386/libc6/g" control
tar -czf control.tar.gz conffiles config control md5sums postinst postrm
prerm templates
ar r jigasi-xxx.deb debian-binary control.tar.gz data.tar.gz

And then clean up

rm -f conffiles config control control.tar.gz data.tar.gz debian-binary
md5sums postinst postrm prerm templates

The file jigasi-xxx.deb should now be with the correct dependencies.

N.B.: If you are not sure what this is doing, please wait for the new
version release as all these things above could potentially be dangerous
for your system.

···

On Sat, Nov 29, 2014 at 8:51 AM, Damian Minkov <damencho@jitsi.org> wrote:

It was fixed in the sources. But there is no build yet, as there are some
problems with accessing the download location. Once it is resolved I will
inform you so you can test.

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#6

Thnk Emil , Damian , excellent Yasen the explanation,but I prefer to
install the deb, I do not like much from the source install any
application, I'll wait for the new packages, so far I'm doing tests
with Jitsi VideoBRIDGE and works well what I have running with a
ejabberd 14.07.

my best regards

···

2014-11-29 5:58 GMT-06:00 Yasen Pramatarov <yasen@bluejimp.com>:

On Sat, Nov 29, 2014 at 8:51 AM, Damian Minkov <damencho@jitsi.org> wrote:

It was fixed in the sources. But there is no build yet, as there are some
problems with accessing the download location. Once it is resolved I will
inform you so you can test.

Hi Ricky,

In the meantime before the release is available for download you can fix
this manually if you want. It is a matter of editing the control file in the
debian package and removing the -i386 from the libc6 dependency. It should
become Depends: libc6 (>= 2.7)... instead of Depends: libc6-i386 (>= 2.7)...

Changing this is done by (change jigasi-xxx.deb with the exact filename of
your package; if you don't see it it should still be in
/var/cache/apt/archives/):

ar x jigasi-xxx.deb
tar -xzf control.tar.gz
sed -i "s/libc6-i386/libc6/g" control
tar -czf control.tar.gz conffiles config control md5sums postinst postrm
prerm templates
ar r jigasi-xxx.deb debian-binary control.tar.gz data.tar.gz

And then clean up

rm -f conffiles config control control.tar.gz data.tar.gz debian-binary
md5sums postinst postrm prerm templates

The file jigasi-xxx.deb should now be with the correct dependencies.

N.B.: If you are not sure what this is doing, please wait for the new
version release as all these things above could potentially be dangerous for
your system.

--
Yasen Pramatarov
sysadmin, https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com


#7

Hey,

It is fixed now. Package is in the repo.

Cheers
damencho

···

On Sat, Nov 29, 2014 at 5:54 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

Thnk Emil , Damian , excellent Yasen the explanation,but I prefer to
install the deb, I do not like much from the source install any
application, I'll wait for the new packages, so far I'm doing tests
with Jitsi VideoBRIDGE and works well what I have running with a
ejabberd 14.07.

my best regards

2014-11-29 5:58 GMT-06:00 Yasen Pramatarov <yasen@bluejimp.com>:

On Sat, Nov 29, 2014 at 8:51 AM, Damian Minkov <damencho@jitsi.org> wrote:

It was fixed in the sources. But there is no build yet, as there are some
problems with accessing the download location. Once it is resolved I will
inform you so you can test.

Hi Ricky,

In the meantime before the release is available for download you can fix
this manually if you want. It is a matter of editing the control file in the
debian package and removing the -i386 from the libc6 dependency. It should
become Depends: libc6 (>= 2.7)... instead of Depends: libc6-i386 (>= 2.7)...

Changing this is done by (change jigasi-xxx.deb with the exact filename of
your package; if you don't see it it should still be in
/var/cache/apt/archives/):

ar x jigasi-xxx.deb
tar -xzf control.tar.gz
sed -i "s/libc6-i386/libc6/g" control
tar -czf control.tar.gz conffiles config control md5sums postinst postrm
prerm templates
ar r jigasi-xxx.deb debian-binary control.tar.gz data.tar.gz

And then clean up

rm -f conffiles config control control.tar.gz data.tar.gz debian-binary
md5sums postinst postrm prerm templates

The file jigasi-xxx.deb should now be with the correct dependencies.

N.B.: If you are not sure what this is doing, please wait for the new
version release as all these things above could potentially be dangerous for
your system.

--
Yasen Pramatarov
sysadmin, https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Just a side note -- I was not talking about installation "from source",
but about modifying the deb package to make it installable.

Anyway I see the issue if already fixed, so there is no problem now :slight_smile:

···

On Sat, Nov 29, 2014 at 5:54 PM, ricky gutierrez <xserverlinux@gmail.com> wrote:

install the deb, I do not like much from the source install any
application, I'll wait for the new packages, so far I'm doing tests

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#9

thnk my friends work the installation.

regardss

···

2014-12-01 3:22 GMT-06:00 Yasen Pramatarov <yasen@bluejimp.com>:

On Sat, Nov 29, 2014 at 5:54 PM, ricky gutierrez <xserverlinux@gmail.com> > wrote:

install the deb, I do not like much from the source install any
application, I'll wait for the new packages, so far I'm doing tests

Just a side note -- I was not talking about installation "from source", but
about modifying the deb package to make it installable.

Anyway I see the issue if already fixed, so there is no problem now :slight_smile:

--
Yasen Pramatarov
sysadmin, https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com


#10

Installation worked smoothly on wheezy - great! Thanks, great job, Thomas

···

Am 01.12.2014 um 15:34 schrieb ricky gutierrez <xserverlinux@gmail.com>:

thnk my friends work the installation.

regardss

2014-12-01 3:22 GMT-06:00 Yasen Pramatarov <yasen@bluejimp.com>:

On Sat, Nov 29, 2014 at 5:54 PM, ricky gutierrez <xserverlinux@gmail.com> >> wrote:

install the deb, I do not like much from the source install any
application, I'll wait for the new packages, so far I'm doing tests

Just a side note -- I was not talking about installation "from source", but
about modifying the deb package to make it installable.

Anyway I see the issue if already fixed, so there is no problem now :slight_smile:

--
Yasen Pramatarov
sysadmin, https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
rickygm

http://gnuforever.homelinux.com

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users