[jitsi-users] Jigasi dependancy on audio system (?) and connection issue


#1

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a Debian Jessie virtual machine) I can’t get Jigasi setting up a connection anymore:

I) It is starting - however with error:

SEVERE: [9] org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.
java.lang.IllegalStateException: audioSystem
  at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-3,5,main] and message was: null
java.lang.NullPointerException
  at org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267) -

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up ALSA...done (none loaded).
This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in „initializing call“ and times out after 20-30s :

SEVERE: [40] service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190 An error occurred while executing RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent) of net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4
java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

jigasi.log (30.3 KB)


#2

Damencho could you please see if we can remove alsa as a dependency? I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is not breaking anything.

Emil

···

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a Debian Jessie virtual machine) I can�t get Jigasi setting up a connection anymore:

I) It is starting - however with error:

SEVERE: [9] org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.
java.lang.IllegalStateException: audioSystem
  at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-3,5,main] and message was: null
java.lang.NullPointerException
  at org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267) -

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up ALSA...done (none loaded).
This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in �initializing call� and times out after 20-30s :

SEVERE: [40] service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190 An error occurred while executing RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent) of net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4
java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#3

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a Ubuntu 14.04 system and was able to setup calls (outbound, inbound I cannot verify yet due to missing SIP header).
However, there are still some more error messages in the log (attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu right now (it has already worked on Debian) - contrary to the rest of jitsi-meet/videobridge.

Regards, Thomas

another log:

jigasi2.txt (34.4 KB)


#4

Hi,

I've just tested it on Debian sid with clean install (purged prosody
nginx meet jvb ...), with all updates on the system till this morning
doing just apt-get install jigasi and everything works just fine.
In the first logs attached there seems to be some problem with xmpp
signaling not sure what the problem is as the xmpp messages are not
availbale but this seems to be the problem:
CallPeerJabberImpl.processSessionInitiate().810 Failed to process an
incoming session initiate
and
IllegalStateException: The initiator is expected to specify the
transport in their offer.
at net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.getTransportManager(CallPeerMediaHandlerJabberImpl.java:903)

The exceptions you see are normal and doesn't do any harm, I can see it also.

Regards
damencho

···

On Fri, Oct 24, 2014 at 1:20 AM, Thomas Odorfer <odotom@gmail.com> wrote:

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a Ubuntu 14.04 system and was able to setup calls (outbound, inbound I cannot verify yet due to missing SIP header).
However, there are still some more error messages in the log (attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu right now (it has already worked on Debian) - contrary to the rest of jitsi-meet/videobridge.

Regards, Thomas

another log:

Am Oct 23, 2014 um 10:33 PM schrieb Emil Ivov <emcho@jitsi.org>:

Damencho could you please see if we can remove alsa as a dependency? I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is not breaking anything.

Emil

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a Debian Jessie virtual machine) I can’t get Jigasi setting up a connection anymore:

I) It is starting - however with error:

SEVERE: [9] org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.
java.lang.IllegalStateException: audioSystem
      at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-3,5,main] and message was: null
java.lang.NullPointerException
      at org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267) -

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up ALSA...done (none loaded).
This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in „initializing call“ and times out after 20-30s :

SEVERE: [40] service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190 An error occurred while executing RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent) of net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4
java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

I've just tested it on Debian sid with clean install (purged prosody
nginx meet jvb ...), with all updates on the system till this morning
doing just apt-get install jigasi and everything works just fine.
In the first logs attached there seems to be some problem with xmpp
signaling not sure what the problem is as the xmpp messages are not
availbale but this seems to be the problem:
CallPeerJabberImpl.processSessionInitiate().810 Failed to process an
incoming session initiate
and
IllegalStateException: The initiator is expected to specify the
transport in their offer.

Maybe the focus is using bundle, which jigasi doesn't understand yet?

Boris

···

On October 24, 2014 12:19:23 AM PDT, Damian Minkov <damencho@jitsi.org> wrote:

at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.getTransportManager(CallPeerMediaHandlerJabberImpl.java:903)

The exceptions you see are normal and doesn't do any harm, I can see it
also.

Regards
damencho

On Fri, Oct 24, 2014 at 1:20 AM, Thomas Odorfer <odotom@gmail.com> >wrote:

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems

apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a

Ubuntu 14.04 system and was able to setup calls (outbound, inbound I
cannot verify yet due to missing SIP header).

However, there are still some more error messages in the log

(attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu

right now (it has already worked on Debian) - contrary to the rest of
jitsi-meet/videobridge.

Regards, Thomas

another log:

Am Oct 23, 2014 um 10:33 PM schrieb Emil Ivov <emcho@jitsi.org>:

Damencho could you please see if we can remove alsa as a dependency?

I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is

not breaking anything.

Emil

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a

Debian Jessie virtual machine) I can’t get Jigasi setting up a
connection anymore:

I) It is starting - however with error:

SEVERE: [9]

org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with JMF.

java.lang.IllegalStateException: audioSystem
      at

org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught

exception occurred in thread=Thread[Thread-3,5,main] and message was:
null

java.lang.NullPointerException
      at

org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
-

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up

ALSA...done (none loaded).

This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in

„initializing call“ and times out after 20-30s :

SEVERE: [40]

service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4

java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the

sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.


#6

Hi Damian,

that is good news, I will also try myself a fresh Debian install. Probably something went wrong during update/upgrade including lots of jessie updates. I remember that installation on a debian stable eg. wheezy was not possible last time due to some debian package dependency.
I will look again into this xmpp issue, however I haven’t seen any other issues around xmpp signaling - prosody is uptodate.
Thanks for investigating

Best regards, Thomas

Hi,

I've just tested it on Debian sid with clean install (purged prosody
nginx meet jvb ...), with all updates on the system till this morning
doing just apt-get install jigasi and everything works just fine.
In the first logs attached there seems to be some problem with xmpp
signaling not sure what the problem is as the xmpp messages are not
availbale but this seems to be the problem:
CallPeerJabberImpl.processSessionInitiate().810 Failed to process an
incoming session initiate
and
IllegalStateException: The initiator is expected to specify the
transport in their offer.
at net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.getTransportManager(CallPeerMediaHandlerJabberImpl.java:903)

The exceptions you see are normal and doesn't do any harm, I can see it also.

Regards
damencho

···

Am Oct 24, 2014 um 9:19 AM schrieb Damian Minkov <damencho@jitsi.org>:

On Fri, Oct 24, 2014 at 1:20 AM, Thomas Odorfer <odotom@gmail.com> wrote:

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a Ubuntu 14.04 system and was able to setup calls (outbound, inbound I cannot verify yet due to missing SIP header).
However, there are still some more error messages in the log (attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu right now (it has already worked on Debian) - contrary to the rest of jitsi-meet/videobridge.

Regards, Thomas

another log:

Am Oct 23, 2014 um 10:33 PM schrieb Emil Ivov <emcho@jitsi.org>:

Damencho could you please see if we can remove alsa as a dependency? I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is not breaking anything.

Emil

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a Debian Jessie virtual machine) I can’t get Jigasi setting up a connection anymore:

I) It is starting - however with error:

SEVERE: [9] org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.
java.lang.IllegalStateException: audioSystem
     at org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught exception occurred in thread=Thread[Thread-3,5,main] and message was: null
java.lang.NullPointerException
     at org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267) -

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up ALSA...done (none loaded).
This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in „initializing call“ and times out after 20-30s :

SEVERE: [40] service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190 An error occurred while executing RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent) of net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4
java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hey,

well the configuration of jigasi takes care of this and maybe on a
clean install it works. But if edited or there was some old jitsi-meet
upgrade which overrides the config this can be broken at some point.
Thanks Boris.

So Thomas if you spot it again check please for the following values
in config.js:
    useRtcpMux: false,
    useBundle: false,

Regards
damencho

···

On Fri, Oct 24, 2014 at 3:47 PM, Boris Grozev <boris@jitsi.org> wrote:

On October 24, 2014 12:19:23 AM PDT, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

I've just tested it on Debian sid with clean install (purged prosody
nginx meet jvb ...), with all updates on the system till this morning
doing just apt-get install jigasi and everything works just fine.
In the first logs attached there seems to be some problem with xmpp
signaling not sure what the problem is as the xmpp messages are not
availbale but this seems to be the problem:
CallPeerJabberImpl.processSessionInitiate().810 Failed to process an
incoming session initiate
and
IllegalStateException: The initiator is expected to specify the
transport in their offer.

Maybe the focus is using bundle, which jigasi doesn't understand yet?

Boris

at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.getTransportManager(CallPeerMediaHandlerJabberImpl.java:903)

The exceptions you see are normal and doesn't do any harm, I can see it
also.

Regards
damencho

On Fri, Oct 24, 2014 at 1:20 AM, Thomas Odorfer <odotom@gmail.com> >>wrote:

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems

apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a

Ubuntu 14.04 system and was able to setup calls (outbound, inbound I
cannot verify yet due to missing SIP header).

However, there are still some more error messages in the log

(attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu

right now (it has already worked on Debian) - contrary to the rest of
jitsi-meet/videobridge.

Regards, Thomas

another log:

Am Oct 23, 2014 um 10:33 PM schrieb Emil Ivov <emcho@jitsi.org>:

Damencho could you please see if we can remove alsa as a dependency?

I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is

not breaking anything.

Emil

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a

Debian Jessie virtual machine) I can’t get Jigasi setting up a
connection anymore:

I) It is starting - however with error:

SEVERE: [9]

org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with JMF.

java.lang.IllegalStateException: audioSystem
      at

org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught

exception occurred in thread=Thread[Thread-3,5,main] and message was:
null

java.lang.NullPointerException
      at

org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
-

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up

ALSA...done (none loaded).

This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in

„initializing call“ and times out after 20-30s :

SEVERE: [40]

service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4

java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the

sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.


#8

Hi Damencho, Boris,
many thanks for this input. That was probably the reason.
I kept my standard config.js as it included some modifications for the screen sharing chrome app - and that was derived from the original config.js in jitsi-meet.
Maybe we should add some comment in config.js highlighting the effect of these flags onto jigasi as there sometimes circumstances when the install script does not work.
Best regards and have a nice weekend,
Thomas

Hey,

well the configuration of jigasi takes care of this and maybe on a
clean install it works. But if edited or there was some old jitsi-meet
upgrade which overrides the config this can be broken at some point.
Thanks Boris.

So Thomas if you spot it again check please for the following values
in config.js:
   useRtcpMux: false,
   useBundle: false,

Regards
damencho

···

Am Oct 24, 2014 um 2:54 PM schrieb Damian Minkov <damencho@jitsi.org>:

On Fri, Oct 24, 2014 at 3:47 PM, Boris Grozev <boris@jitsi.org> wrote:

On October 24, 2014 12:19:23 AM PDT, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

I've just tested it on Debian sid with clean install (purged prosody
nginx meet jvb ...), with all updates on the system till this morning
doing just apt-get install jigasi and everything works just fine.
In the first logs attached there seems to be some problem with xmpp
signaling not sure what the problem is as the xmpp messages are not
availbale but this seems to be the problem:
CallPeerJabberImpl.processSessionInitiate().810 Failed to process an
incoming session initiate
and
IllegalStateException: The initiator is expected to specify the
transport in their offer.

Maybe the focus is using bundle, which jigasi doesn't understand yet?

Boris

at
net.java.sip.communicator.impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.getTransportManager(CallPeerMediaHandlerJabberImpl.java:903)

The exceptions you see are normal and doesn't do any harm, I can see it
also.

Regards
damencho

On Fri, Oct 24, 2014 at 1:20 AM, Thomas Odorfer <odotom@gmail.com> >> wrote:

Hi Emil,
thanks for redirecting.
It seems that the alsa dependency does not cause any further problems

apart from the startup error messages.

I solved my connectivity problem by performing a fresh install on a

Ubuntu 14.04 system and was able to setup calls (outbound, inbound I
cannot verify yet due to missing SIP header).

However, there are still some more error messages in the log

(attached).

To summarize: It seems that Jigasi is exclusively working on Ubuntu

right now (it has already worked on Debian) - contrary to the rest of
jitsi-meet/videobridge.

Regards, Thomas

another log:

Am Oct 23, 2014 um 10:33 PM schrieb Emil Ivov <emcho@jitsi.org>:

Damencho could you please see if we can remove alsa as a dependency?

I think we have the silence audio system there so we shouldn't need it.

ZRTP is not used in Jigasi so we should make sure this exception is

not breaking anything.

Emil

On 23.10.14, 17:40, Thomas Odorfer wrote:

Hi,

after upgrading (jitsi-meet/prosody 1.0.221, jigasi 1.0-30 on a

Debian Jessie virtual machine) I can’t get Jigasi setting up a
connection anymore:

I) It is starting - however with error:

SEVERE: [9]

org.jitsi.impl.neomedia.device.DeviceConfiguration.error() Failed to
register custom Renderer
org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer
with JMF.

java.lang.IllegalStateException: audioSystem
     at

org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer.<init>(PulseAudioRenderer.java:112)

and following:

SEVERE: [13] util.UtilActivator.uncaughtException().108 An uncaught

exception occurred in thread=Thread[Thread-3,5,main] and message was:
null

java.lang.NullPointerException
     at

org.jitsi.impl.neomedia.transform.zrtp.ZrtpFortunaEntropyGatherer$GatherAudio.run(ZrtpFortunaEntropyGatherer.java:267)
-

I installed alsa-utils - however due to cloud-VM: [ ok ] Setting up

ALSA...done (none loaded).

This did not help and installing pulse audio either.

II) Trying to setup a call from within jitsi-meet, it is stuck in

„initializing call“ and times out after 20-30s :

SEVERE: [40]

service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged().190
An error occurred while executing
RegistrationStateChangeListener#registrationStateChanged(RegistrationStateChangeEvent)
of
net.java.sip.communicator.impl.protocol.jabber.OperationSetPersistentPresenceJabberImpl$RegistrationStateListener@3eb94db4

java.lang.IllegalArgumentException: Connection cannot be anonymous

I can see from the pcap that the DNS queries concerning the

sip-proxy have been made, but nothing else.

Did I miss some specific platform requirements or settings?

Thanks
Thomas

see attached the log

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.