[jitsi-users] Jigasi default SIP port


#1

Hi,
I'm assuming that Jigasi is using 5060 port to register.
Is there a way to change the default port for registration?

here is the log snippet where registrating fails to reach server even if I
can ping/telnet to it on desired port:
LOG:

23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
23:35:32.465 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
23:36:04.554 INFO: [23]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=*Connection Failed; reasonCode=-1; reason=A
timeout occurred while trying to connect to the server.]*
23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
(END)

JIGASI sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=
*<SERVER.IP>:<CUSTOM_PORT>*

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>

Any suggestion is helpful.
Thanks,

Mirko


#2

Hi,

to change the registration destination you need to add the following
properties and leave SERVER_ADDRESS:

PREFERRED_TRANSPORT=UDP
PROXY_ADDRESS=<SERVER.IP>
PROXY_AUTO_CONFIG=false
PROXY_PORT=<CUSTOM_PORT>

SERVER_ADDRESS is the Request URI address, where jigasi as jitsi
always uses outbound proxy settings which by default are auto
discovered and are covered by the PROXY_... account properties from
above.

The easiest way to do some custom modifications is run jitsi configure
successfully this account then open its config and reuse the
properties for jigasi, both jitsi and jigasi use the same xmpp and sip
providers and its configurations.

Regards
Damian

ยทยทยท

On Mon, Mar 2, 2015 at 12:49 AM, Mirko Brankovic <mirkobrankovic@gmail.com> wrote:

Hi,
I'm assuming that Jigasi is using 5060 port to register.
Is there a way to change the default port for registration?

here is the log snippet where registrating fails to reach server even if I
can ping/telnet to it on desired port:
LOG:

23:35:32.157 WARNING: [16] impl.protocol.sip.SipLogger.logWarning().174
Warning from the JAIN-SIP stackusing default tls security policy
23:35:32.171 INFO: [16] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been started
23:35:32.465 INFO: [25]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Unregistered;
newState=RegistrationState=Registering; reasonCode=-1; reason=null]
23:36:04.554 INFO: [23]
org.jitsi.jigasi.SipGateway.registrationStateChanged().159 REG STATE CHANGE
ProtocolProviderServiceSipImpl(<USER>@<SERVER.IP> (SIP)) ->
RegistrationStateChangeEvent[ oldState=Registering;
newState=RegistrationState=Connection Failed; reasonCode=-1; reason=A
timeout occurred while trying to connect to the server.]
23:36:04.555 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
23:36:05.559 INFO: [23] impl.protocol.sip.SipLogger.logInfo().185 Info
from the JAIN-SIP stack: the sip stack timer
gov.nist.javax.sip.stack.timers.DefaultSipTimer has been stopped
(END)

JIGASI sip-communicator.properties:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:<USER>@<SERVER.IP>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=.......

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=<SERVER.IP>:<CUSTOM_PORT>

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=<USER>@<SERVER.IP>

Any suggestion is helpful.
Thanks,

Mirko

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users