[jitsi-users] Jigasi and Twilio: problem with INVITE header


#1

Hi all

we are builing an IVr like app on Twilio to make PST call to
jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to
the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything works

any suggestion?

···

--

Andrea Magatti
about.me/amagatti


#2

I think Twilio might append X- at the beginning of it.

Try changing the header name with
*net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME*
and add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and
grep Jitsi-Conference-Room.

···

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to
jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to
the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything works

any suggestion?

--

Andrea Magatti
about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi all

we are builing an IVr like app on Twilio to make PST call to
jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to
the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

How does the outgoing SIP INVITE look like?

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything works

any suggestion?

I don’t think JIgasi currently supports setting headers in the RURI (can you confirm Damian?) maybe there is some API you can use on the Twilio side to set regular headers instead?

Cheers,

···

On May 19, 2017, at 11:19, Andrea Magatti <andrea.magatti@gmail.com> wrote:

--
Saúl


#4

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

···

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with
net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and
add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and
grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to
jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to
the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything works

any suggestion?

--

Andrea Magatti
about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti


#5

Yep. We only support regular headers.

···

On May 19, 2017 6:38 AM, "Saúl Ibarra Corretgé" <scorretge@atlassian.com> wrote:

> On May 19, 2017, at 11:19, Andrea Magatti <andrea.magatti@gmail.com> > wrote:
>
> Hi all
>
> we are builing an IVr like app on Twilio to make PST call to
> jitsi-meet, using jigasi
>
> This is the issue:
>
> according to twilio documentation, the way to add a custom header to
> the SIP INVITE is calling someone with such a url:
>
> andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test
>

How does the outgoing SIP INVITE look like?

> the call reach jigasi correctly but in the logs i see:
>
> ...No JVB room name provided in INVITE header
>
> Of course if i define a default room on jigasi config, the everything
works
>
> any suggestion?
>
>

I don’t think JIgasi currently supports setting headers in the RURI (can
you confirm Damian?) maybe there is some API you can use on the Twilio side
to set regular headers instead?

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Just to be sure:

do you mean using something like: ?

andrea@xxx.sip.us1.twilio.com?net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-first_test

thanks

···

Da: Andrea Magatti
Inviato: venerdì 19 maggio 2017 14:56
A: Jitsi Users
Oggetto: Re: [jitsi-users] Jigasi and Twilio: problem with INVITE header

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with
net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and
add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and
grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to
jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to
the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything works

any suggestion?

--

Andrea Magatti
about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti


#7

Hi,

I think you need to dial from twiliio:
andrea@xxx.sip.us1.twilio.com?ROOM_NAME=sometestroom (at least this is
how I understand their documentation about custom headers
https://www.twilio.com/docs/api/twiml/sip)
And in Jigasi config you need to add the following property to your
sip account properties:
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-ROOM_NAME

So when jigasi receives the sip call will join in room with name sometestroom

Cheers
damencho

···

On Fri, May 19, 2017 at 8:42 AM, Andrea Magatti <andrea.magatti@gmail.com> wrote:

Just to be sure:

do you mean using something like: ?

andrea@xxx.sip.us1.twilio.com?net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-first_test

thanks

Da: Andrea Magatti
Inviato: venerdì 19 maggio 2017 14:56
A: Jitsi Users
Oggetto: Re: [jitsi-users] Jigasi and Twilio: problem with INVITE header

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with

net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and

add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and

grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> >> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to

jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to

the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything
works

any suggestion?

--

Andrea Magatti

about.me/amagatti

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti

about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi Damian
fast update:

i've set in sip.communicator.properties :
net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-Jitsi-Conference-Room

and via my djanog app
andrea@xxxx.sip.us1.twilio.com?X-Jitsi-Conference-Room=%s" % (room_id)

where room_id is the room name

and it works like a charm
:slight_smile:

···

On Fri, May 19, 2017 at 4:33 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

I think you need to dial from twiliio:
andrea@xxx.sip.us1.twilio.com?ROOM_NAME=sometestroom (at least this is
how I understand their documentation about custom headers
https://www.twilio.com/docs/api/twiml/sip)
And in Jigasi config you need to add the following property to your
sip account properties:
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-ROOM_NAME

So when jigasi receives the sip call will join in room with name sometestroom

Cheers
damencho

On Fri, May 19, 2017 at 8:42 AM, Andrea Magatti > <andrea.magatti@gmail.com> wrote:

Just to be sure:

do you mean using something like: ?

andrea@xxx.sip.us1.twilio.com?net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-first_test

thanks

Da: Andrea Magatti
Inviato: venerdì 19 maggio 2017 14:56
A: Jitsi Users
Oggetto: Re: [jitsi-users] Jigasi and Twilio: problem with INVITE header

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with

net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and

add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and

grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> >>> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to

jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to

the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything
works

any suggestion?

--

Andrea Magatti

about.me/amagatti

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti

about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti


#9

Sorry for not being very thorough and I'm happy to hear it worked :slight_smile:

···

On Fri, May 19, 2017 at 11:51 AM, Andrea Magatti <andrea.magatti@gmail.com> wrote:

Hi Damian
fast update:

i've set in sip.communicator.properties :
net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-Jitsi-Conference-Room

and via my djanog app
andrea@xxxx.sip.us1.twilio.com?X-Jitsi-Conference-Room=%s" % (room_id)

where room_id is the room name

and it works like a charm
:slight_smile:

On Fri, May 19, 2017 at 4:33 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

I think you need to dial from twiliio:
andrea@xxx.sip.us1.twilio.com?ROOM_NAME=sometestroom (at least this is
how I understand their documentation about custom headers
https://www.twilio.com/docs/api/twiml/sip)
And in Jigasi config you need to add the following property to your
sip account properties:
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-ROOM_NAME

So when jigasi receives the sip call will join in room with name sometestroom

Cheers
damencho

On Fri, May 19, 2017 at 8:42 AM, Andrea Magatti >> <andrea.magatti@gmail.com> wrote:

Just to be sure:

do you mean using something like: ?

andrea@xxx.sip.us1.twilio.com?net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-first_test

thanks

Da: Andrea Magatti
Inviato: venerdì 19 maggio 2017 14:56
A: Jitsi Users
Oggetto: Re: [jitsi-users] Jigasi and Twilio: problem with INVITE header

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with

net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and

add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and

grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> >>>> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to

jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to

the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything
works

any suggestion?

--

Andrea Magatti

about.me/amagatti

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti

about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Thanks to you all.
just wanted to write down the exact steps for future users

BTW: i'm going to release a django app, fot that: twilio --> jigasi integration

By

···

On Fri, May 19, 2017 at 7:18 PM, Camilo <camilo@camilo.fm> wrote:

Sorry for not being very thorough and I'm happy to hear it worked :slight_smile:

On Fri, May 19, 2017 at 11:51 AM, Andrea Magatti > <andrea.magatti@gmail.com> wrote:

Hi Damian
fast update:

i've set in sip.communicator.properties :
net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-Jitsi-Conference-Room

and via my djanog app
andrea@xxxx.sip.us1.twilio.com?X-Jitsi-Conference-Room=%s" % (room_id)

where room_id is the room name

and it works like a charm
:slight_smile:

On Fri, May 19, 2017 at 4:33 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

I think you need to dial from twiliio:
andrea@xxx.sip.us1.twilio.com?ROOM_NAME=sometestroom (at least this is
how I understand their documentation about custom headers
https://www.twilio.com/docs/api/twiml/sip)
And in Jigasi config you need to add the following property to your
sip account properties:
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-ROOM_NAME

So when jigasi receives the sip call will join in room with name sometestroom

Cheers
damencho

On Fri, May 19, 2017 at 8:42 AM, Andrea Magatti >>> <andrea.magatti@gmail.com> wrote:

Just to be sure:

do you mean using something like: ?

andrea@xxx.sip.us1.twilio.com?net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME=X-first_test

thanks

Da: Andrea Magatti
Inviato: venerdì 19 maggio 2017 14:56
A: Jitsi Users
Oggetto: Re: [jitsi-users] Jigasi and Twilio: problem with INVITE header

thanks will try that soon.

and yes Twilio prepend X- (to extra headers i suppose)

On Fri, May 19, 2017 at 2:00 PM, Camilo <camilo@camilo.fm> wrote:

I think Twilio might append X- at the beginning of it.

Try changing the header name with

net.java.sip.communicator.service.protocol.JITSI_MEET_ROOM_HEADER_NAME and

add X-Jitsi-Conference-Room or your own header name (starting with X-).

I don't remember exactly how I found out, but increase the log level and

grep Jitsi-Conference-Room.

On May 19, 2017 7:19 AM, "Andrea Magatti" <andrea.magatti@gmail.com> >>>>> wrote:

Hi all

we are builing an IVr like app on Twilio to make PST call to

jitsi-meet, using jigasi

This is the issue:

according to twilio documentation, the way to add a custom header to

the SIP INVITE is calling someone with such a url:

andrea@xxx.sip.us1.twilio.com?Jitsi-Conference-Room=first_test

the call reach jigasi correctly but in the logs i see:

...No JVB room name provided in INVITE header

Of course if i define a default room on jigasi config, the everything
works

any suggestion?

--

Andrea Magatti

about.me/amagatti

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti

about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

Andrea Magatti
about.me/amagatti