[jitsi-users] jicofo not starting up, focus error in jig-meet

I have installed latest jit-meet as per official documentation, which gave me focus related error on jitsi-meet. On debugging I figured jicofo is not starting up with some sasl error.

16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor=Oracle Corporation
16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() file.separator=/
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor.url.bug=http://bugreport.sun.com/bugreport/
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.io.unicode.encoding=UnicodeLittle
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.endian=little
16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.isalist=
16:13:17.758 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
16:13:17.759 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-defaults.properties with class loader, will continue without it.
16:13:17.760 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
16:13:17.761 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-default-overrides.properties with class loader, will continue without it.
16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().81 Network Address Manager ...[ STARTED ]
16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().87 Network Address Manager Service ...[REGISTERED]
16:13:17.924 INFO: [9] impl.netaddr.NetworkConfigurationWatcher.checkNetworkInterfaces().387 Currently Active eth0:[/128.199.185.133]
16:13:17.927 FINE: [9] plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already installed providers.
16:13:18.274 SEVERE: [19] org.jitsi.jicofo.util.RegisterThread.run().42 net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:161)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: service-unavailable(-1)
        at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication.java:77)
        at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:217)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
        ... 1 more

I have verified all configuration everything is ok. I have a production app which is broken since migrating to new version. Really hope to get some help here.

It looks like the focus user password that jicofo is configured to connect with isn't consistent with the actual password set for that user. Get the value for JICOFO_AUTH_PASSWORD from /etc/Jitsi/jicofo/config then run this command:

Sudo prosodyctl passwd focus@auth.jitsi.domain.com (obviously replace with your real domain)

Enter the value for JICOFO_AUTH_PASSWORD. Restart jicofo and see if the log is clear of the connect errors.

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Sunil Nagi
Sent: Thursday, March 19, 2015 1:29 PM
To: users@jitsi.org; dev@jitsi.org
Subject: [jitsi-users] jicofo not starting up, focus error in jig-meet

I have installed latest jit-meet as per official documentation, which gave me focus related error on jitsi-meet. On debugging I figured jicofo is not starting up with some sasl error.

16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor=Oracle Corporation
16:13:17.755 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() file.separator=/
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() java.vendor.url.bug=http://bugreport.sun.com/bugreport/
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.io.unicode.encoding=UnicodeLittle
16:13:17.756 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.endian=little
16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
16:13:17.757 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() sun.cpu.isalist=
16:13:17.758 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
16:13:17.759 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-defaults.properties with class loader, will continue without it.
16:13:17.760 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() Normal classloader
16:13:17.761 INFO: [9] org.jitsi.impl.configuration.ConfigurationServiceImpl.info() failed to find jitsi-default-overrides.properties with class loader, will continue without it.
16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().81 Network Address Manager ...[ STARTED ]
16:13:17.894 INFO: [9] impl.netaddr.NetworkAddressManagerServiceImpl.start().87 Network Address Manager Service ...[REGISTERED]
16:13:17.924 INFO: [9] impl.netaddr.NetworkConfigurationWatcher.checkNetworkInterfaces().387 Currently Active eth0:[/128.199.185.133]
16:13:17.927 FINE: [9] plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already installed providers.
16:13:18.274 SEVERE: [19] org.jitsi.jicofo.util.RegisterThread.run().42 net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to connect
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:161)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:38)
Caused by: service-unavailable(-1)
        at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication.java:77)
        at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:217)
        at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:156)
        ... 1 more

I have verified all configuration everything is ok. I have a production app which is broken since migrating to new version. Really hope to get some help here.
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users