[jitsi-users] Jicofo exception upon conference start - Maximum members limit reached


#1

Hi!

I am hitting a wall trying to deploy jitsi meet manually on an arch-linux box. Prosody, jicofo and Jitsi-videobridge are running on the same machine. Upon entering a conference with the first user, jicofo throws an IllegalArgumentException and the confernce seems to disconnect immediately. After an automatic reconnect, the webinterface prints "Maximum members limit reached".

I am running:

jitsi-meet_3053 (tag: 2797). I am only getting the blue background screen without any other response using the latest commit.

Jicofo tag 413

Jitsi-videobrige assembly 1056

jicofog-log: https://pastebin.com/kQh0RnZ5

videobrige-log: https://pastebin.com/CtdUTcHi

prosody-log: https://pastebin.com/Tkt0suLT

config.js: https://pastebin.com/qr33sVKN

prosody.cfg.lua: https://pastebin.com/ynvHtdar

Any help is very much appreciated.

Thanks a lot and keep up the good work!


#2

Hi!

I am hitting a wall trying to deploy jitsi meet manually on an
arch-linux box. Prosody, jicofo and Jitsi-videobridge are running on the
same machine. Upon entering a conference with the first user, jicofo
throws an IllegalArgumentException and the confernce seems to disconnect
immediately. After an automatic reconnect, the webinterface prints
"Maximum members limit reached".

I am running:

jitsi-meet_3053 (tag: 2797). I am only getting the blue background
screen without any other response using the latest commit.

Jicofo tag 413

Jitsi-videobrige assembly 1056

jicofog-log: https://pastebin.com/kQh0RnZ5

videobrige-log: https://pastebin.com/CtdUTcHi

prosody-log: https://pastebin.com/Tkt0suLT

config.js: https://pastebin.com/qr33sVKN

prosody.cfg.lua: https://pastebin.com/ynvHtdar

Any help is very much appreciated.

Thanks a lot and keep up the good work!


#3

Hi Maximilian,

The error is really strange and I haven't seen it. And the error of
invoking the stop method hides the initial error that can give more
information, maybe. As you are running from source, can you modify this
line:
https://github.com/jitsi/jicofo/blob/4fa190bddead6df0f1392bf8b0582c9ca01181c6/src/main/java/org/jitsi/jicofo/JitsiMeetConferenceImpl.java#L367
and just before the stop method add the following line: logger.error("Error
starting", e);
Then run it and again attach the logs from jicofo here.

Regards
damencho

···

On Sat, May 19, 2018 at 9:01 AM Maximilian Schöbel < max.schoebel@googlemail.com> wrote:

Hi!

I am hitting a wall trying to deploy jitsi meet manually on an
arch-linux box. Prosody, jicofo and Jitsi-videobridge are running on the
same machine. Upon entering a conference with the first user, jicofo
throws an IllegalArgumentException and the confernce seems to disconnect
immediately. After an automatic reconnect, the webinterface prints
"Maximum members limit reached".

I am running:

jitsi-meet_3053 (tag: 2797). I am only getting the blue background
screen without any other response using the latest commit.

Jicofo tag 413

Jitsi-videobrige assembly 1056

jicofog-log: https://pastebin.com/kQh0RnZ5

videobrige-log: https://pastebin.com/CtdUTcHi

prosody-log: https://pastebin.com/Tkt0suLT

config.js: https://pastebin.com/qr33sVKN

prosody.cfg.lua: https://pastebin.com/ynvHtdar

Any help is very much appreciated.

Thanks a lot and keep up the good work!

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi Maximilian,

My guess is that your MUC component is misconfigured, so jicofo (and
the clients too) fails to join the room. Double check your prosody
config for the conference.meet.roboland-projekt.de component.

Regards,
Boris

···

On Mon, May 21, 2018 at 10:55 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi Maximilian,

The error is really strange and I haven't seen it. And the error of
invoking the stop method hides the initial error that can give more
information, maybe. As you are running from source, can you modify this
line:
https://github.com/jitsi/jicofo/blob/4fa190bddead6df0f1392bf8b0582c9ca01181c6/src/main/java/org/jitsi/jicofo/JitsiMeetConferenceImpl.java#L367
and just before the stop method add the following line: logger.error("Error
starting", e);
Then run it and again attach the logs from jicofo here.

Regards
damencho

On Sat, May 19, 2018 at 9:01 AM Maximilian Schöbel < > max.schoebel@googlemail.com> wrote:

Hi!

I am hitting a wall trying to deploy jitsi meet manually on an
arch-linux box. Prosody, jicofo and Jitsi-videobridge are running on the
same machine. Upon entering a conference with the first user, jicofo
throws an IllegalArgumentException and the confernce seems to disconnect
immediately. After an automatic reconnect, the webinterface prints
"Maximum members limit reached".

I am running:

jitsi-meet_3053 (tag: 2797). I am only getting the blue background
screen without any other response using the latest commit.

Jicofo tag 413

Jitsi-videobrige assembly 1056

jicofog-log: https://pastebin.com/kQh0RnZ5

videobrige-log: https://pastebin.com/CtdUTcHi

prosody-log: https://pastebin.com/Tkt0suLT

config.js: https://pastebin.com/qr33sVKN

prosody.cfg.lua: https://pastebin.com/ynvHtdar

Any help is very much appreciated.

Thanks a lot and keep up the good work!

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Yeah, there is an error in your prosody log:

May 17 23:13:11 modulemanager error Error initializing module 'muc' on '
conference.meet.roboland-projekt.de':
/usr/lib/prosody/modules/muc/mod_muc.lua:43: no data storage active

So maybe that is the problem.

Hi Maximilian,

My guess is that your MUC component is misconfigured, so jicofo (and
the clients too) fails to join the room. Double check your prosody
config for the conference.meet.roboland-projekt.de component.

Regards,
Boris

> Hi Maximilian,
>
> The error is really strange and I haven't seen it. And the error of
> invoking the stop method hides the initial error that can give more
> information, maybe. As you are running from source, can you modify this
> line:
>

https://github.com/jitsi/jicofo/blob/4fa190bddead6df0f1392bf8b0582c9ca01181c6/src/main/java/org/jitsi/jicofo/JitsiMeetConferenceImpl.java#L367

> and just before the stop method add the following line:

logger.error("Error

> starting", e);
> Then run it and again attach the logs from jicofo here.
>
> Regards
> damencho
>
>
>> Hi!
>
>> I am hitting a wall trying to deploy jitsi meet manually on an
>> arch-linux box. Prosody, jicofo and Jitsi-videobridge are running on

the

>> same machine. Upon entering a conference with the first user, jicofo
>> throws an IllegalArgumentException and the confernce seems to

disconnect

···

On Mon, May 21, 2018 at 4:08 PM Boris Grozev <boris@sip-communicator.org> wrote:

On Mon, May 21, 2018 at 10:55 AM, Damian Minkov <damencho@jitsi.org> wrote:
> On Sat, May 19, 2018 at 9:01 AM Maximilian Schöbel < > > max.schoebel@googlemail.com> wrote:
>> immediately. After an automatic reconnect, the webinterface prints
>> "Maximum members limit reached".
>
>
>> I am running:
>
>> jitsi-meet_3053 (tag: 2797). I am only getting the blue background
>> screen without any other response using the latest commit.
>
>> Jicofo tag 413
>
>> Jitsi-videobrige assembly 1056
>
>
>> jicofog-log: https://pastebin.com/kQh0RnZ5
>
>> videobrige-log: https://pastebin.com/CtdUTcHi
>
>> prosody-log: https://pastebin.com/Tkt0suLT
>
>> config.js: https://pastebin.com/qr33sVKN
>
>> prosody.cfg.lua: https://pastebin.com/ynvHtdar
>
>
>> Any help is very much appreciated.
>
>> Thanks a lot and keep up the good work!
>
>
>
>
>
>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users