[jitsi-users] Jibri setup


#1

Hello,

I was glad to see recently that the Jibri project of witch Emil spoke us on our call was out :slight_smile:

I followed the instructions of the Jibri README on a KVM VM running Ubuntu server 12.10 (2 cores, 2048 Mo RAM, virtio 10 Go disk for a start, virtio bridged network, VMVGA display with VNC, AC97 audio).

I think i will be among the first ones to bother you with my questions :slight_smile:

For the moment Jibri creates a video file showing a puple icewm with the menu bar, the mouse at the center and the running clock on the lower-right corner. But nothing happens in it :frowning:

While i will have a deeper look at the scripts and the logs, my first question is : Is there a cleaner way to stop recording than my "pkill ffmpeg" ? I am not yet using the xmpp client because i'm using a vanilla jicofo, not the specific one.

David


#2

Hello,

I was glad to see recently that the Jibri project of witch Emil spoke us
on our call was out :slight_smile:

I followed the instructions of the Jibri README on a KVM VM running
Ubuntu server 12.10 (2 cores, 2048 Mo RAM, virtio 10 Go disk for a
start, virtio bridged network, VMVGA display with VNC, AC97 audio).

I think i will be among the first ones to bother you with my questions :slight_smile:

Indeed, you get the badge! But I'm afraid it's no bother :slight_smile:

For the moment Jibri creates a video file showing a puple icewm with the
menu bar, the mouse at the center and the running clock on the
lower-right corner. But nothing happens in it :frowning:

The browser must have failed to launch. We grab the output of the whole screen, and if there is no browser it will just show icewm (I can't remember exactly why we needed to run a WM, but it solved some problem. Maybe chrome "maximizing").

While i will have a deeper look at the scripts and the logs, my first
question is : Is there a cleaner way to stop recording than my "pkill
ffmpeg" ? I am not yet using the xmpp client because i'm using a vanilla
jicofo, not the specific one.

The stop_recording.sh script will be a bit nicer and only kill the specific ffmpeg process.

Also, I think this is now be included in the latest jicofo/master, but I don't know what the setup procedure is.

Regards,
Boris

路路路

On 30/03/16 09:10, David M茅zi猫re wrote:


#3

Boris,

Thank you for that immediate answer :slight_smile:

In fact after looking at the scripts, i saw the stop-script :stuck_out_tongue:

I see launch_recording.sh, that starts xorg, launch a session and passes the relay to ffmpeg.

I see start-ffmpeg.sh, that screen casts x11 to my output file.

But i don't see the part that handles chromium.

I only see a warmup-chromium-selenium.py script, that doesn't seems to be called, and that seems to call Google home page. And when i call it, i get an "ImportError: No module named 'selenium'". I've installed "python-selenium" with apt.

Maybe i am missing something, Your guess ?

David

路路路

Le 30/03/2016 17:00, Boris Grozev a 茅crit :

On 30/03/16 09:10, David M茅zi猫re wrote:

Hello,

I was glad to see recently that the Jibri project of witch Emil spoke us
on our call was out :slight_smile:

I followed the instructions of the Jibri README on a KVM VM running
Ubuntu server 12.10 (2 cores, 2048 Mo RAM, virtio 10 Go disk for a
start, virtio bridged network, VMVGA display with VNC, AC97 audio).

I think i will be among the first ones to bother you with my questions :slight_smile:

Indeed, you get the badge! But I'm afraid it's no bother :slight_smile:

For the moment Jibri creates a video file showing a puple icewm with the
menu bar, the mouse at the center and the running clock on the
lower-right corner. But nothing happens in it :frowning:

The browser must have failed to launch. We grab the output of the whole screen, and if there is no browser it will just show icewm (I can't remember exactly why we needed to run a WM, but it solved some problem. Maybe chrome "maximizing").

While i will have a deeper look at the scripts and the logs, my first
question is : Is there a cleaner way to stop recording than my "pkill
ffmpeg" ? I am not yet using the xmpp client because i'm using a vanilla
jicofo, not the specific one.

The stop_recording.sh script will be a bit nicer and only kill the specific ffmpeg process.

Also, I think this is now be included in the latest jicofo/master, but I don't know what the setup procedure is.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

To answer my own email and update the thread, i would say that only the XMPP client currently handles Chromium interraction. Am i right ?

David.

路路路

Le 30/03/2016 17:08, David M茅zi猫re a 茅crit :

Boris,

Thank you for that immediate answer :slight_smile:

In fact after looking at the scripts, i saw the stop-script :stuck_out_tongue:

I see launch_recording.sh, that starts xorg, launch a session and passes the relay to ffmpeg.

I see start-ffmpeg.sh, that screen casts x11 to my output file.

But i don't see the part that handles chromium.

I only see a warmup-chromium-selenium.py script, that doesn't seems to be called, and that seems to call Google home page. And when i call it, i get an "ImportError: No module named 'selenium'". I've installed "python-selenium" with apt.

Maybe i am missing something, Your guess ?

David

Le 30/03/2016 17:00, Boris Grozev a 茅crit :

On 30/03/16 09:10, David M茅zi猫re wrote:

Hello,

I was glad to see recently that the Jibri project of witch Emil spoke us
on our call was out :slight_smile:

I followed the instructions of the Jibri README on a KVM VM running
Ubuntu server 12.10 (2 cores, 2048 Mo RAM, virtio 10 Go disk for a
start, virtio bridged network, VMVGA display with VNC, AC97 audio).

I think i will be among the first ones to bother you with my questions :slight_smile:

Indeed, you get the badge! But I'm afraid it's no bother :slight_smile:

For the moment Jibri creates a video file showing a puple icewm with the
menu bar, the mouse at the center and the running clock on the
lower-right corner. But nothing happens in it :frowning:

The browser must have failed to launch. We grab the output of the whole screen, and if there is no browser it will just show icewm (I can't remember exactly why we needed to run a WM, but it solved some problem. Maybe chrome "maximizing").

While i will have a deeper look at the scripts and the logs, my first
question is : Is there a cleaner way to stop recording than my "pkill
ffmpeg" ? I am not yet using the xmpp client because i'm using a vanilla
jicofo, not the specific one.

The stop_recording.sh script will be a bit nicer and only kill the specific ffmpeg process.

Also, I think this is now be included in the latest jicofo/master, but I don't know what the setup procedure is.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

To answer my own email and update the thread, i would say that only the
XMPP client currently handles Chromium interraction. Am i right ?

Yes. Sorry, I wasn't aware of that. I *think* you should now be able start the browser instance with jibriselenium.py (without the actual XMPP stuff), but I haven't tried.

[...]

I only see a warmup-chromium-selenium.py script, that doesn't seems to
be called, and that seems to call Google home page. And when i call
it, i get an "ImportError: No module named 'selenium'". I've installed
"python-selenium" with apt.

I don't know, but have you tried installing it through pip?

Boris

路路路

On 30/03/16 10:42, David M茅zi猫re wrote:

Le 30/03/2016 17:08, David M茅zi猫re a 茅crit :