[jitsi-users] [jibri] Is there something wrong with the launch_recording.sh script?


#1

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han


#2

Hello,

I think I am at almost the same point than you. But I had better results launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the jibri-xmpp-client directory, prior to recording. But anyway, I still hang at the Jitsi Meet screen telling me that something is wrong with my webcam.

David

···

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

···

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script
and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi, David Mézière

I do not understand very well when you say:

ut anyway, I still hang at the Jitsi Meet screen telling me that something
is wrong with my webcam.

What exactly do you mean, where does this error show you?

···

2017-04-03 11:42 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon of a jibri user granted as "moderator" at the bottom-right corner of the user interface.
Is that what you achieved ?
  
Regards !

Guofu Han

···

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the jibri-xmpp-client directory, prior to recording. But anyway, I still hang at the Jitsi Meet screen telling me that something is wrong with my webcam.

David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hello,

I mean this screen :

David

···

Le 03/04/2017 à 18:45, Alfredo Guzman a écrit :

Hi, David Mézière

I do not understand very well when you say:

    ut anyway, I still hang at the Jitsi Meet screen telling me that
    something is wrong with my webcam.

What exactly do you mean, where does this error show you?

2017-04-03 11:42 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>:

    hi hanguofu,

    I'm not sure how to do a manual test,
    The test you do (as indicated by the documentation) is to verify
    that jibri, can send an RTMP stream to youtube, the way to execute
    it is:

    ./launch_recording.sh null null null STREAM_KEY

    Then go to youtube and verify that you receive data, you should
    see an image that says: "connecting ..."
    If so, then the test is okay.

    regards

    2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com
    <mailto:d.meziere@immanens.com>>:

        Hello,

        I think I am at almost the same point than you. But I had
        better results launching "DISPLAY=:0 ./jibriselenium.py -u
        [Room URL]" in the jibri-xmpp-client directory, prior to
        recording. But anyway, I still hang at the Jitsi Meet screen
        telling me that something is wrong with my webcam.

        David

        Le 02/04/2017 à 05:50, hanguofu a écrit :

        I use the script to start recording manually :

        ./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room
        <https://my_jitsi_meet_ip_addr/my_room> test.flv

        As expected , the output file only a connecting picture. I
        read the script and cannot understand why the URL=$1 is not
        needed at all .

        Is it the right way to manually record the conference ? Is
        there sth. wrong with the script ?

        Regards !

        Guofu Han

        _______________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

        _______________________________________________ users mailing
        list users@jitsi.org <mailto:users@jitsi.org> Unsubscribe
        instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

hi, hanguofu.

I have already managed to work jibri correctly.

* If you can see the new user in jitsi means JIBRISELENIUM is able to
"connect" to the jitsi session.
When you run: jibriselenium.py you should verify that you receive the
bitrate correctly.
Check the log that shows: "starting to wait for DownloadBitrate"
Then you should say lgo as: "downloadbitrate> 0, done waiting" if so, you
should see a log that shows: "Successful connection to meet".

If on the contrary you see a message like: "waiting 1 = 1 <2 for
DownloadBitrate" then jibri has problems to "connect" to the room.

You can do the tests and tell us how you're doing.

Greetings.

···

2017-04-04 10:54 GMT-05:00 hanguofu <hanguofu@163.com>:

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon
of a jibri user granted as "moderator" at the bottom-right corner of the
user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi, david.

Sometimes something similar happens to me with my camera, in my case the
reason is that an error occurs with some process and takes up my camera.

If you use "Mac" you can solve it by running this on your console:

"Sudo killall VDCAssistant"

Ready!

I hope this helps.

Greetings.

···

2017-04-04 11:09 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

hi, hanguofu.

I have already managed to work jibri correctly.

* If you can see the new user in jitsi means JIBRISELENIUM is able to
"connect" to the jitsi session.
When you run: jibriselenium.py you should verify that you receive the
bitrate correctly.
Check the log that shows: "starting to wait for DownloadBitrate"
Then you should say lgo as: "downloadbitrate> 0, done waiting" if so, you
should see a log that shows: "Successful connection to meet".

If on the contrary you see a message like: "waiting 1 = 1 <2 for
DownloadBitrate" then jibri has problems to "connect" to the room.

You can do the tests and tell us how you're doing.

Greetings.

2017-04-04 10:54 GMT-05:00 hanguofu <hanguofu@163.com>:

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the
icon of a jibri user granted as "moderator" at the bottom-right corner
of the user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too. But for now, without sound, and with that same camera error message in the middle of the screen.

David

···

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon of a jibri user granted as "moderator" at the bottom-right corner of the user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

    hi hanguofu,

    I'm not sure how to do a manual test,
    The test you do (as indicated by the documentation) is to verify
    that jibri, can send an RTMP stream to youtube, the way to execute
    it is:

    ./launch_recording.sh null null null STREAM_KEY

    Then go to youtube and verify that you receive data, you should
    see an image that says: "connecting ..."
    If so, then the test is okay.

    regards

    2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com
    <mailto:d.meziere@immanens.com>>:

        Hello,

        I think I am at almost the same point than you. But I had
        better results launching "DISPLAY=:0 ./jibriselenium.py -u
        [Room URL]" in the jibri-xmpp-client directory, prior to
        recording. But anyway, I still hang at the Jitsi Meet screen
        telling me that something is wrong with my webcam.

        David

        Le 02/04/2017 à 05:50, hanguofu a écrit :

        I use the script to start recording manually :

        ./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room
        <https://my_jitsi_meet_ip_addr/my_room> test.flv

        As expected , the output file only a connecting picture. I
        read the script and cannot understand why the URL=$1 is not
        needed at all .

        Is it the right way to manually record the conference ? Is
        there sth. wrong with the script ?

        Regards !

        Guofu Han

        _______________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

        _______________________________________________ users mailing
        list users@jitsi.org <mailto:users@jitsi.org> Unsubscribe
        instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Great !

Did you mean you have the record button avail. at the user interface ?
I did see the messages you mentioned with the cmd :
DISPLAY=:0 ./jibriselenium.py -u https://URL-TO-MEETING

...
2017-04-04 10:49:43,659 DEBUG Finished Request
isXMPPConnected:True
Successful connection to meet
2017-04-04 10:49:43,660 INFO starting to wait for DownloadBitrate
2017-04-04 10:49:43,660 DEBUG POST http://127.0.0.1:51241/session/99906ce96c252fbdb7684ded54b00eeb/execute {"script": "return APP.conference.getStats();",
"sessionId": "99906ce96c252fbdb7684ded54b00eeb", "args": []}
2017-04-04 10:49:43,670 DEBUG Finished Request
2017-04-04 10:49:43,671 INFO downloadbitrate > 0, done waiting
Successfully receving data in meet, waiting 60 seconds for fun
...

Regards !

Guofu Han

···

At 2017-04-05 00:09:13, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi, hanguofu.

I have already managed to work jibri correctly.

* If you can see the new user in jitsi means JIBRISELENIUM is able to "connect" to the jitsi session.
When you run: jibriselenium.py you should verify that you receive the bitrate correctly.
Check the log that shows: "starting to wait for DownloadBitrate"
Then you should say lgo as: "downloadbitrate> 0, done waiting" if so, you should see a log that shows: "Successful connection to meet".

If on the contrary you see a message like: "waiting 1 = 1 <2 for DownloadBitrate" then jibri has problems to "connect" to the room.

You can do the tests and tell us how you're doing.

Greetings.

2017-04-04 10:54 GMT-05:00 hanguofu <hanguofu@163.com>:

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon of a jibri user granted as "moderator" at the bottom-right corner of the user interface.
Is that what you achieved ?
  
Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the jibri-xmpp-client directory, prior to recording. But anyway, I still hang at the Jitsi Meet screen telling me that something is wrong with my webcam.

David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

···

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com> wrote:

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too. But for now, without sound, and with that same camera error message in the middle of the screen.

David

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon of a jibri user granted as "moderator" at the bottom-right corner of the user interface.
Is that what you achieved ?
  
Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the jibri-xmpp-client directory, prior to recording. But anyway, I still hang at the Jitsi Meet screen telling me that something is wrong with my webcam.

David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

Alfredo,

The VM I run Jibri has no camera. It is an Ubuntu 16.10 server img, installed using the process explained on the Jibri github page.

David

···

Le 04/04/2017 à 18:22, Alfredo Guzman a écrit :

Hi, david.

Sometimes something similar happens to me with my camera, in my case the reason is that an error occurs with some process and takes up my camera.

If you use "Mac" you can solve it by running this on your console:

"Sudo killall VDCAssistant"

Ready!

I hope this helps.

Greetings.

2017-04-04 11:09 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>:

    hi, hanguofu.

    I have already managed to work jibri correctly.

    * If you can see the new user in jitsi means JIBRISELENIUM is able
    to "connect" to the jitsi session.
    When you run: jibriselenium.py you should verify that you receive
    the bitrate correctly.
    Check the log that shows: "starting to wait for DownloadBitrate"
    Then you should say lgo as: "downloadbitrate> 0, done waiting" if
    so, you should see a log that shows: "Successful connection to meet".

    If on the contrary you see a message like: "waiting 1 = 1 <2 for
    DownloadBitrate" then jibri has problems to "connect" to the room.

    You can do the tests and tell us how you're doing.

    Greetings.

    2017-04-04 10:54 GMT-05:00 hanguofu <hanguofu@163.com
    <mailto:hanguofu@163.com>>:

        Hi , Alfredo :

        Thanks for the clarification :slight_smile: Do you have any luck to make
        jibri work ?

        I did not see the recording option/button at all , but I
        did see the icon of a jibri user granted as "moderator" at
        the bottom-right corner of the user interface.
        Is that what you achieved ?

        Regards !

        Guofu Han

        At 2017-04-04 00:42:14, "Alfredo Guzman" > <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>> > wrote:

            hi hanguofu,

            I'm not sure how to do a manual test,
            The test you do (as indicated by the documentation) is to
            verify that jibri, can send an RTMP stream to youtube, the
            way to execute it is:

            ./launch_recording.sh null null null STREAM_KEY

            Then go to youtube and verify that you receive data, you
            should see an image that says: "connecting ..."
            If so, then the test is okay.

            regards

            2017-04-03 4:04 GMT-05:00 David Mézière
            <d.meziere@immanens.com <mailto:d.meziere@immanens.com>>:

                Hello,

                I think I am at almost the same point than you. But I
                had better results launching "DISPLAY=:0
                ./jibriselenium.py -u [Room URL]" in the
                jibri-xmpp-client directory, prior to recording. But
                anyway, I still hang at the Jitsi Meet screen telling
                me that something is wrong with my webcam.

                David

                Le 02/04/2017 à 05:50, hanguofu a écrit :

                I use the script to start recording manually :

                ./launch_recording.sh
                https://my_jitsi_meet_ip_addr/my_room
                <https://my_jitsi_meet_ip_addr/my_room> test.flv

                As expected , the output file only a connecting
                picture. I read the script and cannot understand why
                the URL=$1 is not needed at all .

                Is it the right way to manually record the conference
                ? Is there sth. wrong with the script ?

                Regards !

                Guofu Han

                _______________________________________________
                users mailing list
                users@jitsi.org <mailto:users@jitsi.org>
                Unsubscribe instructions and other list options:
                http://lists.jitsi.org/mailman/listinfo/users
                <http://lists.jitsi.org/mailman/listinfo/users>

                _______________________________________________ users
                mailing list users@jitsi.org <mailto:users@jitsi.org>
                Unsubscribe instructions and other list options:
                http://lists.jitsi.org/mailman/listinfo/users
                <http://lists.jitsi.org/mailman/listinfo/users>

        _______________________________________________ users mailing
        list users@jitsi.org <mailto:users@jitsi.org> Unsubscribe
        instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

On your config.js file, change enableRecording: true and recordingType:
'jibri'. This will remove these pop-ups.

···

On Apr 4, 2017 4:49 AM, "David Mézière" <d.meziere@immanens.com> wrote:

Hello,

I mean this screen :

David

Le 03/04/2017 à 18:45, Alfredo Guzman a écrit :

Hi, David Mézière

I do not understand very well when you say:

ut anyway, I still hang at the Jitsi Meet screen telling me that
something is wrong with my webcam.

What exactly do you mean, where does this error show you?

2017-04-03 11:42 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

Excelent hangoufu, You are going for the good way.

What you have just done is a test to verify that jibri can coenctarse to a
reunion of jitisi.

You should now integrate jibri with jitsi-meet
To integrate jibri with jitsi-meet. You must edit your config.js so that
the button appears in your interface.

You must edit a config.js file:

RecordingType: 'jibri',

EnableRecording: true,
HiddenDomain: 'recorder.yourdomain.com',

You must take into account the capital and the lower case.

Then restart jitsi-videobridge and you should see the recording button on
the interface.

Greetings.

···

2017-04-04 11:29 GMT-05:00 hanguofu <hanguofu@163.com>:

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have
the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com> wrote:

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too.
But for now, without sound, and with that same camera error message in the
middle of the screen.

David

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon
of a jibri user granted as "moderator" at the bottom-right corner of the
user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> > <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#15

Damn ! I had a typo at "recordingType", the first letter was missing. Now everything is in French, and the error message talks about camera constraint :

David

···

Le 04/04/2017 à 12:57, Camilo a écrit :

On your config.js file, change enableRecording: true and recordingType: 'jibri'. This will remove these pop-ups.

On Apr 4, 2017 4:49 AM, "David Mézière" <d.meziere@immanens.com > <mailto:d.meziere@immanens.com>> wrote:

    Hello,

    I mean this screen :

    David

    Le 03/04/2017 à 18:45, Alfredo Guzman a écrit :

    Hi, David Mézière

    I do not understand very well when you say:

        ut anyway, I still hang at the Jitsi Meet screen telling me
        that something is wrong with my webcam.

    What exactly do you mean, where does this error show you?

    2017-04-03 11:42 GMT-05:00 Alfredo Guzman
    <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>:

        hi hanguofu,

        I'm not sure how to do a manual test,
        The test you do (as indicated by the documentation) is to
        verify that jibri, can send an RTMP stream to youtube, the
        way to execute it is:

        ./launch_recording.sh null null null STREAM_KEY

        Then go to youtube and verify that you receive data, you
        should see an image that says: "connecting ..."
        If so, then the test is okay.

        regards

        2017-04-03 4:04 GMT-05:00 David Mézière
        <d.meziere@immanens.com <mailto:d.meziere@immanens.com>>:

            Hello,

            I think I am at almost the same point than you. But I had
            better results launching "DISPLAY=:0 ./jibriselenium.py
            -u [Room URL]" in the jibri-xmpp-client directory, prior
            to recording. But anyway, I still hang at the Jitsi Meet
            screen telling me that something is wrong with my webcam.

            David

            Le 02/04/2017 à 05:50, hanguofu a écrit :

            I use the script to start recording manually :

            ./launch_recording.sh
            https://my_jitsi_meet_ip_addr/my_room
            <https://my_jitsi_meet_ip_addr/my_room> test.flv

            As expected , the output file only a connecting picture.
            I read the script and cannot understand why the URL=$1 is not needed at all .

            Is it the right way to manually record the conference ?
            Is there sth. wrong with the script ?

            Regards !

            Guofu Han

            _______________________________________________
            users mailing list
            users@jitsi.org <mailto:users@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/users
            <http://lists.jitsi.org/mailman/listinfo/users>

            _______________________________________________ users
            mailing list users@jitsi.org <mailto:users@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/users
            <http://lists.jitsi.org/mailman/listinfo/users>

    _______________________________________________
    users mailing list
    users@jitsi.org <mailto:users@jitsi.org>
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users
    <http://lists.jitsi.org/mailman/listinfo/users>

    _______________________________________________ users mailing list
    users@jitsi.org <mailto:users@jitsi.org> Unsubscribe instructions
    and other list options:
    http://lists.jitsi.org/mailman/listinfo/users
    <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#16

Hi , Alfredo :

Thanks for the instructions. My config.js did have the following settings :

hiddenDomain: 'recorder.my_jitsi_meet_ip_addr',
enableRecording: true,
recordingType: 'jibri',

Did you install jitsi meet stable or a nightly build ?

Regards !

Guofu Han

···

At 2017-04-05 00:42:47, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

Excelent hangoufu, You are going for the good way.

What you have just done is a test to verify that jibri can coenctarse to a reunion of jitisi.

You should now integrate jibri with jitsi-meet
To integrate jibri with jitsi-meet. You must edit your config.js so that the button appears in your interface.

You must edit a config.js file:

RecordingType: 'jibri',
EnableRecording: true,
HiddenDomain: 'recorder.yourdomain.com',

You must take into account the capital and the lower case.

Then restart jitsi-videobridge and you should see the recording button on the interface.

Greetings.

2017-04-04 11:29 GMT-05:00 hanguofu <hanguofu@163.com>:

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com> wrote:

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too. But for now, without sound, and with that same camera error message in the middle of the screen.

David

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon of a jibri user granted as "moderator" at the bottom-right corner of the user interface.
Is that what you achieved ?
  
Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the jibri-xmpp-client directory, prior to recording. But anyway, I still hang at the Jitsi Meet screen telling me that something is wrong with my webcam.

David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth. wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#17

Guofu Han,

I use|"cd /home/jibri/jibri-xmpp-client" and||"DISPLAY=:0 ./jibriselenium.py -u https://URL-TO-MEETING", and aside, in my terminal multiplexer (byobu) i use||"cd /home/jibri/scripts"||and "./start-ffmpeg.sh filename.flv".|

I don't have the record button. Sometimes it appears, but is never

functional.|

···

David

Le 04/04/2017 à 18:29, hanguofu a écrit :

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com> wrote:

    Hello Guofu Han,

    I am one step further. On a manuel test I can now record the video
    too. But for now, without sound, and with that same camera error
    message in the middle of the screen.

    David

    Le 04/04/2017 à 17:54, hanguofu a écrit :

    Hi , Alfredo :

    Thanks for the clarification :slight_smile: Do you have any luck to make
    jibri work ?

    I did not see the recording option/button at all , but I did see
    the icon of a jibri user granted as "moderator" at
    the bottom-right corner of the user interface.
    Is that what you achieved ?

    Regards !

    Guofu Han

    At 2017-04-04 00:42:14, "Alfredo Guzman" >> <alfredo.sil.gt@gmail.com> wrote:

        hi hanguofu,

        I'm not sure how to do a manual test,
        The test you do (as indicated by the documentation) is to
        verify that jibri, can send an RTMP stream to youtube, the
        way to execute it is:

        ./launch_recording.sh null null null STREAM_KEY

        Then go to youtube and verify that you receive data, you
        should see an image that says: "connecting ..."
        If so, then the test is okay.

        regards

        2017-04-03 4:04 GMT-05:00 David Mézière
        <d.meziere@immanens.com <mailto:d.meziere@immanens.com>>:

            Hello,

            I think I am at almost the same point than you. But I had
            better results launching "DISPLAY=:0 ./jibriselenium.py
            -u [Room URL]" in the jibri-xmpp-client directory, prior
            to recording. But anyway, I still hang at the Jitsi Meet
            screen telling me that something is wrong with my webcam.

            David

            Le 02/04/2017 à 05:50, hanguofu a écrit :

            I use the script to start recording manually :

            ./launch_recording.sh
            https://my_jitsi_meet_ip_addr/my_room
            <https://my_jitsi_meet_ip_addr/my_room> test.flv

            As expected , the output file only a connecting picture.
            I read the script and cannot understand why the URL=$1 is not needed at all .

            Is it the right way to manually record the conference ?
            Is there sth. wrong with the script ?

            Regards !

            Guofu Han

            _______________________________________________
            users mailing list
            users@jitsi.org <mailto:users@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/users
            <http://lists.jitsi.org/mailman/listinfo/users>

            _______________________________________________ users
            mailing list users@jitsi.org <mailto:users@jitsi.org>
            Unsubscribe instructions and other list options:
            http://lists.jitsi.org/mailman/listinfo/users
            <http://lists.jitsi.org/mailman/listinfo/users>

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#18

That's odd. I have no idea about the French message, and Jibri is
viewing/recording itself.

Damn ! I had a typo at "recordingType", the first letter was missing. Now
everything is in French, and the error message talks about camera
constraint :

David

On your config.js file, change enableRecording: true and recordingType:
'jibri'. This will remove these pop-ups.

···

On Apr 4, 2017 9:27 AM, "David Mézière" <d.meziere@immanens.com> wrote:
Le 04/04/2017 à 12:57, Camilo a écrit :

On Apr 4, 2017 4:49 AM, "David Mézière" <d.meziere@immanens.com> wrote:

Hello,

I mean this screen :

David

Le 03/04/2017 à 18:45, Alfredo Guzman a écrit :

Hi, David Mézière

I do not understand very well when you say:

ut anyway, I still hang at the Jitsi Meet screen telling me that
something is wrong with my webcam.

What exactly do you mean, where does this error show you?

2017-04-03 11:42 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list
options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#19

Hi, david.

I think I know the reason why your button shows only once in a while:

If you enter the first time to a room (http://mydomain-jitsi.com/myroom)
jitsi makes you moderator automatically.

You can only see the button if you are moderator of the room.

When you refresh the page, jitsi may take a while to disconnect that user,
so the next time you're not a moderator (you might see two people in the
room).
I think that's the reason why you do not see the button sometimes.

My suggestion is to change rooms when you do not see the button.
(Https://mydomain-jitsi.com/myroom2, https://mydomain-jitsi.com/myroom3,
https://mydomain-jitsi.com/myroom4 ...)

In this way you ensure that you are the first in the room and thus you will
always be moderator.

I hope you understand my explanation (my English is not so good)

* Jibri does not need a camera.

On the other hand, if the button does not work is because jitsi has not
detected that jibri is connected to xmpp.

The reason may be for various reasons, I had some problems regarding it,
permissions, users ...

Start by reviewing the jibri-xmpp.service logs, there you can check if
jibri connects correctly to xmpp.
Also check the prosody logs, so you can see if there are any connection
errors.

I hope I have given you some idea of ​​how to continue, try what I tell you
and tell us.

Greetings.

···

2017-04-05 2:32 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Guofu Han,

I use "cd /home/jibri/jibri-xmpp-client" and "DISPLAY=:0
./jibriselenium.py -u https://URL-TO-MEETING", and aside, in my terminal
multiplexer (byobu) i use "cd /home/jibri/scripts" and "./start-ffmpeg.sh
filename.flv".

I don't have the record button. Sometimes it appears, but is never
functional.

David

Le 04/04/2017 à 18:29, hanguofu a écrit :

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have
the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com>
<d.meziere@immanens.com> wrote:

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too.
But for now, without sound, and with that same camera error message in the
middle of the screen.

David

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the icon
of a jibri user granted as "moderator" at the bottom-right corner of the
user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> > <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#20

hi higoufu,

I have installed jitsi with quick-install

Your config.js seems to be fine.

···

2017-04-05 9:14 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

Hi, david.

I think I know the reason why your button shows only once in a while:

If you enter the first time to a room (http://mydomain-jitsi.com/myroom)
jitsi makes you moderator automatically.

You can only see the button if you are moderator of the room.

When you refresh the page, jitsi may take a while to disconnect that user,
so the next time you're not a moderator (you might see two people in the
room).
I think that's the reason why you do not see the button sometimes.

My suggestion is to change rooms when you do not see the button.
(Https://mydomain-jitsi.com/myroom2, https://mydomain-jitsi.com/myroom3,
https://mydomain-jitsi.com/myroom4 ...)

In this way you ensure that you are the first in the room and thus you
will always be moderator.

I hope you understand my explanation (my English is not so good)

* Jibri does not need a camera.

On the other hand, if the button does not work is because jitsi has not
detected that jibri is connected to xmpp.

The reason may be for various reasons, I had some problems regarding it,
permissions, users ...

Start by reviewing the jibri-xmpp.service logs, there you can check if
jibri connects correctly to xmpp.
Also check the prosody logs, so you can see if there are any connection
errors.

I hope I have given you some idea of ​​how to continue, try what I tell
you and tell us.

Greetings.

2017-04-05 2:32 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Guofu Han,

I use "cd /home/jibri/jibri-xmpp-client" and "DISPLAY=:0
./jibriselenium.py -u https://URL-TO-MEETING", and aside, in my terminal
multiplexer (byobu) i use "cd /home/jibri/scripts" and
"./start-ffmpeg.sh filename.flv".

I don't have the record button. Sometimes it appears, but is never
functional.

David

Le 04/04/2017 à 18:29, hanguofu a écrit :

Hi , David :

Could you please tell me which cmd you use for manual test ? Did you have
the record button at the user interface too ?
I would like to have a trial :slight_smile:

Regards !

Guofu Han

At 2017-04-05 00:01:22, "David Mézière" <d.meziere@immanens.com>
<d.meziere@immanens.com> wrote:

Hello Guofu Han,

I am one step further. On a manuel test I can now record the video too.
But for now, without sound, and with that same camera error message in the
middle of the screen.

David

Le 04/04/2017 à 17:54, hanguofu a écrit :

Hi , Alfredo :

Thanks for the clarification :slight_smile: Do you have any luck to make jibri work ?

I did not see the recording option/button at all , but I did see the
icon of a jibri user granted as "moderator" at the bottom-right corner
of the user interface.
Is that what you achieved ?

Regards !

Guofu Han

At 2017-04-04 00:42:14, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >> <alfredo.sil.gt@gmail.com> wrote:

hi hanguofu,

I'm not sure how to do a manual test,
The test you do (as indicated by the documentation) is to verify that
jibri, can send an RTMP stream to youtube, the way to execute it is:

./launch_recording.sh null null null STREAM_KEY

Then go to youtube and verify that you receive data, you should see an
image that says: "connecting ..."
If so, then the test is okay.

regards

2017-04-03 4:04 GMT-05:00 David Mézière <d.meziere@immanens.com>:

Hello,

I think I am at almost the same point than you. But I had better results
launching "DISPLAY=:0 ./jibriselenium.py -u [Room URL]" in the
jibri-xmpp-client directory, prior to recording. But anyway, I still hang
at the Jitsi Meet screen telling me that something is wrong with my webcam.
David

Le 02/04/2017 à 05:50, hanguofu a écrit :

I use the script to start recording manually :

./launch_recording.sh https://my_jitsi_meet_ip_addr/my_room test.flv

As expected , the output file only a connecting picture. I read the
script and cannot understand why the URL=$1 is not needed at all .

Is it the right way to manually record the conference ? Is there sth.
wrong with the script ?

Regards !

Guofu Han

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing listusers@jitsi.org
Unsubscribe instructions and other list options:http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users