[jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message


#1

Hi guys,
I followed up the updated redme file to setup Jibri, to record the conference. The manuals tests seems to be OK ; when I play the filename.flv after ./start-ffmpeg.sh filename.flv command, I have a black screen with "connecting".

From the webpage, when I click to the "start/stop live steam" button, I have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.


#2

Hi Raphael,

It sounds like you haven’t gotten the jibri daemon properly connected to your Prosody install. Make sure that app.py is running, and take a look at the log messages both from the app.py (jibri-xmpp) service and the jicofo instance. Make sure you’ve got jicofo configured to look for jibri in the appropriate MUC. I realized the README has an error, which I am fixing now. The real jicofo setting should be something like the following, with YOURDOMAIN replaced with your real prosody virtual host domain:

org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN

I also suggest setting the following, since sometimes jibri can take a while to start. This will also be in the README shortly:

org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Hope this helps!

Cheers,

-Aaron

···

On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:

Hi guys,
I followed up the updated redme file to setup Jibri, to record the conference. The manuals tests seems to be OK ; when I play the filename.flv after ./start-ffmpeg.sh filename.flv command, I have a black screen with “connecting”.
From the webpage, when I click to the “start/stop live steam” button, I have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e= <https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=>


#3

Hi, I have the same problem (the live stream service is currently unavailabl
e) , this is the jibri-xmpp.service log (*service jibri-xmpp status*)

*Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...*

*Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.*

*Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating a client for hostname: 127.0.0.1 with options: {'usage_timeout':
0, 'xmpp_domain': 'xmpp.en*

*Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
property deprecated. Use boundjid.bare*

*Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
jibri_watcher starting up...*

*Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
Running on http://0.0.0.0:5000/ (Press CTRL+C to
quit)*

*Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting for </stream:stream> from server*

*Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting for </stream:stream> from server*

-- Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC --

how I do this?

(I do not know if it is important but I do not have a valid SSL certificate)

Thanks.

···

2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com>:

Hi Raphael,

It sounds like you haven’t gotten the jibri daemon properly connected to
your Prosody install. Make sure that app.py is running, and take a look at
the log messages both from the app.py (jibri-xmpp) service and the jicofo
instance. Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC. I realized the README has an error, which I am fixing
now. The real jicofo setting should be something like the following, with
YOURDOMAIN replaced with your real prosody virtual host domain:

org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN

I also suggest setting the following, since sometimes jibri can take a
while to start. This will also be in the README shortly:

org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Hope this helps!

Cheers,

-Aaron

On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:

Hi guys,
I followed up the updated redme file to setup Jibri, to record the
conference. The manuals tests seems to be OK ; when I play the filename.flv
after ./start-ffmpeg.sh filename.flv command, I have a black screen with
“connecting”.
From the webpage, when I click to the “start/stop live steam” button, I
have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.
jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_
7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_
EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_
JzGGyW7J3fejGA7HPNDhD4Tcco&e=

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

Hi, I have the same problem (the live stream service is currently
unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
status)

Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...

Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO Creating
a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
'xmpp_domain': 'xmpp.en

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
property deprecated. Use boundjid.bare

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
jibri_watcher starting up...

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO Waiting
for </stream:stream> from server

Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO Waiting
for </stream:stream> from server

-- Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC --

how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

(I do not know if it is important but I do not have a valid SSL certificate)

I think this should be fine.

Regards
damencho

···

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

Thanks.

2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com>:

Hi Raphael,

It sounds like you haven’t gotten the jibri daemon properly connected to
your Prosody install. Make sure that app.py is running, and take a look at
the log messages both from the app.py (jibri-xmpp) service and the jicofo
instance. Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC. I realized the README has an error, which I am fixing now.
The real jicofo setting should be something like the following, with
YOURDOMAIN replaced with your real prosody virtual host domain:

org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN

I also suggest setting the following, since sometimes jibri can take a
while to start. This will also be in the README shortly:

org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Hope this helps!

Cheers,

-Aaron

On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:

Hi guys,
I followed up the updated redme file to setup Jibri, to record the
conference. The manuals tests seems to be OK ; when I play the filename.flv
after ./start-ffmpeg.sh filename.flv command, I have a black screen with
“connecting”.
From the webpage, when I click to the “start/stop live steam” button, I
have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:

https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com
<TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

···

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org>:

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman > <alfredo.sil.gt@gmail.com> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL
certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com
>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly connected to
>> your Prosody install. Make sure that app.py is running, and take a
look at
>> the log messages both from the app.py (jibri-xmpp) service and the
jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri in
the
>> appropriate MUC. I realized the README has an error, which I am fixing
now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the
filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam” button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.
jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_
7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_
EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_
JzGGyW7J3fejGA7HPNDhD4Tcco&e=
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

···

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Tuesday, March 28, 2017 4:51:52 PM
Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY= TheBrewery@conference.midomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov < damencho@jitsi.org > :

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman < alfredo.sil.gt@gmail.com > wrote:

Hi, I have the same problem (the live stream service is currently
unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
status)

Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...

Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO Creating
a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
'xmpp_domain': 'xmpp.en

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
property deprecated. Use boundjid.bare

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
jibri_watcher starting up...

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO Waiting
for </stream:stream> from server

Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO Waiting
for </stream:stream> from server

-- Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC --

how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

(I do not know if it is important but I do not have a valid SSL certificate)

I think this should be fine.

Regards
damencho

Thanks.

2017-03-28 11:17 GMT-05:00 Aaron van Meerten < avanmeerten@atlassian.com >:

Hi Raphael,

It sounds like you haven’t gotten the jibri daemon properly connected to
your Prosody install. Make sure that app.py is running, and take a look at
the log messages both from the app.py (jibri-xmpp) service and the jicofo
instance. Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC. I realized the README has an error, which I am fixing now.
The real jicofo setting should be something like the following, with
YOURDOMAIN replaced with your real prosody virtual host domain:

org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN

I also suggest setting the following, since sometimes jibri can take a
while to start. This will also be in the README shortly:

org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Hope this helps!

Cheers,

-Aaron

On Mar 28, 2017, at 09:45, Raphael Kong < rkong@h2ad.net > wrote:

Hi guys,
I followed up the updated redme file to setup Jibri, to record the
conference. The manuals tests seems to be OK ; when I play the filename.flv
after ./start-ffmpeg.sh filename.flv command, I have a black screen with
“connecting”.
From the webpage, when I click to the “start/stop live steam” button, I
have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:

https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

···

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 4:51:52 PM
*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com
<TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org>:

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman >> <alfredo.sil.gt@gmail.com> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL
certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com
>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly connected
to
>> your Prosody install. Make sure that app.py is running, and take a
look at
>> the log messages both from the app.py (jibri-xmpp) service and the
jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri in
the
>> appropriate MUC. I realized the README has an error, which I am
fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the
filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen
with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam” button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.
jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_
7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_
EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_
JzGGyW7J3fejGA7HPNDhD4Tcco&e=
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Alfredo,

Depending on your configuration, app.py log inforamtion may be in /var/log/ syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

···

----- Original Message -----

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Tuesday, March 28, 2017 5:34:42 PM
Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 < royblog@comcast.net > :

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

From: "Alfredo Guzman" < alfredo.sil.gt@gmail.com >
To: "Jitsi Users" < users@jitsi.org >
Sent: Tuesday, March 28, 2017 4:51:52 PM
Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY= TheBrewery@conference.midomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov < damencho@jitsi.org > :

<blockquote>
Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman < alfredo.sil.gt@gmail.com > wrote:

Hi, I have the same problem (the live stream service is currently
unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
status)

Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...

Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO Creating
a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
'xmpp_domain': 'xmpp.en

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
property deprecated. Use boundjid.bare

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
jibri_watcher starting up...

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)

Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO Waiting
for </stream:stream> from server

Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO Waiting
for </stream:stream> from server

-- Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC --

how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

(I do not know if it is important but I do not have a valid SSL certificate)

I think this should be fine.

Regards
damencho

Thanks.

2017-03-28 11:17 GMT-05:00 Aaron van Meerten < avanmeerten@atlassian.com >:

Hi Raphael,

It sounds like you haven’t gotten the jibri daemon properly connected to
your Prosody install. Make sure that app.py is running, and take a look at
the log messages both from the app.py (jibri-xmpp) service and the jicofo
instance. Make sure you’ve got jicofo configured to look for jibri in the
appropriate MUC. I realized the README has an error, which I am fixing now.
The real jicofo setting should be something like the following, with
YOURDOMAIN replaced with your real prosody virtual host domain:

org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN

I also suggest setting the following, since sometimes jibri can take a
while to start. This will also be in the README shortly:

org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

Hope this helps!

Cheers,

-Aaron

On Mar 28, 2017, at 09:45, Raphael Kong < rkong@h2ad.net > wrote:

Hi guys,
I followed up the updated redme file to setup Jibri, to record the
conference. The manuals tests seems to be OK ; when I play the filename.flv
after ./start-ffmpeg.sh filename.flv command, I have a black screen with
“connecting”.
From the webpage, when I click to the “start/stop live steam” button, I
have "the live stream service is currently unavailable" message.

Any clues ?

Raphael.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:

https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Has anyone managed to make it work?

I have already reviewed the logs and none shows me error messages, all
messages are of type "INFO".

in the jibri-xmpp.service logs show me:

*Running on http://0.0.0.0:5000/*

this is good?

Any suggestions?

Thank you.

···

2017-03-28 20:14 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Depending on your configuration, app.py log inforamtion may be in
/var/log/syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

------------------------------
*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 5:34:42 PM

*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 4:51:52 PM
*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com
<TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org>:

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman >>> <alfredo.sil.gt@gmail.com> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL
certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <
avanmeerten@atlassian.com>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly connected
to
>> your Prosody install. Make sure that app.py is running, and take a
look at
>> the log messages both from the app.py (jibri-xmpp) service and the
jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri
in the
>> appropriate MUC. I realized the README has an error, which I am
fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the
filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen
with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam” button,
I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.
jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_
7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_
EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_
JzGGyW7J3fejGA7HPNDhD4Tcco&e=
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

hi, everyone
I do not know if it's important, but checking the chrome console I found
this line:

*[Modules / xmpp / recording.js] <r.handleJibriPresence>: Handle jibri
presence: undefined*

Any ideas?

...
I already installed it all 3 times, and I still can not make jibri work.
If someone can help me I would appreciate it, of course I could pay you.

Thanks.

···

2017-03-29 11:44 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

Has anyone managed to make it work?

I have already reviewed the logs and none shows me error messages, all
messages are of type "INFO".

in the jibri-xmpp.service logs show me:

*Running on http://0.0.0.0:5000/*

this is good?

Any suggestions?

Thank you.

2017-03-28 20:14 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Depending on your configuration, app.py log inforamtion may be in
/var/log/syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

------------------------------
*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 5:34:42 PM

*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 4:51:52 PM
*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com
<TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org>:

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman >>>> <alfredo.sil.gt@gmail.com> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING
jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL
certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <
avanmeerten@atlassian.com>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly
connected to
>> your Prosody install. Make sure that app.py is running, and take a
look at
>> the log messages both from the app.py (jibri-xmpp) service and the
jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri
in the
>> appropriate MUC. I realized the README has an error, which I am
fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take
a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the
filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen
with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam”
button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.ji
tsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHO
Qgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=
UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=
ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

I have been working with another user about this very issue as well. It may be that Jibri requires a newer version of Prosody than you are running. What version of prosody do you have installed? I’ve only tested/used Jibri with a very recent Prosody nightly, but I have confidence it ought to work with at least prosody 0.10. I’m not sure it’ll work with 0.9, so it’s worth trying a newer prosody and see if you see the issue resolve.

The presence you see in chrome console means Jicofo hasn’t seen any jibri connect, so it hasn’t sent the updated presence indicating jibri is “off” and ready for recording. You may need to review your jibri configuration and jibri logs to see why it’s not connecting to your prosody.

The Running on 0.0.0.0:5000 just means the internal REST interface is enabled, and only indicates that the daemon is running at all, not that it’s properly configured/connected. You want to look for messages about connecting to your prosody server, joining the brewery muc and sending an idle presence. Can you post part of your config.json file? From your log snippets it looks like you’re trying to configure jibri to connect to a server on 127.0.0.1, which may not be what you want. Jibri is meant to run on a standalone server with enough CPU to handle rendering the conference video and re-transcoding it. It may not perform well on the same server as the jicofo/prosody/videobridge.

I hope this helps!

Cheers,

-Aaron

···

On Mar 29, 2017, at 21:22, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

hi, everyone
I do not know if it's important, but checking the chrome console I found this line:

[Modules / xmpp / recording.js] <r.handleJibriPresence>: Handle jibri presence: undefined

Any ideas?

...
I already installed it all 3 times, and I still can not make jibri work.
If someone can help me I would appreciate it, of course I could pay you.

Thanks.

2017-03-29 11:44 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>:
Has anyone managed to make it work?

I have already reviewed the logs and none shows me error messages, all messages are of type "INFO".

in the jibri-xmpp.service logs show me:
Running on http://0.0.0.0:5000/
this is good?

Any suggestions?

Thank you.

2017-03-28 20:14 GMT-05:00 <royblog@comcast.net <mailto:royblog@comcast.net>>:
Alfredo,

Depending on your configuration, app.py log inforamtion may be in /var/log/syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>
To: "Jitsi Users" <users@jitsi.org <mailto:users@jitsi.org>>
Sent: Tuesday, March 28, 2017 5:34:42 PM

Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net <mailto:royblog@comcast.net>>:
Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>
To: "Jitsi Users" <users@jitsi.org <mailto:users@jitsi.org>>
Sent: Tuesday, March 28, 2017 4:51:52 PM
Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com <mailto:TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org <mailto:damencho@jitsi.org>>:
Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman > <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com <mailto:avanmeerten@atlassian.com>>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly connected to
>> your Prosody install. Make sure that app.py is running, and take a look at
>> the log messages both from the app.py (jibri-xmpp) service and the jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri in the
>> appropriate MUC. I realized the README has an error, which I am fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net <mailto:rkong@h2ad.net>> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam” button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org <mailto:users@jitsi.org>
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e= <https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org <mailto:users@jitsi.org>
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org <mailto:users@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

I have reviewed some prosody logs, I found this:

C2s stream for <127.0.0.1> closed: This server does not serve
auth.xmpp.mydomain.com

Why?

In the documentation do not ask me to create the VirtualHost
auth.xmpp.mydomain.com

I created the VirtualHost in prosody, "*auth.xmpp.mydomain.com
<http://auth.xmpp.mydomain.com>*" and tried again.

I had errors with SSL, "Could not find pyasn1 and pyasn1_modules. SSL
certificate COULD NOT BE VERIFIED."
I have solved it by installing the Module.

Now I get these errors in Jibri-Xmpp:

app.py[20926]: INFO Negotiating TLS
app.py[20926]: INFO Using SSL version: TLS 1.0
app.py[20926]: ERROR Could not match certficate against hostname:*
auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com>*
app.py[20926]: WARNING Failed to send b"<stream:stream
to='*auth.xmpp.mydomain.com
<http://auth.xmpp.mydomain.com>*' xmlns:stream='http://etherx.j
app.py[20926]: ERROR Socket Error #9: Bad file descriptor
app.py[20926]: INFO Negotiating TLS
app.py[20926]: INFO Using SSL version: TLS 1.0
app.py[20926]: ERROR Could not match certficate against hostname:
*auth.xmpp.mydomai.com
<http://auth.xmpp.mydomai.com>*
app.py[20926]: WARNING Failed to send b"<stream:stream
to='*auth.xmpp.mydomain.com
<http://auth.xmpp.mydomain.com>*' xmlns:stream='http://etherx.j
app.py[20926]: ERROR Socket Error #9: Bad file descriptor

Why use VirtualHost auth.xmpp.mydomain.com ???

What should I do?

Thanks, to all.

···

2017-03-29 23:40 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com>:

I have been working with another user about this very issue as well. It
may be that Jibri requires a newer version of Prosody than you are
running. What version of prosody do you have installed? I’ve only
tested/used Jibri with a very recent Prosody nightly, but I have confidence
it ought to work with at least prosody 0.10. I’m not sure it’ll work with
0.9, so it’s worth trying a newer prosody and see if you see the issue
resolve.

The presence you see in chrome console means Jicofo hasn’t seen any jibri
connect, so it hasn’t sent the updated presence indicating jibri is “off”
and ready for recording. You may need to review your jibri configuration
and jibri logs to see why it’s not connecting to your prosody.

The Running on 0.0.0.0:5000 just means the internal REST interface is
enabled, and only indicates that the daemon is running at all, not that
it’s properly configured/connected. You want to look for messages about
connecting to your prosody server, joining the brewery muc and sending an
idle presence. Can you post part of your config.json file? From your log
snippets it looks like you’re trying to configure jibri to connect to a
server on 127.0.0.1, which may not be what you want. Jibri is meant to run
on a standalone server with enough CPU to handle rendering the conference
video and re-transcoding it. It may not perform well on the same server as
the jicofo/prosody/videobridge.

I hope this helps!

Cheers,

-Aaron

On Mar 29, 2017, at 21:22, Alfredo Guzman <alfredo.sil.gt@gmail.com> > wrote:

hi, everyone
I do not know if it's important, but checking the chrome console I found
this line:

*[Modules / xmpp / recording.js] <r.handleJibriPresence>: Handle jibri
presence: undefined*

Any ideas?

...
I already installed it all 3 times, and I still can not make jibri work.
If someone can help me I would appreciate it, of course I could pay you.

Thanks.

2017-03-29 11:44 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com>:

Has anyone managed to make it work?

I have already reviewed the logs and none shows me error messages, all
messages are of type "INFO".

in the jibri-xmpp.service logs show me:

*Running on http://0.0.0.0:5000/*

this is good?

Any suggestions?

Thank you.

2017-03-28 20:14 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Depending on your configuration, app.py log inforamtion may be in
/var/log/syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

------------------------------
*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 5:34:42 PM

*Subject: *Re: [jitsi-users] Jibri, almost running, but still have "the
live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net>:

Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Tuesday, March 28, 2017 4:51:52 PM
*Subject: *Re: [jitsi-users] Jibri, almost running, but still have
"the live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com
<TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org>:

Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman >>>>> <alfredo.sil.gt@gmail.com> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control
Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO
Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING
jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO
*
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO
Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO
Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL
certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <
avanmeerten@atlassian.com>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly
connected to
>> your Prosody install. Make sure that app.py is running, and take a
look at
>> the log messages both from the app.py (jibri-xmpp) service and the
jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri
in the
>> appropriate MUC. I realized the README has an error, which I am
fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOMAIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can
take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the
filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen
with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam”
button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.ji
tsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHO
Qgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMM
oXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_
JzGGyW7J3fejGA7HPNDhD4Tcco&e=
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

I use the auth virtual host for the jibri user connecting to the Brewery MUC. This distinguishes between the jibri user as a service (jibri@auth.xmpp.mydomain.com <mailto:jibri@auth.xmpp.mydomain.com>) vs jibri selenium as a client (recroder@recorder.xmpp.mydomain.com <mailto:recroder@recorder.xmpp.mydomain.com>). I used the auth. domain because it already exists in the default jitsi meet deployment and is already a simple username/password auth virtual host. You could use any virtual host here as long as you end up with a valid user account that can join the brewery muc.

Obviously you will need to update auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/> to be the actual auth domain for your jitsi meet install.

Cheers,

-Aaron

···

On Mar 30, 2017, at 15:23, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

I have reviewed some prosody logs, I found this:

C2s stream for <127.0.0.1> closed: This server does not serve auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>

Why?

In the documentation do not ask me to create the VirtualHost auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>

I created the VirtualHost in prosody, "auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>" and tried again.

I had errors with SSL, "Could not find pyasn1 and pyasn1_modules. SSL certificate COULD NOT BE VERIFIED."
I have solved it by installing the Module.

Now I get these errors in Jibri-Xmpp:

app.py[20926]: INFO Negotiating TLS
app.py[20926]: INFO Using SSL version: TLS 1.0
app.py[20926]: ERROR Could not match certficate against hostname: auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>
app.py[20926]: WARNING Failed to send b"<stream:stream to='auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>' xmlns:stream='http://etherx.j <http://etherx.j/>
app.py[20926]: ERROR Socket Error #9: Bad file descriptor
app.py[20926]: INFO Negotiating TLS
app.py[20926]: INFO Using SSL version: TLS 1.0
app.py[20926]: ERROR Could not match certficate against hostname: auth.xmpp.mydomai.com <http://auth.xmpp.mydomai.com/>
app.py[20926]: WARNING Failed to send b"<stream:stream to='auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/>' xmlns:stream='http://etherx.j <http://etherx.j/>
app.py[20926]: ERROR Socket Error #9: Bad file descriptor

Why use VirtualHost auth.xmpp.mydomain.com <http://auth.xmpp.mydomain.com/> ???

What should I do?

Thanks, to all.

2017-03-29 23:40 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com <mailto:avanmeerten@atlassian.com>>:
I have been working with another user about this very issue as well. It may be that Jibri requires a newer version of Prosody than you are running. What version of prosody do you have installed? I’ve only tested/used Jibri with a very recent Prosody nightly, but I have confidence it ought to work with at least prosody 0.10. I’m not sure it’ll work with 0.9, so it’s worth trying a newer prosody and see if you see the issue resolve.

The presence you see in chrome console means Jicofo hasn’t seen any jibri connect, so it hasn’t sent the updated presence indicating jibri is “off” and ready for recording. You may need to review your jibri configuration and jibri logs to see why it’s not connecting to your prosody.

The Running on 0.0.0.0:5000 <http://0.0.0.0:5000/> just means the internal REST interface is enabled, and only indicates that the daemon is running at all, not that it’s properly configured/connected. You want to look for messages about connecting to your prosody server, joining the brewery muc and sending an idle presence. Can you post part of your config.json file? From your log snippets it looks like you’re trying to configure jibri to connect to a server on 127.0.0.1, which may not be what you want. Jibri is meant to run on a standalone server with enough CPU to handle rendering the conference video and re-transcoding it. It may not perform well on the same server as the jicofo/prosody/videobridge.

I hope this helps!

Cheers,

-Aaron

On Mar 29, 2017, at 21:22, Alfredo Guzman <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>> wrote:

hi, everyone
I do not know if it's important, but checking the chrome console I found this line:

[Modules / xmpp / recording.js] <r.handleJibriPresence>: Handle jibri presence: undefined

Any ideas?

...
I already installed it all 3 times, and I still can not make jibri work.
If someone can help me I would appreciate it, of course I could pay you.

Thanks.

2017-03-29 11:44 GMT-05:00 Alfredo Guzman <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>:
Has anyone managed to make it work?

I have already reviewed the logs and none shows me error messages, all messages are of type "INFO".

in the jibri-xmpp.service logs show me:
Running on http://0.0.0.0:5000/
this is good?

Any suggestions?

Thank you.

2017-03-28 20:14 GMT-05:00 <royblog@comcast.net <mailto:royblog@comcast.net>>:
Alfredo,

Depending on your configuration, app.py log inforamtion may be in /var/log/syslog.
Your Jicofo log may be at /var/log/jitsi/Jiocofo.log

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>
To: "Jitsi Users" <users@jitsi.org <mailto:users@jitsi.org>>
Sent: Tuesday, March 28, 2017 5:34:42 PM

Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

royBlog,

Logs in jicofo, all are of type INFO.

I can not find where I can see the full app.py logs?

thanks

2017-03-28 19:10 GMT-05:00 <royblog@comcast.net <mailto:royblog@comcast.net>>:
Alfredo,

Have you checked jicofo & app.py logs for errors?

Also, what version of Jitsi-meet are you using?
We have encountered a similar issue which we are working through now.

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>>
To: "Jitsi Users" <users@jitsi.org <mailto:users@jitsi.org>>
Sent: Tuesday, March 28, 2017 4:51:52 PM
Subject: Re: [jitsi-users] Jibri, almost running, but still have "the live stream service is currently unavailable" message

thanks damian.

Yes,
I added the configuration
org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.midomain.com <mailto:TheBrewery@conference.yourdomain.com>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

and restart jicofo.

Also, Manually testing Jibri, all ok

any ideas?

Thanks.

2017-03-28 18:24 GMT-05:00 Damian Minkov <damencho@jitsi.org <mailto:damencho@jitsi.org>>:
Hi,

On Tue, Mar 28, 2017 at 6:18 PM, Alfredo Guzman >> <alfredo.sil.gt@gmail.com <mailto:alfredo.sil.gt@gmail.com>> wrote:
> Hi, I have the same problem (the live stream service is currently
> unavailable) , this is the jibri-xmpp.service log (service jibri-xmpp
> status)
>
> Mar 28 23:09:23 ip- systemd[1]: Starting Jibri XMPP Control Process...
>
> Mar 28 23:09:23 ip- systemd[1]: Started Jibri XMPP Control Process.
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,616 INFO Creating
> a client for hostname: 127.0.0.1 with options: {'usage_timeout': 0,
> 'xmpp_domain': 'xmpp.en
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,630 WARNING jid
> property deprecated. Use boundjid.bare
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,636 INFO
> jibri_watcher starting up...
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,637 INFO *
> Running on http://0.0.0.0:5000/ (Press CTRL+C to quit)
>
> Mar 28 23:09:23 ip- app.py[18056]: 2017-03-28 23:09:23,639 INFO Waiting
> for </stream:stream> from server
>
> Mar 28 23:09:25 ip- app.py[18056]: 2017-03-28 23:09:25,545 INFO Waiting
> for </stream:stream> from server
>
>
> -- Make sure you’ve got jicofo configured to look for jibri in the
> appropriate MUC --
>
> how I do this?

Checkout the readme about org.jitsi.jicofo.jibri.BREWERY=

>
> (I do not know if it is important but I do not have a valid SSL certificate)

I think this should be fine.

Regards
damencho

>
>
> Thanks.
>
> 2017-03-28 11:17 GMT-05:00 Aaron van Meerten <avanmeerten@atlassian.com <mailto:avanmeerten@atlassian.com>>:
>>
>> Hi Raphael,
>>
>>
>> It sounds like you haven’t gotten the jibri daemon properly connected to
>> your Prosody install. Make sure that app.py is running, and take a look at
>> the log messages both from the app.py (jibri-xmpp) service and the jicofo
>> instance. Make sure you’ve got jicofo configured to look for jibri in the
>> appropriate MUC. I realized the README has an error, which I am fixing now.
>> The real jicofo setting should be something like the following, with
>> YOURDOMAIN replaced with your real prosody virtual host domain:
>>
>> org.jitsi.jicofo.jibri.BREWERY=TheBrewery@conference.YOURDOM <mailto:TheBrewery@conference.YOURDOM>AIN
>>
>>
>> I also suggest setting the following, since sometimes jibri can take a
>> while to start. This will also be in the README shortly:
>>
>> org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
>>
>>
>> Hope this helps!
>>
>> Cheers,
>>
>> -Aaron
>>
>> On Mar 28, 2017, at 09:45, Raphael Kong <rkong@h2ad.net <mailto:rkong@h2ad.net>> wrote:
>>
>> Hi guys,
>> I followed up the updated redme file to setup Jibri, to record the
>> conference. The manuals tests seems to be OK ; when I play the filename.flv
>> after ./start-ffmpeg.sh filename.flv command, I have a black screen with
>> “connecting”.
>> From the webpage, when I click to the “start/stop live steam” button, I
>> have "the live stream service is currently unavailable" message.
>>
>> Any clues ?
>>
>> Raphael.
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org <mailto:users@jitsi.org>
>> Unsubscribe instructions and other list options:
>>
>> https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e= <https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=_7kz7gzvN7Bw2xMift9VAihjP3L582hi9LeDM_GmfXY&m=UXQdjMMoXOI_EOX7hdtoABAsozVV_t_FEkZw-ecx6vk&s=ZC8xdREPJgFcKZKz_JzGGyW7J3fejGA7HPNDhD4Tcco&e=>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org <mailto:users@jitsi.org>
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org <mailto:users@jitsi.org>
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users