[jitsi-users] issues following quick install


#1

Hello everyone I just installed jitsi-meet using the instructions on the quick install guide and it success but I'm not having any audio / video. The more relevant lines on the logs are the following:

root@myhost:~# cat /var/log/jitsi/jvb.log | grep SEVERE
JVB 2016-08-22 14:30:13.425 SEVERE: [16] org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException: Connection refused, host:localhost, port:5347
JVB 2016-08-22 14:30:18.439 SEVERE: [16] org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException: Connection refused, host:localhost, port:5347

root@myhost:~# cat /var/log/jitsi/jicofo.log | grep SEVERE
Jicofo 2016-08-22 14:30:17.452 SEVERE: [15] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to connect: XMPPError connecting to localhost:5222.
Jicofo 2016-08-22 14:30:17.606 SEVERE: [29] org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException: Connection refused, host:localhost, port:5347

also I'm having the following output running /etc/init.d/prosody status, but can't tell if it's related to my issue:

Aug 22 14:42:36 talk prosody[11563]: Starting Prosody XMPP Server: prosody.
Aug 22 14:42:36 talk prosody[11573]: certmanager: SSL/TLS: Failed to load '/etc/prosody/certs/localhost.crt': Check that the path is correct, and the file... port 5281)
Aug 22 14:42:36 talk prosody[11573]: portmanager: Error binding encrypted port for https: error loading certificate (No such file or directory)
Aug 22 14:42:36 talk prosody[11573]: certmanager: SSL/TLS: Failed to load '/etc/prosody/certs/localhost.crt': Check that the path is correct, and the file... port 5281)
Aug 22 14:42:36 talk prosody[11573]: portmanager: Error binding encrypted port for https: error loading certificate (No such file or directory)

Any help is appreciated

···

--
--
raz


#2

Ok, I fixed the problems with the prosody certificates but still I'm having problems to hear any conversation on the app.

The Jifico log don't show anymore the problem connecting to port 5222. But my port 5437 still is closed how do I grant permissions to Prosody/Jitsi to use the port, supponing that it is the main issue now??

Thanks

···

On 2016-08-22 14:32, andrea.magatti@gmail.com wrote:
The main issue is port 5437 closed.

It is used by prosody for jifoco and videobridge.

Too 5222 is closed , standard port for xmpp.

Then prosody don’t find your ssl certificate…

Inviato dal mio telefono Windows 10

DA: raz
INVIATO: lunedì 22 agosto 2016 21:05
A: users@jitsi.org
OGGETTO: [jitsi-users] issues following quick install

Hello everyone I just installed jitsi-meet using the instructions on
the

quick install guide and it success but I'm not having any audio /
video.

The more relevant lines on the logs are the following:

root@myhost:~# cat /var/log/jitsi/jvb.log | grep SEVERE

JVB 2016-08-22 14:30:13.425 SEVERE: [16]

org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:

Connection refused, host:localhost, port:5347

JVB 2016-08-22 14:30:18.439 SEVERE: [16]

org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:

Connection refused, host:localhost, port:5347

root@myhost:~# cat /var/log/jitsi/jicofo.log | grep SEVERE

Jicofo 2016-08-22 14:30:17.452 SEVERE: [15]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to

connect: XMPPError connecting to localhost:5222.

Jicofo 2016-08-22 14:30:17.606 SEVERE: [29]

org.jitsi.meet.ComponentMain.call().278 java.net.ConnectException:

Connection refused, host:localhost, port:5347

also I'm having the following output running /etc/init.d/prosody
status,

but can't tell if it's related to my issue:

Aug 22 14:42:36 talk prosody[11563]: Starting Prosody XMPP Server:

prosody.

Aug 22 14:42:36 talk prosody[11573]: certmanager: SSL/TLS: Failed to

load '/etc/prosody/certs/localhost.crt': Check that the path is
correct,

and the file... port 5281)

Aug 22 14:42:36 talk prosody[11573]: portmanager: Error binding

encrypted port for https: error loading certificate (No such file or

directory)

Aug 22 14:42:36 talk prosody[11573]: certmanager: SSL/TLS: Failed to

load '/etc/prosody/certs/localhost.crt': Check that the path is
correct,

and the file... port 5281)

Aug 22 14:42:36 talk prosody[11573]: portmanager: Error binding

encrypted port for https: error loading certificate (No such file or

directory)

Any help is appreciated

--

--

raz

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

--
--
raz lupercio
software security auditor