[jitsi-users] Is there a way to disable pop-ups?


#1

I think it is very annoying that every time a contact is even typing
Jitsi spams with constant messages about that, when they do enter, the
window comes all the way to front, regardless of what I am doing,

I disabled that stuff already, but it just keeps coming, please,
someone knows a way to deactivate the come-to-front behaviour and the
precognition "your horde of contacts is like typing as of like now!"

Here is the screenshot of my config:

http://img198.imageshack.us/img198/5209/jitsi.jpg

Thanks!

Angel Luciano Somarriba Mendoza
818-6555-456


#2

Hi Angel

You need to click on the little "cloud" images in the configuration
screen you included in your screenshot (Tools -> Options -> Events) to
disable popup messages for the most frequent events (e.g. friends
typing, or someone sending you a message).

Hope this helps

Alex

···

On 24 May 2012 00:39, Angel Mendoza <bancatech@gmail.com> wrote:

I think it is very annoying that every time a contact is even typing
Jitsi spams with constant messages about that, when they do enter, the
window comes all the way to front, regardless of what I am doing,

I disabled that stuff already, but it just keeps coming, please,
someone knows a way to deactivate the come-to-front behaviour and the
precognition "your horde of contacts is like typing as of like now!"


#3

To my detriment I just noticed that this _does not_ work as expected,
at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming Message" from the
options -> events menu, but it still either pops up a baloon or a full
Jitsi window on incoming messages.

I confirmed with a friend and he sees the same behaviour. Am I missing
something or is this a bug?

Alex

···

On 24 May 2012 00:52, <ix4svs@gmail.com> wrote:

On 24 May 2012 00:39, Angel Mendoza <bancatech@gmail.com> wrote:

I think it is very annoying that every time a contact is even typing
Jitsi spams with constant messages about that, when they do enter, the
window comes all the way to front, regardless of what I am doing,

I disabled that stuff already, but it just keeps coming, please,
someone knows a way to deactivate the come-to-front behaviour and the
precognition "your horde of contacts is like typing as of like now!"

Hi Angel

You need to click on the little "cloud" images in the configuration
screen you included in your screenshot (Tools -> Options -> Events) to
disable popup messages for the most frequent events (e.g. friends
typing, or someone sending you a message).


#4

Can someone please confirm or dis-confirm this? It's quite annoying to
end users to be unable to control the behaviour of the client.

If there is no way to supress popups, this is a bug that needs to be
addressed and I'll be happy to forward this to the dev list.

Alex

<snip>

···

On 6 July 2012 15:12, <ix4svs@gmail.com> wrote:

To my detriment I just noticed that this _does not_ work as expected,
at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming Message" from the
options -> events menu, but it still either pops up a baloon or a full
Jitsi window on incoming messages.

I confirmed with a friend and he sees the same behaviour. Am I missing
something or is this a bug?

Alex


#5

Hey Alex,

Have you tried disabling the baloon itself rather than the entire event?

As for the message window: there's no way to prevent that I am afraid.
We show any message we get.

Cheers,
Emil

···

On 14.07.12 16:59, ix4svs@gmail.com wrote:

Can someone please confirm or dis-confirm this? It's quite annoying to
end users to be unable to control the behaviour of the client.

If there is no way to supress popups, this is a bug that needs to be
addressed and I'll be happy to forward this to the dev list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> wrote:
<snip>

To my detriment I just noticed that this _does not_ work as expected,
at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming Message" from the
options -> events menu, but it still either pops up a baloon or a full
Jitsi window on incoming messages.

I confirmed with a friend and he sees the same behaviour. Am I missing
something or is this a bug?

Alex

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#6

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

···

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com > wrote:
> Can someone please confirm or dis-confirm this? It's
quite annoying to
> end users to be unable to control the behaviour of the
client.
>
> If there is no way to supress popups, this is a bug
that needs to be
> addressed and I'll be happy to forward this to the dev
list.
>
> Alex
>
> On 6 July 2012 15:12, <ix4svs@gmail.com> > wrote:
> <snip>
>> To my detriment I just noticed that this _does not_
work as expected,
>> at least on Windows 7 with build 4103.
>>
>> I have completely disabled the event "Incoming
Message" from the
>> options -> events menu, but it still either pops
up a baloon or a full
>> Jitsi window on incoming messages.
>>
>> I confirmed with a friend and he sees the same
behaviour. Am I missing
>> something or is this a bug?
>>
>> Alex
>

--
Emil Ivov, Ph.D.
67000
Strasbourg,
Project Lead
France
Jitsi
emcho@jitsi.org

  PHONE: \+33\.1\.77\.62\.43\.30

http://jitsi.org

FAX: +33.1.77.62.47.31


#7

Yes, this is exactly what my users expect. Would be great to see it
implemented as the default behaviour in Jitsi.

Thank you

Alex

···

On 26 July 2012 11:22, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >> wrote:
> Can someone please confirm or dis-confirm this? It's
quite annoying to
> end users to be unable to control the behaviour of the
client.
>
> If there is no way to supress popups, this is a bug
that needs to be
> addressed and I'll be happy to forward this to the dev
list.
>
> Alex
>
> On 6 July 2012 15:12, <ix4svs@gmail.com> >> wrote:
> <snip>
>> To my detriment I just noticed that this _does not_
work as expected,
>> at least on Windows 7 with build 4103.
>>
>> I have completely disabled the event "Incoming
Message" from the
>> options -> events menu, but it still either pops
up a baloon or a full
>> Jitsi window on incoming messages.
>>
>> I confirmed with a friend and he sees the same
behaviour. Am I missing
>> something or is this a bug?
>>
>> Alex
>

--
Emil Ivov, Ph.D.
           67000
Strasbourg,
Project Lead
             France
Jitsi
emcho@jitsi.org

      PHONE: +33.1.77.62.43.30
http://jitsi.org

   FAX: +33.1.77.62.47.31


#8

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our contributors page.

I've made a slight modification though by adding the code directly to the ChatWindow.openChat() instead of ChatWindowManager. This allow us to take into account the "Bring chat window to front" property (configured in General settings) and the case where the user has opened the chat herself (for example by double clicking on the contact in the contact list). Everything related to chat window focus is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

···

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >> wrote:

Can someone please confirm or dis-confirm this? It's

quite annoying to

end users to be unable to control the behaviour of the

client.

If there is no way to supress popups, this is a bug

that needs to be

addressed and I'll be happy to forward this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >> wrote:
<snip>

To my detriment I just noticed that this _does not_

work as expected,

at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming

Message" from the

options -> events menu, but it still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.
           67000
Strasbourg,
Project Lead
             France
Jitsi
emcho@jitsi.org
               
      PHONE: +33.1.77.62.43.30
http://jitsi.org
         
   FAX: +33.1.77.62.47.31


#9

Hi

Even in "Do Not Disturb" mode, when we receive a message a window pops
up and steals the focus. This is quite intrusive and at least in DND
mode should be suppressed.

Thanks

Alex

···

On 26 July 2012 12:24, <ix4svs@gmail.com> wrote:

Yes, this is exactly what my users expect. Would be great to see it
implemented as the default behaviour in Jitsi.

Thank you

Alex

On 26 July 2012 11:22, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>> wrote:
> Can someone please confirm or dis-confirm this? It's
quite annoying to
> end users to be unable to control the behaviour of the
client.
>
> If there is no way to supress popups, this is a bug
that needs to be
> addressed and I'll be happy to forward this to the dev
list.
>
> Alex
>
> On 6 July 2012 15:12, <ix4svs@gmail.com> >>> wrote:
> <snip>
>> To my detriment I just noticed that this _does not_
work as expected,
>> at least on Windows 7 with build 4103.
>>
>> I have completely disabled the event "Incoming
Message" from the
>> options -> events menu, but it still either pops
up a baloon or a full
>> Jitsi window on incoming messages.
>>
>> I confirmed with a friend and he sees the same
behaviour. Am I missing
>> something or is this a bug?
>>
>> Alex
>

--
Emil Ivov, Ph.D.
           67000
Strasbourg,
Project Lead
             France
Jitsi
emcho@jitsi.org

      PHONE: +33.1.77.62.43.30
http://jitsi.org

   FAX: +33.1.77.62.47.31


#10

Hi Vieri,

There was a small issue with my previous commit. The problem was that when the chat window is already visible and we receive a message while typing to someone, if we call:

chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be very annoying. So I've just added a check if we're in a new chat window or not (r9776).

I'm testing on MacOSX though and I don't experience the previously described problem here so could you please confirm that this still does the work the patch was about ?

Cheers,
Yana

···

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our contributors page.

I've made a slight modification though by adding the code directly to the ChatWindow.openChat() instead of ChatWindowManager. This allow us to take into account the "Bring chat window to front" property (configured in General settings) and the case where the user has opened the chat herself (for example by double clicking on the contact in the contact list). Everything related to chat window focus is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>> wrote:

Can someone please confirm or dis-confirm this? It's

quite annoying to

end users to be unable to control the behaviour of the

client.

If there is no way to supress popups, this is a bug

that needs to be

addressed and I'll be happy to forward this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >>> wrote:
<snip>

To my detriment I just noticed that this _does not_

work as expected,

at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming

Message" from the

options -> events menu, but it still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.
          67000
Strasbourg,
Project Lead
            France
Jitsi
emcho@jitsi.org

     PHONE: +33.1.77.62.43.30
http://jitsi.org

  FAX: +33.1.77.62.47.31


#11

Hey Alex,

We'll try Vieri's work around soon.

Emil

···

On Tue, Aug 7, 2012 at 3:13 PM, <ix4svs@gmail.com> wrote:

Hi

Even in "Do Not Disturb" mode, when we receive a message a window pops
up and steals the focus. This is quite intrusive and at least in DND
mode should be suppressed.

Thanks

Alex

On 26 July 2012 12:24, <ix4svs@gmail.com> wrote:

Yes, this is exactly what my users expect. Would be great to see it
implemented as the default behaviour in Jitsi.

Thank you

Alex

On 26 July 2012 11:22, Vieri <rentorbuy@yahoo.com> wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>>> wrote:
> Can someone please confirm or dis-confirm this? It's
quite annoying to
> end users to be unable to control the behaviour of the
client.
>
> If there is no way to supress popups, this is a bug
that needs to be
> addressed and I'll be happy to forward this to the dev
list.
>
> Alex
>
> On 6 July 2012 15:12, <ix4svs@gmail.com> >>>> wrote:
> <snip>
>> To my detriment I just noticed that this _does not_
work as expected,
>> at least on Windows 7 with build 4103.
>>
>> I have completely disabled the event "Incoming
Message" from the
>> options -> events menu, but it still either pops
up a baloon or a full
>> Jitsi window on incoming messages.
>>
>> I confirmed with a friend and he sees the same
behaviour. Am I missing
>> something or is this a bug?
>>
>> Alex
>

--
Emil Ivov, Ph.D.
           67000
Strasbourg,
Project Lead
             France
Jitsi
emcho@jitsi.org

      PHONE: +33.1.77.62.43.30
http://jitsi.org

   FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#12

Hi Yana et al.,

I tested build 4147 and it works great for me.
Keyboard focus is not stolen, as expected.

Thanks for the update.

Vieri

···

--- On Wed, 8/8/12, Yana Stamcheva <yana@jitsi.org> wrote:

Hi Vieri,

There was a small issue with my previous commit. The problem
was that when the chat window is already visible and we
receive a message while typing to someone, if we call:

>>>
chatContainer.getFrame().setFocusableWindowState(false);
>>> chatContainer.getFrame().setVisible(true);
>>>
chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be very
annoying. So I've just added a check if we're in a new chat
window or not (r9776).

I'm testing on MacOSX though and I don't experience the
previously described problem here so could you please
confirm that this still does the work the patch was about ?

Cheers,
Yana

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

> Hi Vieri, all,
>
> Thanks for the patch!
>
> It's committed in revision 9774 and ack-ed on our
contributors page.
>
> I've made a slight modification though by adding the
code directly to the ChatWindow.openChat() instead of
ChatWindowManager. This allow us to take into account the
"Bring chat window to front" property (configured in General
settings) and the case where the user has opened the chat
herself (for example by double clicking on the contact in
the contact list). Everything related to chat window focus
is now in there. We also take care of the ICONIFIED state.
>
> Please let me know if this works for you.
>
> Cheers,
> Yana
>
> On Jul 26, 2012, at 12:22 PM, Vieri wrote:
>
>> Hi,
>>
>> Actually Alex has a good point.
>> In a corporate environment, having a chat window
popup in front while the user is working (typing somewhere
else) is annoying because it steals focus.
>> On a new incoming chat message (xmpp), it's
desirable that a new chat window is created (as it's the
case now) but it shouldn't necessarily take focus and popup
up front. Maybe Jitsi could have a user-defined property for
the new chat window display, eg. TAKE_FOCUS={true,false}. If
we don't want the chat window to come up front, then create
it but set it eg. minimized or something of the sort.
>>
>> What I did is a quick hack in
impl/gui/main/chat/ChatWindowManager.java and modified the
following:
>>
chatContainer.getFrame().setFocusableWindowState(false);
>> chatContainer.getFrame().setVisible(true);
>>
chatContainer.getFrame().setFocusableWindowState(true);
>> in
>> public void openChat(final ChatPanel chatPanel,
final boolean setSelected)
>>
>> With this code change:
>>
>> - users receive Windows task bar notifications for
incoming messages (no keyboard focus stealing) which is
useful so that they now they have new messages and from
whom
>>
>> - users won't have a new chat panel window appear
on screen while they're typing in another application. So
they won't get annoyed by it. The new chat window is created
but won't take focus. Just click on the Jitsi icon in the
Windows bar and you can open up the chat window.
>>
>> - all the above is to avoid keyboard focus
problems. There's another reason one should avoid having a
new chat window appear all of a sudden on screen: privacy.
Users want to be connected and chat but don't want the
message contents to display on screen automatically in case
there's confidential information (think of a busy corporate
environment where lots of people move around computers). So
with the above hack and by disabling the "balloon" message
in Jitsi->Tools->Options->Events->Incoming
message (only disable the balloon) then users will have
almost-total privacy (no popup ChatPanel window and no text
within the Windows notification bar). They will only be
notified that someone wrote them a message and will then be
able to click on the chat window in order to view the
messages whenever they please. It's "almost-total privacy"
because if the user has no other window/application covering
the desktop area then the chat window WILL appear there and
be
>> visible. However, that's usually not the case in a
busy work/office scenario - there's always at least one
other app window open and usually covers the whole screen.
In any case, if this were of concern then we could also
call:
>>
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
>> within
>> openChat()
>> and that would definitely be more private.
>>
>> The hack is simple so I don't think a patch needs
to be posted on JIRA?
>>
>> Alex, is this what you were looking for more or
less?
>>
>> Vieri
>>
>>
>> --- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> > wrote:
>>
>>> Hey Alex,
>>>
>>> Have you tried disabling the baloon itself
rather than the
>>> entire event?
>>>
>>> As for the message window: there's no way to
prevent that I
>>> am afraid.
>>> We show any message we get.
>>>
>>> Cheers,
>>> Emil
>>>
>>> On 14.07.12 16:59, ix4svs@gmail.com > >>> wrote:
>>>> Can someone please confirm or dis-confirm
this? It's
>>> quite annoying to
>>>> end users to be unable to control the
behaviour of the
>>> client.
>>>>
>>>> If there is no way to supress popups, this
is a bug
>>> that needs to be
>>>> addressed and I'll be happy to forward this
to the dev
>>> list.
>>>>
>>>> Alex
>>>>
>>>> On 6 July 2012 15:12, <ix4svs@gmail.com> > >>> wrote:
>>>> <snip>
>>>>> To my detriment I just noticed that
this _does not_
>>> work as expected,
>>>>> at least on Windows 7 with build 4103.
>>>>>
>>>>> I have completely disabled the event
"Incoming
>>> Message" from the
>>>>> options -> events menu, but it still
either pops
>>> up a baloon or a full
>>>>> Jitsi window on incoming messages.
>>>>>
>>>>> I confirmed with a friend and he sees
the same
>>> behaviour. Am I missing
>>>>> something or is this a bug?
>>>>>
>>>>> Alex
>>>>
>>>
>>> --
>>> Emil Ivov, Ph.D.

>>>
67000
>>> Strasbourg,
>>> Project Lead

>>>
France
>>> Jitsi
>>> emcho@jitsi.org
>>>
>>> PHONE: +33.1.77.62.43.30
>>> http://jitsi.org

>>>
>>> FAX: +33.1.77.62.47.31
>>>
>


#13

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either completely disabled
or it has the "display a messagebox" disabled
- I'm in Do Not Disturb Mode
- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and steals my focus.

This is on Linux x86 (XUbuntu 12.04), Jitsi v. 4146

Thanks,

Alex

···

On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> wrote:

Hi Vieri,

There was a small issue with my previous commit. The problem was that when the chat window is already visible and we receive a message while typing to someone, if we call:

chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be very annoying. So I've just added a check if we're in a new chat window or not (r9776).

I'm testing on MacOSX though and I don't experience the previously described problem here so could you please confirm that this still does the work the patch was about ?

Cheers,
Yana

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our contributors page.

I've made a slight modification though by adding the code directly to the ChatWindow.openChat() instead of ChatWindowManager. This allow us to take into account the "Bring chat window to front" property (configured in General settings) and the case where the user has opened the chat herself (for example by double clicking on the contact in the contact list). Everything related to chat window focus is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>>> wrote:

Can someone please confirm or dis-confirm this? It's

quite annoying to

end users to be unable to control the behaviour of the

client.

If there is no way to supress popups, this is a bug

that needs to be

addressed and I'll be happy to forward this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >>>> wrote:
<snip>

To my detriment I just noticed that this _does not_

work as expected,

at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming

Message" from the

options -> events menu, but it still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.
          67000
Strasbourg,
Project Lead
            France
Jitsi
emcho@jitsi.org

     PHONE: +33.1.77.62.43.30
http://jitsi.org

  FAX: +33.1.77.62.47.31


#14

Hey Alex,

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either completely disabled
or it has the "display a messagebox" disabled

Right, this only affects the baloons you see on the bottom right side
of your scree. They are not the ones bothering you are they?

- I'm in Do Not Disturb Mode

We haven't implemented any relationship between window behaviour and
presence status.

- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and steals my focus.

Did this work differently with builds prior to 4146? 4145 to be precise.

Can you please check if your "General" configuration tab has the
"Bring chat window to front" option unchecked?

Cheers,
Emil

···

On Thu, Aug 9, 2012 at 11:44 AM, <ix4svs@gmail.com> wrote:

This is on Linux x86 (XUbuntu 12.04), Jitsi v. 4146

Thanks,

Alex

On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> wrote:

Hi Vieri,

There was a small issue with my previous commit. The problem was that when the chat window is already visible and we receive a message while typing to someone, if we call:

chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be very annoying. So I've just added a check if we're in a new chat window or not (r9776).

I'm testing on MacOSX though and I don't experience the previously described problem here so could you please confirm that this still does the work the patch was about ?

Cheers,
Yana

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our contributors page.

I've made a slight modification though by adding the code directly to the ChatWindow.openChat() instead of ChatWindowManager. This allow us to take into account the "Bring chat window to front" property (configured in General settings) and the case where the user has opened the chat herself (for example by double clicking on the contact in the contact list). Everything related to chat window focus is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat window popup in front while the user is working (typing somewhere else) is annoying because it steals focus.
On a new incoming chat message (xmpp), it's desirable that a new chat window is created (as it's the case now) but it shouldn't necessarily take focus and popup up front. Maybe Jitsi could have a user-defined property for the new chat window display, eg. TAKE_FOCUS={true,false}. If we don't want the chat window to come up front, then create it but set it eg. minimized or something of the sort.

What I did is a quick hack in impl/gui/main/chat/ChatWindowManager.java and modified the following:
chatContainer.getFrame().setFocusableWindowState(false);
chatContainer.getFrame().setVisible(true);
chatContainer.getFrame().setFocusableWindowState(true);
in
public void openChat(final ChatPanel chatPanel, final boolean setSelected)

With this code change:

- users receive Windows task bar notifications for incoming messages (no keyboard focus stealing) which is useful so that they now they have new messages and from whom

- users won't have a new chat panel window appear on screen while they're typing in another application. So they won't get annoyed by it. The new chat window is created but won't take focus. Just click on the Jitsi icon in the Windows bar and you can open up the chat window.

- all the above is to avoid keyboard focus problems. There's another reason one should avoid having a new chat window appear all of a sudden on screen: privacy. Users want to be connected and chat but don't want the message contents to display on screen automatically in case there's confidential information (think of a busy corporate environment where lots of people move around computers). So with the above hack and by disabling the "balloon" message in Jitsi->Tools->Options->Events->Incoming message (only disable the balloon) then users will have almost-total privacy (no popup ChatPanel window and no text within the Windows notification bar). They will only be notified that someone wrote them a message and will then be able to click on the chat window in order to view the messages whenever they please. It's "almost-total privacy" because if the user has no other window/application covering the desktop area then the chat window WILL appear there and be
visible. However, that's usually not the case in a busy work/office scenario - there's always at least one other app window open and usually covers the whole screen. In any case, if this were of concern then we could also call:
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch needs to be posted on JIRA?

Alex, is this what you were looking for more or less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

Have you tried disabling the baloon itself rather than the
entire event?

As for the message window: there's no way to prevent that I
am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>>>> wrote:

Can someone please confirm or dis-confirm this? It's

quite annoying to

end users to be unable to control the behaviour of the

client.

If there is no way to supress popups, this is a bug

that needs to be

addressed and I'll be happy to forward this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >>>>> wrote:
<snip>

To my detriment I just noticed that this _does not_

work as expected,

at least on Windows 7 with build 4103.

I have completely disabled the event "Incoming

Message" from the

options -> events menu, but it still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.
          67000
Strasbourg,
Project Lead
            France
Jitsi
emcho@jitsi.org

     PHONE: +33.1.77.62.43.30
http://jitsi.org

  FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#15

Hi,

I admit I only tested Jitsi v. 4147 on Windows 7 32-bits and Windows XP.
Haven't tried Linux yet.

Vieri

···

--- On Thu, 8/9/12, ix4svs@gmail.com <ix4svs@gmail.com> wrote:

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either
completely disabled
or it has the "display a messagebox" disabled
- I'm in Do Not Disturb Mode
- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and
steals my focus.

This is on Linux x86 (XUbuntu 12.04), Jitsi v. 4146

Thanks,

Alex

On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> > wrote:
> Hi Vieri,
>
> There was a small issue with my previous commit. The
problem was that when the chat window is already visible and
we receive a message while typing to someone, if we call:
>
>>>>
chatContainer.getFrame().setFocusableWindowState(false);
>>>> chatContainer.getFrame().setVisible(true);
>>>>
chatContainer.getFrame().setFocusableWindowState(true);
>
> the focus was lost from the write area, which could be
very annoying. So I've just added a check if we're in a new
chat window or not (r9776).
>
> I'm testing on MacOSX though and I don't experience the
previously described problem here so could you please
confirm that this still does the work the patch was about ?
>
> Cheers,
> Yana
>
> On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:
>
>> Hi Vieri, all,
>>
>> Thanks for the patch!
>>
>> It's committed in revision 9774 and ack-ed on our
contributors page.
>>
>> I've made a slight modification though by adding
the code directly to the ChatWindow.openChat() instead of
ChatWindowManager. This allow us to take into account the
"Bring chat window to front" property (configured in General
settings) and the case where the user has opened the chat
herself (for example by double clicking on the contact in
the contact list). Everything related to chat window focus
is now in there. We also take care of the ICONIFIED state.
>>
>> Please let me know if this works for you.
>>
>> Cheers,
>> Yana
>>
>> On Jul 26, 2012, at 12:22 PM, Vieri wrote:
>>
>>> Hi,
>>>
>>> Actually Alex has a good point.
>>> In a corporate environment, having a chat
window popup in front while the user is working (typing
somewhere else) is annoying because it steals focus.
>>> On a new incoming chat message (xmpp), it's
desirable that a new chat window is created (as it's the
case now) but it shouldn't necessarily take focus and popup
up front. Maybe Jitsi could have a user-defined property for
the new chat window display, eg. TAKE_FOCUS={true,false}. If
we don't want the chat window to come up front, then create
it but set it eg. minimized or something of the sort.
>>>
>>> What I did is a quick hack in
impl/gui/main/chat/ChatWindowManager.java and modified the
following:
>>>
chatContainer.getFrame().setFocusableWindowState(false);
>>> chatContainer.getFrame().setVisible(true);
>>>
chatContainer.getFrame().setFocusableWindowState(true);
>>> in
>>> public void openChat(final ChatPanel chatPanel,
final boolean setSelected)
>>>
>>> With this code change:
>>>
>>> - users receive Windows task bar notifications
for incoming messages (no keyboard focus stealing) which is
useful so that they now they have new messages and from
whom
>>>
>>> - users won't have a new chat panel window
appear on screen while they're typing in another
application. So they won't get annoyed by it. The new chat
window is created but won't take focus. Just click on the
Jitsi icon in the Windows bar and you can open up the chat
window.
>>>
>>> - all the above is to avoid keyboard focus
problems. There's another reason one should avoid having a
new chat window appear all of a sudden on screen: privacy.
Users want to be connected and chat but don't want the
message contents to display on screen automatically in case
there's confidential information (think of a busy corporate
environment where lots of people move around computers). So
with the above hack and by disabling the "balloon" message
in Jitsi->Tools->Options->Events->Incoming
message (only disable the balloon) then users will have
almost-total privacy (no popup ChatPanel window and no text
within the Windows notification bar). They will only be
notified that someone wrote them a message and will then be
able to click on the chat window in order to view the
messages whenever they please. It's "almost-total privacy"
because if the user has no other window/application covering
the desktop area then the chat window WILL appear there and
be
>>> visible. However, that's usually not the case
in a busy work/office scenario - there's always at least one
other app window open and usually covers the whole screen.
In any case, if this were of concern then we could also
call:
>>>
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
>>> within
>>> openChat()
>>> and that would definitely be more private.
>>>
>>> The hack is simple so I don't think a patch
needs to be posted on JIRA?
>>>
>>> Alex, is this what you were looking for more or
less?
>>>
>>> Vieri
>>>
>>>
>>> --- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> > wrote:
>>>
>>>> Hey Alex,
>>>>
>>>> Have you tried disabling the baloon itself
rather than the
>>>> entire event?
>>>>
>>>> As for the message window: there's no way
to prevent that I
>>>> am afraid.
>>>> We show any message we get.
>>>>
>>>> Cheers,
>>>> Emil
>>>>
>>>> On 14.07.12 16:59, ix4svs@gmail.com > >>>> wrote:
>>>>> Can someone please confirm or
dis-confirm this? It's
>>>> quite annoying to
>>>>> end users to be unable to control the
behaviour of the
>>>> client.
>>>>>
>>>>> If there is no way to supress popups,
this is a bug
>>>> that needs to be
>>>>> addressed and I'll be happy to forward
this to the dev
>>>> list.
>>>>>
>>>>> Alex
>>>>>
>>>>> On 6 July 2012 15:12, <ix4svs@gmail.com> > >>>> wrote:
>>>>> <snip>
>>>>>> To my detriment I just noticed that
this _does not_
>>>> work as expected,
>>>>>> at least on Windows 7 with build
4103.
>>>>>>
>>>>>> I have completely disabled the
event "Incoming
>>>> Message" from the
>>>>>> options -> events menu, but it
still either pops
>>>> up a baloon or a full
>>>>>> Jitsi window on incoming messages.
>>>>>>
>>>>>> I confirmed with a friend and he
sees the same
>>>> behaviour. Am I missing
>>>>>> something or is this a bug?
>>>>>>
>>>>>> Alex
>>>>>
>>>>
>>>> --
>>>> Emil Ivov, Ph.D.
>>>>
67000
>>>> Strasbourg,
>>>> Project Lead
>>>>
France
>>>> Jitsi
>>>> emcho@jitsi.org
>>>>
>>>> PHONE:
+33.1.77.62.43.30
>>>> http://jitsi.org
>>>>
>>>> FAX: +33.1.77.62.47.31
>>>>
>>
>


#16

Hey Alex,

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either completely disabled
or it has the "display a messagebox" disabled

Right, this only affects the baloons you see on the bottom right side
of your scree. They are not the ones bothering you are they?

Not at all - I was referring to the fully-fledged chat window that
pops up in the middle of my screen. Thanks for pointing out these two
(notifications and chat window) are not related, I was not aware of
that.

- I'm in Do Not Disturb Mode

We haven't implemented any relationship between window behaviour and
presence status.

- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and steals my focus.

Did this work differently with builds prior to 4146? 4145 to be precise.

I believe not. I always run the latest nightly and always had this
behaviour. Nothing seems to have changed for me.

Can you please check if your "General" configuration tab has the
"Bring chat window to front" option unchecked?

Confirmed - this option is unchecked.

Just tested on Win7 and I see the same behaviour. It's not possible to
stop the chat window appearing and stealing focus when I receive an
IM. So for me, the issue remains.

Thanks

Alex

···

On 9 August 2012 11:07, Emil Ivov <emcho@jitsi.org> wrote:

On Thu, Aug 9, 2012 at 11:44 AM, <ix4svs@gmail.com> wrote:


#17

Well if this trick doesn't work on Linux, then we'd be grateful to have
one that does :slight_smile:

It's still nice it does the job for windows.

Mac has always been fine.

Its all a matter of window manager implementation choices.

Emil

···

On 10.08.12, 10:03, Vieri wrote:

Hi,

I admit I only tested Jitsi v. 4147 on Windows 7 32-bits and Windows XP.
Haven't tried Linux yet.

Vieri

--- On Thu, 8/9/12, ix4svs@gmail.com <ix4svs@gmail.com> wrote:

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either
completely disabled
or it has the "display a messagebox" disabled
- I'm in Do Not Disturb Mode
- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and
steals my focus.

This is on Linux x86 (XUbuntu 12.04), Jitsi v. 4146

Thanks,

Alex

On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> >> wrote:

Hi Vieri,

There was a small issue with my previous commit. The

problem was that when the chat window is already visible and
we receive a message while typing to someone, if we call:

chatContainer.getFrame().setFocusableWindowState(false);

chatContainer.getFrame().setVisible(true);

chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be

very annoying. So I've just added a check if we're in a new
chat window or not (r9776).

I'm testing on MacOSX though and I don't experience the

previously described problem here so could you please
confirm that this still does the work the patch was about ?

Cheers,
Yana

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our

contributors page.

I've made a slight modification though by adding

the code directly to the ChatWindow.openChat() instead of
ChatWindowManager. This allow us to take into account the
"Bring chat window to front" property (configured in General
settings) and the case where the user has opened the chat
herself (for example by double clicking on the contact in
the contact list). Everything related to chat window focus
is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat

window popup in front while the user is working (typing
somewhere else) is annoying because it steals focus.

On a new incoming chat message (xmpp), it's

desirable that a new chat window is created (as it's the
case now) but it shouldn't necessarily take focus and popup
up front. Maybe Jitsi could have a user-defined property for
the new chat window display, eg. TAKE_FOCUS={true,false}. If
we don't want the chat window to come up front, then create
it but set it eg. minimized or something of the sort.

What I did is a quick hack in

impl/gui/main/chat/ChatWindowManager.java and modified the
following:

chatContainer.getFrame().setFocusableWindowState(false);

chatContainer.getFrame().setVisible(true);

chatContainer.getFrame().setFocusableWindowState(true);

in
public void openChat(final ChatPanel chatPanel,

final boolean setSelected)

With this code change:

- users receive Windows task bar notifications

for incoming messages (no keyboard focus stealing) which is
useful so that they now they have new messages and from
whom

- users won't have a new chat panel window

appear on screen while they're typing in another
application. So they won't get annoyed by it. The new chat
window is created but won't take focus. Just click on the
Jitsi icon in the Windows bar and you can open up the chat
window.

- all the above is to avoid keyboard focus

problems. There's another reason one should avoid having a
new chat window appear all of a sudden on screen: privacy.
Users want to be connected and chat but don't want the
message contents to display on screen automatically in case
there's confidential information (think of a busy corporate
environment where lots of people move around computers). So
with the above hack and by disabling the "balloon" message
in Jitsi->Tools->Options->Events->Incoming
message (only disable the balloon) then users will have
almost-total privacy (no popup ChatPanel window and no text
within the Windows notification bar). They will only be
notified that someone wrote them a message and will then be
able to click on the chat window in order to view the
messages whenever they please. It's "almost-total privacy"
because if the user has no other window/application covering
the desktop area then the chat window WILL appear there and
be

visible. However, that's usually not the case

in a busy work/office scenario - there's always at least one
other app window open and usually covers the whole screen.
In any case, if this were of concern then we could also
call:

chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)

within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch

needs to be posted on JIRA?

Alex, is this what you were looking for more or

less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> >> wrote:

Hey Alex,

Have you tried disabling the baloon itself

rather than the

entire event?

As for the message window: there's no way

to prevent that I

am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>>>>> wrote:

Can someone please confirm or

dis-confirm this? It's

quite annoying to

end users to be unable to control the

behaviour of the

client.

If there is no way to supress popups,

this is a bug

that needs to be

addressed and I'll be happy to forward

this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >>>>>> wrote:
<snip>

To my detriment I just noticed that

this _does not_

work as expected,

at least on Windows 7 with build

4103.

I have completely disabled the

event "Incoming

Message" from the

options -> events menu, but it

still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he

sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.
       

   67000

Strasbourg,
Project Lead
         

   France

Jitsi
emcho@jitsi.org

      PHONE:

+33.1.77.62.43.30

http://jitsi.org

   FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#18

Hi Alex, Vieri,

Thanks both of you for the feedback!

I'll try to make some tests myself on Windows and Linux and will come back to you.

Cheers,
Yana

···

On Aug 9, 2012, at 1:48 PM, ix4svs@gmail.com wrote:

On 9 August 2012 11:07, Emil Ivov <emcho@jitsi.org> wrote:

Hey Alex,

On Thu, Aug 9, 2012 at 11:44 AM, <ix4svs@gmail.com> wrote:

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either completely disabled
or it has the "display a messagebox" disabled

Right, this only affects the baloons you see on the bottom right side
of your scree. They are not the ones bothering you are they?

Not at all - I was referring to the fully-fledged chat window that
pops up in the middle of my screen. Thanks for pointing out these two
(notifications and chat window) are not related, I was not aware of
that.

- I'm in Do Not Disturb Mode

We haven't implemented any relationship between window behaviour and
presence status.

- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and steals my focus.

Did this work differently with builds prior to 4146? 4145 to be precise.

I believe not. I always run the latest nightly and always had this
behaviour. Nothing seems to have changed for me.

Can you please check if your "General" configuration tab has the
"Bring chat window to front" option unchecked?

Confirmed - this option is unchecked.

Just tested on Win7 and I see the same behaviour. It's not possible to
stop the chat window appearing and stealing focus when I receive an
IM. So for me, the issue remains.

Thanks

Alex


#19

Some suggest that setFocusableWindowState doesn't work as expected with JFrame in Linux (or with certain Window Managers) but it should work with JWindow. ie. use JWindow instead of JFrame.
Anyway, my users are all Windows-based and I only have console-based Linux servers (no GUI) so I can't confirm what I'm saying or do any testing.

Vieri

···

--- On Fri, 8/10/12, Emil Ivov <emcho@jitsi.org> wrote:

Well if this trick doesn't work on
Linux, then we'd be grateful to have
one that does :slight_smile:

It's still nice it does the job for windows.

Mac has always been fine.

Its all a matter of window manager implementation choices.

Emil

On 10.08.12, 10:03, Vieri wrote:
> Hi,
>
> I admit I only tested Jitsi v. 4147 on Windows 7
32-bits and Windows XP.
> Haven't tried Linux yet.
>
> Vieri
>
> --- On Thu, 8/9/12, ix4svs@gmail.com > <ix4svs@gmail.com> > wrote:
>
>> Hi Yana
>>
>> Unfortunately I'm still seeing the previous
behaviour.
>>
>> - Options -> Events -> Incoming Message is
either
>> completely disabled
>> or it has the "display a messagebox" disabled
>> - I'm in Do Not Disturb Mode
>> - Jitsi window is minimised
>> - There are no active chat windows.
>>
>> Still, when someone writes to me, a chat window
pops up and
>> steals my focus.
>>
>> This is on Linux x86 (XUbuntu 12.04), Jitsi v.
4146
>>
>> Thanks,
>>
>> Alex
>>
>> On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> > >> wrote:
>>> Hi Vieri,
>>>
>>> There was a small issue with my previous
commit. The
>> problem was that when the chat window is already
visible and
>> we receive a message while typing to someone, if we
call:
>>>
>>>>>>
>>
chatContainer.getFrame().setFocusableWindowState(false);
>>>>>>
chatContainer.getFrame().setVisible(true);
>>>>>>
>>
chatContainer.getFrame().setFocusableWindowState(true);
>>>
>>> the focus was lost from the write area, which
could be
>> very annoying. So I've just added a check if we're
in a new
>> chat window or not (r9776).
>>>
>>> I'm testing on MacOSX though and I don't
experience the
>> previously described problem here so could you
please
>> confirm that this still does the work the patch was
about ?
>>>
>>> Cheers,
>>> Yana
>>>
>>> On Aug 7, 2012, at 7:23 PM, Yana Stamcheva > wrote:
>>>
>>>> Hi Vieri, all,
>>>>
>>>> Thanks for the patch!
>>>>
>>>> It's committed in revision 9774 and ack-ed
on our
>> contributors page.
>>>>
>>>> I've made a slight modification though by
adding
>> the code directly to the ChatWindow.openChat()
instead of
>> ChatWindowManager. This allow us to take into
account the
>> "Bring chat window to front" property (configured
in General
>> settings) and the case where the user has opened
the chat
>> herself (for example by double clicking on the
contact in
>> the contact list). Everything related to chat
window focus
>> is now in there. We also take care of the ICONIFIED
state.
>>>>
>>>> Please let me know if this works for you.
>>>>
>>>> Cheers,
>>>> Yana
>>>>
>>>> On Jul 26, 2012, at 12:22 PM, Vieri wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> Actually Alex has a good point.
>>>>> In a corporate environment, having a
chat
>> window popup in front while the user is working
(typing
>> somewhere else) is annoying because it steals
focus.
>>>>> On a new incoming chat message (xmpp),
it's
>> desirable that a new chat window is created (as
it's the
>> case now) but it shouldn't necessarily take focus
and popup
>> up front. Maybe Jitsi could have a user-defined
property for
>> the new chat window display, eg.
TAKE_FOCUS={true,false}. If
>> we don't want the chat window to come up front,
then create
>> it but set it eg. minimized or something of the
sort.
>>>>>
>>>>> What I did is a quick hack in
>> impl/gui/main/chat/ChatWindowManager.java and
modified the
>> following:
>>>>>
>>
chatContainer.getFrame().setFocusableWindowState(false);
>>>>>
chatContainer.getFrame().setVisible(true);
>>>>>
>>
chatContainer.getFrame().setFocusableWindowState(true);
>>>>> in
>>>>> public void openChat(final ChatPanel
chatPanel,
>> final boolean setSelected)
>>>>>
>>>>> With this code change:
>>>>>
>>>>> - users receive Windows task bar
notifications
>> for incoming messages (no keyboard focus stealing)
which is
>> useful so that they now they have new messages and
from
>> whom
>>>>>
>>>>> - users won't have a new chat panel
window
>> appear on screen while they're typing in another
>> application. So they won't get annoyed by it. The
new chat
>> window is created but won't take focus. Just click
on the
>> Jitsi icon in the Windows bar and you can open up
the chat
>> window.
>>>>>
>>>>> - all the above is to avoid keyboard
focus
>> problems. There's another reason one should avoid
having a
>> new chat window appear all of a sudden on screen:
privacy.
>> Users want to be connected and chat but don't want
the
>> message contents to display on screen automatically
in case
>> there's confidential information (think of a busy
corporate
>> environment where lots of people move around
computers). So
>> with the above hack and by disabling the "balloon"
message
>> in
Jitsi->Tools->Options->Events->Incoming
>> message (only disable the balloon) then users will
have
>> almost-total privacy (no popup ChatPanel window and
no text
>> within the Windows notification bar). They will
only be
>> notified that someone wrote them a message and will
then be
>> able to click on the chat window in order to view
the
>> messages whenever they please. It's "almost-total
privacy"
>> because if the user has no other window/application
covering
>> the desktop area then the chat window WILL appear
there and
>> be
>>>>> visible. However, that's usually not
the case
>> in a busy work/office scenario - there's always at
least one
>> other app window open and usually covers the whole
screen.
>> In any case, if this were of concern then we could
also
>> call:
>>>>>
>>
chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)
>>>>> within
>>>>> openChat()
>>>>> and that would definitely be more
private.
>>>>>
>>>>> The hack is simple so I don't think a
patch
>> needs to be posted on JIRA?
>>>>>
>>>>> Alex, is this what you were looking for
more or
>> less?
>>>>>
>>>>> Vieri
>>>>>
>>>>>
>>>>> --- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> > >> wrote:
>>>>>
>>>>>> Hey Alex,
>>>>>>
>>>>>> Have you tried disabling the baloon
itself
>> rather than the
>>>>>> entire event?
>>>>>>
>>>>>> As for the message window: there's
no way
>> to prevent that I
>>>>>> am afraid.
>>>>>> We show any message we get.
>>>>>>
>>>>>> Cheers,
>>>>>> Emil
>>>>>>
>>>>>> On 14.07.12 16:59, ix4svs@gmail.com > >>>>>> wrote:
>>>>>>> Can someone please confirm or
>> dis-confirm this? It's
>>>>>> quite annoying to
>>>>>>> end users to be unable to
control the
>> behaviour of the
>>>>>> client.
>>>>>>>
>>>>>>> If there is no way to supress
popups,
>> this is a bug
>>>>>> that needs to be
>>>>>>> addressed and I'll be happy to
forward
>> this to the dev
>>>>>> list.
>>>>>>>
>>>>>>> Alex
>>>>>>>
>>>>>>> On 6 July 2012 15:12, > <ix4svs@gmail.com> > >>>>>> wrote:
>>>>>>> <snip>
>>>>>>>> To my detriment I just
noticed that
>> this _does not_
>>>>>> work as expected,
>>>>>>>> at least on Windows 7 with
build
>> 4103.
>>>>>>>>
>>>>>>>> I have completely disabled
the
>> event "Incoming
>>>>>> Message" from the
>>>>>>>> options -> events menu,
but it
>> still either pops
>>>>>> up a baloon or a full
>>>>>>>> Jitsi window on incoming
messages.
>>>>>>>>
>>>>>>>> I confirmed with a friend
and he
>> sees the same
>>>>>> behaviour. Am I missing
>>>>>>>> something or is this a
bug?
>>>>>>>>
>>>>>>>> Alex
>>>>>>>
>>>>>>
>>>>>> --
>>>>>> Emil Ivov, Ph.D.
>>>>>>
>> 67000
>>>>>> Strasbourg,
>>>>>> Project Lead
>>>>>>
>> France
>>>>>> Jitsi
>>>>>> emcho@jitsi.org
>>>>>>
>>>>>>
PHONE:
>> +33.1.77.62.43.30
>>>>>> http://jitsi.org
>>>>>>
>>>>>>
FAX: +33.1.77.62.47.31
>>>>>>
>>>>
>>>
>>
>

--
Emil Ivov, Ph.D.
67000
Strasbourg,
Project Lead
France
Jitsi
emcho@jitsi.org

  PHONE: \+33\.1\.77\.62\.43\.30

http://jitsi.org

FAX: +33.1.77.62.47.31

.


#20

Please note that as far as I can tell it does not do the trick for
Windows or Linux.

I'm testing on Win 7 32-bit and 64-bit and am seeing the same
behaviour: A new incoming IM creates a chat window, which pops up on
the user's screen taking up a significant portion of it, and steals
focus.

Jitsi behaves properly when a chat window _already exists_: in that
case the focus is not stolen and the window is not brought to the
front.

But when there are no chat windows open and Jitsi is just running in
the background, anyone sending us an IM interrupts whatever we might
have been doing and takes over a significant part of our desktop.

Tested with build 4153

Cheers

Alex

···

On 10 August 2012 14:39, Emil Ivov <emcho@jitsi.org> wrote:

Well if this trick doesn't work on Linux, then we'd be grateful to have
one that does :slight_smile:

It's still nice it does the job for windows.

Mac has always been fine.

Its all a matter of window manager implementation choices.

Emil

On 10.08.12, 10:03, Vieri wrote:

Hi,

I admit I only tested Jitsi v. 4147 on Windows 7 32-bits and Windows XP.
Haven't tried Linux yet.

Vieri

--- On Thu, 8/9/12, ix4svs@gmail.com <ix4svs@gmail.com> wrote:

Hi Yana

Unfortunately I'm still seeing the previous behaviour.

- Options -> Events -> Incoming Message is either
completely disabled
or it has the "display a messagebox" disabled
- I'm in Do Not Disturb Mode
- Jitsi window is minimised
- There are no active chat windows.

Still, when someone writes to me, a chat window pops up and
steals my focus.

This is on Linux x86 (XUbuntu 12.04), Jitsi v. 4146

Thanks,

Alex

On 8 August 2012 15:37, Yana Stamcheva <yana@jitsi.org> >>> wrote:

Hi Vieri,

There was a small issue with my previous commit. The

problem was that when the chat window is already visible and
we receive a message while typing to someone, if we call:

chatContainer.getFrame().setFocusableWindowState(false);

chatContainer.getFrame().setVisible(true);

chatContainer.getFrame().setFocusableWindowState(true);

the focus was lost from the write area, which could be

very annoying. So I've just added a check if we're in a new
chat window or not (r9776).

I'm testing on MacOSX though and I don't experience the

previously described problem here so could you please
confirm that this still does the work the patch was about ?

Cheers,
Yana

On Aug 7, 2012, at 7:23 PM, Yana Stamcheva wrote:

Hi Vieri, all,

Thanks for the patch!

It's committed in revision 9774 and ack-ed on our

contributors page.

I've made a slight modification though by adding

the code directly to the ChatWindow.openChat() instead of
ChatWindowManager. This allow us to take into account the
"Bring chat window to front" property (configured in General
settings) and the case where the user has opened the chat
herself (for example by double clicking on the contact in
the contact list). Everything related to chat window focus
is now in there. We also take care of the ICONIFIED state.

Please let me know if this works for you.

Cheers,
Yana

On Jul 26, 2012, at 12:22 PM, Vieri wrote:

Hi,

Actually Alex has a good point.
In a corporate environment, having a chat

window popup in front while the user is working (typing
somewhere else) is annoying because it steals focus.

On a new incoming chat message (xmpp), it's

desirable that a new chat window is created (as it's the
case now) but it shouldn't necessarily take focus and popup
up front. Maybe Jitsi could have a user-defined property for
the new chat window display, eg. TAKE_FOCUS={true,false}. If
we don't want the chat window to come up front, then create
it but set it eg. minimized or something of the sort.

What I did is a quick hack in

impl/gui/main/chat/ChatWindowManager.java and modified the
following:

chatContainer.getFrame().setFocusableWindowState(false);

chatContainer.getFrame().setVisible(true);

chatContainer.getFrame().setFocusableWindowState(true);

in
public void openChat(final ChatPanel chatPanel,

final boolean setSelected)

With this code change:

- users receive Windows task bar notifications

for incoming messages (no keyboard focus stealing) which is
useful so that they now they have new messages and from
whom

- users won't have a new chat panel window

appear on screen while they're typing in another
application. So they won't get annoyed by it. The new chat
window is created but won't take focus. Just click on the
Jitsi icon in the Windows bar and you can open up the chat
window.

- all the above is to avoid keyboard focus

problems. There's another reason one should avoid having a
new chat window appear all of a sudden on screen: privacy.
Users want to be connected and chat but don't want the
message contents to display on screen automatically in case
there's confidential information (think of a busy corporate
environment where lots of people move around computers). So
with the above hack and by disabling the "balloon" message
in Jitsi->Tools->Options->Events->Incoming
message (only disable the balloon) then users will have
almost-total privacy (no popup ChatPanel window and no text
within the Windows notification bar). They will only be
notified that someone wrote them a message and will then be
able to click on the chat window in order to view the
messages whenever they please. It's "almost-total privacy"
because if the user has no other window/application covering
the desktop area then the chat window WILL appear there and
be

visible. However, that's usually not the case

in a busy work/office scenario - there's always at least one
other app window open and usually covers the whole screen.
In any case, if this were of concern then we could also
call:

chatContainer.getFrame().setExtendedState(JFrame.ICONIFIED)

within
openChat()
and that would definitely be more private.

The hack is simple so I don't think a patch

needs to be posted on JIRA?

Alex, is this what you were looking for more or

less?

Vieri

--- On Sat, 7/14/12, Emil Ivov <emcho@jitsi.org> >>> wrote:

Hey Alex,

Have you tried disabling the baloon itself

rather than the

entire event?

As for the message window: there's no way

to prevent that I

am afraid.
We show any message we get.

Cheers,
Emil

On 14.07.12 16:59, ix4svs@gmail.com >>>>>>> wrote:

Can someone please confirm or

dis-confirm this? It's

quite annoying to

end users to be unable to control the

behaviour of the

client.

If there is no way to supress popups,

this is a bug

that needs to be

addressed and I'll be happy to forward

this to the dev

list.

Alex

On 6 July 2012 15:12, <ix4svs@gmail.com> >>>>>>> wrote:
<snip>

To my detriment I just noticed that

this _does not_

work as expected,

at least on Windows 7 with build

4103.

I have completely disabled the

event "Incoming

Message" from the

options -> events menu, but it

still either pops

up a baloon or a full

Jitsi window on incoming messages.

I confirmed with a friend and he

sees the same

behaviour. Am I missing

something or is this a bug?

Alex

--
Emil Ivov, Ph.D.

   67000

Strasbourg,
Project Lead

   France

Jitsi
emcho@jitsi.org

      PHONE:

+33.1.77.62.43.30

http://jitsi.org

   FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

.