[jitsi-users] Is Jitsi Meet simulcast working


#1

Hi all,

When i enable simulcast (or with recent jitsi-meet not disable it),
I only see the small resolution video (320x180), never the full one
If i disable simulcast everything works (but it uses more bandwidth)

Is it know bug (i see that meet.jit.si disable simulcast)?

Do i need some special config to make it work? (i already have
org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)

What can i provide to help?

I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...
(compiled my self)

Regards
Etienne


#2

Hi Etienne,

You normally don't need any special configuration in
sip-communicator.properties file, it is automatically enabled from
signaling.

Can you try to increase the resolution in config.js in the client to '720'
and see if it helps? Also, make sure you have the latest version of the
bridge.

You're right that simulcast is disabled in production because want to have
adaptive simulcast to enable it. https://beta.meet.jit.si/ has simulcast
enabled tho, so you can compare your config.js with that deployment if you
want.

Hope this helps.

Best,
George

···

On Mon, Feb 22, 2016 at 7:56 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:

Hi all,

When i enable simulcast (or with recent jitsi-meet not disable it),
I only see the small resolution video (320x180), never the full one
If i disable simulcast everything works (but it uses more bandwidth)

Is it know bug (i see that meet.jit.si disable simulcast)?

Do i need some special config to make it work? (i already have

org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)

What can i provide to help?

I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...
(compiled my self)

Regards
Etienne

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi

Hi Etienne,

You normally don't need any special configuration in

sip-communicator.properties file, it is automatically enabled from
signaling.

Can you try to increase the resolution in config.js in the client to

'720' and see if it helps? Also, make sure you have the latest version of
the bridge.

Always running latest version + patches, i will have to try without them.
Already tried multiple resolution but no luck.

You're right that simulcast is disabled in production because want to

have adaptive simulcast to enable it. https://beta.meet.jit.si/ has
simulcast enabled tho, so you can compare your config.js with that
deployment if you want.

Would it be possible for 'beta' to listen on 443 port, i would like to
confirm that my clients are working but i'm behind over restrictive firewall

Hope this helps.

Thanks,
Etienne

Best,
George

Hi all,

When i enable simulcast (or with recent jitsi-meet not disable it),
I only see the small resolution video (320x180), never the full one
If i disable simulcast everything works (but it uses more bandwidth)

Is it know bug (i see that meet.jit.si disable simulcast)?

Do i need some special config to make it work? (i already have

org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)

What can i provide to help?

I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...

(compiled my self)

···

Le 22 févr. 2016 4:48 PM, "George Politis" <gp@jitsi.org> a écrit :

On Mon, Feb 22, 2016 at 7:56 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:

Regards
Etienne

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi Etienne,

It's possible that Chrome doesn't ramp up enough to stream HD when the link
is over TCP, probably because you have 2 congestion control algorithms
running together GCC and TCP congestion control.

Could you please start a conference, open the "about:webrtc-internals" page
and expand the "Stats graphs for bweforvideo", let it run for a while, take
a screenshot and share it with us?

Thank you.

Best,
George

···

On Mon, Feb 22, 2016 at 12:01 PM, Etienne Champetier < champetier.etienne@gmail.com> wrote:

Hi

Le 22 févr. 2016 4:48 PM, "George Politis" <gp@jitsi.org> a écrit :
>
> Hi Etienne,
>
> You normally don't need any special configuration in
sip-communicator.properties file, it is automatically enabled from
signaling.
>
> Can you try to increase the resolution in config.js in the client to
'720' and see if it helps? Also, make sure you have the latest version of
the bridge.

Always running latest version + patches, i will have to try without them.
Already tried multiple resolution but no luck.

>
> You're right that simulcast is disabled in production because want to
have adaptive simulcast to enable it. https://beta.meet.jit.si/ has
simulcast enabled tho, so you can compare your config.js with that
deployment if you want.

Would it be possible for 'beta' to listen on 443 port, i would like to
confirm that my clients are working but i'm behind over restrictive firewall

>
> Hope this helps.

Thanks,
Etienne

>
> Best,
> George
>
> On Mon, Feb 22, 2016 at 7:56 AM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> When i enable simulcast (or with recent jitsi-meet not disable it),
>> I only see the small resolution video (320x180), never the full one
>> If i disable simulcast everything works (but it uses more bandwidth)
>>
>> Is it know bug (i see that meet.jit.si disable simulcast)?
>>
>> Do i need some special config to make it work? (i already have
>>
org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)
>>
>> What can i provide to help?
>>
>> I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...
(compiled my self)
>>
>> Regards
>> Etienne
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Etienne,

It's possible that Chrome doesn't ramp up enough to stream HD when the
link is over TCP, probably because you have 2 congestion control algorithms
running together GCC and TCP congestion control.

Could you please start a conference, open the "about:webrtc-internals"
page and expand the "Stats graphs for bweforvideo", let it run for a while,
take a screenshot and share it with us?

I just found out :slight_smile:
i was settings "openSctp" to false, because my first test server was centos
6, with glibc 2.12, and libjnsctp.so "require" glibc 2.14
maybe we should rename openSctp in disableSctp and remove it from default
config, as it's a bad idea to disable it

I also tried to run "master" jitsi-video bridge but it fails (fedora 23):
mvn clean
rm -rf ~/.m2/
mvn compile exec:java -Djava.library.path="./lib/native/linux-64"
-Dexec.args="--domain=jitsi.fiducial.net --secret=123456 --subdomain=jvb
--host=192.168.122.72 --port=5275"

it starts but fails at the first colibri request with
[WARNING]
java.lang.NoClassDefFoundError:
net/java/sip/communicator/impl/protocol/jabber/extensions/colibri/ColibriConferenceIQ$Content
    at
net.java.sip.communicator.impl.protocol.jabber.extensions.colibri.ColibriIQProvider.parseIQ(ColibriIQProvider.java:590)
    at org.jitsi.xmpp.util.IQUtils.convert(IQUtils.java:171)
    at
org.jitsi.videobridge.xmpp.ComponentImpl.handleIQ(ComponentImpl.java:266)
    at
org.jitsi.videobridge.xmpp.ComponentImpl.handleIQGet(ComponentImpl.java:366)
    at
org.xmpp.component.AbstractComponent.processIQRequest(AbstractComponent.java:511)
    at
org.xmpp.component.AbstractComponent.processIQ(AbstractComponent.java:289)
    at
org.xmpp.component.AbstractComponent.processQueuedPacket(AbstractComponent.java:239)
    at
org.xmpp.component.AbstractComponent.access$100(AbstractComponent.java:81)
    at
org.xmpp.component.AbstractComponent$PacketProcessor.run(AbstractComponent.java:1051)
    at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException:
net.java.sip.communicator.impl.protocol.jabber.extensions.colibri.ColibriConferenceIQ$Content
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 12 more

Any idea for this one?

···

2016-02-22 19:09 GMT+01:00 George Politis <gp@jitsi.org>:

Thank you.

Best,
George

On Mon, Feb 22, 2016 at 12:01 PM, Etienne Champetier < > champetier.etienne@gmail.com> wrote:

Hi

Le 22 févr. 2016 4:48 PM, "George Politis" <gp@jitsi.org> a écrit :
>
> Hi Etienne,
>
> You normally don't need any special configuration in
sip-communicator.properties file, it is automatically enabled from
signaling.
>
> Can you try to increase the resolution in config.js in the client to
'720' and see if it helps? Also, make sure you have the latest version of
the bridge.

Always running latest version + patches, i will have to try without them.
Already tried multiple resolution but no luck.

>
> You're right that simulcast is disabled in production because want to
have adaptive simulcast to enable it. https://beta.meet.jit.si/ has
simulcast enabled tho, so you can compare your config.js with that
deployment if you want.

Would it be possible for 'beta' to listen on 443 port, i would like to
confirm that my clients are working but i'm behind over restrictive firewall

>
> Hope this helps.

Thanks,
Etienne

>
> Best,
> George
>
> On Mon, Feb 22, 2016 at 7:56 AM, Etienne Champetier < >> champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> When i enable simulcast (or with recent jitsi-meet not disable it),
>> I only see the small resolution video (320x180), never the full one
>> If i disable simulcast everything works (but it uses more bandwidth)
>>
>> Is it know bug (i see that meet.jit.si disable simulcast)?
>>
>> Do i need some special config to make it work? (i already have
>>
org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)
>>
>> What can i provide to help?
>>
>> I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...
(compiled my self)
>>
>> Regards
>> Etienne
>> <http://lists.jitsi.org/mailman/listinfo/users>


#6

Hi Etienne,

That must have been tricky to find :slight_smile: Also keep in mind that occasionally
(rarely) SCTP data channel establishment fails. It looks like something is
wrong with the native code but we don't know exactly what.

About the new error, I have no idea why this would happen. I just checked
out master and it runs fine here. Do you have more complete logs to share?

Best,
George

···

On Tue, Feb 23, 2016 at 6:59 AM, Etienne Champetier < champetier.etienne@gmail.com> wrote:

2016-02-22 19:09 GMT+01:00 George Politis <gp@jitsi.org>:

Hi Etienne,

It's possible that Chrome doesn't ramp up enough to stream HD when the
link is over TCP, probably because you have 2 congestion control algorithms
running together GCC and TCP congestion control.

Could you please start a conference, open the "about:webrtc-internals"
page and expand the "Stats graphs for bweforvideo", let it run for a while,
take a screenshot and share it with us?

I just found out :slight_smile:
i was settings "openSctp" to false, because my first test server was
centos 6, with glibc 2.12, and libjnsctp.so "require" glibc 2.14
maybe we should rename openSctp in disableSctp and remove it from default
config, as it's a bad idea to disable it

I also tried to run "master" jitsi-video bridge but it fails (fedora 23):
mvn clean
rm -rf ~/.m2/
mvn compile exec:java -Djava.library.path="./lib/native/linux-64"
-Dexec.args="--domain=jitsi.fiducial.net --secret=123456 --subdomain=jvb
--host=192.168.122.72 --port=5275"

it starts but fails at the first colibri request with
[WARNING]
java.lang.NoClassDefFoundError:
net/java/sip/communicator/impl/protocol/jabber/extensions/colibri/ColibriConferenceIQ$Content
    at
net.java.sip.communicator.impl.protocol.jabber.extensions.colibri.ColibriIQProvider.parseIQ(ColibriIQProvider.java:590)
    at org.jitsi.xmpp.util.IQUtils.convert(IQUtils.java:171)
    at
org.jitsi.videobridge.xmpp.ComponentImpl.handleIQ(ComponentImpl.java:266)
    at
org.jitsi.videobridge.xmpp.ComponentImpl.handleIQGet(ComponentImpl.java:366)
    at
org.xmpp.component.AbstractComponent.processIQRequest(AbstractComponent.java:511)
    at
org.xmpp.component.AbstractComponent.processIQ(AbstractComponent.java:289)
    at
org.xmpp.component.AbstractComponent.processQueuedPacket(AbstractComponent.java:239)
    at
org.xmpp.component.AbstractComponent.access$100(AbstractComponent.java:81)
    at
org.xmpp.component.AbstractComponent$PacketProcessor.run(AbstractComponent.java:1051)
    at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException:
net.java.sip.communicator.impl.protocol.jabber.extensions.colibri.ColibriConferenceIQ$Content
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 12 more

Any idea for this one?

Thank you.

Best,
George

On Mon, Feb 22, 2016 at 12:01 PM, Etienne Champetier < >> champetier.etienne@gmail.com> wrote:

Hi

Le 22 févr. 2016 4:48 PM, "George Politis" <gp@jitsi.org> a écrit :
>
> Hi Etienne,
>
> You normally don't need any special configuration in
sip-communicator.properties file, it is automatically enabled from
signaling.
>
> Can you try to increase the resolution in config.js in the client to
'720' and see if it helps? Also, make sure you have the latest version of
the bridge.

Always running latest version + patches, i will have to try without
them. Already tried multiple resolution but no luck.

>
> You're right that simulcast is disabled in production because want to
have adaptive simulcast to enable it. https://beta.meet.jit.si/ has
simulcast enabled tho, so you can compare your config.js with that
deployment if you want.

Would it be possible for 'beta' to listen on 443 port, i would like to
confirm that my clients are working but i'm behind over restrictive firewall

>
> Hope this helps.

Thanks,
Etienne

>
> Best,
> George
>
> On Mon, Feb 22, 2016 at 7:56 AM, Etienne Champetier < >>> champetier.etienne@gmail.com> wrote:
>>
>> Hi all,
>>
>> When i enable simulcast (or with recent jitsi-meet not disable it),
>> I only see the small resolution video (320x180), never the full one
>> If i disable simulcast everything works (but it uses more bandwidth)
>>
>> Is it know bug (i see that meet.jit.si disable simulcast)?
>>
>> Do i need some special config to make it work? (i already have
>>
org.jitsi.videobridge.rtcp.strategy=org.jitsi.impl.neomedia.rtcp.termination.strategies.BasicRTCPTerminationStrategy)
>>
>> What can i provide to help?
>>
>> I'm using latest chrome (48) with latest jitsi-meet/jvb/jicofo/...
(compiled my self)
>>
>> Regards
>> Etienne
>> <http://lists.jitsi.org/mailman/listinfo/users>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users