[jitsi-users] ICE connected with no Audio with org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn() Will not translate RTP packet.


#1

Thanks for the reply. I’ll update and check if it happens again.

···

On 18-Feb-2016, at 4:30 PM, users-request@jitsi.org wrote:

Send users mailing list submissions to
  users@jitsi.org

To subscribe or unsubscribe via the World Wide Web, visit
  http://lists.jitsi.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
  users-request@jitsi.org

You can reach the person managing the list at
  users-owner@jitsi.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."

Today's Topics:

  1. Re: ICE connected with no Audio with
     org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn()
     Will not translate RTP packet. (Boris Grozev)
  2. screen sharing dosn't work on virtual machine environment
     (Li Zhijian)
  3. Re: screen sharing dosn't work on virtual machine environment
     (Li Zhijian)

----------------------------------------------------------------------

Message: 1
Date: Wed, 17 Feb 2016 09:54:53 -0600
From: Boris Grozev <boris@jitsi.org>
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] ICE connected with no Audio with
  org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn()
  Will not translate RTP packet.
Message-ID: <56C497CD.1040602@jitsi.org>
Content-Type: text/plain; charset=utf-8; format=flowed

On 17/02/16 07:50, Somil Bansal wrote:

Hi,
I am using standalone JVB without jicofo and jitsi-meet. Sometimes the ICE connects but no packets are received on the browser’s end. Whenever this happens “org.jitsi.impl.neomedia.rtp.translator.OutputDataStreamImpl.warn() Will not translate RTP packet.” appears in the log continuously. Also in my recording metadata.json, for that particular call the endpointId does not get recorded and for all further calls in the same conference the start time in metadata file is recorded very inaccurately. Please find attached the logs for the situation. The first call works fine in the logs but the second one has problems -

I am using video bridge tag 627.

We fixed an issue with exactly the same symptoms recently (after 627).

Regards,
Boris

------------------------------

Message: 2
Date: Thu, 18 Feb 2016 13:42:05 +0800
From: Li Zhijian <lizhijian@cn.fujitsu.com>
To: <users@jitsi.org>
Subject: [jitsi-users] screen sharing dosn't work on virtual machine
  environment
Message-ID: <56C559AD.6030904@cn.fujitsu.com>
Content-Type: text/plain; charset="utf-8"; format=flowed

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
      Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated

--
Best regards.
Li Zhijian

------------------------------

Message: 3
Date: Thu, 18 Feb 2016 14:13:42 +0800
From: Li Zhijian <lizhijian@cn.fujitsu.com>
To: <users@jitsi.org>, <upsv106@gmail.com>
Subject: Re: [jitsi-users] screen sharing dosn't work on virtual
  machine environment
Message-ID: <56C56116.80209@cn.fujitsu.com>
Content-Type: text/plain; charset="utf-8"; format=flowed

Add Toru HIROSE

Hi Toru HIROSE

Have you found the solution of this issue ?

Best regards.
Li Zhijian

On 02/18/2016 01:42 PM, Li Zhijian wrote:

hi, guy

Recently, I found jitsi's scree sharing didn't work on virtual machine.
I google it and try to find the resolution but i can't find the anwser.

the only tip is that
http://lists.jitsi.org/pipermail/users/2014-June/007333.html
==================================mail detail BEGIN==================================
Hi

I am having trouble testing jitsi's screen share over VM(VMware/Hyper-V)
guest OS
environments and like to know if this is an issue or limitation. My testing
environment and results
are as follows.

----------------------------------------
[Environment]

- Server side: openfire + jitsi video-bridge plugin (both latest release)
- Client side : Windows7Pro SP1 + jitsi (latest release)
- Network: same IP address segment (no firewalls)

Using Same Client OSs + jitsi client, I've tested screen sharing on
following pattern
(DesktopPC means normal PC(no virtual machine))

1) Desktop PC1 <-> Desktop PC2
2) Desktop PC1 <-> VM guest2(Vmware/Hyper-V)
3) VM guest1 <-> VM guest2

[Results]

1) screen sharing OK on both sides.
2) VM guest2 -> Desktop PC1 screen sharing is OK
      Desktop PC1 -> VM guest2 sceen sharing is NG ( black screen)
3) screen sharing NG on both sides (black screen).

#tested over couple VMware/Hyper-V version, but results are the same.

-------------------------------------------

On VM guest environment, it seems

- encoding it's own screen and sending capability works OK
- receiving and decoding capabilty have issues (or limitation)

I suspect some DirectX(DirectShow/Direct3D) limitation on VMs...

Any clues, suggestion, workaround is appreciated

Best Regards,
Toru HIROSE
==================================mail END==================================

the same issue post 2 years agao, but there is no any reply.

I believe i have encountered the same problem, and further more
I tried any other popular virual environment including KVM/XEN(hvm and pv) with ubuntu guest or WIN7 guest,
it has the same problem.

So, Is there something wrong in jitsi?

Any clues, suggestion, workaround is appreciated

------------------------------

Subject: Digest Footer

_______________________________________________
users mailing list
users@jitsi.org
http://lists.jitsi.org/mailman/listinfo/users

------------------------------

End of users Digest, Vol 35, Issue 24
*************************************