[jitsi-users] How to force an alternate DNS resolver? Jitsi fails resolving


#1

Is there a Jitsi command-line parmeter, (or Jitsi "property") which dictates to Jitsi which name server to use?

Is this what Bauersachs hints to, in this article:

http://www.internetsociety.org/deploy360/blog/2012/04/jitsi-is-the-first-voip-softphone-to-support-dnssec/,
Mr. Bauersachs, one of Jitsi's developers, mentions an option to override the OS default resolver, for running Jitsi:

···

The option to override the OS’s default resolver is there because during development,

   > the only servers supporting all relevant record types were from DNS-OARC and Verisign.

The file: /etc/resolv.conf links to: /etc/resolvconf/run/resolv.conf

The directory: /etc/resolvconf/run/ links to the directory: /run/resolvconf

Therefore the file: /run/resolvconf/resolv.conf, which I have modified (as mentioned in the OP), is the end entity, pointed to by /etc/resolv.conf

So the question remains; why does Jitsi fail in dns srv resolution, while the dig command succeeds under the same conditions. And most importantly: how to fix this? (since it prevents Jitsi from running)?

On Thursday 04 February 2016 at 00:18:51, Hsu Tsai wrote:

Thank you, Marious. But sorry I wasn't clear enough: I have erased the
previous name server address, and left only

the new one. Here is the entire /run/resolvconf/resolv.conf file:

> # Dynamic resolv.conf(5) file for glibc resolver(3) generated by
> resolvconf(8)
> # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
> nameserver 127.0.0.2

and still, dig works fine (uses the 127.0.0.2 name server address, and
succeeds in resolving), but Jitsi fails.

Do you also have a file /etc/resolv.conf ?

If yes, do the contents differ from the above "nameserver 127.0.0.2"?

Antony.

Please reply to the list; please *don't* CC me.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#2

Usually Jitsi would obtain the DNS server ip from /etc/resolv.conf. Have you checked the logs? Jitsi writes out which nameservers are being queried.
The manual configuration is in Tools/Options/Advanced/DNS

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

On 04.02.2016, at 13:57, Hsu Tsai <hsutsai@yandex.com> wrote:

Is there a Jitsi command-line parmeter, (or Jitsi "property") which dictates to Jitsi which name server to use?

Is this what Bauersachs hints to, in this article:

http://www.internetsociety.org/deploy360/blog/2012/04/jitsi-is-the-first-voip-softphone-to-support-dnssec/,
Mr. Bauersachs, one of Jitsi's developers, mentions an option to override the OS default resolver, for running Jitsi:
  > The option to override the OS’s default resolver is there because during development,
  > the only servers supporting all relevant record types were from DNS-OARC and Verisign.

The file: /etc/resolv.conf links to: /etc/resolvconf/run/resolv.conf

The directory: /etc/resolvconf/run/ links to the directory: /run/resolvconf

Therefore the file: /run/resolvconf/resolv.conf, which I have modified (as mentioned in the OP), is the end entity, pointed to by /etc/resolv.conf

So the question remains; why does Jitsi fail in dns srv resolution, while the dig command succeeds under the same conditions. And most importantly: how to fix this? (since it prevents Jitsi from running)?

On Thursday 04 February 2016 at 00:18:51, Hsu Tsai wrote:

Thank you, Marious. But sorry I wasn't clear enough: I have erased the
previous name server address, and left only

the new one. Here is the entire /run/resolvconf/resolv.conf file:

> # Dynamic resolv.conf(5) file for glibc resolver(3) generated by
> resolvconf(8)
> # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
> nameserver 127.0.0.2

and still, dig works fine (uses the 127.0.0.2 name server address, and
succeeds in resolving), but Jitsi fails.

Do you also have a file /etc/resolv.conf ?

If yes, do the contents differ from the above "nameserver 127.0.0.2"?

Antony.

Please reply to the list; please *don't* CC me.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users