[jitsi-users] How to force an alternate DNS resolver? Jitsi fails resolving


#1

I am using jitsi_2.8.5426-1_i386 on a version of Debian 7. The system, (without tweaking) can resolve only part of DNS queries.

This blocks Jitsi from resolving "contacts" addresses, preventing communication (even login) - since Jitsi requires SRV dns record resolution.

Here are Jitsi error messages on attempted login:

   > 12:22:54.521 SEVERE: [55]
   > impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().901
   > No SRV addresses found for _xmpp-client._tcp.google.com
   > 12:22:54.524 SEVERE: [55]
   > impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin().738
   > No server addresses found

And, indeed, the dig command fails: ("ANSWER: 0" means failure):
   > ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> _xmpp-client._tcp.google.com srv
   > ;; global options: +cmd
   > ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39323
   > ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
   > ;; QUESTION SECTION:
   > ;_xmpp-client._tcp.google.com. IN SRV ;; Query time: 0 msec
   > ;; SERVER: 127.0.0.1#53(127.0.0.1)
   > ;; WHEN: Sun Jan 21 12:32:17 2016 ;; MSG SIZE rcvd: 46

Now, in the system I'm running there is an alternate, "full fledged" resolver listening on
127.0.0.2; and indeed, when I set, in /run/resolvconf/resolv.conf: "nameserver 127.0.0.2",
then the dig command works:

   > dig _xmpp-client._tcp.google.com srv
   > ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> _xmpp-client._tcp.google.com srv
   > ;; global options: +cmd
   > ;; Got answer:
   > ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14033
   > ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0
   > ;; QUESTION SECTION: ;_xmpp-client._tcp.google.com. IN SRV
   > ;; ANSWER SECTION:
   > ;_xmpp-client._tcp.google.com. 900 IN SRV 20 0 5222 alt1.xmpp.l.google.com.
   > ... etc ...
   > ;; Query time: 232 msec
   > ;; SERVER: 127.0.0.2#53(127.0.0.2)
   > ;; WHEN: Sun Jan 21 12:44:22 2016 ;; MSG SIZE rcvd: 251

Note that "dig" uses the right resolver pointed to in /run/resolvconf/resolv.conf

But, when running Jitsi and trying to log in, Jitsi still fails with:
   > 12:35:35.598 SEVERE: [51]
   > impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().901
   > No SRV addresses found for _xmpp-client._tcp.google.com
   > 12:35:35.601 SEVERE: [51]
   > impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin().738
   > No server addresses found

So, seemingly Jitsi does not use /run/resolvconf/resolv.conf for determining which dns resolver to use?

Note that in this article:
http://www.internetsociety.org/deploy360/blog/2012/04/jitsi-is-the-first-voip-softphone-to-support-dnssec/,
Mr. Bauersachs, one of Jitsi's developers, mentions an option to override the OS default
resolver, for running Jitsi:
   > The option to override the OS’s default resolver is there because during development,
   > the only servers supporting all relevant record types were from DNS-OARC and Verisign.

Can anyone help in explaining how to do this?

Many thanks in advance - Hsu


#2

echo "nameserver 127.0.0.2" >>/etc/resolver

if you move it up to be the TOP entry , it will be asked first. use a
texteditor like vi or nano for it.

Marius

···

Am 02.02.2016 um 08:37 schrieb Hsu Tsai:

I am using jitsi_2.8.5426-1_i386 on a version of Debian 7. The system, (without tweaking) can resolve only part of DNS queries.