[jitsi-users] How to Disable Jingle (Audio/Video)


#1

We use the jitsi-defaults.properties file to "provision" clients. However, I cannot find out a way to setup default for new accounts to disable jingle (gray out audio/video calls and screen sharing).

The checkbox in the GUI is "Disable Jingle (audio and video calls with XMPP)". Which will create line in sip-communicator.properties as
net.java.sip.communicator.impl.protocol.jabber.acc1389209943697.CALLING_DISABLED=false

But since it is account specific I cannot add this to the jitis-defaults.properties. I would think the following would work but it does not
net.java.sip.communicator.service.protocol.jabber.IS_CALLING_DISABLED_FOR_ACCOUNT=true

Anyone have any advice?

Aaron Dixon
IT Specialist
aaron.dixon@ssdcservices.com

SSDC Services
28125 Cabot Drive, Suite 201
Novi, MI 48377
O: (248) 277-9304
C: (248) 935-7353
F: (248) 344-1623
www.ssdcservices.com<http://www.ssdcservices.com/>


#2

We use the jitsi-defaults.properties file to "provision" clients. However,

I

cannot find out a way to setup default for new accounts to disable jingle
(gray out audio/video calls and screen sharing).

The checkbox in the GUI is "Disable Jingle (audio and video calls with
XMPP)". Which will create line in sip-communicator.properties as

net.java.sip.communicator.impl.protocol.jabber.acc1389209943697.CALLING_D
ISAB LED=false

But since it is account specific I cannot add this to the jitis-
defaults.properties. I would think the following would work but it does

not

net.java.sip.communicator.service.protocol.jabber.IS_CALLING_DISABLED_FOR
_ACC OUNT=true

Anyone have any advice?

net.java.sip.communicator.impl.protocol.jabber.CALLING_DISABLED=true
should do the trick

Aaron Dixon

Ingo


#3

Yes, that did it. Thank you Ingo.

Is there any way to mute Inbound Message via the default config? I have entered in the following lines, but this only works if the sip-communicator.properties is deleted before Jitsi runs (due the account number 138869...)

net.java.sip.communicator.impl.notifications.eventType1388693492537=IncomingMessage
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553=SoundAction
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.default=false
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.enabled=true
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.isSoundNotificationEnabled=false
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.isSoundPCSpeakerEnabled=false
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.isSoundPlaybackEnabled=false
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.loopInterval=-1
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.soundFileDescriptor=resources/sounds/incomingMessage.wav
net.java.sip.communicator.impl.notifications.eventType1388693492537.actions.actionType1388693492553.timeout=-1

Aaron Dixon
IT Specialist
aaron.dixon@ssdcservices.com

SSDC Services
28125 Cabot Drive, Suite 201
Novi, MI 48377
O: (248) 277-9304
C: (248) 935-7353
F: (248) 344-1623
www.ssdcservices.com

ยทยทยท

-----Original Message-----
From: users-bounces@jitsi.org [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Wednesday, January 8, 2014 3:07 PM
To: 'Jitsi Users'
Subject: Re: [jitsi-users] How to Disable Jingle (Audio/Video)

We use the jitsi-defaults.properties file to "provision" clients.
However,

I

cannot find out a way to setup default for new accounts to disable
jingle (gray out audio/video calls and screen sharing).

The checkbox in the GUI is "Disable Jingle (audio and video calls with
XMPP)". Which will create line in sip-communicator.properties as

net.java.sip.communicator.impl.protocol.jabber.acc1389209943697.CALLIN
G_D
ISAB LED=false

But since it is account specific I cannot add this to the jitis-
defaults.properties. I would think the following would work but it
does

not

net.java.sip.communicator.service.protocol.jabber.IS_CALLING_DISABLED_
FOR
_ACC OUNT=true

Anyone have any advice?

net.java.sip.communicator.impl.protocol.jabber.CALLING_DISABLED=true
should do the trick

Aaron Dixon

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Yes, that did it. Thank you Ingo.

Is there any way to mute Inbound Message via the default config? I have
entered in the following lines, but this only works if the sip-
communicator.properties is deleted before Jitsi runs (due the account
number 138869...)

I don't know of any way to circumvent that. It has previously annoyed me as
well, so I might take a look at it at some point. Feel free to open a
feature request in our issue tracker.

But maybe you could use the provisioning service, clear all properties with
net.java.sip.communicator.impl.notifications=${null} and set them however
you like. But given how you fiddle with the defaults file, this is probably
not an option for you.

[...]

Aaron Dixon

Ingo