[jitsi-users] How to disable Call Waiting?


#1

Hi!

A user is regularily annoyed by incoming calls during an active call.
There are 2 problems with call waiting in the given case:

1. The "ringing" sound is very loud. Is there a way to make the notification silent?

2. When the user is in a call, she cannot handle another call anyway. So the incoming call should be forwarded to the next agent or voicemail as if the user was not even online.

Can this be configured somehow? Ideally on a per-user base within jitsi?

Regards,
Peter


#2

Hi,

there is a property to control this:
http://lists.jitsi.org/pipermail/users/2013-July/004383.html

Regards
damencho

···

On Thu, Jun 11, 2015 at 12:15 PM, Peter Schmidt <peter.schmidt@bixa.cc> wrote:

Hi!

A user is regularily annoyed by incoming calls during an active call.
There are 2 problems with call waiting in the given case:

1. The "ringing" sound is very loud. Is there a way to make the notification
silent?

2. When the user is in a call, she cannot handle another call anyway. So the
incoming call should be forwarded to the next agent or voicemail as if the
user was not even online.

Can this be configured somehow? Ideally on a per-user base within jitsi?

Regards,
Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Thanks Damian.

If anybody else is interested:

Adding the setting
  net.java.sip.communicator.impl.protocol.CallWaitingDisabled=true
to the properties file will forward an incoming call to the queue or voicemail, just as if the user was not available. The user does not even notice that someone tried to call him.

It's kinda funny, that this feature has not been implemented in the GUI and is only available via the properties file for 2 years now.

Regards,
Peter

···

On 2015-06-11 11:28, Damian Minkov wrote:

Hi,

there is a property to control this:
http://lists.jitsi.org/pipermail/users/2013-July/004383.html

Regards
damencho

On Thu, Jun 11, 2015 at 12:15 PM, Peter Schmidt <peter.schmidt@bixa.cc> wrote:

Hi!

A user is regularily annoyed by incoming calls during an active call.
There are 2 problems with call waiting in the given case:

1. The "ringing" sound is very loud. Is there a way to make the notification
silent?

2. When the user is in a call, she cannot handle another call anyway. So the
incoming call should be forwarded to the next agent or voicemail as if the
user was not even online.

Can this be configured somehow? Ideally on a per-user base within jitsi?

Regards,
Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Thanks Damien and Peter, this is exactly what I was looking for too.

Is there anywhere that settings like this are documented?

Thanks
Rod

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Peter Schmidt
Sent: Thursday, 11 June 2015 10:17 PM
To: Jitsi Users
Subject: Re: [jitsi-users] How to disable Call Waiting?

Thanks Damian.

If anybody else is interested:

Adding the setting
  net.java.sip.communicator.impl.protocol.CallWaitingDisabled=true
to the properties file will forward an incoming call to the queue or voicemail, just as if the user was not available. The user does not even notice that someone tried to call him.

It's kinda funny, that this feature has not been implemented in the GUI and is only available via the properties file for 2 years now.

Regards,
Peter
On 2015-06-11 11:28, Damian Minkov wrote:

Hi,

there is a property to control this:
http://lists.jitsi.org/pipermail/users/2013-July/004383.html

Regards
damencho

On Thu, Jun 11, 2015 at 12:15 PM, Peter Schmidt <peter.schmidt@bixa.cc> wrote:

Hi!

A user is regularily annoyed by incoming calls during an active call.
There are 2 problems with call waiting in the given case:

1. The "ringing" sound is very loud. Is there a way to make the
notification silent?

2. When the user is in a call, she cannot handle another call anyway.
So the incoming call should be forwarded to the next agent or
voicemail as if the user was not even online.

Can this be configured somehow? Ideally on a per-user base within jitsi?

Regards,
Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi everybody,

it's been a while since this has been discussed, but recently I had this issue again, so I would like to open official feature requests for this.

1.: Allow configuration of property "net.java.sip.communicator.impl.protocol.CallWaitingDisabled" via GUI

2.: Documentation about possible properties

I know the latter one will be pretty messy, but maybe someone can come up with an at least semi-automatic method (via Call Hierarchy of ConfigurationServiceImpl.getProperty(String))

Kind regards,

Peter

···

On 2015-06-12 00:36, Rod Taylor wrote:

Thanks Damien and Peter, this is exactly what I was looking for too.

Is there anywhere that settings like this are documented?

Thanks
Rod

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Peter Schmidt
Sent: Thursday, 11 June 2015 10:17 PM
To: Jitsi Users
Subject: Re: [jitsi-users] How to disable Call Waiting?

Thanks Damian.

If anybody else is interested:

Adding the setting
   net.java.sip.communicator.impl.protocol.CallWaitingDisabled=true
to the properties file will forward an incoming call to the queue or voicemail, just as if the user was not available. The user does not even notice that someone tried to call him.

It's kinda funny, that this feature has not been implemented in the GUI and is only available via the properties file for 2 years now.

Regards,
Peter
On 2015-06-11 11:28, Damian Minkov wrote:

Hi,

there is a property to control this:
http://lists.jitsi.org/pipermail/users/2013-July/004383.html

Regards
damencho

On Thu, Jun 11, 2015 at 12:15 PM, Peter Schmidt <peter.schmidt@bixa.cc> wrote:

Hi!

A user is regularily annoyed by incoming calls during an active call.
There are 2 problems with call waiting in the given case:

1. The "ringing" sound is very loud. Is there a way to make the
notification silent?

2. When the user is in a call, she cannot handle another call anyway.
So the incoming call should be forwarded to the next agent or
voicemail as if the user was not even online.

Can this be configured somehow? Ideally on a per-user base within jitsi?

Regards,
Peter

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users