[jitsi-users] How to configure jitsi videobridge


#1

Hi,

I use instructions on jitsi.org videobridge page to download latest
version jitsi-videobridge-linux-x64-32.zip and connect it to my openfire
3.8.2 jabber server, installed on Debian 6.0.7 x86_64 GNU/Linux.

Seems, after starting extension with command:

./jvb.sh --secret=mysecret --domain='mydomain.com' --port=5275 &

extension is running and connected to openfire server. But, creating of
videobridge is unstable.

For example, i start videobridge with 2 contacts in my roster (3
contacts total), i se my video and 2 videos of my friends, but they only
can see themselves video, not my.

How can i debug this problem, and possibly send report to developers?

Please, advice, if i should write such question to dev@jitsi.org list,
not in users?

Dmitry.

Best Regards,
Dmitry

···

---
Dmitry KORZHEVIN
System Administrator
STIDIA S.A. - Luxembourg

e: dmitry.korzhevin@stidia.com
m: +38 093 874 5453
w: http://www.stidia.com


#2

Hello,

Hi,

I use instructions on jitsi.org videobridge page to download latest
version jitsi-videobridge-linux-x64-32.zip and connect it to my openfire
3.8.2 jabber server, installed on Debian 6.0.7 x86_64 GNU/Linux.

Seems, after starting extension with command:

./jvb.sh --secret=mysecret --domain='mydomain.com' --port=5275 &

extension is running and connected to openfire server. But, creating of
videobridge is unstable.

For example, i start videobridge with 2 contacts in my roster (3
contacts total), i se my video and 2 videos of my friends, but they only
can see themselves video, not my.

How can i debug this problem, and possibly send report to developers?

Debugging usually isn't straight forward. We have found that most such problems are caused by bugs in the client. Since you see all videos, connection establishments problems can be pretty much ruled out.

Many fixes have been incorporated since the last stable release, so the first thing to do would be to make sure you're running the latest nightly everywhere.

If you want to dig into it, you can go through the logs[1] of all clients, looking for errors. Then go through the pcap file on the focus.

Reports of specific problems are most welcome here. Please provide a description and log files[1].

Please, advice, if i should write such question to dev@jitsi.org list,
not in users?

I think both lists are fine.

Regards,
Boris

[1] https://jitsi.org/Documentation/FAQ#logs

···

On 7/22/13 9:26 PM, Dmitry Korzhevin wrote: