[jitsi-users] How to change RTP port range?


#1

Hello,

I am using Jitsi 2.4.4997 on OS X 10.9.2 and really like it. But I
cannot figure out how to change the RTP port range. How could this be
done?

Gene


#2

Specify values to the following properties in the file
"$HOME/Library/Application Support/Jitsi/sip-communicator.properties"
(which can be done through the Property Editor on the Advanced tab in
Preferences as an alternative to manual file editing):

net.java.sip.communicator.service.media.MIN_PORT_NUMBER
net.java.sip.communicator.service.media.MAX_PORT_NUMBER

The above should come into effect in subsequent SIP calls and XMPP
calls utilizing the Raw UDP Jingle transport.

net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_VIDEO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_VIDEO_PORT_NUMBER

The above should come into effect in subsequent XMPP calls utilizing
the ICE-UDP Jingle transport.

···

2014-03-19 4:19 GMT+02:00 Gene Wu <genewu7@gmail.com>:

I am using Jitsi 2.4.4997 on OS X 10.9.2 and really like it. But I
cannot figure out how to change the RTP port range. How could this be
done?


#3

Yes, it was for SIP calling. Thank you Lyubomir!

Gene

···

On Tue, Mar 18, 2014 at 11:31 PM, Lyubomir Marinov <lyubomir.marinov@jitsi.org> wrote:

2014-03-19 4:19 GMT+02:00 Gene Wu <genewu7@gmail.com>:

I am using Jitsi 2.4.4997 on OS X 10.9.2 and really like it. But I
cannot figure out how to change the RTP port range. How could this be
done?

Specify values to the following properties in the file
"$HOME/Library/Application Support/Jitsi/sip-communicator.properties"
(which can be done through the Property Editor on the Advanced tab in
Preferences as an alternative to manual file editing):

net.java.sip.communicator.service.media.MIN_PORT_NUMBER
net.java.sip.communicator.service.media.MAX_PORT_NUMBER

The above should come into effect in subsequent SIP calls and XMPP
calls utilizing the Raw UDP Jingle transport.

net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_VIDEO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_VIDEO_PORT_NUMBER

The above should come into effect in subsequent XMPP calls utilizing
the ICE-UDP Jingle transport.


#4

I have made these settings:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=22020
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=22000
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER=22030
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER=22040
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER=22021
net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER=22031

But jitsi uses port 5002 for an XMPP audio call. Why?

···

2014-03-19 7:31 GMT+01:00 Lyubomir Marinov <lyubomir.marinov@jitsi.org>:

2014-03-19 4:19 GMT+02:00 Gene Wu <genewu7@gmail.com>:

I am using Jitsi 2.4.4997 on OS X 10.9.2 and really like it. But I
cannot figure out how to change the RTP port range. How could this be
done?

Specify values to the following properties in the file
"$HOME/Library/Application Support/Jitsi/sip-communicator.properties"
(which can be done through the Property Editor on the Advanced tab in
Preferences as an alternative to manual file editing):

net.java.sip.communicator.service.media.MIN_PORT_NUMBER
net.java.sip.communicator.service.media.MAX_PORT_NUMBER

The above should come into effect in subsequent SIP calls and XMPP
calls utilizing the Raw UDP Jingle transport.

net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MIN_VIDEO_PORT_NUMBER
net.java.sip.communicator.service.protocol.MAX_VIDEO_PORT_NUMBER

The above should come into effect in subsequent XMPP calls utilizing
the ICE-UDP Jingle transport.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I can confirm that the above properties don't have any effect for calls
using XMPP and ICE in the Jitsi client. I couldn't find out why.

Could you open a bug on our tracker[1], please?

Regards,
Boris

[1] https://trac.jitsi.org/

···

On 21/03/14 23:25, Mitchell Langs wrote:

I have made these settings:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=22020
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=22000
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER=22030
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER=22040
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER=22021
net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER=22031

But jitsi uses port 5002 for an XMPP audio call. Why?


#6

Thank you for the report! It appears these have stopped working as
expected, I'm sorry. I have just fixed the problem in our source so I
expect Jitsi 2.5.5154/nightly build #5154 to fix them for you as well.
Please let us know if these fail to work for you.

···

2014-03-22 0:25 GMT+02:00 Mitchell Langs <napole@gmail.com>:

I have made these settings:
net.java.sip.communicator.service.media.MAX_PORT_NUMBER=22020
net.java.sip.communicator.service.media.MIN_PORT_NUMBER=22000
net.java.sip.communicator.service.protocol.MAX_AUDIO_PORT_NUMBER=22030
net.java.sip.communicator.service.protocol.MAX_MEDIA_PORT_NUMBER=22040
net.java.sip.communicator.service.protocol.MIN_AUDIO_PORT_NUMBER=22021
net.java.sip.communicator.service.protocol.MIN_MEDIA_PORT_NUMBER=22031

But jitsi uses port 5002 for an XMPP audio call. Why?