[jitsi-users] How to bypas DNS resolving


#1

Hi,
i'd like to use my hostnames defined on the hosts file, actually i fill the server name's box with its related ip address, in jitsi's connection tab. Is there a way to tell jitsi to try to locally resolve hostnames before looking on the Internet?

Thanks,
Mark ( mrK )


#2

You may be able to do this by setting the *HOSTALIASES *environment
variable.

See http://man7.org/linux/man-pages/man3/gethostbyname.3.html

Alternately, you can try changing /etc/host.conf (but this will affect all
DNS lookups on your PC).

See http://man7.org/linux/man-pages/man5/host.conf.5.html

Failing the above, you could try running a DNS server on your PC. If you
try this, you may need to update /etc/resolve.conf

See http://man7.org/linux/man-pages/man5/resolv.conf.5.html

···

On Tue, Apr 8, 2014 at 7:51 AM, mrk <marcorossi2k@gmail.com> wrote:

Hi,
i'd like to use my hostnames defined on the hosts file, actually i fill
the server name's box with its related ip address, in jitsi's connection
tab. Is there a way to tell jitsi to try to locally resolve hostnames
before looking on the Internet?


#3

i'd like to use my hostnames defined on the hosts file, actually i fill
the server name's box with its related ip address, in jitsi's connection
tab. Is there a way to tell jitsi to try to locally resolve hostnames
before looking on the Internet?

Sorry, no, this is currently not possible.

Thanks,
Mark ( mrK )

Ingo


#4

A workaround for some situations: you can override the IP address of the
XMPP server under the 'Connection' tab for the account properties.

Regards,
Boris

···

On 08/04/14 13:51, mrk wrote:

Hi,
i'd like to use my hostnames defined on the hosts file, actually i fill
the server name's box with its related ip address, in jitsi's connection
tab. Is there a way to tell jitsi to try to locally resolve hostnames
before looking on the Internet?

Thanks,
Mark ( mrK )


#5

Some linux distributions run a local dnsmasq (supervised by
NetworkManager) to cache name resolutions.

Check if you ave one running. If so, try using it.

···

On Tue, Apr 08, 2014 at 01:51:15PM +0200, mrk wrote:

Hi,
i'd like to use my hostnames defined on the hosts file, actually i
fill the server name's box with its related ip address, in jitsi's
connection tab. Is there a way to tell jitsi to try to locally
resolve hostnames before looking on the Internet?

--
Tzafrir Cohen | tzafrir@jabber.org | VIM is
http://tzafrir.org.il | | a Mutt's
tzafrir@cohens.org.il | | best
tzafrir@debian.org | | friend


#6

Thank you all for your replies and useful infos!

I had a fast tries on all your solutions: hostaliases is considered obsolete ( http://blog.tremily.us/posts/HOSTALIASES/ ) and the reported example didn't work for me, implementing a dns server is something that actually i can't afford since i need to master a bit some concepts about it .

I found a faster and more obvious solution, I missed that option before and don't know why !
You simply need to enable the follow option "Treat all domain names as absolute" located in jitsi's advanced options -> Dns ->Dns Security and using your local domain in the file /etc/hosts.

That's the easier and cleaner option for most common jitsi's installations .

Thanks again,

Mark ( mrK )

···

On 08/04/2014 19:10, Ron Wilson wrote:

On Tue, Apr 8, 2014 at 7:51 AM, mrk <marcorossi2k@gmail.com > <mailto:marcorossi2k@gmail.com>> wrote:

    Hi,
    i'd like to use my hostnames defined on the hosts file, actually i
    fill the server name's box with its related ip address, in jitsi's
    connection tab. Is there a way to tell jitsi to try to locally
    resolve hostnames before looking on the Internet?

You may be able to do this by setting the *HOSTALIASES *environment variable.

See http://man7.org/linux/man-pages/man3/gethostbyname.3.html

Alternately, you can try changing /etc/host.conf (but this will affect all DNS lookups on your PC).

See http://man7.org/linux/man-pages/man5/host.conf.5.html

Failing the above, you could try running a DNS server on your PC. If you try this, you may need to update /etc/resolve.conf

See http://man7.org/linux/man-pages/man5/resolv.conf.5.html

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi, thanks both for the reply . Boris , yes that's my actual solution , i wrote it in the message.

Regards,
Mark ( mrK )

···

On 08/04/2014 14:08, Boris Grozev wrote:

On 08/04/14 13:51, mrk wrote:

Hi,
i'd like to use my hostnames defined on the hosts file, actually i fill
the server name's box with its related ip address, in jitsi's connection
tab. Is there a way to tell jitsi to try to locally resolve hostnames
before looking on the Internet?

Thanks,
Mark ( mrK )

A workaround for some situations: you can override the IP address of the
XMPP server under the 'Connection' tab for the account properties.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Sorry, I don't know how I missed it.

Boris

···

On 08/04/14 16:01, mrk wrote:

Hi, thanks both for the reply . Boris , yes that's my actual solution ,
i wrote it in the message.