[jitsi-users] host-unknown issue


#1

Hi Developers,

I was trying to install and configure Jitsi-Meet on centOS 6.9 using
the instructions at https://github.com/jitsi/jitsi-meet/blob/master/doc
/manual-install.md.

But I keep getting an error while trying to start the videobridge using
the following command.

./jvb.sh --host=localhost --domain=tube.chalphal.com --port=5347 --secret=
YOURSECRET1 &

Error:

JVB 2017-07-20 23:48:39.964 INFO: [11]
org.jitsi.rest.AbstractJettyBundleActivator.start().572 Not starting
the Jetty service for
org.jitsi.videobridge.rest.PublicRESTBundleActivator(port=-1)
JVB 2017-07-20 23:48:39.990 INFO: [1]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
net.java.sip.communicator.SC_HOME_DIR_NAME=.sip-communicator
JVB 2017-07-20 23:48:39.991 INFO: [1]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
net.java.sip.communicator.SC_HOME_DIR_LOCATION=/root
JVB 2017-07-20 23:48:40.239 SEVERE: [19]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
org.xmpp.component.ComponentException: host-unknown
at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java
:219)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalCo
mponentManager.java:221)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalCo
mponentManager.java:201)
at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)
at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)
at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ac
cess$201(ScheduledThreadPoolExecutor.java:180)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ru
n(ScheduledThreadPoolExecutor.java:293)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.ja
va:1142)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.j
ava:617)
at java.lang.Thread.run(Thread.java:748)

prosody config file (tube.chalphal.com): https://pastebin.com/dj3AtAAU
nginx config file (tube.chalphal.cfg.lua): http://pastebin.com/5Txp22wz
<https://pastebin.com/5Txp22wz>
sip-communicator.properties: https://pastebin.com/UNLPqe8N

We're using the subdomain chat.chalphal.com. Do we have to actually create
the subdomain in order to run the videobridge? We've already tried with and
without it.

Could you guys please help us resolve this issue, as we have been trying to
figure out the problem for sometime and haven't had any luck with
it.

Thanks,
Uki Malla


#2

Hi,

So your component config for the bridge is
cp-videobridge.tube.chalphal.com, and the bridge param for domain is
tube.chalphal.com, so the bridge tries to connect using component
address videobridge.tube.chalphal.com, which does not match.
Hope this helps.

Regards
damencho

ยทยทยท

On Fri, Jul 21, 2017 at 8:13 PM, Uki Malla <uki.malla@gmail.com> wrote:

Hi Developers,

I was trying to install and configure Jitsi-Meet on centOS 6.9 using
the instructions at https://github.com/jitsi/jitsi-meet/blob/master/doc
/manual-install.md.

But I keep getting an error while trying to start the videobridge using
the following command.

./jvb.sh --host=localhost --domain=tube.chalphal.com --port=5347 --secret=
YOURSECRET1 &

Error:

JVB 2017-07-20 23:48:39.964 INFO: [11]
org.jitsi.rest.AbstractJettyBundleActivator.start().572 Not starting
the Jetty service for
org.jitsi.videobridge.rest.PublicRESTBundleActivator(port=-1)
JVB 2017-07-20 23:48:39.990 INFO: [1]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
net.java.sip.communicator.SC_HOME_DIR_NAME=.sip-communicator
JVB 2017-07-20 23:48:39.991 INFO: [1]
org.jitsi.impl.configuration.ConfigurationServiceImpl.log()
net.java.sip.communicator.SC_HOME_DIR_LOCATION=/root
JVB 2017-07-20 23:48:40.239 SEVERE: [19]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:localhost,
port:5347
org.xmpp.component.ComponentException: host-unknown
at
org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java
:219)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalCo
mponentManager.java:221)
at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalCo
mponentManager.java:201)
at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)
at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)
at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ac
cess$201(ScheduledThreadPoolExecutor.java:180)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.ru
n(ScheduledThreadPoolExecutor.java:293)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.ja
va:1142)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.j
ava:617)
at java.lang.Thread.run(Thread.java:748)

prosody config file (tube.chalphal.com): https://pastebin.com/dj3AtAAU
nginx config file (tube.chalphal.cfg.lua): http://pastebin.com/5Txp22wz
sip-communicator.properties: https://pastebin.com/UNLPqe8N

We're using the subdomain chat.chalphal.com. Do we have to actually create
the subdomain in order to run the videobridge? We've already tried with and
without it.

Could you guys please help us resolve this issue, as we have been trying to
figure out the problem for sometime and haven't had any luck with
it.

Thanks,
Uki Malla

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users