[jitsi-users] Horrible sound in openSUSE on landlines and mobiles


#1

Good day all,

Our private land line is hooked up with VoipBuster which works very well at
our end. (Our DECT phone is connected to a FrizBox 7170A modem having a few
SIP accounts).

However, when I'm using Jitsi using our VoipBuster account to call a landline
or a mobile phone, the sound is horrible. It squeaks, cracks, drops sound,
making it totally useless. I've tried this from home and from our friends
house (to rule out a VoipBuster dependency)

I'm on openSUSE 12.2 x64 and I'm using a analog, bi-wire Logitech head set.

I've used up quit some evenings to figure out where the problem is, but I
can't get my fingers behind it. So I'd like to call the collective wisdom here.

What I've done so far + symptoms:

1. I have no other sound related problems, everything sounds great (games,
notices, video, etc)
2. I also have the latest Linux Skype installed on my PC and the sound is perfect.
3. I've booted my PC with the latest LiveCD version of Ubuntu (32 bits), and
than the sound is perfect too. Including Jitsi over VoipBuster (both landlines
and mobiles)
4. I also had Jitsi sound problems on openSUSE 12.1 x64
5. I've removed PulseAudio without any effect.
6. I've created a new user for this with clean settings to rule out crappy KDE
config from the 12.1 upgrade.
7. Soundcard is YasT auto configured (HDA Intel ALC 889A)

I've researched most of Googles relevant hits, but couldn't find the final
clue. Since Jitsi sounds great on Ubuntu I expect it to be a problem with
openSUSE, but I can't make it stick.

Any pointers greatly appreciated.
Many thanks,

Koos

···

--
http://www.malarianomore.org
For $10 a mosquito net + distribution + education + monitoring + evaluation.


#2

Hi, Koos

What I've done so far + symptoms:

1. I have no other sound related problems, everything sounds great (games,
notices, video, etc)
2. I also have the latest Linux Skype installed on my PC and the sound is
perfect.
3. I've booted my PC with the latest LiveCD version of Ubuntu (32 bits),
and
than the sound is perfect too. Including Jitsi over VoipBuster (both
landlines
and mobiles)
4. I also had Jitsi sound problems on openSUSE 12.1 x64
5. I've removed PulseAudio without any effect.
6. I've created a new user for this with clean settings to rule out crappy
KDE
config from the 12.1 upgrade.
7. Soundcard is YasT auto configured (HDA Intel ALC 889A)

I've researched most of Googles relevant hits, but couldn't find the final
clue. Since Jitsi sounds great on Ubuntu I expect it to be a problem with
openSUSE, but I can't make it stick.

Any pointers greatly appreciated.
Many thanks,

Koos

When testing under Ubuntu and opesSUSE did you use the same version of
Jitsi and the same codec? Is there any difference if you change the codec?

If you open the call info window during a call with bad quality, do you
notice any packet loss? What about discarded packets (this one is only
shown since r9981)?

It would help us figure out what's wrong if you provided log files[1]
collected after a call.

One last question -- what is the CPU? I have a similar problem on a 1.6GHz
atom, and I assumed it's just too slow. I have not tried to boot a
different system yet.

Regards,
Boris

https://jitsi.org/index.php/Documentation/FAQ#logs

···

On Sat, Oct 20, 2012 at 8:49 PM, Koos Pol <koos2012@pohw.nl> wrote:


#3

One more question: can you bring back pulse audio and then choose the
PulseAudio sound system in Jitsi? Rather than PortAudio that is.

Emil

···

On Sat, Oct 20, 2012 at 9:11 PM, Boris Grozev <boris@jitsi.org> wrote:

Hi, Koos

On Sat, Oct 20, 2012 at 8:49 PM, Koos Pol <koos2012@pohw.nl> wrote:

What I've done so far + symptoms:

1. I have no other sound related problems, everything sounds great (games,
notices, video, etc)
2. I also have the latest Linux Skype installed on my PC and the sound is
perfect.
3. I've booted my PC with the latest LiveCD version of Ubuntu (32 bits),
and
than the sound is perfect too. Including Jitsi over VoipBuster (both
landlines
and mobiles)
4. I also had Jitsi sound problems on openSUSE 12.1 x64
5. I've removed PulseAudio without any effect.
6. I've created a new user for this with clean settings to rule out crappy
KDE
config from the 12.1 upgrade.
7. Soundcard is YasT auto configured (HDA Intel ALC 889A)

I've researched most of Googles relevant hits, but couldn't find the final
clue. Since Jitsi sounds great on Ubuntu I expect it to be a problem with
openSUSE, but I can't make it stick.

Any pointers greatly appreciated.
Many thanks,

Koos

When testing under Ubuntu and opesSUSE did you use the same version of Jitsi
and the same codec? Is there any difference if you change the codec?

If you open the call info window during a call with bad quality, do you
notice any packet loss? What about discarded packets (this one is only shown
since r9981)?

It would help us figure out what's wrong if you provided log files[1]
collected after a call.

One last question -- what is the CPU? I have a similar problem on a 1.6GHz
atom, and I assumed it's just too slow. I have not tried to boot a different
system yet.

Regards,
Boris

https://jitsi.org/index.php/Documentation/FAQ#logs

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31