[jitsi-users] high cpu use


#1

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Thanks,
  Mike


#2

Java is a drunker;)

···

----- Original Message -----

From: <mpicher@gmail.com>

To: <users@jitsi.java.net>
Sent: Tuesday, August 23, 2011 1:34 PM
Subject: [jitsi-users] high cpu use

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Thanks,
Mike

__________ Information provenant d'ESET NOD32 Antivirus, version de la base des signatures de virus 6402 (20110823) __________

Le message a �t� v�rifi� par ESET NOD32 Antivirus.

http://www.eset.com

__________ Information provenant d'ESET NOD32 Antivirus, version de la base des signatures de virus 6402 (20110823) __________

Le message a �t� v�rifi� par ESET NOD32 Antivirus.

http://www.eset.com


#3

На 23.08.11 13:27, Meftah Tayeb написа:

Java is a drunker;)

.... that was helpful. Thanks Tayeb!

Mike,

На 23.08.11 13:34, mpicher@gmail.com написа:

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Does this happen regularly? Does it happen during audio/video calls?
Audio only? We've had some similar issues previously but they seemed to
be related to the use of PortAudio on Atom processors.

Cheers,
Emil


#4

This happens just sitting idle. Even right after start and never making a
call.

···

On Aug 23, 2011 7:48 AM, "Emil Ivov" <emcho@jitsi.org> wrote:

На 23.08.11 13:27, Meftah Tayeb написа:

Java is a drunker;)

.... that was helpful. Thanks Tayeb!

Mike,

На 23.08.11 13:34, mpicher@gmail.com написа:

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Does this happen regularly? Does it happen during audio/video calls?
Audio only? We've had some similar issues previously but they seemed to
be related to the use of PortAudio on Atom processors.

Cheers,
Emil


#5

I had this issue on Intel core2duo (T7200 on a laptop, E6550 on a desktop) and AMD CPUs (Athlon 3200+ and Athlon II 250 x2).
So it is not CPU related, it is PulseAudio+PulseAudio related issue.
It happened to me when i ran Ubuntu 9.04 and higher with PulseAudio and with Debian Squeeze/Wheezy with PulseAudio. And this bug was eliminated in the release cycle but brought back at a certain point when portaudio was updated.
It happened randomly, either from the beginning of a call or during a call. I messed around with PulseAudio's various settings but none helped. The only thing that worked temporarily was restarting ALSA (but after a while the high cpu usage was back).

Since i removed PulseAudio and use ALSA only i never had this problem.

···

On Tue, 23 Aug 2011 14:48:37 +0300, Emil Ivov <emcho@jitsi.org> wrote:

На 23.08.11 13:27, Meftah Tayeb написа:

Java is a drunker;)

.... that was helpful. Thanks Tayeb!

Mike,

На 23.08.11 13:34, mpicher@gmail.com написа:

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Does this happen regularly? Does it happen during audio/video calls?
Audio only? We've had some similar issues previously but they seemed to
be related to the use of PortAudio on Atom processors.

Cheers,
Emil

--
O zi buna,

Kertesz Laszlo

Using Opera's revolutionary email client: http://www.opera.com/mail/


#6

Hey Michael,

На 23.08.11 14:38, Michael Picher написа:

This happens just sitting idle. Even right after start and never making
a call.

I am afraid we'd need you to make a heap and a thread dump to better
understand what's wrong. It's a somewhat convoluted process so we'd
understand if you are not crazy about the idea. Let us know if you are
interested and I'll send you some more details.

Cheers,
Emil

···

On Aug 23, 2011 7:48 AM, "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> wrote:

На 23.08.11 13:27, Meftah Tayeb написа:

Java is a drunker;)

.... that was helpful. Thanks Tayeb!

Mike,

На 23.08.11 13:34, mpicher@gmail.com <mailto:mpicher@gmail.com> написа:

Tried searching the forums a bit but no luck.

I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
cpu use by java (consuming 100% cpu on an Intel i5 system).

For Jitsi, I've got one SIP account active and one XMPP account active.
Also, I'm setup for PortAudio for my audio with Audio in and out set
to pulse. I've got 2 video cameras but by HD cam is selected.

I'm running under Ubuntu 11.04.

Does this happen regularly? Does it happen during audio/video calls?
Audio only? We've had some similar issues previously but they seemed to
be related to the use of PortAudio on Atom processors.

Cheers,
Emil

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#7

Hi Emil,

Thanks for the offer but I had to bail on Ubuntu and go back to Windoze 7
because the audio stuff was driving me nuts. This has mostly to do with
audio quality over bluetooth and with usb-type headsets.

I have to say the video stuff has gotten much better with Linux & Unix but
the state of audio is about where video was 3 or 4 years ago. And forget
about trying to do it in a virtual.

For somebody who has to work with softphones all day it's too bad. I try to
flop over at least once a year and I lasted longer (a couple months) on it
this time.

Thanks,
  Mike

···

2011/8/26 Emil Ivov <emcho@jitsi.org>

Hey Michael,

На 23.08.11 14:38, Michael Picher написа:
> This happens just sitting idle. Even right after start and never making
> a call.

I am afraid we'd need you to make a heap and a thread dump to better
understand what's wrong. It's a somewhat convoluted process so we'd
understand if you are not crazy about the idea. Let us know if you are
interested and I'll send you some more details.

Cheers,
Emil

>
> On Aug 23, 2011 7:48 AM, "Emil Ivov" <emcho@jitsi.org > > <mailto:emcho@jitsi.org>> wrote:
>> На 23.08.11 13:27, Meftah Tayeb написа:
>>> Java is a drunker;)
>>
>> .... that was helpful. Thanks Tayeb!
>>
>> Mike,
>>
>> На 23.08.11 13:34, mpicher@gmail.com <mailto:mpicher@gmail.com> написа:
>>> Tried searching the forums a bit but no luck.
>>>
>>> I'm running 1.0-beta1-nightly.build.3593 and am experiencing very high
>>> cpu use by java (consuming 100% cpu on an Intel i5 system).
>>>
>>> For Jitsi, I've got one SIP account active and one XMPP account active.
>>> Also, I'm setup for PortAudio for my audio with Audio in and out set
>>> to pulse. I've got 2 video cameras but by HD cam is selected.
>>>
>>> I'm running under Ubuntu 11.04.
>>
>> Does this happen regularly? Does it happen during audio/video calls?
>> Audio only? We've had some similar issues previously but they seemed to
>> be related to the use of PortAudio on Atom processors.
>>
>> Cheers,
>> Emil
>>

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31

--
There are 10 kinds of people in this world, those who understand binary and
those who don't.

mpicher@gmail.com
blog: http://www.sipxecs.info
call: sip:mpicher@sipxecs.info