[jitsi-users] Help: Unable to run Jitsi on Mac OS


#1

Hi,
I am currently trying to test Jitsi 2.2 across all platform and has
successfully compile and run Jitsi on Ubuntu and Windows.
I am a noob in Java as well as in Mac OS. I am using Jitsi 2.2 source code
in NetBeans 7.3.1. I am running on Mac OS X Mountain Lion. When using ant
commands, rebuild and make are successful but fail in run. It states;
[java] Error occurred during initialization of VM
[java] Could not find agent library AEGetURLEventHandlerAgent on the
library path, with error: dlopen(libAEGetURLEventHandlerAgent.dybib, 1)
image not found
Jitsi can run perfectly when I use the downloaded build.
I would appreciate any help on this. Thank you.

Regards;
Rosnin Mustaffa


#2

You're unlikely to benefit from AEGetURLEventHandlerAgent if you're
starting Jitsi (from source) with "ant run" so you may delete
"-agentlib:AEGetURLEventHandlerAgent" from build.xml.

···

2013/10/16 Rosnin Bin Mustaffa <rosninm@gmail.com>:

fail in run. It states;
[java] Error occurred during initialization of VM
[java] Could not find agent library AEGetURLEventHandlerAgent on the library
path, with error: dlopen(libAEGetURLEventHandlerAgent.dybib, 1) image not
found


#3

Send us the crash log generated by OS X and Jitsi's logs
(https://jitsi.org/Documentation/FAQ#logs).

···

2013/10/18 Rosnin Bin Mustaffa <rosninm@gmail.com>:

Hi,
Thank you for the help. Taking your advice, I edited the build.xml file
(delete "-agentlib:
AEGetURLEventHandlerAgent") to be as follows;
        <condition property="jvmarg.line"
                value="-Xdock:name='Jitsi'
-Xdock:icon='resources/images/logo/sc_logo_128x128.icns'"
                else="">
            <isset property="is.running.macos"/>
        </condition>
Now the code is able to be executed but unfortunately, every time jitsi is
connected to another jitsi program (both when receiving and making video
calls) it crashes. Jitsi is able to have text and voice connection, but the
moment the video button is pressed, jitsi crashes. On Mac it says, "Jitsi
quit unexpectedly while using the liblwawt.dylib plug-in."

Thank you.

Regards;
Rosnin Mustaffa


#4

Hi,
Thank you for the help. Taking your advice, I edited the build.xml file
(delete "-agentlib:
AEGetURLEventHandlerAgent") to be as follows;
        <condition property="jvmarg.line"
                value="-Xdock:name='Jitsi'
-Xdock:icon='resources/images/logo/sc_logo_128x128.icns'"
                else="">
            <isset property="is.running.macos"/>
        </condition>
Now the code is able to be executed but unfortunately, every time jitsi is
connected to another jitsi program (both when receiving and making video
calls) it crashes. Jitsi is able to have text and voice connection, but the
moment the video button is pressed, jitsi crashes. On Mac it says, "Jitsi
quit unexpectedly while using the liblwawt.dylib plug-in."

Attached is the zip file created when "Archive Logs" button is pressed.

Thank you.

Regards;
Rosnin Mustaffa

2013-10-18@16.30.52-logs.zip (41.6 KB)

···

On Thu, Oct 17, 2013 at 2:14 AM, Lyubomir Marinov < lyubomir.marinov@jitsi.org> wrote:

2013/10/16 Rosnin Bin Mustaffa <rosninm@gmail.com>:
> fail in run. It states;
> [java] Error occurred during initialization of VM
> [java] Could not find agent library AEGetURLEventHandlerAgent on the
library
> path, with error: dlopen(libAEGetURLEventHandlerAgent.dybib, 1) image not
> found

You're unlikely to benefit from AEGetURLEventHandlerAgent if you're
starting Jitsi (from source) with "ant run" so you may delete
"-agentlib:AEGetURLEventHandlerAgent" from build.xml.


#5

Hi guys,
Any help on this?

Regards;
Rosnin Mustaffa

···

On Mon, Oct 28, 2013 at 9:01 AM, Rosnin Bin Mustaffa <rosninm@gmail.com>wrote:

Hi,
Thank you for the help. Taking your advice, I edited the build.xml file
(delete "-agentlib:
AEGetURLEventHandlerAgent") to be as follows;
        <condition property="jvmarg.line"
                value="-Xdock:name='Jitsi'
-Xdock:icon='resources/images/logo/sc_logo_128x128.icns'"
                else="">
            <isset property="is.running.macos"/>
        </condition>
Now the code is able to be executed but unfortunately, every time jitsi is
connected to another jitsi program (both when receiving and making video
calls) it crashes. Jitsi is able to have text and voice connection, but the
moment the video button is pressed, jitsi crashes. On Mac it says, "Jitsi
quit unexpectedly while using the liblwawt.dylib plug-in."

Attached is the zip file created when "Archive Logs" button is pressed.

Thank you.

Regards;
Rosnin Mustaffa

On Thu, Oct 17, 2013 at 2:14 AM, Lyubomir Marinov < > lyubomir.marinov@jitsi.org> wrote:

2013/10/16 Rosnin Bin Mustaffa <rosninm@gmail.com>:
> fail in run. It states;
> [java] Error occurred during initialization of VM
> [java] Could not find agent library AEGetURLEventHandlerAgent on the
library
> path, with error: dlopen(libAEGetURLEventHandlerAgent.dybib, 1) image
not
> found

You're unlikely to benefit from AEGetURLEventHandlerAgent if you're
starting Jitsi (from source) with "ant run" so you may delete
"-agentlib:AEGetURLEventHandlerAgent" from build.xml.


#6

Thank you for the feedback!

We are experiencing a crash in the video functionality on Java 7 + OS
X as well. We will be trying to fix it soon.

In the meantime, Java 6 should allow the application to function as expected.


#7

Thanks, will download JDK6 and try it out.

Regards;
Rosnin Mustaffa

···

On Thu, Oct 31, 2013 at 3:13 PM, Lyubomir Marinov < lyubomir.marinov@jitsi.org> wrote:

Thank you for the feedback!

We are experiencing a crash in the video functionality on Java 7 + OS
X as well. We will be trying to fix it soon.

In the meantime, Java 6 should allow the application to function as
expected.


#8

Thanks all, I uninstalled JDK7 and have Jitsi with JDK6 and now I manage
to get the code working on NetBeans on Mac.
Just wanted to know is there any simplified Jitsi that only caters for SIP
protocol only.

Regards;
Rosnin Mustaffa

···

On Thu, Oct 31, 2013 at 3:20 PM, Rosnin Bin Mustaffa <rosninm@gmail.com>wrote:

Thanks, will download JDK6 and try it out.

Regards;
Rosnin Mustaffa

On Thu, Oct 31, 2013 at 3:13 PM, Lyubomir Marinov < > lyubomir.marinov@jitsi.org> wrote:

Thank you for the feedback!

We are experiencing a crash in the video functionality on Java 7 + OS
X as well. We will be trying to fix it soon.

In the meantime, Java 6 should allow the application to function as
expected.