[jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi


#1

Hi, I am running into sip calling problem. I have a server with jitsi-meet installed, and configured jigasi on the same server in order to get SIP call working. When calling a phone from jitsi-meet’s web browser user interface. The desktop is caller, and the phone is callee. The callee can NOT hear what is the caller saying. But the caller can hear callee very well.

And I tried jitisi, the desktop application. Everything works fine. Both caller and callee can hear each other clearly.

I am newbie to this tool. Is there anyone have the same problem like me? Or is there anyway for me to get rid this problem? Thanks a lot.

···

--

Respects,

Colin


#2

Hi,

Check the codecs priority you use in jigasi and the codecs in jitsi
desktop and make sure they are the same.

Regards
damencho

···

On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:

Hi, I am running into sip calling problem. I have a server with jitsi-meet
installed, and configured jigasi on the same server in order to get SIP call
working. When calling a phone from jitsi-meet’s web browser user interface.
The desktop is caller, and the phone is callee. The callee can NOT hear what
is the caller saying. But the caller can hear callee very well.

And I tried jitisi, the desktop application. Everything works fine. Both
caller and callee can hear each other clearly.

I am newbie to this tool. Is there anyone have the same problem like me? Or
is there anyway for me to get rid this problem? Thanks a lot.

--

Respects,

Colin

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.

    Hi,
    
    Check the codecs priority you use in jigasi and the codecs in jitsi
    desktop and make sure they are the same.
    
    Regards
    damencho

···

On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > installed, and configured jigasi on the same server in order to get SIP call
    > working. When calling a phone from jitsi-meet’s web browser user interface.
    > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > is the caller saying. But the caller can hear callee very well.
    >
    >
    >
    > And I tried jitisi, the desktop application. Everything works fine. Both
    > caller and callee can hear each other clearly.
    >
    >
    >
    > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > is there anyway for me to get rid this problem? Thanks a lot.
    >
    >
    >
    > --
    >
    > Respects,
    >
    > Colin
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users


#4

Well if you tried jitsi desktop and it works fine, make sure you use
the same settings in jigasi.

···

On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:

Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.

On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Hi,

    Check the codecs priority you use in jigasi and the codecs in jitsi
    desktop and make sure they are the same.

    Regards
    damencho

    On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > installed, and configured jigasi on the same server in order to get SIP call
    > working. When calling a phone from jitsi-meet’s web browser user interface.
    > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > is the caller saying. But the caller can hear callee very well.
    >
    >
    >
    > And I tried jitisi, the desktop application. Everything works fine. Both
    > caller and callee can hear each other clearly.
    >
    >
    >
    > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > is there anyway for me to get rid this problem? Thanks a lot.
    >
    >
    >
    > --
    >
    > Respects,
    >
    > Colin
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

···

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > > installed, and configured jigasi on the same server in order to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser user interface.
    > > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users


#6

Yes.

···

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > Thanks, any suggestions on the codec order? And is there any codec
recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in
jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > > Hi, I am running into sip calling problem. I have a server
with jitsi-meet
    > > installed, and configured jigasi on the same server in order
to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser
user interface.
    > > The desktop is caller, and the phone is callee. The callee can
NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works
fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same
problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Thanks, I’ve tried changing the encoding, no luck yet. The installation is inside a virtual machine. I wonder whether audio device(hardware) or any other audio component in linux OS will cause the problem? Any idea?

···

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov <damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Saturday, 2 September 2017 at 10:17 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > > installed, and configured jigasi on the same server in order to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser user interface.
    > > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users


#8

Hello,
     We used to ask you before the colleague, I would like to continue to
explain the reasons for the problem, we use the local mac computer jisti
desktop version of the dial is no problem, but in the same local network to
build a jisti server problem using jigasi and is The same service providers
will appear one end of the sound intermittent, from the local server to sip
server packet loss rate% 97. But in the local mac desktop version is no
problem. What is the problem may be caused?
<http://www.mydreamplus.com/>
李云
运维工程师
M +86 186-1261-5725
北京梦想加信息技术有限公司
百子湾路29号i工厂文化产业园壹号库

···

---------- Forwarded message ----------
From: Colin Zou <zoukaiping@gmail.com>
Date: Mon, Sep 4, 2017 at 9:26 AM
Subject: FW: [jitsi-users] Help please: call real phone via sip provider
inside jitsi desktop application was fine, but it was awful in jigasi
To: 李云 <li.yun@mydreamplus.com>

FYI

*From: *users <users-bounces@jitsi.org> on behalf of Damian Minkov <
damencho@damencho.com>
*Reply-To: *Jitsi Users <users@jitsi.org>
*Date: *Saturday, 2 September 2017 at 10:17 PM
*To: *Jitsi Users <users@jitsi.org>
*Subject: *Re: [jitsi-users] Help please: call real phone via sip provider
inside jitsi desktop application was fine, but it was awful in jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec
recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in
jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, I am running into sip calling problem. I have a server with
jitsi-meet
    > > installed, and configured jigasi on the same server in order to
get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser
user interface.
    > > The desktop is caller, and the phone is callee. The callee can
NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works
fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem
like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

FYI: I am trying the unstable version. Tried changing the encoding priorities, and the code sticky to encoding iLBC/8000. No matter what changes I’ve made to the encoding setup.

···

From: Colin Zou <zoukaiping@gmail.com>
Date: Wednesday, 6 September 2017 at 2:47 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Thanks, I’ve tried changing the encoding, no luck yet. The installation is inside a virtual machine. I wonder whether audio device(hardware) or any other audio component in linux OS will cause the problem? Any idea?

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov <damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Saturday, 2 September 2017 at 10:17 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > > installed, and configured jigasi on the same server in order to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser user interface.
    > > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users


#10

Can you post your config or send it directly to me?

···

On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:

FYI: I am trying the unstable version. Tried changing the encoding
priorities, and the code sticky to encoding iLBC/8000. No matter what
changes I’ve made to the encoding setup.

*From: *Colin Zou <zoukaiping@gmail.com>
*Date: *Wednesday, 6 September 2017 at 2:47 PM
*To: *Jitsi Users <users@jitsi.org>
*Subject: *Re: [jitsi-users] Help please: call real phone via sip
provider inside jitsi desktop application was fine, but it was awful in
jigasi

Thanks, I’ve tried changing the encoding, no luck yet. The installation is
inside a virtual machine. I wonder whether audio device(hardware) or any
other audio component in linux OS will cause the problem? Any idea?

*From: *users <users-bounces@jitsi.org> on behalf of Damian Minkov <
damencho@damencho.com>
*Reply-To: *Jitsi Users <users@jitsi.org>
*Date: *Saturday, 2 September 2017 at 10:17 PM
*To: *Jitsi Users <users@jitsi.org>
*Subject: *Re: [jitsi-users] Help please: call real phone via sip
provider inside jitsi desktop application was fine, but it was awful in
jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > Thanks, any suggestions on the codec order? And is there any codec
recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <
users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in
jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > > Hi, I am running into sip calling problem. I have a server
with jitsi-meet
    > > installed, and configured jigasi on the same server in order
to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser
user interface.
    > > The desktop is caller, and the phone is callee. The callee can
NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works
fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same
problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

Here’s the configuration file we are using.

#Sample config with one XMPP and one SIP account configured

# Replace {sip-pass-hash} with SIP user password hash

# as well as other account properties

# Name of default JVB room that will be joined if no special header is included

# in SIP invite

sip-communicator.properties (6.28 KB)

···

#####

net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false

net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false

#####

org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode

#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity

net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false

# Disables packet logging

net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true

net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false

net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false

net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false

net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060

net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060

net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false

# Used when incoming calls are used in multidomain environment, used to detect subdomains

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>

# the pattern to be used as bosh url when using bosh in multidomain environment

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true

# We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the

# properties that will be used for creating xmpp account for communication.

# The following two props assume we are using jigasi on the same machine as

# the xmpp server.

org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true

org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1

org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

#Used when outgoing calls are used in multidomain environment, used to detect subdomains

#org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>

#org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.

#org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true

# If you want jigasi to perform authenticated login instead of anonymous login

# to the XMPP server, you can set the following properties.

# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN

# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS

org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true

# org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}

# If you want to use the SIP user part of the incoming/outgoing call SIP URI

# you can set the following property to true.

# org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true

# Activate this property if you are using self-signed certificates or other

# type of non-trusted certicates. In this mode your service trust in the

# remote certificates always.

# net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

# Enable this property to be able to shutdown gracefully jigasi using

# a rest command

# org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov <damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Wednesday, 6 September 2017 at 9:51 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Can you post your config or send it directly to me?

On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:

FYI: I am trying the unstable version. Tried changing the encoding priorities, and the code sticky to encoding iLBC/8000. No matter what changes I’ve made to the encoding setup.

From: Colin Zou <zoukaiping@gmail.com>
Date: Wednesday, 6 September 2017 at 2:47 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Thanks, I’ve tried changing the encoding, no luck yet. The installation is inside a virtual machine. I wonder whether audio device(hardware) or any other audio component in linux OS will cause the problem? Any idea?

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov <damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Saturday, 2 September 2017 at 10:17 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider inside jitsi desktop application was fine, but it was awful in jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, I am running into sip calling problem. I have a server with jitsi-meet
    > > installed, and configured jigasi on the same server in order to get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser user interface.
    > > The desktop is caller, and the phone is callee. The callee can NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list users@jitsi.org Unsubscribe instructions and other list options: http://lists.jitsi.org/mailman/listinfo/users


#12

Hi,

Can you set all the encodings, switch off whatever you don't need.
You are overriding just g722 and leaving the rest with default values
and apparently, it uses the wrong codec.

Regards
damencho

···

On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:

Here’s the configuration file we are using.

#Sample config with one XMPP and one SIP account configured

# Replace {sip-pass-hash} with SIP user password hash

# as well as other account properties

# Name of default JVB room that will be joined if no special header is
included

# in SIP invite

#####

net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false

net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false

#####

org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode

#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity

net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false

# Disables packet logging

net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true

net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false

net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false

net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false

net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com

net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060

net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP

net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060

net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060

net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false

# Used when incoming calls are used in multidomain environment, used to
detect subdomains

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>

# the pattern to be used as bosh url when using bosh in multidomain
environment

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act
as jvb, just forward every ssrc stream it receives.

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true

# We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the

# properties that will be used for creating xmpp account for communication.

# The following two props assume we are using jigasi on the same machine as

# the xmpp server.

org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true

org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1

org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

#Used when outgoing calls are used in multidomain environment, used to
detect subdomains

#org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>

#org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act
as jvb, just forward every ssrc stream it receives.

#org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true

# If you want jigasi to perform authenticated login instead of anonymous
login

# to the XMPP server, you can set the following properties.

# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN

# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS

org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true

#
org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}

# If you want to use the SIP user part of the incoming/outgoing call SIP URI

# you can set the following property to true.

# org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true

# Activate this property if you are using self-signed certificates or other

# type of non-trusted certicates. In this mode your service trust in the

# remote certificates always.

# net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

# Enable this property to be able to shutdown gracefully jigasi using

# a rest command

# org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
<damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Wednesday, 6 September 2017 at 9:51 PM

To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider
inside jitsi desktop application was fine, but it was awful in jigasi

Can you post your config or send it directly to me?

On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:

FYI: I am trying the unstable version. Tried changing the encoding
priorities, and the code sticky to encoding iLBC/8000. No matter what
changes I’ve made to the encoding setup.

From: Colin Zou <zoukaiping@gmail.com>
Date: Wednesday, 6 September 2017 at 2:47 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider
inside jitsi desktop application was fine, but it was awful in jigasi

Thanks, I’ve tried changing the encoding, no luck yet. The installation is
inside a virtual machine. I wonder whether audio device(hardware) or any
other audio component in linux OS will cause the problem? Any idea?

From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
<damencho@damencho.com>
Reply-To: Jitsi Users <users@jitsi.org>
Date: Saturday, 2 September 2017 at 10:17 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Help please: call real phone via sip provider
inside jitsi desktop application was fine, but it was awful in jigasi

Yes.

On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:

Thanks, where is the priority. Is it the number after “=” ?

Encodings.AMR-WB/16000=0
Encodings.G722/8000=705
Encodings.GSM/8000=450
Encodings.H264/90000=1100
Encodings.PCMA/8000=600
Encodings.PCMU/8000=650
Encodings.SILK/12000=0
Encodings.SILK/16000=713
Encodings.SILK/24000=714
Encodings.SILK/8000=0
Encodings.VP8/90000=0
Encodings.iLBC/8000=500
Encodings.opus/48000=750
Encodings.red/90000=0
Encodings.rtx/90000=0
Encodings.speex/16000=700
Encodings.speex/32000=701
Encodings.speex/8000=352
Encodings.telephone-event/8000=1
Encodings.ulpfec/90000=0

On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
<users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Well if you tried jitsi desktop and it works fine, make sure you use
    the same settings in jigasi.

    On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Thanks, any suggestions on the codec order? And is there any codec
recommended? I was trying a lot, but still had not figured it out yet.
    >
    > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
<users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Check the codecs priority you use in jigasi and the codecs in
jitsi
    > desktop and make sure they are the same.
    >
    > Regards
    > damencho
    >
    >
    > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > > Hi, I am running into sip calling problem. I have a server with
jitsi-meet
    > > installed, and configured jigasi on the same server in order to
get SIP call
    > > working. When calling a phone from jitsi-meet’s web browser user
interface.
    > > The desktop is caller, and the phone is callee. The callee can
NOT hear what
    > > is the caller saying. But the caller can hear callee very well.
    > >
    > >
    > >
    > > And I tried jitisi, the desktop application. Everything works
fine. Both
    > > caller and callee can hear each other clearly.
    > >
    > >
    > >
    > > I am newbie to this tool. Is there anyone have the same problem
like me? Or
    > > is there anyway for me to get rid this problem? Thanks a lot.
    > >
    > >
    > >
    > > --
    > >
    > > Respects,
    > >
    > > Colin
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

Thanks, how can I switch a codec off? By setting the value to zero?

    Hi,
    
    Can you set all the encodings, switch off whatever you don't need.
    You are overriding just g722 and leaving the rest with default values
    and apparently, it uses the wrong codec.
    
    Regards
    damencho

···

On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Here’s the configuration file we are using.
    >
    >
    >
    > #Sample config with one XMPP and one SIP account configured
    >
    > # Replace {sip-pass-hash} with SIP user password hash
    >
    > # as well as other account properties
    >
    >
    >
    > # Name of default JVB room that will be joined if no special header is
    > included
    >
    > # in SIP invite
    >
    >
    >
    > #####
    >
    > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    >
    > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    >
    > #####
    >
    >
    >
    > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    >
    >
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    >
    >
    >
    > # Should be enabled when using translator mode
    >
    > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    >
    >
    >
    > # Adjust opus encoder complexity
    >
    > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    >
    > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    >
    >
    >
    > # Disables packet logging
    >
    > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    >
    >
    >
    >
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    >
    >
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    >
    >
    >
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    >
    > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    >
    > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    >
    > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    >
    > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    >
    > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    >
    > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    >
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    >
    > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    >
    > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    >
    >
    >
    > # Used when incoming calls are used in multidomain environment, used to
    > detect subdomains
    >
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    >
    > # the pattern to be used as bosh url when using bosh in multidomain
    > environment
    >
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    >
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act
    > as jvb, just forward every ssrc stream it receives.
    >
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    >
    >
    > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    >
    > # properties that will be used for creating xmpp account for communication.
    >
    >
    >
    > # The following two props assume we are using jigasi on the same machine as
    >
    > # the xmpp server.
    >
    > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    >
    > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    >
    > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    >
    >
    >
    > #Used when outgoing calls are used in multidomain environment, used to
    > detect subdomains
    >
    > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    >
    > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    >
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act
    > as jvb, just forward every ssrc stream it receives.
    >
    > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    >
    >
    > # If you want jigasi to perform authenticated login instead of anonymous
    > login
    >
    > # to the XMPP server, you can set the following properties.
    >
    > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    >
    > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    >
    > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    >
    > #
    > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    >
    >
    >
    > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    >
    > # you can set the following property to true.
    >
    > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    >
    >
    >
    > # Activate this property if you are using self-signed certificates or other
    >
    > # type of non-trusted certicates. In this mode your service trust in the
    >
    > # remote certificates always.
    >
    > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    >
    >
    >
    > # Enable this property to be able to shutdown gracefully jigasi using
    >
    > # a rest command
    >
    > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    >
    >
    >
    >
    >
    >
    >
    > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > <damencho@damencho.com>
    > Reply-To: Jitsi Users <users@jitsi.org>
    > Date: Wednesday, 6 September 2017 at 9:51 PM
    >
    >
    > To: Jitsi Users <users@jitsi.org>
    > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > inside jitsi desktop application was fine, but it was awful in jigasi
    >
    >
    >
    > Can you post your config or send it directly to me?
    >
    >
    >
    > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    >
    > FYI: I am trying the unstable version. Tried changing the encoding
    > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > changes I’ve made to the encoding setup.
    >
    >
    >
    > From: Colin Zou <zoukaiping@gmail.com>
    > Date: Wednesday, 6 September 2017 at 2:47 PM
    > To: Jitsi Users <users@jitsi.org>
    > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > inside jitsi desktop application was fine, but it was awful in jigasi
    >
    >
    >
    > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > inside a virtual machine. I wonder whether audio device(hardware) or any
    > other audio component in linux OS will cause the problem? Any idea?
    >
    >
    >
    > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > <damencho@damencho.com>
    > Reply-To: Jitsi Users <users@jitsi.org>
    > Date: Saturday, 2 September 2017 at 10:17 PM
    > To: Jitsi Users <users@jitsi.org>
    > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > inside jitsi desktop application was fine, but it was awful in jigasi
    >
    >
    >
    > Yes.
    >
    >
    >
    > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    >
    > Thanks, where is the priority. Is it the number after “=” ?
    >
    > Encodings.AMR-WB/16000=0
    > Encodings.G722/8000=705
    > Encodings.GSM/8000=450
    > Encodings.H264/90000=1100
    > Encodings.PCMA/8000=600
    > Encodings.PCMU/8000=650
    > Encodings.SILK/12000=0
    > Encodings.SILK/16000=713
    > Encodings.SILK/24000=714
    > Encodings.SILK/8000=0
    > Encodings.VP8/90000=0
    > Encodings.iLBC/8000=500
    > Encodings.opus/48000=750
    > Encodings.red/90000=0
    > Encodings.rtx/90000=0
    > Encodings.speex/16000=700
    > Encodings.speex/32000=701
    > Encodings.speex/8000=352
    > Encodings.telephone-event/8000=1
    > Encodings.ulpfec/90000=0
    >
    > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Well if you tried jitsi desktop and it works fine, make sure you use
    > the same settings in jigasi.
    >
    > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Thanks, any suggestions on the codec order? And is there any codec
    > recommended? I was trying a lot, but still had not figured it out yet.
    > >
    > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > Hi,
    > >
    > > Check the codecs priority you use in jigasi and the codecs in
    > jitsi
    > > desktop and make sure they are the same.
    > >
    > > Regards
    > > damencho
    > >
    > >
    > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
    > > > Hi, I am running into sip calling problem. I have a server with
    > jitsi-meet
    > > > installed, and configured jigasi on the same server in order to
    > get SIP call
    > > > working. When calling a phone from jitsi-meet’s web browser user
    > interface.
    > > > The desktop is caller, and the phone is callee. The callee can
    > NOT hear what
    > > > is the caller saying. But the caller can hear callee very well.
    > > >
    > > >
    > > >
    > > > And I tried jitisi, the desktop application. Everything works
    > fine. Both
    > > > caller and callee can hear each other clearly.
    > > >
    > > >
    > > >
    > > > I am newbie to this tool. Is there anyone have the same problem
    > like me? Or
    > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > >
    > > >
    > > >
    > > > --
    > > >
    > > > Respects,
    > > >
    > > > Colin
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________ users mailing list
    > users@jitsi.org Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________ users mailing list
    > users@jitsi.org Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users


#14

Hi, thank you for your info.

We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.

What shall we try next?

#Sample config with one XMPP and one SIP account configured
# Replace {sip-pass-hash} with SIP user password hash
# as well as other account properties

# Name of default JVB room that will be joined if no special header is included
# in SIP invite

···

#####
net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
#####

org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode
#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

# Disables packet logging
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602

net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false

# Used when incoming calls are used in multidomain environment, used to detect subdomains
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
# the pattern to be used as bosh url when using bosh in multidomain environment
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true

# We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
# properties that will be used for creating xmpp account for communication.

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

#Used when outgoing calls are used in multidomain environment, used to detect subdomains
#org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
#org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
#org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true

# If you want jigasi to perform authenticated login instead of anonymous login
# to the XMPP server, you can set the following properties.
# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
# org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}

# If you want to use the SIP user part of the incoming/outgoing call SIP URI
# you can set the following property to true.
# org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true

# Activate this property if you are using self-signed certificates or other
# type of non-trusted certicates. In this mode your service trust in the
# remote certificates always.
# net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

# Enable this property to be able to shutdown gracefully jigasi using
# a rest command
# org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true

On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:

    Thanks, how can I switch a codec off? By setting the value to zero?
    
    On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
        Hi,
        
        Can you set all the encodings, switch off whatever you don't need.
        You are overriding just g722 and leaving the rest with default values
        and apparently, it uses the wrong codec.
        
        Regards
        damencho
        
        On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
        > Here’s the configuration file we are using.
        >
        >
        >
        > #Sample config with one XMPP and one SIP account configured
        >
        > # Replace {sip-pass-hash} with SIP user password hash
        >
        > # as well as other account properties
        >
        >
        >
        > # Name of default JVB room that will be joined if no special header is
        > included
        >
        > # in SIP invite
        >
        >
        >
        > #####
        >
        > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
        >
        > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
        >
        > #####
        >
        >
        >
        > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
        >
        >
        >
        > # Should be enabled when using translator mode
        >
        > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
        >
        >
        >
        > # Adjust opus encoder complexity
        >
        > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
        >
        > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
        >
        >
        >
        > # Disables packet logging
        >
        > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
        >
        >
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
        >
        > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
        >
        > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
        >
        > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
        >
        >
        >
        > # Used when incoming calls are used in multidomain environment, used to
        > detect subdomains
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
        >
        > # the pattern to be used as bosh url when using bosh in multidomain
        > environment
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
        >
        >
        >
        > # can be enabled to disable audio mixing and use translator, jigasi will act
        > as jvb, just forward every ssrc stream it receives.
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
        >
        >
        >
        > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
        >
        > # properties that will be used for creating xmpp account for communication.
        >
        >
        >
        > # The following two props assume we are using jigasi on the same machine as
        >
        > # the xmpp server.
        >
        > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
        >
        > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
        >
        > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
        >
        >
        >
        > #Used when outgoing calls are used in multidomain environment, used to
        > detect subdomains
        >
        > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
        >
        > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
        >
        >
        >
        > # can be enabled to disable audio mixing and use translator, jigasi will act
        > as jvb, just forward every ssrc stream it receives.
        >
        > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
        >
        >
        >
        > # If you want jigasi to perform authenticated login instead of anonymous
        > login
        >
        > # to the XMPP server, you can set the following properties.
        >
        > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
        >
        > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
        >
        > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
        >
        > #
        > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
        >
        >
        >
        > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
        >
        > # you can set the following property to true.
        >
        > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
        >
        >
        >
        > # Activate this property if you are using self-signed certificates or other
        >
        > # type of non-trusted certicates. In this mode your service trust in the
        >
        > # remote certificates always.
        >
        > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
        >
        >
        >
        > # Enable this property to be able to shutdown gracefully jigasi using
        >
        > # a rest command
        >
        > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
        >
        >
        >
        >
        >
        >
        >
        > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
        > <damencho@damencho.com>
        > Reply-To: Jitsi Users <users@jitsi.org>
        > Date: Wednesday, 6 September 2017 at 9:51 PM
        >
        >
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Can you post your config or send it directly to me?
        >
        >
        >
        > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
        >
        > FYI: I am trying the unstable version. Tried changing the encoding
        > priorities, and the code sticky to encoding iLBC/8000. No matter what
        > changes I’ve made to the encoding setup.
        >
        >
        >
        > From: Colin Zou <zoukaiping@gmail.com>
        > Date: Wednesday, 6 September 2017 at 2:47 PM
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
        > inside a virtual machine. I wonder whether audio device(hardware) or any
        > other audio component in linux OS will cause the problem? Any idea?
        >
        >
        >
        > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
        > <damencho@damencho.com>
        > Reply-To: Jitsi Users <users@jitsi.org>
        > Date: Saturday, 2 September 2017 at 10:17 PM
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Yes.
        >
        >
        >
        > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
        >
        > Thanks, where is the priority. Is it the number after “=” ?
        >
        > Encodings.AMR-WB/16000=0
        > Encodings.G722/8000=705
        > Encodings.GSM/8000=450
        > Encodings.H264/90000=1100
        > Encodings.PCMA/8000=600
        > Encodings.PCMU/8000=650
        > Encodings.SILK/12000=0
        > Encodings.SILK/16000=713
        > Encodings.SILK/24000=714
        > Encodings.SILK/8000=0
        > Encodings.VP8/90000=0
        > Encodings.iLBC/8000=500
        > Encodings.opus/48000=750
        > Encodings.red/90000=0
        > Encodings.rtx/90000=0
        > Encodings.speex/16000=700
        > Encodings.speex/32000=701
        > Encodings.speex/8000=352
        > Encodings.telephone-event/8000=1
        > Encodings.ulpfec/90000=0
        >
        > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
        > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
        >
        > Well if you tried jitsi desktop and it works fine, make sure you use
        > the same settings in jigasi.
        >
        > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
        > > Thanks, any suggestions on the codec order? And is there any codec
        > recommended? I was trying a lot, but still had not figured it out yet.
        > >
        > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
        > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
        > >
        > > Hi,
        > >
        > > Check the codecs priority you use in jigasi and the codecs in
        > jitsi
        > > desktop and make sure they are the same.
        > >
        > > Regards
        > > damencho
        > >
        > >
        > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > wrote:
        > > > Hi, I am running into sip calling problem. I have a server with
        > jitsi-meet
        > > > installed, and configured jigasi on the same server in order to
        > get SIP call
        > > > working. When calling a phone from jitsi-meet’s web browser user
        > interface.
        > > > The desktop is caller, and the phone is callee. The callee can
        > NOT hear what
        > > > is the caller saying. But the caller can hear callee very well.
        > > >
        > > >
        > > >
        > > > And I tried jitisi, the desktop application. Everything works
        > fine. Both
        > > > caller and callee can hear each other clearly.
        > > >
        > > >
        > > >
        > > > I am newbie to this tool. Is there anyone have the same problem
        > like me? Or
        > > > is there anyway for me to get rid this problem? Thanks a lot.
        > > >
        > > >
        > > >
        > > > --
        > > >
        > > > Respects,
        > > >
        > > > Colin
        > > >
        > > >
        > > > _______________________________________________
        > > > users mailing list
        > > > users@jitsi.org
        > > > Unsubscribe instructions and other list options:
        > > > http://lists.jitsi.org/mailman/listinfo/users
        > >
        > > _______________________________________________
        > > users mailing list
        > > users@jitsi.org
        > > Unsubscribe instructions and other list options:
        > > http://lists.jitsi.org/mailman/listinfo/users
        > >
        > >
        > >
        > > _______________________________________________
        > > users mailing list
        > > users@jitsi.org
        > > Unsubscribe instructions and other list options:
        > > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________ users mailing list
        > users@jitsi.org Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________ users mailing list
        > users@jitsi.org Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        
        _______________________________________________
        users mailing list
        users@jitsi.org
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users


#15

What are the codecs supported by your sip side?
The best quality you will get from these: G722 PCMA PCMU, but for PCMA
and PCMU you need a very good connection between jigasi and the sip
side.

Maybe attaching the jigasi logs, that includes the pcap files will help.

Regards
damencho

···

On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:

Hi, thank you for your info.

We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.

What shall we try next?

#Sample config with one XMPP and one SIP account configured
# Replace {sip-pass-hash} with SIP user password hash
# as well as other account properties

# Name of default JVB room that will be joined if no special header is included
# in SIP invite

#####
net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
#####

org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode
#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

# Disables packet logging
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602

net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false

# Used when incoming calls are used in multidomain environment, used to detect subdomains
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
# the pattern to be used as bosh url when using bosh in multidomain environment
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true

# We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
# properties that will be used for creating xmpp account for communication.

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

#Used when outgoing calls are used in multidomain environment, used to detect subdomains
#org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
#org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}

# can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
#org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true

# If you want jigasi to perform authenticated login instead of anonymous login
# to the XMPP server, you can set the following properties.
# org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
# org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
# org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}

# If you want to use the SIP user part of the incoming/outgoing call SIP URI
# you can set the following property to true.
# org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true

# Activate this property if you are using self-signed certificates or other
# type of non-trusted certicates. In this mode your service trust in the
# remote certificates always.
# net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

# Enable this property to be able to shutdown gracefully jigasi using
# a rest command
# org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true

On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:

    Thanks, how can I switch a codec off? By setting the value to zero?

    On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

        Hi,

        Can you set all the encodings, switch off whatever you don't need.
        You are overriding just g722 and leaving the rest with default values
        and apparently, it uses the wrong codec.

        Regards
        damencho

        On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
        > Here’s the configuration file we are using.
        >
        >
        >
        > #Sample config with one XMPP and one SIP account configured
        >
        > # Replace {sip-pass-hash} with SIP user password hash
        >
        > # as well as other account properties
        >
        >
        >
        > # Name of default JVB room that will be joined if no special header is
        > included
        >
        > # in SIP invite
        >
        >
        >
        > #####
        >
        > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
        >
        > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
        >
        > #####
        >
        >
        >
        > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
        >
        >
        >
        > # Should be enabled when using translator mode
        >
        > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
        >
        >
        >
        > # Adjust opus encoder complexity
        >
        > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
        >
        > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
        >
        >
        >
        > # Disables packet logging
        >
        > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
        >
        >
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
        >
        >
        >
        >
        >
        > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
        >
        > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
        >
        > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
        >
        > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
        >
        > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
        >
        > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
        >
        > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
        >
        >
        >
        > # Used when incoming calls are used in multidomain environment, used to
        > detect subdomains
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
        >
        > # the pattern to be used as bosh url when using bosh in multidomain
        > environment
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
        >
        >
        >
        > # can be enabled to disable audio mixing and use translator, jigasi will act
        > as jvb, just forward every ssrc stream it receives.
        >
        > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
        >
        >
        >
        > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
        >
        > # properties that will be used for creating xmpp account for communication.
        >
        >
        >
        > # The following two props assume we are using jigasi on the same machine as
        >
        > # the xmpp server.
        >
        > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
        >
        > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
        >
        > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
        >
        >
        >
        > #Used when outgoing calls are used in multidomain environment, used to
        > detect subdomains
        >
        > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
        >
        > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
        >
        >
        >
        > # can be enabled to disable audio mixing and use translator, jigasi will act
        > as jvb, just forward every ssrc stream it receives.
        >
        > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
        >
        >
        >
        > # If you want jigasi to perform authenticated login instead of anonymous
        > login
        >
        > # to the XMPP server, you can set the following properties.
        >
        > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
        >
        > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
        >
        > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
        >
        > #
        > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
        >
        >
        >
        > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
        >
        > # you can set the following property to true.
        >
        > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
        >
        >
        >
        > # Activate this property if you are using self-signed certificates or other
        >
        > # type of non-trusted certicates. In this mode your service trust in the
        >
        > # remote certificates always.
        >
        > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
        >
        >
        >
        > # Enable this property to be able to shutdown gracefully jigasi using
        >
        > # a rest command
        >
        > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
        >
        >
        >
        >
        >
        >
        >
        > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
        > <damencho@damencho.com>
        > Reply-To: Jitsi Users <users@jitsi.org>
        > Date: Wednesday, 6 September 2017 at 9:51 PM
        >
        >
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Can you post your config or send it directly to me?
        >
        >
        >
        > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
        >
        > FYI: I am trying the unstable version. Tried changing the encoding
        > priorities, and the code sticky to encoding iLBC/8000. No matter what
        > changes I’ve made to the encoding setup.
        >
        >
        >
        > From: Colin Zou <zoukaiping@gmail.com>
        > Date: Wednesday, 6 September 2017 at 2:47 PM
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
        > inside a virtual machine. I wonder whether audio device(hardware) or any
        > other audio component in linux OS will cause the problem? Any idea?
        >
        >
        >
        > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
        > <damencho@damencho.com>
        > Reply-To: Jitsi Users <users@jitsi.org>
        > Date: Saturday, 2 September 2017 at 10:17 PM
        > To: Jitsi Users <users@jitsi.org>
        > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
        > inside jitsi desktop application was fine, but it was awful in jigasi
        >
        >
        >
        > Yes.
        >
        >
        >
        > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
        >
        > Thanks, where is the priority. Is it the number after “=” ?
        >
        > Encodings.AMR-WB/16000=0
        > Encodings.G722/8000=705
        > Encodings.GSM/8000=450
        > Encodings.H264/90000=1100
        > Encodings.PCMA/8000=600
        > Encodings.PCMU/8000=650
        > Encodings.SILK/12000=0
        > Encodings.SILK/16000=713
        > Encodings.SILK/24000=714
        > Encodings.SILK/8000=0
        > Encodings.VP8/90000=0
        > Encodings.iLBC/8000=500
        > Encodings.opus/48000=750
        > Encodings.red/90000=0
        > Encodings.rtx/90000=0
        > Encodings.speex/16000=700
        > Encodings.speex/32000=701
        > Encodings.speex/8000=352
        > Encodings.telephone-event/8000=1
        > Encodings.ulpfec/90000=0
        >
        > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
        > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
        >
        > Well if you tried jitsi desktop and it works fine, make sure you use
        > the same settings in jigasi.
        >
        > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
        > > Thanks, any suggestions on the codec order? And is there any codec
        > recommended? I was trying a lot, but still had not figured it out yet.
        > >
        > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
        > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
        > >
        > > Hi,
        > >
        > > Check the codecs priority you use in jigasi and the codecs in
        > jitsi
        > > desktop and make sure they are the same.
        > >
        > > Regards
        > > damencho
        > >
        > >
        > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > wrote:
        > > > Hi, I am running into sip calling problem. I have a server with
        > jitsi-meet
        > > > installed, and configured jigasi on the same server in order to
        > get SIP call
        > > > working. When calling a phone from jitsi-meet’s web browser user
        > interface.
        > > > The desktop is caller, and the phone is callee. The callee can
        > NOT hear what
        > > > is the caller saying. But the caller can hear callee very well.
        > > >
        > > >
        > > >
        > > > And I tried jitisi, the desktop application. Everything works
        > fine. Both
        > > > caller and callee can hear each other clearly.
        > > >
        > > >
        > > >
        > > > I am newbie to this tool. Is there anyone have the same problem
        > like me? Or
        > > > is there anyway for me to get rid this problem? Thanks a lot.
        > > >
        > > >
        > > >
        > > > --
        > > >
        > > > Respects,
        > > >
        > > > Colin
        > > >
        > > >
        > > > _______________________________________________
        > > > users mailing list
        > > > users@jitsi.org
        > > > Unsubscribe instructions and other list options:
        > > > http://lists.jitsi.org/mailman/listinfo/users
        > >
        > > _______________________________________________
        > > users mailing list
        > > users@jitsi.org
        > > Unsubscribe instructions and other list options:
        > > http://lists.jitsi.org/mailman/listinfo/users
        > >
        > >
        > >
        > > _______________________________________________
        > > users mailing list
        > > users@jitsi.org
        > > Unsubscribe instructions and other list options:
        > > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________ users mailing list
        > users@jitsi.org Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        > _______________________________________________ users mailing list
        > users@jitsi.org Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users
        >
        >
        > _______________________________________________
        > users mailing list
        > users@jitsi.org
        > Unsubscribe instructions and other list options:
        > http://lists.jitsi.org/mailman/listinfo/users

        _______________________________________________
        users mailing list
        users@jitsi.org
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#16

Hi, here were some log lines. The caller can hear callee clearly when calling with jigasi. I called our sip provider, and it supports G711 G712 G722 G729 PCMA PCMU.

2017-09-08 08:20:19.511 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
2017-09-08 08:20:19.517 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides [103->104 ]
2017-09-08 08:20:19.579 INFO: [106] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:19.976 INFO: [84] impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.harvestCandidates().1192 End candidate harvest within 1047 ms
2017-09-08 08:20:20.165 INFO: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().869 Got invite from 37c894df
2017-09-08 08:20:20.166 WARNING: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().874 Calls not initiated from focus are not allowed
2017-09-08 08:20:20.187 SEVERE: [160] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2017-09-08 08:20:20.188 SEVERE: [160] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42c9455
2017-09-08 08:20:20.188 SEVERE: [157] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42c9455

2017-09-08 08:20:20.207 INFO: [106] org.jitsi.jigasi.JvbConference.onJvbCallStarted().687 JVB conference call IN_PROGRESS asda@conference.mxjjitsi.mxj360.com
2017-09-08 08:20:20.221 INFO: [106] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:18612615725@mengxiangjia.s.yunpbx.com
2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:20.223 INFO: [106] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:20.298 WARNING: [106] impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptions().224 No active device for video was found!
2017-09-08 08:20:20.318 INFO: [106] org.jitsi.jigasi.SipGatewaySession.onConferenceCallStarted().405 Created outgoing call to 18612615725 Call: id=15048588202212016160345 peers=1
2017-09-08 08:20:20.318 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting
2017-09-08 08:20:20.331 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.peerStateChanged().914 15e609344a4@callcontrol.mxjjitsi.mxj360.com JVB peer state: net.java.sip.communicator.service.protocol.CallPeerState:Connected
2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().251 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 1595301515 video: null
2017-09-08 08:20:24.866 INFO: [179] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
2017-09-08 08:20:24.867 INFO: [179] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 101=rtpmap:-1 telephone-event/8000;
2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides []
2017-09-08 08:20:25.048 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().660 Sip call IN_PROGRESS: Call: id=15048588202212016160345 peers=1
2017-09-08 08:20:25.049 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().668 SIP call format used: rtpmap:9 G722/8000
2017-09-08 08:20:25.050 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting*
2017-09-08 08:20:25.050 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:25.098 INFO: [60] service.protocol.media.TransportManager.sendHolePunchPacket().534 Send NAT hole punch packets
2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:33.849 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connected
2017-09-08 08:20:33.851 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:35.827 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:35.828 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:35.829 INFO: [62] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:40.988 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:42.668 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:42.678 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().673 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=18612615725 <18612615725@mengxiangjia.s.yunpbx.com>;status=Disconnected
2017-09-08 08:20:42.688 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Disconnected
2017-09-08 08:20:43.058 INFO: [224] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
2017-09-08 08:20:43.059 INFO: [224] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp

    What are the codecs supported by your sip side?
    The best quality you will get from these: G722 PCMA PCMU, but for PCMA
    and PCMU you need a very good connection between jigasi and the sip
    side.
    
    Maybe attaching the jigasi logs, that includes the pcap files will help.
    
    Regards
    damencho

···

On 07/09/2017, 11:47 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, thank you for your info.
    >
    > We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.
    >
    > What shall we try next?
    >
    >
    >
    > #Sample config with one XMPP and one SIP account configured
    > # Replace {sip-pass-hash} with SIP user password hash
    > # as well as other account properties
    >
    > # Name of default JVB room that will be joined if no special header is included
    > # in SIP invite
    >
    > #####
    > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > #####
    >
    > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    >
    >
    > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    >
    > # Should be enabled when using translator mode
    > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    >
    > # Adjust opus encoder complexity
    > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    >
    > # Disables packet logging
    > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    >
    > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
    > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    >
    >
    >
    > # Used when incoming calls are used in multidomain environment, used to detect subdomains
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > # the pattern to be used as bosh url when using bosh in multidomain environment
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > # properties that will be used for creating xmpp account for communication.
    >
    > # The following two props assume we are using jigasi on the same machine as
    > # the xmpp server.
    > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    >
    > #Used when outgoing calls are used in multidomain environment, used to detect subdomains
    > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    > # If you want jigasi to perform authenticated login instead of anonymous login
    > # to the XMPP server, you can set the following properties.
    > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > # org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    >
    > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > # you can set the following property to true.
    > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    >
    > # Activate this property if you are using self-signed certificates or other
    > # type of non-trusted certicates. In this mode your service trust in the
    > # remote certificates always.
    > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    >
    > # Enable this property to be able to shutdown gracefully jigasi using
    > # a rest command
    > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    >
    >
    >
    > On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:
    >
    > Thanks, how can I switch a codec off? By setting the value to zero?
    >
    > On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Can you set all the encodings, switch off whatever you don't need.
    > You are overriding just g722 and leaving the rest with default values
    > and apparently, it uses the wrong codec.
    >
    > Regards
    > damencho
    >
    > On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Here’s the configuration file we are using.
    > >
    > >
    > >
    > > #Sample config with one XMPP and one SIP account configured
    > >
    > > # Replace {sip-pass-hash} with SIP user password hash
    > >
    > > # as well as other account properties
    > >
    > >
    > >
    > > # Name of default JVB room that will be joined if no special header is
    > > included
    > >
    > > # in SIP invite
    > >
    > >
    > >
    > > #####
    > >
    > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > >
    > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > >
    > > #####
    > >
    > >
    > >
    > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > >
    > >
    > >
    > > # Should be enabled when using translator mode
    > >
    > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > >
    > >
    > >
    > > # Adjust opus encoder complexity
    > >
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > >
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    > >
    > >
    > >
    > > # Disables packet logging
    > >
    > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > >
    > >
    > >
    > > # Used when incoming calls are used in multidomain environment, used to
    > > detect subdomains
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > >
    > > # the pattern to be used as bosh url when using bosh in multidomain
    > > environment
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > >
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > as jvb, just forward every ssrc stream it receives.
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > >
    > >
    > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > >
    > > # properties that will be used for creating xmpp account for communication.
    > >
    > >
    > >
    > > # The following two props assume we are using jigasi on the same machine as
    > >
    > > # the xmpp server.
    > >
    > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > >
    > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > >
    > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > >
    > >
    > >
    > > #Used when outgoing calls are used in multidomain environment, used to
    > > detect subdomains
    > >
    > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > >
    > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > >
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > as jvb, just forward every ssrc stream it receives.
    > >
    > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > >
    > >
    > > # If you want jigasi to perform authenticated login instead of anonymous
    > > login
    > >
    > > # to the XMPP server, you can set the following properties.
    > >
    > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > >
    > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > >
    > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > >
    > > #
    > > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > >
    > >
    > >
    > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > >
    > > # you can set the following property to true.
    > >
    > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > >
    > >
    > >
    > > # Activate this property if you are using self-signed certificates or other
    > >
    > > # type of non-trusted certicates. In this mode your service trust in the
    > >
    > > # remote certificates always.
    > >
    > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > >
    > >
    > >
    > > # Enable this property to be able to shutdown gracefully jigasi using
    > >
    > > # a rest command
    > >
    > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > <damencho@damencho.com>
    > > Reply-To: Jitsi Users <users@jitsi.org>
    > > Date: Wednesday, 6 September 2017 at 9:51 PM
    > >
    > >
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Can you post your config or send it directly to me?
    > >
    > >
    > >
    > > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > FYI: I am trying the unstable version. Tried changing the encoding
    > > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > > changes I’ve made to the encoding setup.
    > >
    > >
    > >
    > > From: Colin Zou <zoukaiping@gmail.com>
    > > Date: Wednesday, 6 September 2017 at 2:47 PM
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > > inside a virtual machine. I wonder whether audio device(hardware) or any
    > > other audio component in linux OS will cause the problem? Any idea?
    > >
    > >
    > >
    > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > <damencho@damencho.com>
    > > Reply-To: Jitsi Users <users@jitsi.org>
    > > Date: Saturday, 2 September 2017 at 10:17 PM
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Yes.
    > >
    > >
    > >
    > > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > Thanks, where is the priority. Is it the number after “=” ?
    > >
    > > Encodings.AMR-WB/16000=0
    > > Encodings.G722/8000=705
    > > Encodings.GSM/8000=450
    > > Encodings.H264/90000=1100
    > > Encodings.PCMA/8000=600
    > > Encodings.PCMU/8000=650
    > > Encodings.SILK/12000=0
    > > Encodings.SILK/16000=713
    > > Encodings.SILK/24000=714
    > > Encodings.SILK/8000=0
    > > Encodings.VP8/90000=0
    > > Encodings.iLBC/8000=500
    > > Encodings.opus/48000=750
    > > Encodings.red/90000=0
    > > Encodings.rtx/90000=0
    > > Encodings.speex/16000=700
    > > Encodings.speex/32000=701
    > > Encodings.speex/8000=352
    > > Encodings.telephone-event/8000=1
    > > Encodings.ulpfec/90000=0
    > >
    > > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > Well if you tried jitsi desktop and it works fine, make sure you use
    > > the same settings in jigasi.
    > >
    > > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > Thanks, any suggestions on the codec order? And is there any codec
    > > recommended? I was trying a lot, but still had not figured it out yet.
    > > >
    > > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > >
    > > > Hi,
    > > >
    > > > Check the codecs priority you use in jigasi and the codecs in
    > > jitsi
    > > > desktop and make sure they are the same.
    > > >
    > > > Regards
    > > > damencho
    > > >
    > > >
    > > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > wrote:
    > > > > Hi, I am running into sip calling problem. I have a server with
    > > jitsi-meet
    > > > > installed, and configured jigasi on the same server in order to
    > > get SIP call
    > > > > working. When calling a phone from jitsi-meet’s web browser user
    > > interface.
    > > > > The desktop is caller, and the phone is callee. The callee can
    > > NOT hear what
    > > > > is the caller saying. But the caller can hear callee very well.
    > > > >
    > > > >
    > > > >
    > > > > And I tried jitisi, the desktop application. Everything works
    > > fine. Both
    > > > > caller and callee can hear each other clearly.
    > > > >
    > > > >
    > > > >
    > > > > I am newbie to this tool. Is there anyone have the same problem
    > > like me? Or
    > > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > > >
    > > > >
    > > > >
    > > > > --
    > > > >
    > > > > Respects,
    > > > >
    > > > > Colin
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________ users mailing list
    > > users@jitsi.org Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________ users mailing list
    > > users@jitsi.org Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users


#17

Can you send me the pcap files from /var/log/jitsi/jigasi/log?
So did I understand correctly that the participant on the sip side is
not hearing when using g722?

···

On Fri, Sep 8, 2017 at 3:50 AM, Colin Zou <zoukaiping@gmail.com> wrote:

Hi, here were some log lines. The caller can hear callee clearly when calling with jigasi. I called our sip provider, and it supports G711 G712 G722 G729 PCMA PCMU.

2017-09-08 08:20:19.511 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
2017-09-08 08:20:19.517 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides [103->104 ]
2017-09-08 08:20:19.579 INFO: [106] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:19.976 INFO: [84] impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.harvestCandidates().1192 End candidate harvest within 1047 ms
2017-09-08 08:20:20.165 INFO: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().869 Got invite from 37c894df
2017-09-08 08:20:20.166 WARNING: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().874 Calls not initiated from focus are not allowed
2017-09-08 08:20:20.187 SEVERE: [160] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
2017-09-08 08:20:20.188 SEVERE: [160] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42c9455
2017-09-08 08:20:20.188 SEVERE: [157] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42c9455

2017-09-08 08:20:20.207 INFO: [106] org.jitsi.jigasi.JvbConference.onJvbCallStarted().687 JVB conference call IN_PROGRESS asda@conference.mxjjitsi.mxj360.com
2017-09-08 08:20:20.221 INFO: [106] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:18612615725@mengxiangjia.s.yunpbx.com
2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:20.223 INFO: [106] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:20.298 WARNING: [106] impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptions().224 No active device for video was found!
2017-09-08 08:20:20.318 INFO: [106] org.jitsi.jigasi.SipGatewaySession.onConferenceCallStarted().405 Created outgoing call to 18612615725 Call: id=15048588202212016160345 peers=1
2017-09-08 08:20:20.318 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting
2017-09-08 08:20:20.331 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.peerStateChanged().914 15e609344a4@callcontrol.mxjjitsi.mxj360.com JVB peer state: net.java.sip.communicator.service.protocol.CallPeerState:Connected
2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().251 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 1595301515 video: null
2017-09-08 08:20:24.866 INFO: [179] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
2017-09-08 08:20:24.867 INFO: [179] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 101=rtpmap:-1 telephone-event/8000;
2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides []
2017-09-08 08:20:25.048 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().660 Sip call IN_PROGRESS: Call: id=15048588202212016160345 peers=1
2017-09-08 08:20:25.049 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().668 SIP call format used: rtpmap:9 G722/8000
2017-09-08 08:20:25.050 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting*
2017-09-08 08:20:25.050 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:25.098 INFO: [60] service.protocol.media.TransportManager.sendHolePunchPacket().534 Send NAT hole punch packets
2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:33.849 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connected
2017-09-08 08:20:33.851 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
2017-09-08 08:20:35.827 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:35.828 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:35.829 INFO: [62] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
2017-09-08 08:20:40.988 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:42.668 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
2017-09-08 08:20:42.678 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().673 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=18612615725 <18612615725@mengxiangjia.s.yunpbx.com>;status=Disconnected
2017-09-08 08:20:42.688 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Disconnected
2017-09-08 08:20:43.058 INFO: [224] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
2017-09-08 08:20:43.059 INFO: [224] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp

On 07/09/2017, 11:47 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    What are the codecs supported by your sip side?
    The best quality you will get from these: G722 PCMA PCMU, but for PCMA
    and PCMU you need a very good connection between jigasi and the sip
    side.

    Maybe attaching the jigasi logs, that includes the pcap files will help.

    Regards
    damencho

    On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, thank you for your info.
    >
    > We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.
    >
    > What shall we try next?
    >
    >
    >
    > #Sample config with one XMPP and one SIP account configured
    > # Replace {sip-pass-hash} with SIP user password hash
    > # as well as other account properties
    >
    > # Name of default JVB room that will be joined if no special header is included
    > # in SIP invite
    >
    > #####
    > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > #####
    >
    > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    >
    >
    > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    >
    > # Should be enabled when using translator mode
    > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    >
    > # Adjust opus encoder complexity
    > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    >
    > # Disables packet logging
    > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    >
    >
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    >
    > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
    > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    >
    >
    >
    > # Used when incoming calls are used in multidomain environment, used to detect subdomains
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > # the pattern to be used as bosh url when using bosh in multidomain environment
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > # properties that will be used for creating xmpp account for communication.
    >
    > # The following two props assume we are using jigasi on the same machine as
    > # the xmpp server.
    > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    >
    > #Used when outgoing calls are used in multidomain environment, used to detect subdomains
    > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    >
    > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    >
    > # If you want jigasi to perform authenticated login instead of anonymous login
    > # to the XMPP server, you can set the following properties.
    > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > # org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    >
    > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > # you can set the following property to true.
    > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    >
    > # Activate this property if you are using self-signed certificates or other
    > # type of non-trusted certicates. In this mode your service trust in the
    > # remote certificates always.
    > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    >
    > # Enable this property to be able to shutdown gracefully jigasi using
    > # a rest command
    > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    >
    >
    >
    > On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:
    >
    > Thanks, how can I switch a codec off? By setting the value to zero?
    >
    > On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Hi,
    >
    > Can you set all the encodings, switch off whatever you don't need.
    > You are overriding just g722 and leaving the rest with default values
    > and apparently, it uses the wrong codec.
    >
    > Regards
    > damencho
    >
    > On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Here’s the configuration file we are using.
    > >
    > >
    > >
    > > #Sample config with one XMPP and one SIP account configured
    > >
    > > # Replace {sip-pass-hash} with SIP user password hash
    > >
    > > # as well as other account properties
    > >
    > >
    > >
    > > # Name of default JVB room that will be joined if no special header is
    > > included
    > >
    > > # in SIP invite
    > >
    > >
    > >
    > > #####
    > >
    > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > >
    > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > >
    > > #####
    > >
    > >
    > >
    > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > >
    > >
    > >
    > > # Should be enabled when using translator mode
    > >
    > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > >
    > >
    > >
    > > # Adjust opus encoder complexity
    > >
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > >
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    > >
    > >
    > >
    > > # Disables packet logging
    > >
    > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > >
    > >
    > >
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > >
    > >
    > >
    > > # Used when incoming calls are used in multidomain environment, used to
    > > detect subdomains
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > >
    > > # the pattern to be used as bosh url when using bosh in multidomain
    > > environment
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > >
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > as jvb, just forward every ssrc stream it receives.
    > >
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > >
    > >
    > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > >
    > > # properties that will be used for creating xmpp account for communication.
    > >
    > >
    > >
    > > # The following two props assume we are using jigasi on the same machine as
    > >
    > > # the xmpp server.
    > >
    > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > >
    > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > >
    > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > >
    > >
    > >
    > > #Used when outgoing calls are used in multidomain environment, used to
    > > detect subdomains
    > >
    > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > >
    > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > >
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > as jvb, just forward every ssrc stream it receives.
    > >
    > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > >
    > >
    > > # If you want jigasi to perform authenticated login instead of anonymous
    > > login
    > >
    > > # to the XMPP server, you can set the following properties.
    > >
    > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > >
    > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > >
    > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > >
    > > #
    > > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > >
    > >
    > >
    > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > >
    > > # you can set the following property to true.
    > >
    > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > >
    > >
    > >
    > > # Activate this property if you are using self-signed certificates or other
    > >
    > > # type of non-trusted certicates. In this mode your service trust in the
    > >
    > > # remote certificates always.
    > >
    > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > >
    > >
    > >
    > > # Enable this property to be able to shutdown gracefully jigasi using
    > >
    > > # a rest command
    > >
    > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > <damencho@damencho.com>
    > > Reply-To: Jitsi Users <users@jitsi.org>
    > > Date: Wednesday, 6 September 2017 at 9:51 PM
    > >
    > >
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Can you post your config or send it directly to me?
    > >
    > >
    > >
    > > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > FYI: I am trying the unstable version. Tried changing the encoding
    > > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > > changes I’ve made to the encoding setup.
    > >
    > >
    > >
    > > From: Colin Zou <zoukaiping@gmail.com>
    > > Date: Wednesday, 6 September 2017 at 2:47 PM
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > > inside a virtual machine. I wonder whether audio device(hardware) or any
    > > other audio component in linux OS will cause the problem? Any idea?
    > >
    > >
    > >
    > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > <damencho@damencho.com>
    > > Reply-To: Jitsi Users <users@jitsi.org>
    > > Date: Saturday, 2 September 2017 at 10:17 PM
    > > To: Jitsi Users <users@jitsi.org>
    > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > inside jitsi desktop application was fine, but it was awful in jigasi
    > >
    > >
    > >
    > > Yes.
    > >
    > >
    > >
    > > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > Thanks, where is the priority. Is it the number after “=” ?
    > >
    > > Encodings.AMR-WB/16000=0
    > > Encodings.G722/8000=705
    > > Encodings.GSM/8000=450
    > > Encodings.H264/90000=1100
    > > Encodings.PCMA/8000=600
    > > Encodings.PCMU/8000=650
    > > Encodings.SILK/12000=0
    > > Encodings.SILK/16000=713
    > > Encodings.SILK/24000=714
    > > Encodings.SILK/8000=0
    > > Encodings.VP8/90000=0
    > > Encodings.iLBC/8000=500
    > > Encodings.opus/48000=750
    > > Encodings.red/90000=0
    > > Encodings.rtx/90000=0
    > > Encodings.speex/16000=700
    > > Encodings.speex/32000=701
    > > Encodings.speex/8000=352
    > > Encodings.telephone-event/8000=1
    > > Encodings.ulpfec/90000=0
    > >
    > > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > Well if you tried jitsi desktop and it works fine, make sure you use
    > > the same settings in jigasi.
    > >
    > > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > Thanks, any suggestions on the codec order? And is there any codec
    > > recommended? I was trying a lot, but still had not figured it out yet.
    > > >
    > > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > >
    > > > Hi,
    > > >
    > > > Check the codecs priority you use in jigasi and the codecs in
    > > jitsi
    > > > desktop and make sure they are the same.
    > > >
    > > > Regards
    > > > damencho
    > > >
    > > >
    > > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > > wrote:
    > > > > Hi, I am running into sip calling problem. I have a server with
    > > jitsi-meet
    > > > > installed, and configured jigasi on the same server in order to
    > > get SIP call
    > > > > working. When calling a phone from jitsi-meet’s web browser user
    > > interface.
    > > > > The desktop is caller, and the phone is callee. The callee can
    > > NOT hear what
    > > > > is the caller saying. But the caller can hear callee very well.
    > > > >
    > > > >
    > > > >
    > > > > And I tried jitisi, the desktop application. Everything works
    > > fine. Both
    > > > > caller and callee can hear each other clearly.
    > > > >
    > > > >
    > > > >
    > > > > I am newbie to this tool. Is there anyone have the same problem
    > > like me? Or
    > > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > > >
    > > > >
    > > > >
    > > > > --
    > > > >
    > > > > Respects,
    > > > >
    > > > > Colin
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________ users mailing list
    > > users@jitsi.org Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________ users mailing list
    > > users@jitsi.org Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#18

Exactly, the participant on the sip side hear nothing when using any of G722 PCMA PCMU with jigasi. But everything works fine with jitsi desktop app…

    Can you send me the pcap files from /var/log/jitsi/jigasi/log?
    So did I understand correctly that the participant on the sip side is
    not hearing when using g722?

jigasi-pcap.zip (139 KB)

···

On 08/09/2017, 8:08 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Fri, Sep 8, 2017 at 3:50 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, here were some log lines. The caller can hear callee clearly when calling with jigasi. I called our sip provider, and it supports G711 G712 G722 G729 PCMA PCMU.
    >
    > 2017-09-08 08:20:19.511 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
    > 2017-09-08 08:20:19.517 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides [103->104 ]
    > 2017-09-08 08:20:19.579 INFO: [106] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:19.976 INFO: [84] impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.harvestCandidates().1192 End candidate harvest within 1047 ms
    > 2017-09-08 08:20:20.165 INFO: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().869 Got invite from 37c894df
    > 2017-09-08 08:20:20.166 WARNING: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().874 Calls not initiated from focus are not allowed
    > 2017-09-08 08:20:20.187 SEVERE: [160] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
    > 2017-09-08 08:20:20.188 SEVERE: [160] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42c9455
    > 2017-09-08 08:20:20.188 SEVERE: [157] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42c9455
    >
    > 2017-09-08 08:20:20.207 INFO: [106] org.jitsi.jigasi.JvbConference.onJvbCallStarted().687 JVB conference call IN_PROGRESS asda@conference.mxjjitsi.mxj360.com
    > 2017-09-08 08:20:20.221 INFO: [106] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:18612615725@mengxiangjia.s.yunpbx.com
    > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:20.223 INFO: [106] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:20.298 WARNING: [106] impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptions().224 No active device for video was found!
    > 2017-09-08 08:20:20.318 INFO: [106] org.jitsi.jigasi.SipGatewaySession.onConferenceCallStarted().405 Created outgoing call to 18612615725 Call: id=15048588202212016160345 peers=1
    > 2017-09-08 08:20:20.318 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting
    > 2017-09-08 08:20:20.331 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.peerStateChanged().914 15e609344a4@callcontrol.mxjjitsi.mxj360.com JVB peer state: net.java.sip.communicator.service.protocol.CallPeerState:Connected
    > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().251 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 1595301515 video: null
    > 2017-09-08 08:20:24.866 INFO: [179] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > 2017-09-08 08:20:24.867 INFO: [179] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 101=rtpmap:-1 telephone-event/8000;
    > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides []
    > 2017-09-08 08:20:25.048 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().660 Sip call IN_PROGRESS: Call: id=15048588202212016160345 peers=1
    > 2017-09-08 08:20:25.049 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().668 SIP call format used: rtpmap:9 G722/8000
    > 2017-09-08 08:20:25.050 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting*
    > 2017-09-08 08:20:25.050 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:25.098 INFO: [60] service.protocol.media.TransportManager.sendHolePunchPacket().534 Send NAT hole punch packets
    > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:33.849 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connected
    > 2017-09-08 08:20:33.851 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:35.827 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:35.828 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:35.829 INFO: [62] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:40.988 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:42.668 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:42.678 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().673 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=18612615725 <18612615725@mengxiangjia.s.yunpbx.com>;status=Disconnected
    > 2017-09-08 08:20:42.688 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Disconnected
    > 2017-09-08 08:20:43.058 INFO: [224] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > 2017-09-08 08:20:43.059 INFO: [224] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp
    >
    > On 07/09/2017, 11:47 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > What are the codecs supported by your sip side?
    > The best quality you will get from these: G722 PCMA PCMU, but for PCMA
    > and PCMU you need a very good connection between jigasi and the sip
    > side.
    >
    > Maybe attaching the jigasi logs, that includes the pcap files will help.
    >
    > Regards
    > damencho
    >
    >
    >
    > On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, thank you for your info.
    > >
    > > We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.
    > >
    > > What shall we try next?
    > >
    > >
    > >
    > > #Sample config with one XMPP and one SIP account configured
    > > # Replace {sip-pass-hash} with SIP user password hash
    > > # as well as other account properties
    > >
    > > # Name of default JVB room that will be joined if no special header is included
    > > # in SIP invite
    > >
    > > #####
    > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > #####
    > >
    > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > >
    > > # Should be enabled when using translator mode
    > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > >
    > > # Adjust opus encoder complexity
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > >
    > > # Disables packet logging
    > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
    > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > >
    > >
    > >
    > > # Used when incoming calls are used in multidomain environment, used to detect subdomains
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > # the pattern to be used as bosh url when using bosh in multidomain environment
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > # properties that will be used for creating xmpp account for communication.
    > >
    > > # The following two props assume we are using jigasi on the same machine as
    > > # the xmpp server.
    > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > >
    > > #Used when outgoing calls are used in multidomain environment, used to detect subdomains
    > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > > # If you want jigasi to perform authenticated login instead of anonymous login
    > > # to the XMPP server, you can set the following properties.
    > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > # org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > >
    > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > # you can set the following property to true.
    > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > >
    > > # Activate this property if you are using self-signed certificates or other
    > > # type of non-trusted certicates. In this mode your service trust in the
    > > # remote certificates always.
    > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > >
    > > # Enable this property to be able to shutdown gracefully jigasi using
    > > # a rest command
    > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > >
    > >
    > >
    > > On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > Thanks, how can I switch a codec off? By setting the value to zero?
    > >
    > > On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > Hi,
    > >
    > > Can you set all the encodings, switch off whatever you don't need.
    > > You are overriding just g722 and leaving the rest with default values
    > > and apparently, it uses the wrong codec.
    > >
    > > Regards
    > > damencho
    > >
    > > On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > Here’s the configuration file we are using.
    > > >
    > > >
    > > >
    > > > #Sample config with one XMPP and one SIP account configured
    > > >
    > > > # Replace {sip-pass-hash} with SIP user password hash
    > > >
    > > > # as well as other account properties
    > > >
    > > >
    > > >
    > > > # Name of default JVB room that will be joined if no special header is
    > > > included
    > > >
    > > > # in SIP invite
    > > >
    > > >
    > > >
    > > > #####
    > > >
    > > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > >
    > > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > >
    > > > #####
    > > >
    > > >
    > > >
    > > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > > >
    > > >
    > > >
    > > > # Should be enabled when using translator mode
    > > >
    > > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > > >
    > > >
    > > >
    > > > # Adjust opus encoder complexity
    > > >
    > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > > >
    > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    > > >
    > > >
    > > >
    > > > # Disables packet logging
    > > >
    > > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > > >
    > > >
    > > >
    > > > # Used when incoming calls are used in multidomain environment, used to
    > > > detect subdomains
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > >
    > > > # the pattern to be used as bosh url when using bosh in multidomain
    > > > environment
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > as jvb, just forward every ssrc stream it receives.
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > >
    > > >
    > > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > >
    > > > # properties that will be used for creating xmpp account for communication.
    > > >
    > > >
    > > >
    > > > # The following two props assume we are using jigasi on the same machine as
    > > >
    > > > # the xmpp server.
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > > >
    > > >
    > > >
    > > > #Used when outgoing calls are used in multidomain environment, used to
    > > > detect subdomains
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > as jvb, just forward every ssrc stream it receives.
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > >
    > > >
    > > > # If you want jigasi to perform authenticated login instead of anonymous
    > > > login
    > > >
    > > > # to the XMPP server, you can set the following properties.
    > > >
    > > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > >
    > > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > >
    > > > #
    > > > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > >
    > > > # you can set the following property to true.
    > > >
    > > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > > >
    > > >
    > > >
    > > > # Activate this property if you are using self-signed certificates or other
    > > >
    > > > # type of non-trusted certicates. In this mode your service trust in the
    > > >
    > > > # remote certificates always.
    > > >
    > > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > > >
    > > >
    > > >
    > > > # Enable this property to be able to shutdown gracefully jigasi using
    > > >
    > > > # a rest command
    > > >
    > > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > <damencho@damencho.com>
    > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > Date: Wednesday, 6 September 2017 at 9:51 PM
    > > >
    > > >
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Can you post your config or send it directly to me?
    > > >
    > > >
    > > >
    > > > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > >
    > > > FYI: I am trying the unstable version. Tried changing the encoding
    > > > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > > > changes I’ve made to the encoding setup.
    > > >
    > > >
    > > >
    > > > From: Colin Zou <zoukaiping@gmail.com>
    > > > Date: Wednesday, 6 September 2017 at 2:47 PM
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > > > inside a virtual machine. I wonder whether audio device(hardware) or any
    > > > other audio component in linux OS will cause the problem? Any idea?
    > > >
    > > >
    > > >
    > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > <damencho@damencho.com>
    > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > Date: Saturday, 2 September 2017 at 10:17 PM
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Yes.
    > > >
    > > >
    > > >
    > > > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > >
    > > > Thanks, where is the priority. Is it the number after “=” ?
    > > >
    > > > Encodings.AMR-WB/16000=0
    > > > Encodings.G722/8000=705
    > > > Encodings.GSM/8000=450
    > > > Encodings.H264/90000=1100
    > > > Encodings.PCMA/8000=600
    > > > Encodings.PCMU/8000=650
    > > > Encodings.SILK/12000=0
    > > > Encodings.SILK/16000=713
    > > > Encodings.SILK/24000=714
    > > > Encodings.SILK/8000=0
    > > > Encodings.VP8/90000=0
    > > > Encodings.iLBC/8000=500
    > > > Encodings.opus/48000=750
    > > > Encodings.red/90000=0
    > > > Encodings.rtx/90000=0
    > > > Encodings.speex/16000=700
    > > > Encodings.speex/32000=701
    > > > Encodings.speex/8000=352
    > > > Encodings.telephone-event/8000=1
    > > > Encodings.ulpfec/90000=0
    > > >
    > > > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > >
    > > > Well if you tried jitsi desktop and it works fine, make sure you use
    > > > the same settings in jigasi.
    > > >
    > > > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > > Thanks, any suggestions on the codec order? And is there any codec
    > > > recommended? I was trying a lot, but still had not figured it out yet.
    > > > >
    > > > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > > >
    > > > > Hi,
    > > > >
    > > > > Check the codecs priority you use in jigasi and the codecs in
    > > > jitsi
    > > > > desktop and make sure they are the same.
    > > > >
    > > > > Regards
    > > > > damencho
    > > > >
    > > > >
    > > > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > > wrote:
    > > > > > Hi, I am running into sip calling problem. I have a server with
    > > > jitsi-meet
    > > > > > installed, and configured jigasi on the same server in order to
    > > > get SIP call
    > > > > > working. When calling a phone from jitsi-meet’s web browser user
    > > > interface.
    > > > > > The desktop is caller, and the phone is callee. The callee can
    > > > NOT hear what
    > > > > > is the caller saying. But the caller can hear callee very well.
    > > > > >
    > > > > >
    > > > > >
    > > > > > And I tried jitisi, the desktop application. Everything works
    > > > fine. Both
    > > > > > caller and callee can hear each other clearly.
    > > > > >
    > > > > >
    > > > > >
    > > > > > I am newbie to this tool. Is there anyone have the same problem
    > > > like me? Or
    > > > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > > > >
    > > > > >
    > > > > >
    > > > > > --
    > > > > >
    > > > > > Respects,
    > > > > >
    > > > > > Colin
    > > > > >
    > > > > >
    > > > > > _______________________________________________
    > > > > > users mailing list
    > > > > > users@jitsi.org
    > > > > > Unsubscribe instructions and other list options:
    > > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________ users mailing list
    > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________ users mailing list
    > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users


#19

Hey ahain,

In the pcap files I only see calls using ilbc. Can you make one call
with other codec, when you experience the problem and send again the
pcap file.

Thanks
damencho

···

On Fri, Sep 8, 2017 at 7:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:

Exactly, the participant on the sip side hear nothing when using any of G722 PCMA PCMU with jigasi. But everything works fine with jitsi desktop app…

On 08/09/2017, 8:08 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:

    Can you send me the pcap files from /var/log/jitsi/jigasi/log?
    So did I understand correctly that the participant on the sip side is
    not hearing when using g722?

    On Fri, Sep 8, 2017 at 3:50 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Hi, here were some log lines. The caller can hear callee clearly when calling with jigasi. I called our sip provider, and it supports G711 G712 G722 G729 PCMA PCMU.
    >
    > 2017-09-08 08:20:19.511 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
    > 2017-09-08 08:20:19.517 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides [103->104 ]
    > 2017-09-08 08:20:19.579 INFO: [106] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:19.976 INFO: [84] impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.harvestCandidates().1192 End candidate harvest within 1047 ms
    > 2017-09-08 08:20:20.165 INFO: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().869 Got invite from 37c894df
    > 2017-09-08 08:20:20.166 WARNING: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().874 Calls not initiated from focus are not allowed
    > 2017-09-08 08:20:20.187 SEVERE: [160] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
    > 2017-09-08 08:20:20.188 SEVERE: [160] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42c9455
    > 2017-09-08 08:20:20.188 SEVERE: [157] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42c9455
    >
    > 2017-09-08 08:20:20.207 INFO: [106] org.jitsi.jigasi.JvbConference.onJvbCallStarted().687 JVB conference call IN_PROGRESS asda@conference.mxjjitsi.mxj360.com
    > 2017-09-08 08:20:20.221 INFO: [106] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:18612615725@mengxiangjia.s.yunpbx.com
    > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:20.223 INFO: [106] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:20.298 WARNING: [106] impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptions().224 No active device for video was found!
    > 2017-09-08 08:20:20.318 INFO: [106] org.jitsi.jigasi.SipGatewaySession.onConferenceCallStarted().405 Created outgoing call to 18612615725 Call: id=15048588202212016160345 peers=1
    > 2017-09-08 08:20:20.318 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting
    > 2017-09-08 08:20:20.331 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.peerStateChanged().914 15e609344a4@callcontrol.mxjjitsi.mxj360.com JVB peer state: net.java.sip.communicator.service.protocol.CallPeerState:Connected
    > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().251 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 1595301515 video: null
    > 2017-09-08 08:20:24.866 INFO: [179] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > 2017-09-08 08:20:24.867 INFO: [179] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 101=rtpmap:-1 telephone-event/8000;
    > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides []
    > 2017-09-08 08:20:25.048 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().660 Sip call IN_PROGRESS: Call: id=15048588202212016160345 peers=1
    > 2017-09-08 08:20:25.049 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().668 SIP call format used: rtpmap:9 G722/8000
    > 2017-09-08 08:20:25.050 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting*
    > 2017-09-08 08:20:25.050 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:25.098 INFO: [60] service.protocol.media.TransportManager.sendHolePunchPacket().534 Send NAT hole punch packets
    > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:33.849 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connected
    > 2017-09-08 08:20:33.851 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > 2017-09-08 08:20:35.827 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:35.828 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:35.829 INFO: [62] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > 2017-09-08 08:20:40.988 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:42.668 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > 2017-09-08 08:20:42.678 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().673 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=18612615725 <18612615725@mengxiangjia.s.yunpbx.com>;status=Disconnected
    > 2017-09-08 08:20:42.688 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Disconnected
    > 2017-09-08 08:20:43.058 INFO: [224] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > 2017-09-08 08:20:43.059 INFO: [224] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp
    >
    > On 07/09/2017, 11:47 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > What are the codecs supported by your sip side?
    > The best quality you will get from these: G722 PCMA PCMU, but for PCMA
    > and PCMU you need a very good connection between jigasi and the sip
    > side.
    >
    > Maybe attaching the jigasi logs, that includes the pcap files will help.
    >
    > Regards
    > damencho
    >
    >
    >
    > On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, thank you for your info.
    > >
    > > We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.
    > >
    > > What shall we try next?
    > >
    > >
    > >
    > > #Sample config with one XMPP and one SIP account configured
    > > # Replace {sip-pass-hash} with SIP user password hash
    > > # as well as other account properties
    > >
    > > # Name of default JVB room that will be joined if no special header is included
    > > # in SIP invite
    > >
    > > #####
    > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > #####
    > >
    > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > >
    > > # Should be enabled when using translator mode
    > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > >
    > > # Adjust opus encoder complexity
    > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > >
    > > # Disables packet logging
    > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > >
    > >
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > >
    > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
    > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > >
    > >
    > >
    > > # Used when incoming calls are used in multidomain environment, used to detect subdomains
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > # the pattern to be used as bosh url when using bosh in multidomain environment
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > # properties that will be used for creating xmpp account for communication.
    > >
    > > # The following two props assume we are using jigasi on the same machine as
    > > # the xmpp server.
    > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > >
    > > #Used when outgoing calls are used in multidomain environment, used to detect subdomains
    > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > >
    > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > >
    > > # If you want jigasi to perform authenticated login instead of anonymous login
    > > # to the XMPP server, you can set the following properties.
    > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > # org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > >
    > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > # you can set the following property to true.
    > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > >
    > > # Activate this property if you are using self-signed certificates or other
    > > # type of non-trusted certicates. In this mode your service trust in the
    > > # remote certificates always.
    > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > >
    > > # Enable this property to be able to shutdown gracefully jigasi using
    > > # a rest command
    > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > >
    > >
    > >
    > > On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > >
    > > Thanks, how can I switch a codec off? By setting the value to zero?
    > >
    > > On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > Hi,
    > >
    > > Can you set all the encodings, switch off whatever you don't need.
    > > You are overriding just g722 and leaving the rest with default values
    > > and apparently, it uses the wrong codec.
    > >
    > > Regards
    > > damencho
    > >
    > > On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > Here’s the configuration file we are using.
    > > >
    > > >
    > > >
    > > > #Sample config with one XMPP and one SIP account configured
    > > >
    > > > # Replace {sip-pass-hash} with SIP user password hash
    > > >
    > > > # as well as other account properties
    > > >
    > > >
    > > >
    > > > # Name of default JVB room that will be joined if no special header is
    > > > included
    > > >
    > > > # in SIP invite
    > > >
    > > >
    > > >
    > > > #####
    > > >
    > > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > >
    > > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > >
    > > > #####
    > > >
    > > >
    > > >
    > > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > > >
    > > >
    > > >
    > > > # Should be enabled when using translator mode
    > > >
    > > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > > >
    > > >
    > > >
    > > > # Adjust opus encoder complexity
    > > >
    > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > > >
    > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    > > >
    > > >
    > > >
    > > > # Disables packet logging
    > > >
    > > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > > >
    > > >
    > > >
    > > > # Used when incoming calls are used in multidomain environment, used to
    > > > detect subdomains
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > >
    > > > # the pattern to be used as bosh url when using bosh in multidomain
    > > > environment
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > as jvb, just forward every ssrc stream it receives.
    > > >
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > >
    > > >
    > > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > >
    > > > # properties that will be used for creating xmpp account for communication.
    > > >
    > > >
    > > >
    > > > # The following two props assume we are using jigasi on the same machine as
    > > >
    > > > # the xmpp server.
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > > >
    > > >
    > > >
    > > > #Used when outgoing calls are used in multidomain environment, used to
    > > > detect subdomains
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > as jvb, just forward every ssrc stream it receives.
    > > >
    > > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > >
    > > >
    > > > # If you want jigasi to perform authenticated login instead of anonymous
    > > > login
    > > >
    > > > # to the XMPP server, you can set the following properties.
    > > >
    > > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > >
    > > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > >
    > > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > >
    > > > #
    > > > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > > >
    > > >
    > > >
    > > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > >
    > > > # you can set the following property to true.
    > > >
    > > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > > >
    > > >
    > > >
    > > > # Activate this property if you are using self-signed certificates or other
    > > >
    > > > # type of non-trusted certicates. In this mode your service trust in the
    > > >
    > > > # remote certificates always.
    > > >
    > > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > > >
    > > >
    > > >
    > > > # Enable this property to be able to shutdown gracefully jigasi using
    > > >
    > > > # a rest command
    > > >
    > > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > >
    > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > <damencho@damencho.com>
    > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > Date: Wednesday, 6 September 2017 at 9:51 PM
    > > >
    > > >
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Can you post your config or send it directly to me?
    > > >
    > > >
    > > >
    > > > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > >
    > > > FYI: I am trying the unstable version. Tried changing the encoding
    > > > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > > > changes I’ve made to the encoding setup.
    > > >
    > > >
    > > >
    > > > From: Colin Zou <zoukaiping@gmail.com>
    > > > Date: Wednesday, 6 September 2017 at 2:47 PM
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > > > inside a virtual machine. I wonder whether audio device(hardware) or any
    > > > other audio component in linux OS will cause the problem? Any idea?
    > > >
    > > >
    > > >
    > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > <damencho@damencho.com>
    > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > Date: Saturday, 2 September 2017 at 10:17 PM
    > > > To: Jitsi Users <users@jitsi.org>
    > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > >
    > > >
    > > >
    > > > Yes.
    > > >
    > > >
    > > >
    > > > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > >
    > > > Thanks, where is the priority. Is it the number after “=” ?
    > > >
    > > > Encodings.AMR-WB/16000=0
    > > > Encodings.G722/8000=705
    > > > Encodings.GSM/8000=450
    > > > Encodings.H264/90000=1100
    > > > Encodings.PCMA/8000=600
    > > > Encodings.PCMU/8000=650
    > > > Encodings.SILK/12000=0
    > > > Encodings.SILK/16000=713
    > > > Encodings.SILK/24000=714
    > > > Encodings.SILK/8000=0
    > > > Encodings.VP8/90000=0
    > > > Encodings.iLBC/8000=500
    > > > Encodings.opus/48000=750
    > > > Encodings.red/90000=0
    > > > Encodings.rtx/90000=0
    > > > Encodings.speex/16000=700
    > > > Encodings.speex/32000=701
    > > > Encodings.speex/8000=352
    > > > Encodings.telephone-event/8000=1
    > > > Encodings.ulpfec/90000=0
    > > >
    > > > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > >
    > > > Well if you tried jitsi desktop and it works fine, make sure you use
    > > > the same settings in jigasi.
    > > >
    > > > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > > Thanks, any suggestions on the codec order? And is there any codec
    > > > recommended? I was trying a lot, but still had not figured it out yet.
    > > > >
    > > > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > > >
    > > > > Hi,
    > > > >
    > > > > Check the codecs priority you use in jigasi and the codecs in
    > > > jitsi
    > > > > desktop and make sure they are the same.
    > > > >
    > > > > Regards
    > > > > damencho
    > > > >
    > > > >
    > > > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > > > wrote:
    > > > > > Hi, I am running into sip calling problem. I have a server with
    > > > jitsi-meet
    > > > > > installed, and configured jigasi on the same server in order to
    > > > get SIP call
    > > > > > working. When calling a phone from jitsi-meet’s web browser user
    > > > interface.
    > > > > > The desktop is caller, and the phone is callee. The callee can
    > > > NOT hear what
    > > > > > is the caller saying. But the caller can hear callee very well.
    > > > > >
    > > > > >
    > > > > >
    > > > > > And I tried jitisi, the desktop application. Everything works
    > > > fine. Both
    > > > > > caller and callee can hear each other clearly.
    > > > > >
    > > > > >
    > > > > >
    > > > > > I am newbie to this tool. Is there anyone have the same problem
    > > > like me? Or
    > > > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > > > >
    > > > > >
    > > > > >
    > > > > > --
    > > > > >
    > > > > > Respects,
    > > > > >
    > > > > > Colin
    > > > > >
    > > > > >
    > > > > > _______________________________________________
    > > > > > users mailing list
    > > > > > users@jitsi.org
    > > > > > Unsubscribe instructions and other list options:
    > > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________ users mailing list
    > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________ users mailing list
    > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users

    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#20

Hi Demencho, here’s the pcap file.

    Hey ahain,
    
    In the pcap files I only see calls using ilbc. Can you make one call
    with other codec, when you experience the problem and send again the
    pcap file.
    
    Thanks
    damencho

jitsi0.pcap (124 KB)

···

On 08/09/2017, 8:48 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    
    On Fri, Sep 8, 2017 at 7:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > Exactly, the participant on the sip side hear nothing when using any of G722 PCMA PCMU with jigasi. But everything works fine with jitsi desktop app…
    >
    > On 08/09/2017, 8:08 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    >
    > Can you send me the pcap files from /var/log/jitsi/jigasi/log?
    > So did I understand correctly that the participant on the sip side is
    > not hearing when using g722?
    >
    > On Fri, Sep 8, 2017 at 3:50 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > Hi, here were some log lines. The caller can hear callee clearly when calling with jigasi. I called our sip provider, and it supports G711 G712 G722 G729 PCMA PCMU.
    > >
    > > 2017-09-08 08:20:19.511 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 126=rtpmap:-1 telephone-event/8000; 111=rtpmap:-1 opus/48000/2 fmtp:useinbandfec=1;minptime=10; 103=rtpmap:-1 unknown/90000;
    > > 2017-09-08 08:20:19.517 INFO: [106] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides [103->104 ]
    > > 2017-09-08 08:20:19.579 INFO: [106] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > > 2017-09-08 08:20:19.976 INFO: [84] impl.protocol.jabber.CallPeerMediaHandlerJabberImpl.harvestCandidates().1192 End candidate harvest within 1047 ms
    > > 2017-09-08 08:20:20.165 INFO: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().869 Got invite from 37c894df
    > > 2017-09-08 08:20:20.166 WARNING: [84] org.jitsi.jigasi.JvbConference.incomingCallReceived().874 Calls not initiated from focus are not allowed
    > > 2017-09-08 08:20:20.187 SEVERE: [160] net.sf.fmj.media.Log.error() Unable to handle format: LINEAR, 48000.0 Hz, 16-bit, Mono, LittleEndian, Signed
    > > 2017-09-08 08:20:20.188 SEVERE: [160] net.sf.fmj.media.Log.error() Failed to prefetch: net.sf.fmj.media.ProcessEngine@42c9455
    > > 2017-09-08 08:20:20.188 SEVERE: [157] net.sf.fmj.media.Log.error() Error: Unable to prefetch net.sf.fmj.media.ProcessEngine@42c9455
    > >
    > > 2017-09-08 08:20:20.207 INFO: [106] org.jitsi.jigasi.JvbConference.onJvbCallStarted().687 JVB conference call IN_PROGRESS asda@conference.mxjjitsi.mxj360.com
    > > 2017-09-08 08:20:20.221 INFO: [106] impl.protocol.sip.OperationSetBasicTelephonySipImpl.createOutgoingCall().195 Creating outgoing call to sip:18612615725@mengxiangjia.s.yunpbx.com
    > > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:20.222 INFO: [106] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:20.223 INFO: [106] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > > 2017-09-08 08:20:20.298 WARNING: [106] impl.protocol.sip.CallPeerMediaHandlerSipImpl.createMediaDescriptions().224 No active device for video was found!
    > > 2017-09-08 08:20:20.318 INFO: [106] org.jitsi.jigasi.SipGatewaySession.onConferenceCallStarted().405 Created outgoing call to 18612615725 Call: id=15048588202212016160345 peers=1
    > > 2017-09-08 08:20:20.318 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting
    > > 2017-09-08 08:20:20.331 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.peerStateChanged().914 15e609344a4@callcontrol.mxjjitsi.mxj360.com JVB peer state: net.java.sip.communicator.service.protocol.CallPeerState:Connected
    > > 2017-09-08 08:20:20.334 INFO: [106] org.jitsi.jigasi.JvbConference.advertisePeerSSRCs().251 Peer net.java.sip.communicator.service.protocol.CallPeerState:Connected SSRCs audio: 1595301515 video: null
    > > 2017-09-08 08:20:24.866 INFO: [179] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > > 2017-09-08 08:20:24.867 INFO: [179] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1001 Dynamic PT map: 101=rtpmap:-1 telephone-event/8000;
    > > 2017-09-08 08:20:25.047 INFO: [60] service.protocol.media.MediaHandler.registerDynamicPTsWithStream().1018 PT overrides []
    > > 2017-09-08 08:20:25.048 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().660 Sip call IN_PROGRESS: Call: id=15048588202212016160345 peers=1
    > > 2017-09-08 08:20:25.049 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().668 SIP call format used: rtpmap:9 G722/8000
    > > 2017-09-08 08:20:25.050 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connecting*
    > > 2017-09-08 08:20:25.050 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > > 2017-09-08 08:20:25.098 INFO: [60] service.protocol.media.TransportManager.sendHolePunchPacket().534 Send NAT hole punch packets
    > > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:33.845 INFO: [60] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > > 2017-09-08 08:20:33.849 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Connected
    > > 2017-09-08 08:20:33.851 INFO: [60] service.protocol.media.CallPeerMediaHandler.start().1962 Starting
    > > 2017-09-08 08:20:35.827 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:35.828 INFO: [62] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:35.829 INFO: [62] impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using proxy 101.200.166.167:65060/TCP as hop instead of an address resolved by the SIP router
    > > 2017-09-08 08:20:40.988 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:42.668 INFO: [60] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp)
    > > 2017-09-08 08:20:42.678 INFO: [60] org.jitsi.jigasi.SipGatewaySession.handleCallState().673 SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=18612615725 <18612615725@mengxiangjia.s.yunpbx.com>;status=Disconnected
    > > 2017-09-08 08:20:42.688 INFO: [60] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().735 15e609344a4@callcontrol.mxjjitsi.mxj360.com SIP peer state: Disconnected
    > > 2017-09-08 08:20:43.058 INFO: [224] impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack: Setting SIPMessage peerPacketSource to: /101.200.166.167:65060
    > > 2017-09-08 08:20:43.059 INFO: [224] impl.protocol.sip.SipStackSharing.getLocalAddressForDestination().1204 Gettting source address for /10.250.3.155 -> mengxiangjia.s.yunpbx.com/101.200.166.167:65060(tcp
    > >
    > > On 07/09/2017, 11:47 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > >
    > > What are the codecs supported by your sip side?
    > > The best quality you will get from these: G722 PCMA PCMU, but for PCMA
    > > and PCMU you need a very good connection between jigasi and the sip
    > > side.
    > >
    > > Maybe attaching the jigasi logs, that includes the pcap files will help.
    > >
    > > Regards
    > > damencho
    > >
    > >
    > >
    > > On Thu, Sep 7, 2017 at 1:21 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > Hi, thank you for your info.
    > > >
    > > > We just ran another round of test, and the call will work when codec is any of “G722 GSM PCMA PCMU iLBC”. But there’s no voice at the callee side when codec is NOT iLBC. The callee can barely hear the caller’s voice when using iLBC.
    > > >
    > > > What shall we try next?
    > > >
    > > >
    > > >
    > > > #Sample config with one XMPP and one SIP account configured
    > > > # Replace {sip-pass-hash} with SIP user password hash
    > > > # as well as other account properties
    > > >
    > > > # Name of default JVB room that will be joined if no special header is included
    > > > # in SIP invite
    > > >
    > > > #####
    > > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > > #####
    > > >
    > > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > > >
    > > > # Should be enabled when using translator mode
    > > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > > >
    > > > # Adjust opus encoder complexity
    > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > > >
    > > > # Disables packet logging
    > > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=xxx
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=xxx
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > >
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > > >
    > > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > > net.java.sip.communicator.impl.protocol.sip.OVERRIDE_ENCODINGS=true
    > > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > > >
    > > >
    > > >
    > > > # Used when incoming calls are used in multidomain environment, used to detect subdomains
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > > # the pattern to be used as bosh url when using bosh in multidomain environment
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > > # properties that will be used for creating xmpp account for communication.
    > > >
    > > > # The following two props assume we are using jigasi on the same machine as
    > > > # the xmpp server.
    > > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > > >
    > > > #Used when outgoing calls are used in multidomain environment, used to detect subdomains
    > > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > >
    > > > # can be enabled to disable audio mixing and use translator, jigasi will act as jvb, just forward every ssrc stream it receives.
    > > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > > >
    > > > # If you want jigasi to perform authenticated login instead of anonymous login
    > > > # to the XMPP server, you can set the following properties.
    > > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > > # org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > > >
    > > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > > # you can set the following property to true.
    > > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > > >
    > > > # Activate this property if you are using self-signed certificates or other
    > > > # type of non-trusted certicates. In this mode your service trust in the
    > > > # remote certificates always.
    > > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > > >
    > > > # Enable this property to be able to shutdown gracefully jigasi using
    > > > # a rest command
    > > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > > >
    > > >
    > > >
    > > > On 07/09/2017, 12:22 PM, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > >
    > > > Thanks, how can I switch a codec off? By setting the value to zero?
    > > >
    > > > On 07/09/2017, 12:20 PM, "users on behalf of Damian Minkov" <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > >
    > > > Hi,
    > > >
    > > > Can you set all the encodings, switch off whatever you don't need.
    > > > You are overriding just g722 and leaving the rest with default values
    > > > and apparently, it uses the wrong codec.
    > > >
    > > > Regards
    > > > damencho
    > > >
    > > > On Wed, Sep 6, 2017 at 9:15 PM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > > Here’s the configuration file we are using.
    > > > >
    > > > >
    > > > >
    > > > > #Sample config with one XMPP and one SIP account configured
    > > > >
    > > > > # Replace {sip-pass-hash} with SIP user password hash
    > > > >
    > > > > # as well as other account properties
    > > > >
    > > > >
    > > > >
    > > > > # Name of default JVB room that will be joined if no special header is
    > > > > included
    > > > >
    > > > > # in SIP invite
    > > > >
    > > > >
    > > > >
    > > > > #####
    > > > >
    > > > > net.java.sip.communicator.util.dns.BACKUP_RESOLVER_ENABLED=false
    > > > >
    > > > > net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false
    > > > >
    > > > > #####
    > > > >
    > > > >
    > > > >
    > > > > org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
    > > > >
    > > > >
    > > > >
    > > > > # Should be enabled when using translator mode
    > > > >
    > > > > #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]
    > > > >
    > > > >
    > > > >
    > > > > # Adjust opus encoder complexity
    > > > >
    > > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
    > > > >
    > > > > net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.FEC=false
    > > > >
    > > > >
    > > > >
    > > > > # Disables packet logging
    > > > >
    > > > > net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:602@mengxiangjia.s.yunpbx.com
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=602@mengxiangjia.s.yunpbx.com
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.MUST_REGISTER_TO_CALL=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_P2P_MODE=true
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.FORCE_PROXY_BYPASS=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.TRANSPORT=TCP
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=TCP
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.IS_PRESENCE_ENABLED=true
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SIP_PREFERRED_CLEAR_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=602
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.DEFAULT_ENCRYPTION=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.FORCE_P2P_MODE=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.FORCE_PROXY_BYPASS=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.PROXY_AUTO_CONFIG=false
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.PROXY_ADDRESS=mengxiangjia.s.yunpbx.com
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.PROXY_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.TRANSPORT=TCP
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.PREFERRED_TRANSPORT=TCP
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.IS_PRESENCE_ENABLED=true
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.SERVER_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.SIP_PREFERRED_CLEAR_PORT=65060
    > > > >
    > > > > net.java.sip.communicator.impl.protocol.sip.DNSSEC_ENABLED=false
    > > > >
    > > > >
    > > > >
    > > > > # Used when incoming calls are used in multidomain environment, used to
    > > > > detect subdomains
    > > > >
    > > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > > >
    > > > > # the pattern to be used as bosh url when using bosh in multidomain
    > > > > environment
    > > > >
    > > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > > >
    > > > >
    > > > >
    > > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > > as jvb, just forward every ssrc stream it receives.
    > > > >
    > > > > #net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USE_TRANSLATOR_IN_CONFERENCE=true
    > > > >
    > > > >
    > > > >
    > > > > # We can use the prefix org.jitsi.jigasi.xmpp.acc to override any of the
    > > > >
    > > > > # properties that will be used for creating xmpp account for communication.
    > > > >
    > > > >
    > > > >
    > > > > # The following two props assume we are using jigasi on the same machine as
    > > > >
    > > > > # the xmpp server.
    > > > >
    > > > > org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
    > > > >
    > > > > org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
    > > > >
    > > > > org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
    > > > >
    > > > >
    > > > >
    > > > > #Used when outgoing calls are used in multidomain environment, used to
    > > > > detect subdomains
    > > > >
    > > > > #org.jitsi.jigasi.xmpp.acc.DOMAIN_BASE=<<DOMAIN_BASE>>
    > > > >
    > > > > #org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
    > > > >
    > > > >
    > > > >
    > > > > # can be enabled to disable audio mixing and use translator, jigasi will act
    > > > > as jvb, just forward every ssrc stream it receives.
    > > > >
    > > > > #org.jitsi.jigasi.xmpp.acc.USE_TRANSLATOR_IN_CONFERENCE=true
    > > > >
    > > > >
    > > > >
    > > > > # If you want jigasi to perform authenticated login instead of anonymous
    > > > > login
    > > > >
    > > > > # to the XMPP server, you can set the following properties.
    > > > >
    > > > > # org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
    > > > >
    > > > > # org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
    > > > >
    > > > > org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=true
    > > > >
    > > > > #
    > > > > org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://server.com/http-bind?room={roomName}
    > > > >
    > > > >
    > > > >
    > > > > # If you want to use the SIP user part of the incoming/outgoing call SIP URI
    > > > >
    > > > > # you can set the following property to true.
    > > > >
    > > > > # org.jitsi.jigasi.USE_SIP_USER_AS_XMPP_RESOURCE=true
    > > > >
    > > > >
    > > > >
    > > > > # Activate this property if you are using self-signed certificates or other
    > > > >
    > > > > # type of non-trusted certicates. In this mode your service trust in the
    > > > >
    > > > > # remote certificates always.
    > > > >
    > > > > # net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true
    > > > >
    > > > >
    > > > >
    > > > > # Enable this property to be able to shutdown gracefully jigasi using
    > > > >
    > > > > # a rest command
    > > > >
    > > > > # org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >
    > > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > > <damencho@damencho.com>
    > > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > > Date: Wednesday, 6 September 2017 at 9:51 PM
    > > > >
    > > > >
    > > > > To: Jitsi Users <users@jitsi.org>
    > > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > > >
    > > > >
    > > > >
    > > > > Can you post your config or send it directly to me?
    > > > >
    > > > >
    > > > >
    > > > > On Sep 6, 2017 08:07, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > > >
    > > > > FYI: I am trying the unstable version. Tried changing the encoding
    > > > > priorities, and the code sticky to encoding iLBC/8000. No matter what
    > > > > changes I’ve made to the encoding setup.
    > > > >
    > > > >
    > > > >
    > > > > From: Colin Zou <zoukaiping@gmail.com>
    > > > > Date: Wednesday, 6 September 2017 at 2:47 PM
    > > > > To: Jitsi Users <users@jitsi.org>
    > > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > > >
    > > > >
    > > > >
    > > > > Thanks, I’ve tried changing the encoding, no luck yet. The installation is
    > > > > inside a virtual machine. I wonder whether audio device(hardware) or any
    > > > > other audio component in linux OS will cause the problem? Any idea?
    > > > >
    > > > >
    > > > >
    > > > > From: users <users-bounces@jitsi.org> on behalf of Damian Minkov
    > > > > <damencho@damencho.com>
    > > > > Reply-To: Jitsi Users <users@jitsi.org>
    > > > > Date: Saturday, 2 September 2017 at 10:17 PM
    > > > > To: Jitsi Users <users@jitsi.org>
    > > > > Subject: Re: [jitsi-users] Help please: call real phone via sip provider
    > > > > inside jitsi desktop application was fine, but it was awful in jigasi
    > > > >
    > > > >
    > > > >
    > > > > Yes.
    > > > >
    > > > >
    > > > >
    > > > > On Sep 2, 2017 01:10, "Colin Zou" <zoukaiping@gmail.com> wrote:
    > > > >
    > > > > Thanks, where is the priority. Is it the number after “=” ?
    > > > >
    > > > > Encodings.AMR-WB/16000=0
    > > > > Encodings.G722/8000=705
    > > > > Encodings.GSM/8000=450
    > > > > Encodings.H264/90000=1100
    > > > > Encodings.PCMA/8000=600
    > > > > Encodings.PCMU/8000=650
    > > > > Encodings.SILK/12000=0
    > > > > Encodings.SILK/16000=713
    > > > > Encodings.SILK/24000=714
    > > > > Encodings.SILK/8000=0
    > > > > Encodings.VP8/90000=0
    > > > > Encodings.iLBC/8000=500
    > > > > Encodings.opus/48000=750
    > > > > Encodings.red/90000=0
    > > > > Encodings.rtx/90000=0
    > > > > Encodings.speex/16000=700
    > > > > Encodings.speex/32000=701
    > > > > Encodings.speex/8000=352
    > > > > Encodings.telephone-event/8000=1
    > > > > Encodings.ulpfec/90000=0
    > > > >
    > > > > On 02/09/2017, 7:46 AM, "users on behalf of Damian Minkov"
    > > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > > >
    > > > > Well if you tried jitsi desktop and it works fine, make sure you use
    > > > > the same settings in jigasi.
    > > > >
    > > > > On Fri, Sep 1, 2017 at 10:43 AM, Colin Zou <zoukaiping@gmail.com> wrote:
    > > > > > Thanks, any suggestions on the codec order? And is there any codec
    > > > > recommended? I was trying a lot, but still had not figured it out yet.
    > > > > >
    > > > > > On 01/09/2017, 11:12 PM, "users on behalf of Damian Minkov"
    > > > > <users-bounces@jitsi.org on behalf of damencho@jitsi.org> wrote:
    > > > > >
    > > > > > Hi,
    > > > > >
    > > > > > Check the codecs priority you use in jigasi and the codecs in
    > > > > jitsi
    > > > > > desktop and make sure they are the same.
    > > > > >
    > > > > > Regards
    > > > > > damencho
    > > > > >
    > > > > >
    > > > > > On Fri, Sep 1, 2017 at 4:36 AM, Colin Zou <zoukaiping@gmail.com> > > > > wrote:
    > > > > > > Hi, I am running into sip calling problem. I have a server with
    > > > > jitsi-meet
    > > > > > > installed, and configured jigasi on the same server in order to
    > > > > get SIP call
    > > > > > > working. When calling a phone from jitsi-meet’s web browser user
    > > > > interface.
    > > > > > > The desktop is caller, and the phone is callee. The callee can
    > > > > NOT hear what
    > > > > > > is the caller saying. But the caller can hear callee very well.
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > > > And I tried jitisi, the desktop application. Everything works
    > > > > fine. Both
    > > > > > > caller and callee can hear each other clearly.
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > > > I am newbie to this tool. Is there anyone have the same problem
    > > > > like me? Or
    > > > > > > is there anyway for me to get rid this problem? Thanks a lot.
    > > > > > >
    > > > > > >
    > > > > > >
    > > > > > > --
    > > > > > >
    > > > > > > Respects,
    > > > > > >
    > > > > > > Colin
    > > > > > >
    > > > > > >
    > > > > > > _______________________________________________
    > > > > > > users mailing list
    > > > > > > users@jitsi.org
    > > > > > > Unsubscribe instructions and other list options:
    > > > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > > >
    > > > > > _______________________________________________
    > > > > > users mailing list
    > > > > > users@jitsi.org
    > > > > > Unsubscribe instructions and other list options:
    > > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > > >
    > > > > >
    > > > > >
    > > > > > _______________________________________________
    > > > > > users mailing list
    > > > > > users@jitsi.org
    > > > > > Unsubscribe instructions and other list options:
    > > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > > _______________________________________________ users mailing list
    > > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > > _______________________________________________ users mailing list
    > > > > users@jitsi.org Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > > >
    > > > >
    > > > > _______________________________________________
    > > > > users mailing list
    > > > > users@jitsi.org
    > > > > Unsubscribe instructions and other list options:
    > > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > > >
    > > >
    > > >
    > > >
    > > > _______________________________________________
    > > > users mailing list
    > > > users@jitsi.org
    > > > Unsubscribe instructions and other list options:
    > > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    > >
    > >
    > >
    > > _______________________________________________
    > > users mailing list
    > > users@jitsi.org
    > > Unsubscribe instructions and other list options:
    > > http://lists.jitsi.org/mailman/listinfo/users
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    >
    >
    > _______________________________________________
    > users mailing list
    > users@jitsi.org
    > Unsubscribe instructions and other list options:
    > http://lists.jitsi.org/mailman/listinfo/users
    
    _______________________________________________
    users mailing list
    users@jitsi.org
    Unsubscribe instructions and other list options:
    http://lists.jitsi.org/mailman/listinfo/users